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Introduction
This guide is divided into a number of sections:

Introduction
Covers installing CrossWorks on your machine and verifying that it operates correctly, followed by a brief
guide to the operation of the CrossStudio integrated development environment, debugger, and other
software supplied in the product.

CrossStudio Tutorial
Describes how to get started with CrossStudio and runs through all the steps from creating a project to
debugging it on hardware.

CrossStudio User Guide
Contains information on how to use the CrossStudio development environment to manage your projects,
build, and debug your applications.

C Compiler User Guide
Contains documentation for the C compiler, including syntax and usage details and a description of
extensions provided by CrossWorks.

C Library User Guide
Contains documentation for the functions in the standard C library supplied in CrossWorks.

Assembler User Guide
Contains detailed documentation covering how to use the assembler, the assembler notation, macros, and
other assembler features.
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Target interfaces
Contains a description of the support for programming ARM microcontrollers.
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What is CrossWorks?
CrossWorks for MSP430 is a complete C development system for Texas Instruments MSP430 microcontrollers
that runs on Windows, Mac OS and Linux.

C compiler
CrossWorks C is a faithful implementation of the ANSI and ISO standards for the programming language C. We
have added some extensions that enhance usability in a microcontroller environment.

CrossWorks C Library
CrossWorks for MSP430 has its own royalty-free ANSI and ISO C compliant C library that has been specifically
designed for use within embedded systems.

CrossStudio IDE
CrossStudio for MSP430 is a streamlined integrated development environment for building, testing, and
deploying your applications. CrossStudio provides:
Source Code Editor:A powerful source code editor with multi-level undo and redo, makes editing your
code a breeze.
Project System:A complete project system organizes your source code and build rules.
Build System:With a single key press you can build all your applications in a solution, ready for them to be
loaded onto a target microcontroller.
Debugger and Flash Programming:You can download your programs directly into Flash and debug them
seamlessly from within the IDE using a wide range of target interfaces.
Help system:The built-in help system provides context-sensitive help and a complete reference to the
CrossStudio IDE and tools.
Core Simulator:As well as providing cross-compilation technology, CrossWorks provides a PC-based
fully functional simulation of the target microcontroller core so you can debug parts of your application
without waiting for hardware.

CrossWorks Tools
CrossWorks for MSP430 supplies command line tools that enable you to build your application on the command
line and flash it to the target board using the same project file that the IDE uses.
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What we don't tell you
This documentation does not attempt to teach the C or assembly language programming; rather, you should
seek out one of the many introductory texts available. And similarly the documentation doesn't cover the
MSP430 architecture or microcontroller application development in any great depth.
We also assume that you're fairly familiar with the operating system of the host computer being used.

C programming guides
These are must-have books for any C programmer:
Kernighan, B.W. and Ritchie, D.M., The C Programming Language (2nd edition, 1988). Prentice-Hall,
Englewood Cliffs, NJ, USA. ISBN 0-13-110362-8.
The original C bible, updated to cover the essentials of ANSI C (1990 version).
Harbison, S.P. and Steele, G.L., C: A Reference Manual (second edition, 1987). Prentice-Hall, Englewood
Cliffs, NJ, USA. ISBN 0-13-109802-0.
A nice reference guide to C, including a useful amount of information on ANSI C. Co-authored by Guy
Steele, a noted language expert.

ANSI C reference
If you're serious about C programming, you may want to have the ISO standard on hand:
ISO/IEC 9899:1990, C Standard and ISO/IEC 9899:1999, C Standard. The standard is available from your
national standards body or directly from ISO at http://www.iso.ch/.
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Activating your product
Each copy of CrossWorks must be licensed and registered before it can be used. Each time you purchase a
CrossWorks license, you, as a single user, can use CrossWorks on the computers you need to develop and deploy
your application. This covers the usual scenario of using both a laptop and desktop and, optionally, a laboratory
computer.

Evaluating CrossWorks
If you are evaluating CrossWorks on your computer, you must activate it. To activate your software for
evaluation, follow these instructions:
Install CrossWorks on your computer using the CrossWorks installer and accept the license agreement.
Run the CrossStudio application.
Choose Tools > License Manager.
Click "Evaluate CrossWorks". If you have a default mailer, click the By Mail button.
Using e-mail, send the registration key to the e-mail address license@rowley.co.uk.
If you don't have a default mailer, select the text underneath "Activation request".
Send the registration key to the e-mail address license@rowley.co.uk.
By return you will receive an activation key. To activate CrossWorks for evaluation, do the following:
Run the CrossStudio application.
Choose Tools > License Manager.
Click Activate CrossWorks.
Type in or paste the returned activation key into the dialog and click Install License.
If you need more time to evaluate CrossWorks, simply request a new evaluation key when the issued one expires
or is about to expire.

After purchasing CrossWorks
When you purchase CrossStudio, either directly from ourselves or through a distributor, you will be issued a
Product Key which uniquely identifies your purchase

To permanently activate your software:
Install CrossWorks on your computer using the CrossWorks installer and accept the license agreement.
Run the CrossStudio application.
Choose Tools > License Manager.
Click "Request Activation After Purchasing". If you have a default mailer, click the By Mail button.
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Using e-mail, send the registration key to the e-mail address license@rowley.co.uk.
If you don't have a default mailer, select the text underneath "Activation request".
Send the registration key to the e-mail address license@rowley.co.uk.
By return you will receive an activation key. Then, complete the activation process:
Run the CrossStudio application.
Choose Tools > License Manager.
Click Activate CrossWorks.
Type in or paste the returned activation key into the dialog and click Install License.
As CrossWorks is licensed per developer, you can install the software on any computer that you use such as a
desktop, laptop, and laboratory computer, but on each of these you must go through activation using your
issued product key.
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Text conventions
Menus and user interface elements
When this document refers to any user interface element, it will do so in bold font. For instance, you will often
see reference to the Project Explorer, which is taken to mean the project explorer window. Similarly, you'll see
references to the Standard toolbar which is positioned at the top of the CrossStudio window, just below the
menu bar on Windows and Linux.
When you are directed to select an item from a menu in CrossStudio, we use the form menu-name > item-name.
For instance, File > Save means that you need to click the File menu in the menu bar and then select the Save
item. This form extends to items in sub-menus, so File > Open With Binary Editor has the obvious meaning.

Keyboard accelerators
Frequently-used commands are assigned keyboard accelerators to speed up common tasks. CrossStudio uses
standard Windows and Mac OS keyboard accelerators wherever possible.
Windows and Linux have three key modifiers which are Ctrl, Alt, and Shift. For instance, Ctrl+Alt+P means that
you should hold down the Ctrl and Alt buttons whilst pressing the P key; and Shift+F5 means that you should
hold down the Shift key whilst pressing F5.
Mac OS has four key modifiers which are (command), (option), (control), and (shift). Generally there is a oneto-one correspondence between the Windows modifiers and the Mac OS modifiers: Ctrl is , Alt is , and Shift is .
CrossStudio on Mac OS has its own set of unique key sequences using (control) that have no direct Windows
equivalent.
CrossStudio on Windows and Linux also uses key chords to expand the set of accelerators. Key chords are key
sequences composed of two or more key presses. For instance, the key chord Ctrl+T, D means that you should
type Ctrl+T followed by D; and Ctrl+K, Ctrl+Z means that you should type Ctrl+T followed by Ctrl+Z. Mac OS
does not support accelerator key chords.

Code examples and human interaction
Throughout the documentation, text printed in this typeface represents verbatim communication with the
computer: for example, pieces of C text, commands to the operating system, or responses from the computer.
In examples, text printed in this typeface is not to be used verbatim: it represents a class of items, one of which
should be used. For example, this is the format of one kind of compilation command:
hcl source-file
This means that the command consists of:
The word hcl, typed exactly like that.
A source-file: not the text source-file, but an item of the source-file class, for example myprog.c.
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Whenever commands to and responses from the computer are mixed in the same example, the commands
(i.e. the items which you enter) will be presented in this typeface. For example, here is a dialog with the
computer using the format of the compilation command given above:
c:\code\examples>hcl -v myprog.c

The user types the text hcl -v myprog.c and then presses the enter key (which is assumed and is not shown); the
computer responds with the rest.
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Additional resources
With software as complex as CrossWorks, it's almost inevitable that you will need assistance at some point. Along
with the documentation that comes with CrossWorks for MSP430, there are a variety of other resources you can
use to find out more.

CrossWorks for MSP430 website
http://www.rowley.co.uk/msp430/index.htm

Support
If you need some help working with CrossWorks, or if something you consider a bug, go to:
http://rowley.zendesk.com/
You can subscribe to our RSS newsfeed here:
http://www.rowley.co.uk/rss.xml

Suggestions
If you have any comments or suggestions regarding the software or documentation, you can make suggestions
on our suggestion forum:
https://rowley.zendesk.com/forums/171704-Suggestions

Finding your way around
CrossStudio is a complex program in many ways, but we have tried to simplify it so that it's easy to use. It's very
easy to get started and CrossStudio scales well to complex multi-programmer projects that need to manage
large code bases and the inevitable software variants.
In the tutorial you were presented with a whistle-stop tour of CrossStudio to get you up and running. Here we
dig deeper into the corners of CrossStudio so you can get the best from it.
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Highlights
The development of CrossWorks 3 has taken longer than we ever expected. During that period, we visited each
part of the software to evaluate, polish, improve, and perhaps completely rewrite it. The changes in CrossStudio
range from subtle (changing a few icons here and there, improving performance) to extensive (threaded source
indexer, parallel build system, slick source control, new trace support). Here are some of the highlights in
CrossWorks 3

Parallel and Unity Building
Quad core processor are now standard in desktops and laptops, and CrossStudio can take full advantage of
multi-core processors when building your applications by scheduling projects to build in parallel. To partner
parallel building, CrossStudio also introduces support for unity builds where a set of source files are compiled as a
single unit.
To illustrate the advantages of these new features, here are the build times for rebuilding the example HTTP
server included in many CrossWorks board support packages, with the exception that all projects are source
code rather than object code libraries:
Cores

Unity?

Time

Speedup

Comments

1

No

21s

1x

Baseline

2

No

15s

1.4x

4

No

10s

2.1x

8

No

9.4s

2.2x

1

Yes

6.3s

3.3x

2

Yes

4.5s

4.6x

4

Yes

3.1s

6.8x

8

Yes

3.2s

6.5x

Hyperthreading
doesn't really help

Hyperthreading isn't
an advantage

And, building a set of sensor example projects, again in many board support packages, in a single solution:
Cores

Unity?

Time

Speedup

Comments

1

No

65s

1x

Baseline

2

No

41s

1.6x

4

No

24s

2.7x

8

No

20s

3.3x

1

Yes

39s

1.6x

2

Yes

23s

2.8x
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4

Yes

14s

4.6x

8

Yes

11s

5.9x

Hyperthreading does
help

These timings were taken on Windows 7 running under Parallels 9 on a Retina MacBook Pro with a 4-core 2.3
GHz Intel Core i7 and 8 GB of memory allocated to the virtual machine. The effect of parallel building will depend
upon the way you structure your project and the performance of your hardware.

Source indexer
The source indexer is completely reworked to be much more precise. Indexing takes place in the background,
using threads to index your code quickly. You can change the number of threads launched to index your project,
choosing between performance and responsiveness when indexing.
Hand in hand with the indexer, the code editor is improved with code completion where appropriate suggestions
pop up as you type. Because the indexer is very accurate, code completion is also accurate, increasing your
productivity as a programmer.
To complement the indexer, CrossStudio adds a Find References capability that fill search your application for
references to items. As you would expect, Find References runs in parallel, is configurable, and is a great way to
find the uses of functions, variables, types, and members.

Source control
Source-control integration is now significantly faster in CrossStudio 3. We're added source-control annotations
to the project explorer, but kept the ability to show the source-control column from CrossStudio 2.
We've changed the source-control model that CrossStudio 3 uses from the check-out/lock/check-in model
(as used by Visual Source Safe and RCS) to the widely used update/merge/commit model (as used by CVS and
Subversion).
In addition, we've added the popular Pending Changes window that succinctly shows you the changes you've
made and the overall state of the items in your project. We've also added a source-control state filter to the
project explorer, if you're more comfortable working in that window.
Source-control state updates progress in the background and much more efficient than the CrossStudio 2
implementation, making CrossStudio a real pleasure to use.
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Release notes
Version 3.2.0
IDE
Fast, new look user interface.
Native 64-bit Windows, macOS and Linux versions.
macOS Retina displays now supported.
New WebKit based help viewer.
Added support for CrossKey USB license key.

Version 3.1.2
Build
Fixed hex file records appearing in a different order after each build.

Debug
Added MSP430 DLL target property "Check Firmware Version".

Version 3.1.1
Build
Fixed build not building newly imported files.
Show "Batch Build Configurations" property at the solution node.
Add sys/stat.h, sys/time.h and sys/types.h header files.
Heap size property can now be reset to 0.
Fix crash compiling ((char *)ptr)++.
Fixed Sentinel USB tokens not working after Windows 10 version 1803 update.
Fixed assembler incorrectly parsing hexadecimal, octal and binary numbers under certain circumstances.

Debug
Fixed misc bugs in watch window.
Added "Copy To Clipboard" to register and variable display windows.
Added MSP430 DLL target property "Use MSP430 Breakpoints".
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IDE
Fixed pasting of file into a project explorer folder that is already contained within that folder.
Added Title Bar > Show Full Solution Path environment option.
Fixed editor search not clearing highlights when search string is cleared.
Fixed macOS terminal emulator not accepting # key on UK keyboard.
Fixed incorrectly placed resize grip in property editor.
Fixed bookmark not being removed from bookmarks window when the line it is on has been deleted.
Find and replace window now remembers last search context and file type settings.
Fixed opening of example projects from dashboard and contents window.
Added dependent files to quick open (Ctrl+o) editor action.
Detects project file has changed on disk and prompts for reload.
Function keys can now be displayed permanently on OS X Touch Bar when IDE is running. See Using
function keys on MacBook Pro with Touch Bar for more information on how to do this.
Fixed potential crash when enumerating USB devices on Windows.
Fixed modified target properties not being saved.
Fixed main window resizing when closing solution with no dashboard or help window open.
Fixed reload solution not loading the correct solution if multiple versions of the studio are running with
different projects loaded.
Editor now preserves UTF-8 byte order marks.
Fixed wait parameter on JavaScript function "CWSys.run".
Added Text Editor > Font Rendering environment option.
Fixed text editor scrolling to the far left column when text is selected and the mouse is moved.
Fixed text editor match delimiter and extend selection operation (Shift+Ctrl+]).
Fixed crash reporter hanging if report submission fails.
Fixed drag and drop of file onto a project explorer file node from an external program.
Fixed loss of focus when an expanded project explorer node is deleted.

Version 3.1.0
Build
Fixed build log job counting on folder and file builds.
Fixed memory leak in project explorer.
Fix crash if F4 is held down during a large build.
Added #pragma isrseg to hcc.
Implemented "Standard Libraries Directory" project property.
All library projects that an executable project is dependent on are now added to the link.
Fixed dynamic folder path attribute only expanding macros if macro is right at the start of the string.
Fixed dynamic folder exclude attribute matching on a sub-string.
Added missing C99 float and double precision math functions to C library.
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Files within projects now build in parallel when multi-threaded building is enabled.
Supplied ascii only version of ctype functions in ctype_no_wchar.c in the $(StudioDir)/source directory.
Supplied non threaded version errno in errno_no_thread.c in the $(StudioDir)/source directory.
Fixed setting errno to EDOM with invalid arguments to acos(f), asin(f) and fmod(f).
Fixed setting errno to ERANGE when overflow occurs with ldexp(f).
Added "Optimize Sections" project property.
Added option to linker and IDE to rename input sections.
C library is now compiled into sections that are named LIBC_.
Fixed crash caused by clearing build log whilst building.
Fixed build for project Link and unity folder Compile.

Debug
Hardware breakpoints now cleared after using Target > Download File options.
Stopped unnecessary USB enumeration at startup when the Target > Background Scan for Debug Pod
Presence environment option is enabled.
Fixed the context menu displayed in the disassembly window.
Editing in the memory window now selects the next column for edit.
Implemented a new memory window editor providing 'one click' editing.
Text view can now be edited in memory window.
Added automatic size and column modes to memory window.
Enhanced memory window data/text viewing options.
Added automatic refresh function to memory window.
Mouse, scroll wheel and keyboard can now be used to navigate memory in the memory window.
Added Unicode text viewing and editing when memory window is set to 16 or 32 bit widths.
Removed "Register Definition Macros" project property.
Added drag and drop support to project explorer.
Added range selection to memory window.
Added save selection functions to memory window.
Added data tips to memory window.
The memory window's columns field now scales when changing width field.
The memory window now adds extra space between column 8 and 9 in 16 column mode.
Added "Thread Maximum" project property to limit the number of entries in the threads window.
Threads window now updates based on the "Startup Completion Point" status.
Threads window now selects threads.js script only from the active project.
Added "Start From Entry Point Symbol" project property.
Watch windows have optional columns to display address, size and type.
Watch windows can now contain sub-expressions of existing watched expressions.
Added environment option "Show Data Tips In Text Editor".
Total warning count now displayed on build completion.
Debugger now sets the initial and startup completion breakpoints before the user breakpoints are set.
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Fixed memory leak in watch windows.
Fixed crash while using memory window when not connected to target.
Removed "Debugger Initial Breakpoint" environment options.
Can now optionally specify the main load file to download using the "Load File" project property.
Added "Go To Disassembly" to code editor context menu when debugging.
Added "Export As Text" to variable display windows.
Variable display windows now display char * as null terminated strings by default.
Fixed display of array and struct variables.
Added "Auto Refresh" to the context menu of the execution count window.
Fixed set breakpoint on variable from text editor.
Fixed modifying breakpoint properties.
Fixed memory window always evaluating address expression when auto size is selected.
Fixed memory window switching to auto size mode if size is less than display width.
Fixed watch window not storing the filename and linenumber context in which to evaluate the
expression.

IDE
Fixed "File Exists" error when pasting cut/copied file in project explorer.
Fixed "Folder Name in use" error when creating folders with the same name as the parent folder.
Added Goto Declaration.
Fixed saving of read-only files when using Find References.
Added Code Formatting capability to text editor.
Property dialog group selection now shows only the selected group.
Fixed computing the filepath when pasting files between projects.
Misc improvements to new project wizard.
Properties positioning in project explorer context menu now controlled by an environment property.
Project file is now saved prior to showing properties editor dialog.
Auto reload of project file when edited using the text editor.
Fixed file naming when file extension supplied to new file dialog.
Added c++11 keywords to code editor syntax coloring.
Added SEGGER style to code formatter choices.
Added support for Windows 10.
Assumes .S files are assembly code files.
Fixed code editor undo after saving with the Text Editor > Save Options > Delete Trailing Space On
Save environment option enabled.
Added Text Editor > Programmer Assistance > Template Characters To Match option.
Changed implementation of code completion and source navigation to use external program index.
Fixed auto-recovery when file has been edited within IDE and also with an external editor.
Go To Definition (and other source code operations) work without Source Navigator assistence.
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Go To Definition (and other source code operations) fixed when files contain c++ constructors/
destructors/operators.
Filenames in session files are now stored relative to the session file.
Fixed Find Extras > Find In editor context menu options not working on OS X.
Fixed layout of windows when using monitors with a resolution of 4K and above.
Fixed usage of clang and libclang (e.g. goto definition) on Windows 10.
Fixed smart indentation when previous line is empty.
Fixed problem causing available packages list download to fail.
IDE is now brought to the foreground when a file is opened from an external application.
Fixed code completion leaving PCH files in temporary directory.
Added Window > Zoom and Window > Minimize menu options (OS X only).
Fixed creating folders of the same name as the parent folder.
Fixed crash using "Find References" on newly created project.
Fixed project property dialog forgetting previously modified properties on cancel.
Project property dialog now optionally prompts on cancel if properties have been modified.
JavaScript project properties now have a multi-line editor.
Fixed reading of XML files with a UTF-8 byte order mark.
Register descriptions may now contain UTF-8 characters.
Fixed Spaces In Square Brackets and Spaces In Parentheses text editor code formatting options.
Code formatter tool can now run on header files in project.
Fixed code formatting of a selection.
Fixed code formatting of a modified file.
Fixed disassembly window's font not updating until restart.
Fixed Text Editor > Mouse Options > Alt+Left Click and Text Editor > Mouse Options > Ctrl+Left Click
environment options.
Fixed copying to clipboard in text editor resetting scaled font size.
Changed Import Package Files to also import files referenced via $(StudioDir).
Fixed index.exe holding open header file handles after code completion and goto definition.
Fixed goto definition usage of Source Navigator.
The Space Before Parentheses text editor code formatting option is now taken into account when
generating code completion suggestions.
Fixed crash when dragging a project folder onto itself.
Fixed display of string properties that contain line feeds.
The "Project Type" property can now be set on a per configuration basis.
Fixed reload project not working correctly when the project has been opened from the Recent Projects
window.
Project properties editor dialog is now modal.
Memory window address field now expands to fill available space.
Fixed blank filenames in Open File From Solution dialog.
Fixed binary editor cursor display and mouse tracking.
Fixed crash when right clicking in empty area of build configuration dialog.
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Fixed crash when changing configuration with a property editor focused in properties dialog.
Changed the way modified and inherited properties are shown in the properties dialog/window.
Code editor no longer displays file modified warning if file has been externally deleted.
Properties dialog, removed "All" group, deselecting the group/page will show all properties.
Properties dialog, changed the graphic to indicate that a project property has been modified or is set in
another node or configuration.
Properties dialog, removed the build macros and added a means to display the set of macros on
individual property editors.
Project explorer, added "Exclude From Build" option to folders.
Properties dialog, added option to show modified properties only.
Fixed drag and drop in project explorer only working on a new folder after project has been reloaded.
File path property editor now applies change when enter key is pressed.
The Application Monospace Font property editor will now only allow monospace fonts to be selected.
Parallel building of files in projects now shows a progress bar and ETA, both of these can be disabled
using new environment options.
Removed project property "Build Dependents in Parallel", replaced it with "Project Can Build In Parallel".
Improved appearance of build log's memory usage summary when there are many memory segments.
Fixed code completion on files with paths containing UNICODE characters.
Fixed goto definition and find references on files with paths containing UNICODE characters.
Fixed close solution not stopping when the saving of a modified file has failed.
Fixed crash when dragging a project folder onto one of its own sub folders.
Register window bitfield entries now use monospace font.
Ctrl+C and Ctrl+A now work in project property dialog's description field.
Fixed drag not working in project explorer on new files or folders until project has been reloaded.
Cannot close solution while Source Navigator and References window are active.
Added stop button to Source Navigator window.
Added environment option "Parallel Project Building" to enable dependent project (and solution) builds
to be done in parallel.

Licensing
Sentinel shared license dongle now supported on Mac OS X.

Release 3.0.0
What's New
CrossStudio
Source code editor now has code completion capability.
Source Navigator has a new core that is precise and can run multiple indexing threads in parallel.
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Find References (Alt+R or Ctrl+Alt+F) quickly finds references to a symbol or preprocessor definition.
Find References can run multiple indexing threads in parallel.
Find Symbol (Alt+Y) uses new Source Navigator core to quickly access project-wide symbols.
Search menu simplified and shortened by splitting into Search and Navigate menus to work better on
small laptop screens.
Search Build Configuration (Ctrl+Shift+B) provides a way to directly select a build configuration.
Search Project (Ctrl+Shift+J) provides a way to directly select a project in a loaded solution.
Search Targets (Ctrl+Shift+T) provides a way to directly connect a target interface.
Search Includes (Ctrl+Shift+M) will open include files referenced in the focused source file.
Project Explorer has a Filter Project (Ctrl+;) capability to show matching filenames.
Project Explorer has accelerators for Collapse to Projects (Ctrl+P, J), Collapse to Folders (Ctrl+P, F),
Collapse to Solutions (Ctrl+P, S), Collapse All (Ctrl+P, -), and Expand All (Ctrl+P, =).
Project Explorer will highlight files using stars, above all other files, if the filename matches any wildcard
in the list Tools > Options > Windows > Project Explorer Options > Starred File Names.
Shift double-clicking a file in the Project Explorer will open the file with the external editor set in Tools >
Options > Windows > Project Explorer Options > External Editor.
Project Explorer will highlight dynamic folders, and their child items, using a red shortcut arrow.
File > Open's accelerator, Ctrl+O, will open a file in the solution. Pressing Ctrl+O a second time opens a
dialog to select a file from the solution.
Search > Find's accelerator, Ctrl+F, will open an incremental find. Pressing Ctrl+F a second time opens a
standard Find dialog.
Move Opposite (Alt+O) moves the focused source file to the opposite window; this streamlines putting
files side by side for reference or comparison.
All mouse click actions are configurable through Tools > Options > Text Editor > Mouse Options.
All property dialogs along with Build Configuration and Project Dependencies refreshed.
Properties can be made favorites. A favorite property appears in the (Favorites) group in the Properties
Window and appears on the Project Explorer right-click menu
Target interfaces can be made favorites. Favorite target interface are shown above non-favorite interfaces
in Search Targets and the Targets window.
Memory map files are presented in datasheet form in the Preview pane of the Code Outline window.
Added column tidy option to editor.
Added codec support to editor.
Added option to generate support information.
The Registers window now has search capability and has been reworked for smoother operation
Help contents load much more rapidly than before.
Progress shows in Transcript when loading lengthy projects.
Attributes in project files fit on a single line if less than 75 characters long; if longer, attributes wrap one
per line which allows confortable editing with a text editor.
Added VCS support for subversion, git and mercurial.
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Build
Added support for Thread Local Storage.
Project macros can now be used in filenames in the project system.

Debug
Added support for MSP-FET.

Library
Locales and 16-bit wchar_t implemented.

What's Gone
CrossStudio
Removed Disassemble, Open As Text and Open As Binary options - replaced with File | Open With.
Removed Replace In Files - this is now supported in the Find And Replace window.
Removed VCS support for VisualSourceSafe and SourceOffSite.

Debug
Removed support for MSP-FET430PIF parallel port target interface.

Library
Added debugio.h header file. Use this rather than __cross_studio_io.h or cross_studio_io.h to access
debugIO functions.
Removed debug/target IO libraries - use __debug_stdio.h if you want debug IO by default.
Removed CTL from distribution. CTL is now supplied as a CrossWorks Technology Library package which
you will need to install if you are using it. Projects that reference the old CTL directories will be upgraded
by CrossStudio when they are loaded.
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CrossStudio Tutorial
In this tutorial, we will take you through activating your copy of CrossWorks; installing support packages; and
creating, compiling, and debugging a simple application using the built-in simulator.

Note
If you're viewing this tutorial from within the CrossStudio help Browser window, you may find it more
convenient to view using an external web browser so you can still see the entire CrossStudio window. To do so,
simply right-click on the help content in the CrossStudio Browser and choose Open With External Browser.

In this section
Activating CrossWorks
Describes how to activate your copy of CrossWorks by obtaining and installing an activation key for
evaluation.

Managing support packages
Describes how to download, install, and view CPU-support and board-support packages.

Creating a project
Describes how to start a project, select your target processor, and other common options.

Managing files in a project
Describes how to add existing and new files to a project and how to remove items from a project.

Setting project options
Describes how to set options on project items and how inheritance works for project settings.
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Building projects
Describes how to build a project, correct compilation and linkage errors, and find out how big your
applications are.

Exploring projects
Describes how to use the Project Explorer and Symbol Browser to learn how much memory your project
takes and how to navigate among the files that make up the project.

Using the debugger
Describes the debugger and how to find and fix problems at a high level when executing your application.

Low-level debugging
Describes how to use debugger features to debug your program at the machine level by watching registers
and tracing instructions.

Debugging externally built applications
Describes how to use the debugger to debug externally built applications.

54

CrossWorks for MSP430 Reference Manual

CrossStudio Tutorial

Activating CrossWorks
Each copy of CrossWorks must be registered and activated before it will build projects or download and debug
applications. In this tutorial, we are going to use CrossWorks's License Manager dialog to request an evaluation
activation key and, after the key is received, to activate CrossWorks.
If you have already activated your copy of CrossWorks, you can skip this page.

Requesting an evaluation activation key (with a default e-mail client)
To receive an evaluation activation key that is valid for 30 days:
Choose Tools > License Manager.
Click the Evaluate CrossWorks option.
Choose whether to lock the license to your computer's MAC address or to your system's primary disk.
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Send the e-mail containing the registration key to license@rowley.co.uk. If your development system
does not have a default e-mail client, copy the activation request and paste it into an e-mail to this
address.
Choosing which hardware to lock to is a matter of personal choice. If you lock to your primary disk and then
replace that disk drive, reformat it, or upgrade the operating system, CrossWorks may need to be reactivated.
If you lock to a network adapter and the network adapter fails and is replaced, then CrossWorks will require
reactivation.
When we receive your registration key we will send an activation key back to your e-mail's reply address. You
then will use the activation key to unlock and activate CrossWorks.

Activating CrossWorks
When you receive your activation key from us, you can activate CrossWorks as follows:
Choose Tools > License Manager.
Click the Activate CrossWorks option.
Enter the activation key you have received from us.
Click Install License.
The new activation should now be visible in the list of Installed licenses. Click Close to close the License
Manager window.

Note
If you request an activation key outside office hours, there may be a delay processing the registration. If this is
the case, you can continue the tutorial until you reach the Building projects sectionyou will need to activate
CrossWorks before you can build.
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Managing support packages
Before a project can be created, a CPU-support or board-support package suitable for the device you are
targeting must be installed. A support package is a single, compressed file that can contain project templates,
system files, example projects, and documentation for a particular target.
In this tutorial, we are going to use CrossWorks's Package Manager to download, install, and use the Texas
Instruments MSP430 CPU Support Package.
If you have already installed this support package, you can skip this page.

Downloading and installing a support package
To download and install a support package:
Choose Tools > Manage Packages.
Select the Texas Instruments MSP430 CPU Support Package entry.
(To select more packages to download and install at the same time, you can control-click the additional
packages.)
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Right-click the selected package and choose to Install Selected Packages.

Click the Next button and you will be presented with a list of actions the package manager is going to
carry out.
Click Next again to download and install the support package.
Upon successful completion, you will see a list of the newly installed packages. Click Finish.

Viewing installed support packages
To view the installed support packages:
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Choose Tools > Show Installed Packages to list the support packages you have installed on your system.
You should see the name of the Texas Instruments MSP430 CPU Support Package you just installed.
Click Texas Instruments MSP430 CPU Support Package to view the support package page in the
CrossWorks Browser window. This page provides more information about the support package and links
to any documentation, example projects, and system files that may be included in the package.
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Creating a project
To start developing an application, first create a new project. To create a new project:
Choose File > New Project or press Ctrl+Shift+N
The New Project dialog appears. This dialog displays the set of project types (Categories) and project templates.

)
We'll create a project to develop our application in C:
1. In the Categories pane, select the Standard > Executable
2. From the list in the Project Templates pane, select the A C executable
3. In the Name text field, type Tutorial to assign that as the new project's name.
4. You can use the Location text field or the Browse button to locate where you want to save the project in
your local file system.
5. Click Next.
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Here you can customize the project by altering a number of common project properties, such as an additional
file format to be output when the application is linked and what library support to include if you use printf and
scanf. After the project is created, you can change these settings in the Project Explorer as needed.
1. You can double-click a project property or its value to display either a drop-down menu of potential, valid
values or a text field in which you can type arbitrary values. For our tutorial, the default values are fine.
2. Click Next to display a list of the files CrossWorks will add to this project be default. You can uncheck any
file you plan to add manually or that you know will not be needed.

61

CrossWorks for MSP430 Reference Manual

CrossStudio Tutorial

The Links to system files group shows the links to CrossWorks system files that will be created in the project.
Because these files are links, the default behavior is that they will be shared with other projectsso modifying one
will affect all projects containing similar links. To prevent accidental modification, these files are created as readonly. Should you wish to modify a shared file without affecting other projects, first import it into the project.
(Importing a shared file will be demonstrated later in this tutorial.) See Creating and managing projects for
more information on project links.
The Project files pane shows the files that will be copied into the project. Because these files are copied to the
project directory, they can be modified without affecting any other project.
If you uncheck an item, that file is not linked to, or created in, the project. We will leave all items checked for the
moment.
1. Click Next to view the default configurations that will be added to the project. Again, you can uncheck
any you know will not be needed but, for this tutorial, we will leave the defaults unchanged.
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Here you can specify the default configurations that will be added to the project. See Creating and managing
projects for more information on project configurations.
1. Click Finish to complete the new project's creation.
The Project Explorer shows the overall structure of your project. To invoke it, do one of the following:
Choose View > Project Explorer.
or
Type Ctrl+Alt+P.
This is what our project looks like in the Project Explorer:
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The project name is shown in bold to indicate it is the active project (and, in our case, the only project). If you
have more than one project, you can set the active project by using the drop-down box on the Build tool bar or
by right-clicking the desired project's name in the Project Explorer to display the shortcut menu with the Set as
Active Project command.
The files are arranged into two groups; click the + symbol next to the project name to reveal them:
Source Files contains the main source files for your application, typically header files, C files, and
assembly code files. You may want to add files with other extensions or documentation files in HTML
format, for instance.
System Files contains links to source files that are not part of the project but are required when the
project is built and run. In this case, the system files are: crt0.asm the C run-time startup, written in
assembly code

64

CrossWorks for MSP430 Reference Manual

CrossStudio Tutorial

Files stored outside the project's home directory (with a small purple shortcut indicator at the bottom left of the
icon, as above.
These folders have nothing to do with directories on disk, they are simply a means to group related files in the
Project Explorer. You can create new folders and specify filters for them based on the project files' extensions;
thereafter, when you add a new file to the project, it will be shown in the Project Explorer folder whose filter
matches the new file's extension.
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Managing files in a project
We'll now set up the example project with some files that demonstrate features of the CrossWorks IDE. For this,
we will add one pre-prepared file and one new file to the project.

Adding an existing file to a project
To add one of the existing tutorial files to the project:
Choose Project > Add Existing File or press Ctrl+P, A.
or
In the Project Explorer, right-click the Tutorial project node.
Choose Add Existing File from the shortcut menu.
In response, CrossWorks displays a standard file-locator dialog. Use it to navigate to the CrossWorks installation
directory, then to the tutorial folder, where you should select the fact.c file.
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Click Open to add the file to the project. The Project Explorer will list fact.c in the Project Items' Source Files
folder, with a shortcut arrow because the file is not in the project's home directory. Rather than edit the file in the
tutorial directory, we'll put a copy of it into the project's home directory:
In the Project Explorer, right-click the fact.c node.
From the pop-up menu, click Import.
The shortcut arrow disappears from the fact.c node, indicating that our working version of that file is now in
our Tutorial project's home directory.
We can open a file for editing by double-clicking the node in the Project Explorer. For example, double-clicking
fact.c opens it in the code editor:

Removing a file from a project
We don't need the main.c file that was added to the project by the new-project wizard, so we will remove it.
Do one of the following:
Select main.c in the Project Explorer.
Choose Edit > Delete or press Del.
or
In the Project Explorer, right-click main.c.
From the shortcut menu, click Remove.
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Adding a new file to a project
Our project isn't complete, because fact.c is only part of an application. To our project we'll add a new C file
that will contain the main() function. To add a new file to the project, do the following:
Choose File > New to open the New File dialog.
or
On the Project Explorer tool bar, click the Add New File button.
or
In the Project Explorer, right-click the Tutorial node.
Choose Add New File from the shortcut menu.
or
Type Ctrl+N.
The New File dialog appears.
In the Categories pane, select C C++ to indicate the general type of file.
In the Templates pane, select the C File (.c) option to further specify the kind of file we will be adding.
In the Name edit box, type main.
The dialog box will now look like this:
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Click OK to add the new file. Because main.c already exists on disk, you will be asked whether you wish to
overwrite the file:

Click Yes to overwrite the file and continue with the tutorial.
CrossWorks opens the new file in the code editor. Rather than type the program from scratch, we'll add it from a
file stored on disk. With the new, empty main.c in the foreground:
Choose Edit > Others > Insert File or press Ctrl+K, Ctrl+I.
Using the file-selection dialog, navigate to the tutorial directory.
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Select the main.c file.
Click OK.
Your main.c file should now look like this:

Next, we'll set up some project options.
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Setting project options
Up to this point, you have created a simple project. In this section, we will set some options for that project.
You can set project options on any node of a solution. That is, you can set options on a solution-wide basis, on
a project-wide basis, on a project-group basis, or on an individual-file basis. For instance, options you set on a
solution are inherited by all projects in that solution, by all groups in each of those projects, and by all files in
each of those groups. If you set an option further down in the hierarchy, that setting will be inherited by nodes
that are children of (or grandchildren of, etc.) that node. This provides a powerful way to customize and manage
your projects.

Adding a C preprocessor definition
In this instance, we will define a C preprocessor definition that will apply to the entire Tutorial project. This means
every file in the project will inherit our new definition. If, however, we were to later add other projects to the
solution, they would not inherit the definition; if we wanted that, we could set the property on the solution node
rather than the project node.
To set a C preprocessor definition on the project node:
Right-click the Tutorial project in the Project Explorer and select Properties from the menuthe Project
Manager dialog appears.
Click the Configuration drop-down and change to the Common configuration (it is one of the "Private
Configurations").
Scroll down the list as necessary to click the Preprocessor Options > Preprocessor Definitions property.
Double-click the property name or value field, or click the ... symbol to display the empty Preprocessor
Definitions window, and in that window type the definition DEFINE_ME.
The dialog box will now look like this:
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Notice that, when you change between Debug and Release configurations, the code generation options
change. This dialog shows the options used when building a project (or anything in a project) in a given
configuration. Because we put the above, new definition in the Common configuration, both Debug and
Release configurations will use this setting. We could, however, set the definition to be different in Debug and
Release configurations if we wanted to pass different definitions into debug and release builds.
Now click OK to accept the changes made to the project.

Using the Properties Window
If you click on the project node, the Properties Window will show the properties of the projectall were inherited
from the solution. If you modify a property when the project node is selected, you'll find that its value is
highlighted because you have overridden the property value inherited from the solution. To restore the
inherited value of a property that was changed, right-click the property and select Use Inherited Value.
Next, we'll build the project.
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Building projects
Now that the project is created and set up, it's time to build it. There are some deliberate errors in the program
that we need to correct; doing that is the next step in this tutorial.

Setting the build configuration
The first thing to do is set the active build configuration you want to use:
Select MSP430 Debug from the Active Configuration .
This means we are going to use a build configuration that generates code with debug information and no
optimization, so it can be debugged. If we wanted to produce production code with no debug information and
optimization enabled, we could use the MSP430 Release configuration. However, because we are going to use
the debugger, we shall use the MSP430 Debug configuration.

Building the project
To build the project:
Choose Build > Build Tutorial.
or
On the Build tool bar, click the Build Active Project button.
or
Type F7.
Alternatively, to build the Tutorial project using a shortcut menu:
In the Project Explorer, right-click the Tutorial project node.
Select Build from the shortcut menu.
CrossWorks starts compiling the project files, but stops after detecting an error. The Output window shows the
Transcript, which contains the errors found in the project:

73

CrossWorks for MSP430 Reference Manual

CrossStudio Tutorial

Correcting compilation and linkage errors
The file main.c contains two errors. After compilation, CrossWorks moves the cursor to the line containing
the first reported error and displays an error message in the Output window. (You can change this behavior by
modifying the Text Editor > Editing Options > Enable Popup Diagnostics environment option using the Tools
> Options dialog.)

To correct the error, change the return type of factorial from void to int in its prototype.
To move the cursor to the line containing the next error, type F4 or choose Search > Next Location. The cursor is
now positioned at the debug_printf statement, which is missing a terminating semicolonadd the semicolon to
the end of the line. Using F4 again reveals that we have corrected all errors.
Pressing F4 again wraps around and moves the cursor to the first error, and you can use Shift+F4 or Search >
Previous Location to move back through errors. Now that the errors are corrected, build the project again by
pressing F7. The Transcript shows there still is a problem.
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The remaining error is a linkage error. Double-click fact.c in the Project Explorer to open it for editing
and change the two occurrences of fact to factorial. Rebuild the projectthis time, the project compiles
correctly:

A summary of the memory used by the project is displayed at the end of the build log. The results for your
application may be different, so don't worry if they don't match.
In the next sections, we'll explore the characteristics of the newly built project.
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Exploring projects
Now that the project has no errors and builds correctly, we can turn our attention to uncovering exactly how our
application fits in memory and how to navigate around it.

Using Project Explorer features
The Project Explorer is the central focus for arranging your source code into projects, and it's a good place to
show ancillary information gathered when CrossWorks builds your applications. This section will cover features
the Project Explorer offers to give you an overview of your project.

Project code and data sizes
Developers are always interested in how much memory their applications use, especially when they are working
with small, embedded microcontrollers. The Project Explorer can display the code and data sizes for each
project and individual source file that successfully compiled. To view this information, use the Options pop-up
menu on the Project Explorer tool bar to ensure that Statistics Column is checked.
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When the Statistics Column option is checked, the Project Explorer displays two additional columns, Code and
Data.
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The Code column displays the total code space required for the project. The Data column displays the total
data space required. The code and data sizes shown for each C and assembly source file are estimates, but good
ones. Because the linker removes any unreferenced code and data, and performs a number of optimizations, the
sizes for the linked project may not be the sum of the sizes of each individual file. The code and data sizes for the
project, however, are accurate. As already mentioned, your numbers may not match these exactly.

Dependencies
The Project Explorer is very versatile: not only can you display the code and data sizes for each element of a
project and for the project as a whole, you can also configure it to show the dependencies for a file. As part of
the compilation process, CrossWorks finds and records the relationships between filesthat is, it finds which
files depend upon other files. CrossWorks uses these known relationships when it builds the project again, to
minimize the amount of work required to bring the project up to date.
To show the dependencies for a project, use the Options button on the Project Explorer tool bar to ensure that
either Dependencies Under Node or Dependencies In Folder is checked. Once checked, dependent files are
shown as sub-nodes of the file that depends on them.
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In this case, main.c is dependent upon cross_studio_io.h because it includes it with an #include
directive. It is also dependent on __crossworks.h because that is included by cross_studio_io.h. You
can open the files in an editor by double-clicking them, so having dependencies turned on is an effective way of
navigating to and summarizing the files a source file includes.

Output files
It is useful to know the output files when compiling and linking the application, and CrossWorks can display this
information, too. To turn on output-file display, click the Project Explorer tool bar's Options button and verify
that Output Files Folder option is checked in the menu. Once checked, output files are shown in an Output Files
folder under the node that generates them. Click that folder's + symbol to expand the view of the output files.
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In the above figure, we see that the object files fact.hzo and main.hzo are object files produced
by compiling their corresponding source files; the map file Tutorial.map and the linked executable
Tutorial.hzx are produced by the linker. As a convenience, double-clicking an object file or a linked
executable file in the Project Explorer will open an editor showing the disassembled contents of the file.

Disassembling a project or file
You can disassemble a project either by double-clicking the corresponding file in the Project Explorer, as
described above, or by using the Disassemble tool.

To disassemble a project or file:
Right-click the appropriate project or file in the Project Explorer.
From the shortcut menu, choose Disassemble.
CrossWorks then opens a new read-only editor showing the disassembled listing. If you change your project
and rebuild it, thereby causing a change in the object or executable file, the disassembly updates to keep the
display's contents synchronized with the file on disk.
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Using Memory Usage Window features
The Memory Usage window can be used to view a graphical summary of how memory was used in each
memory segment of a linked application.

To display the memory usage:
Choose View > Memory Usage or press Ctrl+Alt+Z.
For the Tutorial project, the Memory Usage window shows this:

From this, you can see:
The RAM segment is located at 0200, is 2 KB in length, and has 1.9 KB of unused memory.
The FLASH segment is located at 1110, is 59.7 KB in length, and has 59.4 KB of unused memory.
If you expand the FLASH segment, CrossWorks will display the program sections contained within the segment:
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From this, you can see that the the CODE section is located at 114B and is 215 bytes in length.

Using Symbol Browser features
For a more-detailed view of how your application is laid out in memory than the Memory Usage window
provides, you can use the Symbol Browser. It allows you to navigate your application, see which data objects
and functions have been linked into your application, what their sizes are, which section they are in, and where
they are placed in memory.

To activate the Symbol Browser:
Choose Navigate > Symbol Browser or press Ctrl+Alt+Y.

Drilling down into the application
The Tutorial project shows this in the Symbol Browser:
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From this, you can see that the CODE section is 215 bytes in size and is placed in memory between address 114B
and 1221, inclusive. Similarly, the zeroed data section UDATA0 is 2 bytes in size and is placed between 0202
and 0203. The CONST section that holds string constants and read-only data is 25 bytes in size, and is located
between 1132 and 114A. To sort the sections by address, click on the column's Range header, or click Size to sort
them by their sizes.
To drill down, open the CODE node by double-clicking it: CrossWorks displays the individual functions that have
been placed in memory and their sizes:
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Here, we can see that main is 34 bytes in size and is placed in memory between addresses 114C and 116D,
inclusive, and that factorial is 30 bytes and occupies addresses 116E through 118B. Just as in the Project
Explorer, if you double-click a function, CrossWorks moves the cursor to the line containing the definition of that
function, so you can easily use the Symbol Browser to navigate around your application.

Printing Symbol Browser contents
You can print the contents of the Symbol Browser by selecting its window and choosing Print from the File
menu, or Print Preview if you want to see what it will look like before printing. CrossWorks prints only the
columns you have selected for display, and prints items in the order displayed in the Symbol Browser, so you
can choose which columns to print and how to print symbols by configuring the Symbol Browser display.
We have touched on only some of the features the Symbol Browser offers; to learn more, refer to Symbol
Browser, where it is described in detail.
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Using the debugger
Our sample application, which we have just compiled and linked, is now built and ready to run. In this section,
we'll concentrate on downloading and debugging this application, and on using the features of CrossWorks to
see how it performs.

Getting set up
Before running your application, you need to select the target to run it on. Choose Target > Targets to list in the
Targets window each target interface that is defined. You will use these to connect CrossWorks to a target. For
this tutorial, you'll be debugging on the simulator, not hardware, to simplify matters.

To connect to the simulator:
Choose Target > Connect > MSP430 Core Simulator.
or
Choose View > Targets to activate the Targets window.
In the Targets window, double-click MSP430 Core Simulator.
After connecting, the MSP430 Core Simulator target is shown in the status bar:

The color of the target-status LED in the status bar changes according to what CrossWorks and the target are
doing:
White No target is connected.
Yellow Target is connected.
Solid green Target is free running, not under control of CrossWorks or the debugger.
Flashing green Target is running under control of the debugger.
Solid red Target is stopped at a breakpoint or because execution is paused.
Flashing red CrossWorks is programming the application into the target.
Double-clicking the Target Status will show the Targets window, if it is not already visible.
The core simulator target can accurately count the cycles spent executing your application, so the status bar
shows a cycle counter. If you connect a target that cannot provide performance information, the cycle counter
panel is hidden. Double-clicking the Cycle Counter panel will reset the cycle counter to zero.
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Setting a breakpoint
CrossWorks will run a program until it hits a breakpoint. We'll place a breakpoint on the call to debug_printf
in main.c. To set the breakpoint, move the cursor to the line containing debug_printf and choose Debug >
Toggle Breakpoint or press F9.
Alternately, you can set a breakpoint without changing the cursor's position by clicking in the gutter of the line
to set the breakpoint on.

The gutter displays an icon on lines where breakpoints are set. The Breakpoints window updates to show where
each breakpoint is set and whether it's set, disabled, or invalidyou can find more detailed information in the
Breakpoints window section. The breakpoints you set are stored in a session file associated with the project, so
your breakpoints are remembered if you exit and re-run CrossWorks.

Starting the application
To start the application, choose Debug > Start or press F5.
The workspace will change from the standard Editing workspace to the Debugging workspace. You can choose
which windows to display in each of these workspaces and manage them independently. CrossWorks loads the
active project into the target and places the breakpoints you have set. During loading, the Target Log in the
Output Window shows its progress and any problems:
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The program stops at our breakpoint and a yellow arrow in the gutter indicates where the program is paused.

Step into the factorial function by selecting Debug > Step Into, by typing F11, or by clicking the Step Into
button on the Debug tool bar.
Now step to the first statement in the function by selecting Debug > Step Over, by typing F10, or by clicking the
Step Over button on the Debug tool bar.

87

CrossWorks for MSP430 Reference Manual

CrossStudio Tutorial

You can step out of a function by choosing Debug > Step Out, by typing Shift+F11, or by clicking the Step Out
button on the Debug tool bar. You can also step to a specific statement by choosing Debug > Run To Cursor. To
allow your application to run to the next breakpoint, choose Debug > Go.
Note that, when single-stepping, you may step into a function whose source code the debugger cannot locate.
In such cases, the debugger will display the instructions of the application; you can step out to get back to
source code or continue to debug at the instruction-code level. There may be cases in which the debugger
cannot display the instructions; in such cases, you will be informed of this with a dialog and you should step out.

Inspecting data
Being able to control execution isn't very helpful if you can't look at the values of variables, registers, and
peripherals. Hovering the mouse cursor over a variable will show its value as a data tip:
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You can configure CrossWorks to display data tips in a variety of formats at the same time using the
Environment Options dialog. You can also use the Autos, Locals, Globals, Watch, and Memory windows to view
variables and memory. These windows are described in CrossStudio User Guide.
The Call Stack window shows the function calls that have been made but have not yet finished executing, that is
the list of active functions.

To display the call stack:
Choose Debug > Call Stack or press Ctrl+Alt+S.

You can learn more about this in the Call Stack window section.
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Program output
The Tutorial application uses the function debug_printf to output a string to the Debug Terminal in the
Output window. The Debug Terminal appears automatically whenever something is written to itpress F5 to
continue program execution and you will notice that the Debug Terminal appears. In fact, the program runs
forever, writing the same messages over and over again. To pause the program, select Debug > Break or type
Ctrl+. (control-period).
In the next section, we'll cover low-level debugging at the machine level.
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Low-level debugging
This section describes how to debug your application at the register and instruction level. Debugging at a high
level is fine, but sometimes you need to look more closely into the way your program executes to track down the
causes of difficult-to-find bugs. CrossWorks provides the tools you need to do so.

Setting up again
Next, we'll run the sample application again and look at how it executes at the machine level. If you haven't done
so already, stop the program executing by typing Shift+F5, by selecting Debug > Stop, or by clicking the Stop
Debugging button on the Debug tool bar. Now, run the program until it stops at the first breakpoint again.
You can see the current processor state in the Register windows. To show the first Registers window:
Choose Debug > Other Windows > Registers > Registers 1 or press Ctrl+T, R, 1.
The Registers window can be used to view CPU and peripheral registers. First we shall look at just the CPU
registers. To do this, use the Registers 1 window's Register Groups menu to select CPU Registers.

Your registers window will look something like this:
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You can also use the registers window to display peripheral registers. To display the state of the target's
hardware multiplier registers, select Multiplier from the Register Groups menu.
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There are four register windows, so you can open and display four sets of CPU and peripheral registers at the
same time. You can configure which registers and peripherals to display in the Registers windows individually.
As you single-step the program, the contents of the Registers window updates and any change in a register
value is highlighted in red.
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Disassembly
The Disassembly window can be used to debug your program at the instruction level. It displays a disassembly
of the instructions around the currently located instruction, interleaved with the source code of the program, if
the source is available. When the Disassembly window has focus, all single-stepping is done one instruction at a
time. This window also allows you to set breakpoints by clicking in the gutter of lines containing instructions on
which you want to set a breakpoint.

Stopping and starting debugging
You can stop debugging using Debug > Stop or Shift+F5.
To restart debugging without reloading the program, you can use Debug > Debug From Reset. Note
that, when you debug from reset, no loading takes place; it is expected that your program resets any data
values as necessary as part of its startup.
You can attach the debugger to a running target, other than a simulator, using Target > Attach
Debugger.
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Debugging externally built applications
This section describes how to debug applications that were not built by CrossWorks. To keep things simple, we
shall use the application we just built as our externally built application.
Start by creating a new, externally built executable project:
Choose File > New Project or press Ctrl+Shift+N.
The New Project dialog appears. It displays the set of project types and project templates.

We'll create an externally built executable project:
In the Categories pane, select the Standard > Externally Built Executable project type.
In the Project Templates pane, select the An externally built executable icon, which selects the type of
project to add.
Type Externally_Built_Tutorial in the Name field, which names the project.
You can use the Location field or the Browse button to locate where you want the project to be created.
Click OK.
Once created, the project-setup wizard prompts you for the executable file you want to use.
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In the Executable File field, type the path to the Tutorial.hzx executable file we generated earlier. For
example, if the project was created in the C:/CrossWorks Projects/Tutorial directory and was built
using the MSP430 Debug configuration, the path to the executable file will be C:/CrossWorks Projects/
Tutorial/MSP430 Debug/Tutorial.hzx.
Clicking Next displays the configurations that will be added to the project.
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Complete the project creation by clicking Finish.
You will be prompted as to whether you want to overwrite the existing memory map and target script. Click No
to keep the existing files.
Now you have created the externally built executable project. You should be able to use the debugger just as we
did earlier in the tutorial.
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CrossStudio User Guide
This is the user guide for the CrossStudio integrated development environment (IDE). The CrossStudio IDE
consists of:
a project system to organize your source files
a build system to build your applications
programmer aids to navigate and work effectively
a target programmer to download applications into RAM or flash
a debugger to pinpoint bugs
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CrossStudio standard layout
CrossStudio's main window is divided into the following areas:
Title bar:Displays the name of the current solution.
Menu bar:Menus for editing, building, and debugging your program.
Toolbars:Frequently used actions are quickly accessible on toolbars below the menu bar.
Editing area:A tabbed view of any open editor windows and the HTML viewer.
Docked windows:CrossStudio has many windows that dock to the left, right, or below the editing area.
You can configure which windows will be visible, and their placement, when editing and debugging.
Status bar At the bottom of the main window, the status bar contains useful information about the
current editor, build status, and debugging environment.
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Menu bar
The menu bar contains menus for editing, building, and debugging your program. You can navigate menus
using the keyboard or the mouse.

Navigating menus using the mouse
To navigate menus using the mouse:
1. Click a menu title in the menu bar to show the related menu.
2. Click the desired command in the menu to execute that command.
or
1. Click and hold the mouse on a menu title in the menu bar to show the related menu.
2. Drag the mouse to the desired command in the menu.
3. Release the mouse while it is over the command to execute that command.

Navigating menus with the keyboard
To navigate menus using the keyboard:
1. Tap the Alt key activate the menu bar.
2. Tap Return to display the menu.
3. Use the Left and Right keys to select the required menu.
4. Use the Up or Down key to select the required command or submenu.
5. Press Enter to execute the selected command.
6. Press Alt or Esc at any time to cancel menu selection.
After you press the Alt key once, each menu on the menu bar has one letter underlinedits shortcut key. So, to
activate a menu using the keyboard:
While holding down the Alt key, type the desired menu's shortcut key.
After the menu appears, you can navigate it using the cursor keys:
Use Up and Down to move up and down the list of menu items.
Use Esc to cancel a menu.
Use Right or Enter to open a submenu.
Use Left or Esc to close a submenu and return to the parent menu.
Type the underlined letter in a command's name to execute that command.
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Title bar
The first item shown in the title bar is CrossStudio's name. Because CrossStudio can be used to target different
processors, the name of the target processor family is also shown, to help you distinguish between instances of
CrossStudio when debugging multi-processor or multi-core systems.
The filename of the active editor follows CrossStudio's name; you can configure the presentation of this filename
as described below.
After the filename, the title bar displays status information on CrossStudio's state:
[building] CrossStudio is building a solution, building a project, or compiling a file.
[run] An application is running under control of CrossStudio's debugger.
[break] The debugger is stopped at a breakpoint.
[autostep] The debugger is single stepping the application without user interaction (autostepping).
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Status bar
At the bottom of the window, the status bar contains useful information about the current editor, build status,
and debugging environment. The status bar is divided into two regions: one contains a set of fixed panels and
the other is used for messages.

The message area
The leftmost part of the status bar is a message area used for things such as status tips, progress information,
warnings, errors, and other notifications.

Status bar panels
You can show or hide the following panels on the status bar:
Panel

Description

Target device status

Displays the connected target interface. When
connected, this panel contains the selected target
interface's name and, if applicable, the processor to
which the target interface is connected. The LED icon
flashes green when a program is running, is solid red
when stopped at a breakpoint, and is yellow when
connected to a target but not running a program.
Double-clicking this panel displays the Targets pane,
and right-clicking it invokes the Target shortcut menu.

Cycle count panel

Displays the number of processor cycles used by the
executing program. This panel is only visible if the
connected target supports performance counters
that can report the total number of cycles executed.
Double-clicking this panel resets the cycle counter to
zero, and right-clicking it brings up the Cycle Count
shortcut menu.

Insert/overwrite status

Indicates whether the current editor is in insert or
overwrite mode. In overwrite mode, the panel displays
"OVR"; in insert mode, the panel displays "INS".

Read-only status

Indicates whether the editor is in read-only mode. If
the editor is editing a read-only file or is in read-only
mode, the panel display "R/O"; if the editor is in readwrite mode, the panel displays "R/W".

Build status

Indicates the success or failure of the last build. If
the last build completed without errors or warnings,
the build status pane contains Built OK; otherwise, it
contains the number of errors and warnings reported.
If there were errors, double-clicking this panel displays
the Build Log in the Output pane.
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Caret position

Indicates the insertion position position in the editor
window. For text files, the caret position pane displays
the line number and column number of the insertion
point in the active window; when editing binary files, it
displays the address being edited.

Time panel

Displays the current time.

Configuring the status bar panels
To configure which panels are shown on the status bar:
Choose View > Status Bar.
From the status bar menu, select the panels to display and deselect the ones you want hidden.
or
Right-click the status bar.
From the status bar menu, select the panels to display and deselect the ones you want to hide.

To show or hide the status bar:
Choose View > Status Bar.
From the status bar menu, select or deselect the Status Bar item.
You can choose to hide or display the size grip when CrossStudio's main window is not maximized. (The size grip
is never shown in full-screen mode or when maximized.)

To show or hide the size grip
Choose View > Status Bar.
From the status bar menu, select or deselect the Size Grip item.
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Editing workspace
The main area of CrossStudio is the editing workspace. It contains any files being edited, the on-line help
system's HTML browser, and the Dashboard.
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Docking windows
CrossStudio has a flexible docking system you can use to position windows as you like them. You can dock
windows in the CrossStudio window or in the four head-up display windows. CrossStudio will remember the
position of the windows when you leave the IDE and will restore them when you return.

Window groups
You can organize CrossStudio windows into window groups. A window group has multiple windows docked
in it, only one of which is active at a time. The window group displays the active window's title for each of the
windows docked in the group.
Clicking on the window icons in the window group's header changes the active window. Hovering over a
docked window's icon in the header will display that window's title in a tooltip.

To dock a window to a different window group:
Press and hold the left mouse button over the title of the window you wish to move.
As you start dragging, all window groups, including hidden window groups, become visible.
Drag the window over the window group to dock in.
Release the mouse button.
Holding Ctrl when moving the window will prevent the window from being docked. If you do not dock a
window on a window group, the window will float in a new window group.

Perspectives
CrossStudio remembers the dock position and visibility of each window in each perspective. The most common
use for this is to lay your windows out in the Standard perspective, which is the perspective used when you are
editing and not debugging. When CrossStudio starts to debug a program, it switches to the Debug perspective.
You can now lay out your windows in this perspective and CrossStudio will remember how you laid them them
out. When you stop debugging, CrossStudio will revert to the Standard perspective and that window layout for
editing; when you return to Debug perspective on the next debug session, the windows will be restored to how
you laid them out in that for debugging.
CrossStudio remembers the layout of windows, in all perspectives, such that they can be restored when you run
CrossStudio again. However, you may wish to revert back to the standard docking positions; to do this:
Choose Window > Reset Window Layout.
Some customers are accustomed to having the Project Explorer on the left or the right, depending upon which
version of Microsoft Visual Studio they commonly use. To quickly switch the CrossStudio layout to match your
preferred Visual Studio setup:
Choose Window > Reverse Workspace Layout.
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Dashboard
When CrossStudio starts, it presents the Dashboard, a collection of panels that provide useful information, oneclick loading of recent projects, and at-a-glance summaries of activity relevant to you.

Tasks
The Tasks panel indicates tasks you need to carry out before CrossWorks is fully functionalfor instance, whether
you need to activate CrossWorks, install packages, and so on.

Updates
The Updates panel indicates whether any packages you have installed are now out of date because a newer
version is available. You can install each new package individually by clicking the Install button under each
notification, or install all packages by clicking the Install all updates link at the bottom of the panel.

Projects
The Projects panel contains links to projects you have worked on recently. You can load a project by clicking the
appropriate link, or clear the project history by clicking the Clear List button. To manage the contents of the list,
click the Manage Projects link and edit the list of projects in the Recent Projects window.

News
The News panel summarizes the activity of any RSS and Atom feeds you have subscribed to. Clicking a link will
display the published article in an external web browser. You can manage your feed subscriptions to by clicking
the Manage Feeds link at the end of the News panel and pinning the feeds in the Favorites windowyou are only
subscribed to the pinned feeds.

Links
The Links panel is a handy set of links to your favorite websites. If you pin a link in the Favorites window, it
appears in the Links panel.
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CrossStudio help and assistance
CrossStudio provides context-sensitive help in increasing detail:

Tooltips
When you position the pointer over a button and keep it still, a small window displays a brief description of
the button and its keyboard shortcut, if it has one.

Status tips
In addition to tooltips, CrossStudio provides a longer description in the status bar when you hover over a
button or menu item.

Online manual
CrossStudio has links from all windows to the online help system.

The browser
Documentation pages are shown in the Browser.

Help using CrossStudio
CrossStudio provides an extensive, HTML-based help system that is available at all times.

To view the help text for a particular window or other user-interface element:
Click to select the item with which you want assistance.
Choose Help > Help or press F1.

Help within the text editor
The text editor is linked to the help system in a special way. If you place the insertion point within a word and
press F1, the help-system page most likely to be useful is displayed in the HTML browser. This a great way to
quickly find the help text for functions provided in the library.

Browsing the documentation
The Contents window lists all the topics in the CrossWorks documentation and gives a way to search through
them.
The highlighted entry indicates the current help topic. When you click a topic, the corresponding page appears
in the Browser window.
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The Next Topic and Previous Topic items in the Help menu, or the buttons on the Contents window toolbar,
help navigate through topics.
To search the online documentation, type a search phrase into the Search box on the Contents window toolbar.

To search the online documentation:
Choose Help > Contents or press Ctrl+Alt+F1.
Enter your search phrase in the Search box and press Enter (or Return on Macs).
The search commences and the table of contents is replaced by links to pages matching your query, listed in
order of relevance. To clear the search and return to the table of contents, click the clear icon in the Search box.
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Creating and managing projects
A CrossStudio project is a container for everything required to build your applications. It contains all the assorted
resources and maintains the relationships between them.
A project is a convenient place to find every file and piece of information associated with your work. You place
projects into a solution, which can contain one or more projects.
This chapter introduces the various parts of a project, shows how to create projects, and describes how to
organize the contents of a project. It describes how to use the Project Explorer and Project Manager for projectmanagement tasks.
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Solutions and projects
To develop a product using CrossStudio, you must understand the concepts of projects and solutions.
A project contains and organizes everything you need to create a single application or a library.
A solution is a collection of projects and configurations.
Organizing your projects into a solution allows you to build all the projects in a solution with a single keystroke,
and to load them onto the target ready for debugging.
In your CrossWorks project, you
organize build-system inputs for building a product.
add information about items in the project, and their relationships, to assist you in the development
process.
Projects in a solution can reside in the same or different directories. Project directories are always relative to the
directory of the solution file, which enables you to more-easily move or share project-file hierarchies.
The Project Explorer organizes your projects and files, and provides quick access to the commands that operate
on them. A toolbar at the top of the window offers quick access to commonly used commands.

Solutions
When you have created a solution, it is stored in a project file. Project files are text files, with the file extension
hzp, that contain an XML description of your project. See Project file format for a description of the project-file
format.

Projects
The projects you create within a solution have a project type CrossStudio uses to determine how to build the
project. The project type is selected when you use the New Project dialog. The available project types depend
on the CrossWorks variant you are using, but the following are present in most CrossWorks variants:
Executable: a program that can be loaded and executed.
Externally Built Executable: an executable that is not built by the CrossWorks internal build process.
Library: a group of object files collected into a single file (sometimes called an archive).
Externally Built Library: a library that is not built by the CrossWorks internal build process.
Object File: the result of a single compilation.
Staging: a project that will apply a user-defined command to each file in a project.
Combining: a project that can be used to apply a user-defined command when any files in a project have
changed.
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Project properties and configurations
Project properties are attached to project nodes. They are usually used in the build process, for example, to
define C preprocessor symbols. You can assign different values to the same property, based on a configuration:
for example, you can assign one value to a C preprocessor symbol for release build and a different value for a
debug build.

Folders and Dynamic Folders
Projects can contain folders, which are used to group related files. Automated grouping uses the files' extensions
to, for example, put all .c files in one folder, etc. Grouping also can be done manually by explicitly creating a
file within a folder. Note that these project folders do not map onto directories in the file system, they are used
solely to structure the display of content shown in the Project Explorer.
Projects can also contain dynamic folders which will can show the directories and files contained in the file
system in the project explorer. You can specify if the dynamic folder is recursive and use wildcards to include and
exclude files.

Source files
Source files are all the files used to build a product. These include source code files and also section-placement
files, memory-map files, and script files. All the source files you use for a particular product, or for a suite of
related products, are managed in a CrossStudio project. A project can also contain files that are not directly used
by CrossStudio to build a product but contain information you use during development, such as documentation.
You edit source files during development using CrossStudio's built-in text editor, and you organize files into a
target (described next) to define the build-system inputs for creating the product.
The source files of your project can be placed in folders or directly in the project. Ideally, the paths to files
placed in a project should be relative to the project directory, but at times you might want to refer to a file in an
absolute location and this is supported by the project system.
When you add a file to a project, the project system detects whether the file is in the project directory. If a
file is not in the project directory, the project system tries to make a relative path from the file to the project
directory. If the file isn't relative to the project directory, the project system detects whether the file is relative to
the $(StudioDir) directory; if so, the filename is defined using $(StudioDir). If a file is not relative to the project
directory or to $(StudioDir), the full, absolute pathname is used.
The project system will allow (with a warning) duplicate files to be put into a project.
The project system uses a file's extension to determine the appropriate build action to perform on the file:
A file with the extension .c will be compiled by a C compiler.
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A file with the extension .s or .asm will be compiled by an assembler.
A file with the object-file extension .hzo will be linked.
A file with the library-file extension .hza will be linked.
A file with the extension .xml will be opened and its file type determined by the XML document type.
Files with other file extensions will not be compiled or linked.
You can modify this behavior by setting a file's File Type property with the Common configuration selected in
the Properties window, which enables files with non-standard extensions to be compiled by the project system.

Externally Built Executables
You can use an external build process for Externally Built Executable project types by setting the Build
Command project property, for example to make target. Alternatively you can set command lines for specific
build steps to compile/assemble and link. When you create an Externally Built Executable project type
configurations will be created that create command lines for a variety of external tool chains.

Solution links
You can create links to existing project files from a solution, which enables you to create hierarchical builds. For
example, you could have a solution that builds a library together with a stub test driver executable. You can
link to that solution from your current solution by right-clicking the solution node of the Project Explorer and
selecting Add Existing Project. Your current solution can then use the library built by the other project.

Session files
When you exit CrossWorks, details of your current session are stored in a session file. Session files are text files,
with the file extension hzs, that contain details such as which files you have opened in the editor and what
breakpoints you have set in the Breakpoint window.
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Creating a project
You can create a new solution for each project or place multiple projects in an existing solution.

To create a new project in an existing solution:
1. Choose Project > Add New Project.
2. In the New Project wizard, select the type of project you wish to create and specify where it will be
placed.
3. Ensure that Add the project to current solution is checked.
4. Click OK to go to next stage or Cancel to cancel the project's creation.
The project name must be unique to the solution and, ideally, the project directory should be relative to the
solution directory. The project system will use the project directory as the current directory when it builds your
project. Once complete, the Project Explorer displays the new solution, project, and files contained in the
project. To add another project to the solution, repeat the above steps.

To create a new project in a new solution:
1. Choose File > New Project or press Ctrl+Shift+N.
2. Select the type of project you wish to create and where it will be placed.
3. Click OK.
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Adding existing files to a project
You can add existing files to a project in a number of ways.

To add existing files to the active project:
Choose Project > Add Existing File or press Ctrl+P, A.
Using the Open File dialog, navigate to the directory containing the files and select the ones you wish to add to
the project.
Click OK.
The selected files are added to the folders whose filter matches the extension of each of the files. If no filter
matches a file's extension, the file is placed underneath the project node.

To add existing files to a specific project:
1. In the Project Explorer, right-click the project to which you wish to add a new file.
2. Choose Add Existing File.

To add existing files to a specific folder:
1. In the Project Explorer, right-click the folder to which you wish to add a new file.
2. Choose Add Existing File.
The files are added to the specified folder without using filter matching.

To create a dynamic folder:
1. In the Project Explore, right click on the project to which you wish to add a new folder.
2. Choose New Folder....
3. Using the New Folder dialog name the folder and then show the dynamic folder options.
4. Specify the required Source Folder and the Filter Specification.
The files that match the filter specification in the source folder will appear in the newly created folder.
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Adding new files to a project
You can add new files to a project in a number of ways.

To add new files to the active project:
Choose Project > Add New File or press Ctrl+N.

To add a new file to a project:
1. In the Project Explorer, right-click the project to which you wish to add a new file.
2. Choose Add New File.
When adding a new file, CrossStudio displays the New File dialog, from which you can choose the type of file
to add, its filename, and where it will be stored. Once created, the new file is added to the folder whose filter
matches the extension of the newly added file. If no filter matches the newly added file extension, the new file is
placed underneath the project node.

To add new files to a folder:
1. In the Project Explorer, right-click the folder to which you wish to add a new file.
2. Choose Add New File.
The new file is added to the folder without using filter matching.
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Removing a file, folder, project, or project link
You can remove whole projects, folders, or files from a project, or you can remove a project from a solution,
using the Remove button on the Project Explorer toolbar. Note that removing a source file from a project does
not remove it from disk.

To remove an item from the solution:
1. In the Project Explorer, select the item to remove.
2. Choose Edit > Delete or press Del.
or
1. In the Project Explorer, right-click the item to remove.
2. Choose Remove.
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Building your application
CrossStudio builds your application using the resources and build rules it finds in your solution.
When CrossStudio builds your application, it tries to avoid building files that have not changed since they were
last built. It does this by comparing the modification dates of the generated files with the modification dates of
the dependent files together with the modification dates of the properties that pertain to the build. But if you
are copying files, sometimes the modification dates may not be updated when the file is copiedin this instance,
it is wise to use the Rebuild command rather than the Build command.
You can see the build rationale CrossStudio currently is using by setting the Environment Options > Building
> Show Build Information property. To see the build commands themselves, set the Environment Options >
Building > Echo Build Command property.
You may have a solution that contains several interdependent projects. Typically, you might have several
executable projects and some library projects. The Project Dependencies dialog specifies the dependencies
between projects and to see the effect of those dependencies on the solution build order. Note that
dependencies can be set on a per-configuration basis, but the default is for dependencies to be defined in the
Common configuration.
You will also notice that a new folder titled Dependencies has appeared in the Project Explorer. This folder
contains the list of newly generated files and the files from which they were generated. To see if one of files
can be decoded and displayed in the editor, right-click the file to see if the View command is available on the
shortcut menu.
If you have the Symbols window open, it will be updated with the symbol and section information of all
executable files built in the solution.
When CrossStudio builds projects, it uses the values set in the Properties window. To generalize your builds, you
can define macro values that are substituted when the project properties are used. These macro values can be
defined globally at the solution and project level, and can be defined on a per-configuration basis.
The combination of configurations, properties with inheritance, dependencies, and macros provides a very
powerful build-management system. However, such systems can become complicated. To understand the
implications of changing build settings, right-click a node in the Project Explorer and select Properties to view a
dialog that shows which macros and build steps apply to that project node.

To build all projects in the solution:
1. Choose Build > Build Solution or press Shift+F7.
or
1. Right-click the solution in the Project Explorer window.
2. Choose Build from the shortcut menu.
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To build a single project:
1. Select the required project in the Project Explorer.
2. Choose Build > Build or press F7.
or
1. Right-click the project in the Project Explorer.
2. Choose Build.

To compile a single file:
1. In the Project Explorer, click to select the source file to compile.
2. Choose Build > Compile or press Ctrl+F7.
or
1. In the Project Explorer, right-click the source file to compile.
2. Choose Compile from the shortcut menu.

Correcting errors after building
The results of a build are recorded in a Build Log that is displayed in the Output window. Errors are highlighted
in red, warnings are highlighted in yellow. Double-clicking an error, warning, or note will move the insertion
point to the line of source code that triggered that log entry.
You can move forward and backward through errors using Search > Next Location and Search > Next Location.
When you build a single project in a single configuration, the Transcript will display the memory used by the
application and a summary for each memory area.
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Creating variants using configurations
CrossStudio provides a facility to build projects in various configurations. Project configurations are used to
create different software builds for your projects.
A configuration defines a set of project property values. For example, the output of a compilation can be put
into different directories, dependent upon the configuration. When you create a solution, some default project
configurations are created.

Build configurations and their uses
Configurations are typically used to differentiate debug builds from release builds. For example, the compiler
options for debug builds will differ from those of a release build: a debug build will set options so the project can
be debugged easily, whereas a release build will enable optimization to reduce program size or to increase its
speed. Configurations have other uses; for example, you can use configurations to produce variants of software,
such as custom libraries for several different hardware variants.
Configurations inherit properties from other configurations. This provides a single point of change for definitions
common to several configurations. A particular property can be overridden in a particular configuration to
provide configuration-specific settings.
When a solution is created, two configurations are generated Debug and Release and you can create additional
configurations by choosing Build > Build Configurations. Before you build, ensure that the appropriate
configuration is set using Build > Set Active Build Configuration or, alternatively, the Active Configuration
combo box in the Project Explorer. You should also ensure that the appropriate build properties are set in the
Properties window.

Selecting a configuration
To set the configuration that affects your building and debugging, use the combo box in the Project Explorer or
select Build > Set Active Build Configuration

Creating a configuration
To create your own configurations, select Build > Build Configurations to invoke the Configurations dialog. The
New button will produce a dialog allowing you to name your configuration. You can now specify the existing
configurations from which your new configuration will inherit values.

Deleting a configuration
You can delete a configuration by selecting it and clicking the Remove button. This deletion cannot be undone
or canceled, so beware.
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Private configurations
Some configurations are defined purely for inheriting and, as such, should not appear in the Build combo box.
When you select a configuration in the Configuration dialog, you can choose to hide that configuration.
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Project properties
For solutions, projects, folders, and files, properties can be defined that are used by the project system in
the build process. These property values can be viewed and modified by using the Properties window in
conjunction with the Project Explorer. As you select items in the Project Explorer, the Properties window will
list the set of relevant properties.
Some properties are only applicable to a given item type. For example, linker properties are only applicable to
a project that builds an executable file. However, other properties can be applied either at the file, project, or
solution project node. For example, a compiler property can be applied to a solution, project, or individual file.
By setting a property at the solution level, you enable all files of the solution to use that property's value.

Unique properties
A unique property has one value. When a build is done, the value of a unique property is the first one defined
in the project hierarchy. For example, the Treat Warnings As Errors property could be set to Yes at the solution
level, which would then be applicable to every file in the solution that is compiled, assembled, and linked. You
can then selectively define property values for other project items. For example, a particular source file may have
warnings you decide are allowable, so you set the Treat Warnings As Errors to No for that particular file.
Note that, when the Properties window displays a project property, it will be shown in bold if it has been
defined for unique properties. The inherited or default value will be shown if it hasn't been defined.
solution Treat Warnings As Errors = Yes
project1 Treat Warnings As Errors = Yes
file1 Treat Warnings As Errors = Yes
file2 Treat Warnings As Errors = No
project2 Treat Warnings As Errors = No
file1 Treat Warnings As Errors = No
file2 Treat Warnings As Errors = Yes

In the above example, the files will be compiled with these values for Treat Warnings As Errors:
project1/file1

Yes

project1/file2

No

project2/file1

No

project2/file2

Yes

Aggregate properties
An aggregating property collects all the values defined for it in the project hierarchy. For example, when a C
file is compiled, the Preprocessor Definitions property will take all the values defined at the file, project, and
solution levels. Note that the Properties window will not show the inherited values of an aggregating property.
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solution Preprocessor Definitions = SolutionDef
project1 Preprocessor Definitions =
file1 Preprocessor Definitions =
file2 Preprocessor Definitions = File1Def
project2 Preprocessor Definitions = ProjectDef
file1 Preprocessor Definitions =
file2 Preprocessor Definitions = File2Def

In the above example, the files will be compiled with these preprocessor definitions:
project1/file1

SolutionDef

project1/file2

SolutionDef, File1Def

project2/file1

SolutionDef, ProjectDef

project2/file2

SolutionDef, ProjectDef, File2Def
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Configurations and property values
Property values are defined for a configuration so you can have different values for a property for different
builds. A given configuration can inherit the property values of other configurations. When the project system
requires a property value, it checks for the existence of the property value in current configuration and then in
the set of inherited configurations. You can specify the set of inherited configurations using the Configurations
dialog.
A special configuration named Common is always inherited by a configuration. The Common configuration
allows you to set property values that will apply to all configurations you create. You can select the Common
configuration using the Configurations combo box of the properties window. If you are modifying a property
value of your project, you almost certainly want each configuration to inherit it, so ensure that the Common
configuration is selected.
If the property is unique, the build system will use the one defined for the particular configuration. If the
property isn't defined for this configuration, the build system uses an arbitrary one from the set of inherited
configurations.
If the property is still undefined, the build system uses the value for the Common configuration. If it is still
undefined, the build system tries to find the value in the next higher level of the project hierarchy.
solution [Common]
solution [Debug]
solution [Release]

Preprocessor Definitions = CommonSolutionDef
Preprocessor Definitions = DebugSolutionDef
Preprocessor Definitions = ReleaseSolutionDef

project1 - Preprocessor Definitions =
file1 - Preprocessor Definitions =
file2 [Common]
file2 [Debug]
project2 [Common]
file1

Preprocessor Definitions = CommonFile1Def
Preprocessor Definitions = DebugFile1Def
Preprocessor Definitions = ProjectDef

Preprocessor Definitions =

file2 [Common] - Preprocessor Definitions = File2Def

In the above example, the files will be compiled with these preprocessor definitions when in Debug
configuration
File

Setting

project1/file1

CommonSolutionDef, DebugSolutionDef

project1/file2

CommonSolutionDef,
DebugSolutionDef,CommonFile1Def, DebugFile1Def

project2/file1

CommonSolutionDef, DebugSolutionDef, ProjectDef
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ComonSolutionDef, DebugSolutionDef, ProjectDef,
File2Def

and the files will be compiled with these Preprocessor Definitions when in Release configuration:
File

Setting

project1/file1

CommonSolutionDef, ReleaseSolutionDef

project1/file2

CommonSolutionDef, ReleaseSolutionDef,
CommonFile1Def

project2/file1

CommonSolutionDef, ReleaseSolutionDef, ProjectDef

project2/file2

ComonSolutionDef, ReleaseSolutionDef, ProjectDef,
File2Def
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Project macros
You can use macros to modify the way the project system refers to files.
Macros are divided into four classes:
System macros defined by CrossStudio relay information about the environment, such as paths to
common directories.
Global macros are saved in the environment and are shared across all solutions and projects. Typically,
you would set up paths to libraries and any external items here.
Project macros are saved as project properties in the project file and can define values specific to the
solution or project in which they are defined.
Build macros are generated by the project system when you build your project.

System macros
System macros are defined by CrossStudio itself and as such are read-only. System macros can be used in project
properties, environment settings and to refer to files. See System macros list for the list of System macros.

Global macros
Global macros are store in the environment option Global Macros.

To define a global macro:
1. Use Tools > Options to show the environment options dialog.
2. In the Environment Options dialog's Building group, select the Global Macros property.
3. Click the ellipsis button on the right.
4. Set the macro using the syntax name = replacement text.

Project macros
To define a project macro:
You can set the project macros from the Properties window:
1. Select the appropriate solution/project in the Project Explorer.
2. In the Properties window's General Options group, select the Macros property.
3. Click the ellipsis button on the right.
4. Set the macro using the syntax name = replacement text.
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Build macros
Build macros are defined by the project system for a build of a given project node. See Build macros list for the
list of build macros.

Using macros
You can use a macro for a project property or environment setting by using the $(macro) syntax. For example,
the Object File Name property has a default value of $(IntDir)/$(InputName)$(OBJ).
You can also specify a default value for a macro if it is undefined using the $(macro:default) syntax. For example,
$(MyMacro:0) would expand to 0 if the macro MyMacro has not been defined.
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Dependencies and build order
You can set up dependency relationships between projects using the Project Dependencies dialog. Project
dependencies make it possible to build solutions in the correct order and, where the target permits, to load
and delete applications and libraries in the correct order. A typical usage of project dependencies is to make
an executable project dependent upon a library executable. When you elect to build the executable, the build
system will ensure that the library it depends upon is up to date. In the case of a dependent library, the output
file of the library build is supplied as an input to the executable build, so you don't have to worry about it.
Project dependencies are stored as project properties and, as such, can be defined differently based upon the
selected configuration. You almost always want project dependencies to be independent of the configuration,
so the Project Dependencies dialog selects the Common configuration by default.

To make one project dependent upon another:
1. Choose Project > Project Dependencies.
2. From the Project dropdown, select the target project that depends upon other projects.
3. In the Depends Upon list box, select the projects the target project depends upon and deselect the
projects it does not depend upon.
Some items in the Depends Upon list box may be dimmed, indicating that a circular dependency would
result if any of those projects were selected. In this way, CrossStudio prevents you from constructing circular
dependencies using the Project Dependencies dialog.
If your target supports loading multiple projects, the Build Order also reflects the order in which projects are
loaded onto the target. Projects will load, in order, from top to bottom. Generally, libraries need to be loaded
before the applications that use them, and you can ensure this happens by making the application dependent
upon the library. With this dependency set, the library gets built and loaded before the application does.
Applications are deleted from a target in reverse of their build order; in this way, applications are removed
before the libraries on which they depend.
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Linking and section placement
Executable programs consist of a number of sections. Typically, there are program sections for code, initialized
data, and zeroed data. There is often more than one code section and they must be placed at specific addresses
in memory.
To describe how the program sections of your program are positioned in memory, the CrossWorks project
system uses memory-map files and section-placement files. These XML-formatted files are described in Memory
Map file format and Section Placement file format. They can be edited with the CrossWorks text editor. The
memory-map file specifies the start address and size of target memory segments. The section-placement file
specifies where to place program sections in the target's memory segments. Separating the memory map from
the section-placement scheme enables a single hardware description to be shared across projects and also
enables a project to be built for a variety of hardware descriptions.
For example, a memory-map file representing a device with two memory segments called FLASH and SRAM
could look something like this in the memory-map editor.
<Root name="Device1">
<MemorySegment name="FLASH" start="0x10000000" size="0x10000" />
<MemorySegment name="SRAM" start="0x20000000" size="0x1000" />

A corresponding section-placement file will refer to the memory segments of the memory-map file and will
list the sections to be placed in those segments. This is done by using a memory-segment name in the sectionplacement file that matches the corresponding memory-segment name in the memory-map file.
For example, a section-placement file that places a section called .stack in the SRAM segment and the .vectors
and .text sections in the FLASH segment would look like this:
<Root name="Flash Section Placement">
<MemorySegment name="FLASH" >
<ProgramSection name=".vectors" load="Yes" />
<ProgramSection name=".text" load="Yes" />
</MemorySegment>
<MemorySegment name="SRAM" >
<ProgramSection name=".stack" load="No" />
</MemorySegment>
</Root>

Note that the order of section placement within a segment is top down; in this example .vectors is placed at
lower addresses than .text.
The memory-map file and section-placement file to use for linkage can be included as a part of the project or,
alternatively, they can be specified in the project's linker properties.
You can create a new program section using either the assembler or the compiler. For the C compiler, this can be
achieved using one of the #pragma directives. For example:
#pragma codeseg(".foo")
void foobar(void);
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#pragma codeseq(default)

This will allocate foobar in the section called .foo. Alternatively, you can specify the names for the code,
constant, data, and zeroed-data sections of an entire compilation unit by using the Section Options properties.
You can now place the section into the section placement file using the editor so that it will be located after the
vectors sections as follows:
<Root name="Flash Section Placement">
<MemorySegment name="FLASH">
<ProgramSection name=".vectors" load="Yes" />
<ProgramSection name=".foo" load="Yes" />
<ProgramSection name=".text" load="Yes" />
</MemorySegment>
<MemorySegment name="SRAM">
<ProgramSection name=".stack" load="No" />
</MemorySegment>
</Root>

If you are modifying a section-placement file that is supplied in the CrossWorks distribution, you will need to
import it into your project using the Project Explorer.
Sections containing code and constant data should have their load property set to Yes. Some sections don't
require any loading, such as stack sections and zeroed-data sections; such sections should have their load
property set to No.
You can specify that initialization data is stored in the default program section using the INIT directive, and you
can refer to the start and end of the section using the SFE and SFB directives. If, for example, you create a new
data section called IDATA2, you can store this in the program by putting the following into the startup code:
_data2_init_begin::
INIT "IDATA2"
_data2_init_end::

You can then use these symbols to copy the stored section information into the data section using (an assemblycoded version of):
/* Section image located in flash */
extern const unsigned char data2_init_begin[];
extern const unsigned char data2_init_end[];
memcpy(SFB(IDATA2), data2_init_begin, data2_init_end-data2_init_end)
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Using source control
Source control is an essential tool for individuals or development teams. CrossStudio integrates with several
popular source-control systems to provide this feature for files in your CrossWorks projects.
Source-control capability is implemented by a number of third-party providers, but the set of functions provided
by CrossWorks aims to be provider independent.
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Source control capabilities
The source-control integration capability provides:
Connecting to the source-control repository and mapping files in the CrossWorks project to those in
source control.
Showing the source-control status of files in the project.
Adding files in the project to source control.
Fetching files in the project from source control.
Optionally locking and unlocking files in the project for editing.
Comparing a file in the project with the latest version in source control.
Updating a file in the project by merging changes from the latest version in source control.
Committing changes made to project files into source control.
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Configuring source-control providers
CrossStudio supports Subversion, Git, and Mercurial as source-control systems. To enable CrossStudio to utilize
source-control features, you need to install, on your operating system, the appropriate command line client for
the source-control systems that you will use.
Once you have installed the command line client, you must configure CrossStudio to use it.

To configure Subversion:
1. Choose Tools > Options or press Alt+,.
2. Select the Source Control category in the options dialog.
3. Set the Executable property of the Subversion Options group to point to Subversion svn command. On
Windows operating systems, the Subversion command is svn.exe.

To configure Git:
1. Choose Tools > Options or press Alt+,.
2. Select the Source Control category in the options dialog.
3. Set the Executable property of the Git Options group to point to Git git command. On Windows
operating systems, the Git command is git.exe.

To configure Mercurial:
1. Choose Tools > Options or press Alt+,.
2. Select the Source Control category in the options dialog.
3. Set the Executable property of the Mercurial Options group to point to Git hg command. On Windows
operating systems, the Git command is hg.exe.
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Connecting to the source-control system
When CrossStudio loads a project, it examines the file system folder that contains the project to determine the
source-control system the project uses. If CrossStudio cannot determine, from the file system, the source-control
system in use, it disables source-control integration.
That is, if you have not set up the paths to the source-control command line clients, even if a working copy exists
and the appropriate command line client is installed, CrossStudio cannot establish source-control integration for
the project.

User credentials
You can set the credentials that the source-control system uses, for commands that require credentials, using
VCS > Options > Configure. From here you can set the user name and password. These details are saved to the
session file (the password is encrypted) so you won't need to specify this information each time the project is
loaded.

Note
CrossStudio has no facility to create repositories from scratch, nor to clone, pull, or checkout repositories to
a working copy: it is your responsibility to create a working copy outside of CrossStudio using your selected
command-line client or Windows Explorer extension.
The "Tortoise" products are a popular set of tools to provide source-control facilities in the Windows shell. Use
Google to find TortoiseSVN, TortoiseGit, and TortoiseHG and see if you like them.
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File source-control status
Determining the source-control status of a file can be expensive for large repositories, so CrossWorks updates
the source-control status in the background. Priority is given to items that are displayed.
A file will be in one of the following states:
Clean:The file is in source control and matches the tip revision.
Not Controlled:The file is not in source control.
Conflicted:The file is in conflict with changes made to the repository.
Locked:The file is locked.
Update Available:The file is older than the most-recent version in source control.
Added:The file is scheduled to be added to the repository.
Removed:The file is scheduled to be removed from the repository.
If the file has been modified, its status is displayed in red in the Project Explorer. Note that if a file is not under
the local root, it will not have a source-control status.
You can reset any stored source-control file status by choosing VCS > Refresh.
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Source-control operations
Source-control operations can be performed on single files or recursively on multiple files in the Project
Explorer hierarchy. Single-file operations are available on the Source Control toolbar and on the text editor's
shortcut menu. All operations are available using the VCS menu. The operations are described in terms of the
Project Explorer shortcut menu.
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Adding files to source control
To add files to the source-control system:
1. In the Project Explorer, select the file to add. If you select a folder, project, or solution, any eligible child
items will also be added to source control.
2. choose Source Control > Add or press Ctrl+R, A.
3. The dialog will list the files that can be added.
4. In that dialog, you can deselect any files you don't want to add to source control.
5. Click Add.

Note
Files are scheduled to be added to source control and will only be committed to source control (and seen by
others) when you commit the file.
Enabling the VCS > Options > Add Immediately option will bypass the dialog and immediately add (but not
commit) the files.
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Updating files
To update files from source control:
1. In the Project Explorer, select the file to update. If you select a folder, project, or solution, any eligible
child items will also be updated from source control.
2. choose Source Control > Update or press Ctrl+R, U.
3. The dialog will list the files that can be updated.
4. In that dialog, you can deselect any files you don't want to update from source control.
5. Click Update.

Note
Enabling the VCS > Options > Update Immediately option will bypass the dialog and immediately update the
files.
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Committing files
To commit files:
1. In the Project Explorer, select the file to commit. If you select a folder, project, or solution, any eligible
child items will also be committed.
2. Choose Source Control > Commit or press Ctrl+R, C.
3. The dialog will list the files that can be committed.
4. In that dialog, you can deselect any files you don't want to commit and enter an optional comment.
5. Click Commit.

Note
Enabling the VCS > Options > Commit Immediately option will bypass the dialog and immediately commit the
files without a comment.
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Reverting files
To revert files:
1. In the Project Explorer, select the file to revert. If you select a folder, project, or solution, any eligible child
items will also be reverted.
2. Choose Source Control > Revert or press Ctrl+R, V.
3. The dialog will list the files that can be reverted.
4. In that dialog, you can deselect any files you don't want to revert.
5. Click Revert.

Note
Enabling the VCS > Options > Revert Immediately option will bypass the dialog and immediately revert files.
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Locking files
To lock files:
1. In the Project Explorer, select the file to lock. If you select a folder, project, or solution, any eligible child
items will also be locked.
2. Choose Source Control > Lock or press Ctrl+R, L.
3. The dialog will list the files that can be locked.
4. In that dialog, you can deselect any files you don't want to lock and enter an optional comment.
5. Click Lock.

Note
Enabling the VCS > Options > Lock Immediately option will bypass the dialog and immediately lock files
without a comment.

141

CrossWorks for MSP430 Reference Manual

CrossStudio User Guide

Unlocking files
To unlock files:
1. In the Project Explorer, select the file to lock. If you select a folder, project, or solution, any eligible child
items will also be unlocked.
2. Choose Source Control > Unlock or press Ctrl+R, N.
3. The dialog will list the files that can be unlocked.
4. In that dialog, you can deselect any files you don't want to unlock.
5. Click Unlock.

Note
Enabling the VCS > Options > Unlock Immediately option will bypass the dialog and immediately unlock files.

142

CrossWorks for MSP430 Reference Manual

CrossStudio User Guide

Removing files from source control
To remove files from source control:
1. In the Project Explorer, select the file to remove. If you select a folder, project, or solution, any eligible
child items will also be removed.
2. choose Source Control > Remove or press Ctrl+R, R.
3. The dialog will list the files that can be removed.
4. In that dialog, you can deselect any files you don't want to remove.
5. Click Remove.

Note
Files are scheduled to be removed from source control and will still be and seen by others, giving you the
opportunity to revert the removal. When you commit the file, the file is removed from source control.
Enabling the VCS > Options > Remove Immediately option will bypass the dialog and immediately remove (but
not commit) files.
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Showing differences between files
To show the differences between the file in the project and the version checked into source control, do the
following:
1. In the Project Explorer, right-click the file.
2. From the shortcut menu, choose Source Control > Compare.
You can use an external diff tool in preference to the built-in CrossWorks diff tool. To define the diff command
line CrossWorks generates, choose Tools > Options > Source Control > Diff Command Line. The command line
is defined as a list of strings to avoid problems with spaces in arguments. The diff command line can contain the
following macros:
$(localfile):The filename of the file in the project.
$(remotefile):The filename of the latest version of the file in source control.
$(localname):A display name for $(localfile).
$(remotename):A display name for $(remotefile).
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Source-control properties
When a file in the project is in source control, the Properties window shows the following properties in the
Source Control Options group:
Property

Description

CrossStudio Status

The source-control status of working copy as viewed
by CrossStudio.

last Author

The author of the file's head revision.

Path: Relative

The item's path relative to the repository root.

Path: Repository

The pathname of the file in the source-control system,
typically a URL.

Path: Working Copy

The pathname of the file in the working copy.

Provider

The name of the source-control system managing this
file.

Provider Status

The status of the file as reported by the source-control
provider.

Revision: Local

The revision number/name of the local file.

Revision: Remote

The revision number/name of the most-recent version
in source control.

Status: In Conflict?

If Yes, updates merged into the file using Update
conflict with the changes you made locally; if No,
the file is not locked. When conflicted, must resolve
the conflicts and mark them Resolved before
committing the file.

Status: Locked?

If Yes, the file is lock by you; if No, the file is not locked.

Status: Modified?

If Yes, the checked-out file differs from the version in
the source control system; if No, they are identical.

Status: Update Available?

If Yes, the file in the project location is an old version
compared to the latest version in the source-control
systemuse Update to merge in the latest changes.
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Subversion provider
The Subversion source-control provider has been tested with SVN 1.4.3.

Provider-specific options
The following environment options are supported:
Property

Description

Executable

The path to the svn executable.

Lock Supported

If Yes, check out and undo check out operations
are supported. Check out will issue the svn lock
command; check in and undo check out will issue the
svn unlock command.

Authentication

Selects whether authentication (user name and
password) is sent with every command.

Show Updates

Selects whether the update (-u flag) is sent with
status requests in order to show that new versions are
available in the repository. Note that this requires a
live connection to the repository: if you are working
without a network connection to your repository, you
can disable this switch and continue to enjoy source
control status information in the Project Explorer and
Pending Changes windows.

Connecting to the source-control system
When connecting to source control, the provider checks if the local root is in SVN control. If this is the case, the
local and remote root will be set accordingly. If the local root is not in SVN control after you have set the remote
root, a svn checkout -N command will be issued to make the local root SVN controlled. This command will
also copy any files in the remote root to the local root.
The user name and password you enter will be supplied with each svn command the provider issues.

Source control operations
The CrossWorks source-control operations are implemented using Subversion commands. Mapping CrossWorks
source-control operations to Subversion source-control operations is straightforward:
Operation

Command

Commit

svn commit for the file, with optional comment.

Update

svn update for each file.

Revert

svn revert for each file.
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Resolved

svn resolved for each file.

Lock

svn lock for each file, with optional comment.

Unlock

svn unlock for each file.

Add

svn add for each file.

Remove

svn remove for each file.

Source Control Explorer

svn list with a remote root. svn mkdir to create
directories in the repository.
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CVS provider
The CVS source-control provider has been tested with CVSNT 2.5.03. The CVS source-control provider uses the
CVS rls command to browse the repositorythis command is implemented in CVS 1.12 but usage of . as the root
of the module name is not supported.

Provider-specific options
The following environment options are supported:
Property

Description

CVSROOT

The CVSROOT value to access the repository.

Edit/Unedit Supported

If Yes, Check Out and Undo Check Out commands
are supported. Any check-out operation will issue the
cvs edit command; any check-in or undo-checkout operation will issue the cvs unedit command;
the status operation will issue the cvs ss command.

Executable

The path to the cvs executable.

Login/Logout Required

If Yes, Connect will issue the cvs login command.

Connecting to the source-control system
When connecting to source control, the provider checks if the local root is in CVS control. If this is the case, the
local and remote root will be set accordingly. If the local root is not in CVS control after you have set the remote
root, a cvs checkout -l -d command will be issued to make the local root CVS controlled. This command
will also copy any files in the remote root to the local root.

Source-control operations
The CrossWorks source-control operations have been implemented using CVS commands. There are no
multiple-file operations, each operation is done on a single file and committed as part of the operation.
Operation

Command

Get Status

cvs status and optional cvs editors for local
directories in CVS control. cvs rls -e for directories
in the repository.

Add To Source Control

cvs add for each directory not in CVS control.
cvs add for the file. cvs commit for the file and
directories.

Get Latest

cvs update -l -d for each directory not in CVS
control. cvs update to merge the local file. cvs
update -C to overwrite the local file.
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Check Out

Optional cvs update -C to get the latest version.
cvs edit to lock the file.

Undo Check Out

cvs unedit to unlock the file. Optional cvs
update to get the latest version.

Check In

cvs commit for the file.

Source Control Explorer

cvs rls -e with a remote root starting with .. cvs
import to create directories in the repository.
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Package management
Additional target-support functions can be added to, and removed from, CrossWorks with packages.
A CrossWorks package is an archive file containing a collection of target-support files. Installing a package
involves copying the files it contains to an appropriate destination directory and registering the package with
CrossWorks's package system. Keeping target-support files separate from the main CrossWorks installation
allows us to support new hardware and issue bug fixes for existing hardware-support files between CrossWorks
releases, and it allows third parties to develop their own support packages.

Installing packages
Use the Package Manager to automate the download, installation, upgrade and removal of packages.

To activate the Package Manager:
Choose Tools > Manage Packages.
In some situations, such as using CrossWorks on a computer without Internet access or when you want to install
packages that are not on the website, you cannot use the Package Manager to install packages and it will be
necessary to manually install them.

To manually install a package:
1. Choose Tools > Packages > Manually Install Packages.
2. Select one or more package files you want to install.
3. Click Open to install the packages.
Choose Tools > Show Installed Packages to see more information on the installed packages.
The Package Manager window will remove manually installed packages.

The package manager
The Package Manager manages the support packages installed on your system. It lists the available packages,
shows the installed packages, and allows you to install, update, reinstall, and remove them.
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To activate the Package Manager:
Choose Tools > Manage Packages.

Filtering the package list
By default, the Package Manager lists all available and installed packages. You can filter the displayed packages
in a number of ways.

To filter by package status:
Click on the disclosure icon near the top-right corner of the dialog.
Use the pop-up menu to choose how to filter the list of packages.
The list-filter choices are:
Display All Show all packages irrespective of their status.
Display Not Installed Show packages that are available but are not currently installed.
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Display Installed Only show packages that are installed.
Display Updates Only show packages that are installed but are not up-to-date because a newer version is
available.
You can also filter the list of packages by the text in the package's title and documentation.

To filter packages by keyword:
Type the keyword into the Search Packages box at the top-left corner of the dialog.

Installing a package
The package-installation operation downloads a package to $(PackagesDir)/downloads, if it has not been
downloaded already, and unpacks the files contained within the package to their destination directory.

To install a package:
1. Choose Tools > Package Manager and set the status filter to Display Not Installed.
2. Select the package or packages you wish to install.
3. Right-click the selected packages and choose Install Selected Packages from the shortcut menu.
4. Click Next; you will be see the actions the Package Manager is about to carry out.
5. Click Next and the Package Manager will install the selected packages.
6. When installation is complete, click Finish to close the Package Manager.

Updating a package
The package-update operation first removes existing package files, then it downloads the updated package to
$(PackagesDir)/downloads and unpacks the files contained within the package to their destination directory.

To update a package:
1. Choose Tools > Package Manager and set the status filter to Display Updates.
2. Select the package or packages you wish to update.
3. Right-click the selected packages and choose Update Selected Packages from the shortcut menu.
4. Click Next; you will see the actions the Package Manager is about to carry out.
5. Click Next and the Package Manager will update the package(s).
6. When the update is complete, click Finish to close the Package Manager.

Removing a package
The package-remove operation removes all the files that were extracted when the package was installed.
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To remove a package:
1. Choose Tools > Package Manager and set the status filter to Display Installed.
2. Select the package or packages you wish to remove.
3. Right-click the selected packages and choose Remove Selected Packages from the shortcut menu.
4. Click Next; you will see the actions the Package Manager is about to carry out.
5. Click Next and the Package Manager will remove the package(s).
6. When the operation is complete, click Finish to close the Package Manager.

Reinstalling a package
The package-reinstall operation carries out a package-remove operation followed by a package-install
operation.

To reinstall a package:
1. Choose Tools > Package Manager and set the status filter to Display Installed.
2. Select the package or packages you wish to reinstall.
3. Right-click the packages to reinstall and choose Reinstall Selected Packages from the shortcut menu.
4. Click Next; you will see the actions the Package Manager is about to carry out.
5. Click Next and the Package Manager will reinstall the packages.
6. When the operation is complete, click Finish to close the Package Manager.
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Exploring your application
In this section, we discuss the CrossStudio tools that help you examine how your application is built.
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Project explorer
The Project Explorer is the user interface of the CrossWorks project system. It organizes your projects and files
and provides access to the commands that operate on them. A toolbar at the top of the window offers quick
access to commonly used commands for the selected project node or the active project. Right-click to reveal a
shortcut menu with a larger set of commands that will work on the selected project node, ignoring the active
project.
The selected project node determines what operations you can perform. For example, the Compile operation
will compile a single file if a file project node is selected; if a folder project node is selected, each of the files in
the folder are compiled.
You can select project nodes by clicking them in the Project Explorer. Additionally, as you switch between files
in the editor, the selection in the Project Explorer changes to highlight the file you're editing.

To activate the Project Explorer:
Choose View > Project Explorer or press Ctrl+Alt+P.

Left-click operations
The following operations are available in the Project Explorer with a left-click of the mouse:
Action

Description

Single click

Select the node. If the node is already selected and
is a solution, project, or folder node, a rename editor
appears.

Double click

Double-clicking a solution node or folder node will
reveal or hide the node's children. Double-clicking a
project node selects it as the active project. Doubleclicking a file opens the file with the default editor for
that file's type.

Toolbar commands
The following buttons are on the toolbar:
Button

Description
Add a new file to the active project using the New File
dialog.
Add existing files to the active project.
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Remove files, folders, projects, and links from the
project.
Create a new folder in the active project.
Menu of build operations.
Disassemble the active project.
Menu of Project Explorer options.
Display the properties dialog for the selected item.

Shortcut menu commands
The shortcut menu, displayed by right-clicking, contains the commands listed below.

For solutions:
Item

Description

Build and Batch Build

Build all projects under the solution in the current or
batch build configuration.

Rebuild and Batch Rebuild

Rebuild all projects under the solution in the current or
batch build configuration.

Clean and Batch Clean

Remove all output and intermediate build files for the
projects under the solution in the current or batch
build configuration.

Export Build and Batch Export Build

Create an editor with the build commands for the
projects under the solution in the current or batch
build configuration.

Add New Project

Add a new project to the solution.

Add Existing Project

Create a link from an existing solution to this solution.

Paste

Paste a copied project into the solution.

Remove

Remove the link to another solution from the solution.

Rename

Rename the solution node.

Source Control Operations

Source-control operations on the project file and
recursive operations on all files in the solution.

Edit Solution As Text

Create an editor containing the project file.

Save Solution As

Change the filename of the project filenote that the
saved project file is not reloaded.

Properties

Show the Properties dialog with the solution node
selected.
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For projects:
Item

Description

Build and Batch Build

Build the project in the current or batch build
configuration.

Rebuild and Batch Rebuild

Reuild the project in the current or batch build
configuration.

Clean and Batch Clean

Remove all output and intermediate build files for the
project in the current or batch build configuration.

Export Build and Batch Export Build

Create an editor with the build commands for the
project in the current or batch build configuration.

Link

Perform the project node build operation: link for an
Executable project type, archive for a Library project
type, and the combine command for a Combining
project type.

Set As Active Project

Set the project to be the active project.

Debugging Commands

For Executable and Externally Built Executable project
types, the following debugging operations are
available on the project node: Start Debugging, Step
Into Debugging, Reset And Debug, Start Without
Debugging, Attach Debugger, and Verify.

Memory-Map Commands

For Executable project types that don't have memorymap files in the project and have the memory-map file
project property set, there are commands to view the
memory-map file and to import it into the project.

Section-Placement Commands

For Executable project types that don't have sectionplacement files in the project but have the sectionplacement file project property set, there are
commands to view the section-placement file and to
import it into the project.

Target Processor

For Executable and Externally Built Executable project
types that have a Target Processor property group, the
selected target can be changed.

Add New File

Add a new file to the project.

Add Existing File

Add an existing file to the project.

New Folder

Create a new folder in the project.

Cut

Cut the project from the solution.

Copy

Copy the project from the solution.

Paste

Paste a copied folder or file into the project.

Remove

Remove the project from the solution.

Rename

Rename the project.
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Source Control Operations

Source-control, recursive operations on all files in the
project.

Find in Project Files

Run Find in Files in the project directory.

Properties

Show the Project Manager dialog and select the
project node.

For folders:
Item

Description

Add New File

Add a new file to the folder.

Add Existing File

Add an existing file to the folder.

New Folder

Create a new folder in the folder.

Cut

Cut the folder from the project or folder.

Copy

Copy the folder from the project or folder.

Paste

Paste a copied folder or file into the folder.

Remove

Remove the folder from the project or folder.

Rename

Rename the folder.

Source Control Operations

Source-control recursive operations on all files in the
folder.

Compile

Compile each file in the folder.

Properties

Show the properties dialog with the folder node
selected.

For files:
Item

Description

Open

Edit the file with the default editor for the file's type.

Open With

Edit the file with a selected editor. You can choose
from the Binary Editor, Text Editor, and Web Browser.

Select in File Explorer

Create a operating system file system window with the
file selected.

Compile

Compile the file.

Export Build

Create an editor window containing the commands to
compile the file in the active build configuration.

Exclude From Build

Set the Exclude From Build property to Yes for this
project node in the active build configuration.

Disassemble

Disassemble the output file of the compile into an
editor window.

Preprocess

Run the C preprocessor on the file and show the
output in an editor window.

Cut

Cut the file from the project or folder.
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Copy

Copy the file from the project or folder.

Remove

Remove the file from the project or folder.

Import

Import the file into the project.

Source Control Operations

Source-control operations on the file.

Properties

Show the properties dialog with the file node selected.
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Source navigator window
One of the best ways to find your way around your source code is using the Source Navigator. It parses the
active project's source code and organizes classes, functions, and variables in various ways.

To activate the Source Navigator:
Choose Navigate > Source Navigator or press Ctrl+Alt+N.
The main part of the Source Navigator window provides an overview of your application's functions, classes,
and variables.
CrossStudio displays these icons to the left of each object:
Icon

Description
A C or C++ structure or a C++ namespace.
A C++ class.
A C++ member function declared private or a
function declared with static linkage.
A C++ member function declared protected.
A C++ member function declared public or a
function declared with extern linkage.
A C++ member variable declared private or a
variable declared with static linkage.
A C++ member variable declared protected.
A C++ member variable declared public or a variable
declared with extern linkage.

Re-parsing after editing
The Source Navigator does not update automatically, only when you ask it to. To parse source files manually,
click the Refresh button on the Source Navigator toolbar.
CrossStudio re-parses all files in the active project, and any dependent project, and updates the Source
Navigator with the changes. Parsing progress is shown as a progress bar in the in the Source Navigator window.
Errors and warnings detected during parsing are sent to the Source Navigator Log in the Output windowyou can
show the log quickly by clicking the Show Source Navigator Log tool button on the Source Navigator toolbar.

Setting indexing threads
You can configure how many threads CrossStudio launches to index your project.
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To set the number of threads launched when indexing a project:
Choose Navigate > Source Navigator or press Ctrl+Alt+N.
Click the Options dropdown button at the right of the toolbar.
Move the slider to select the number of threads to launch.
Increasing the number of threads will complete indexing faster, but may reduce the responsiveness of
CrossStudio when editing, for example. You should choose a setting that you are comfortable with for your PC.
By default, CrossStudio launches 16 threads to index the project and is a good compromise for a desktop quadcore PC.

Sorting and grouping
You can group objects by their type; that is, whether they are classes, functions, namespaces, structures, or
variables. Each object is placed into a folder according to its type.

To group objects by type:
1. On the Source Navigator toolbar, click the arrow to the right of the Cycle Grouping button.
2. Choose Group By Type
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References window
The References window shows the results of the last Find References operation. The Find References facility
is closely related to the Source Navigator in that it indexes your project and searches for references within the
active source code regions.

To activate the References window:
If you have hidden the References window and want to see it again:
Choose Navigate > References or press Ctrl+Alt+R.

To find all references in a project:
1. Open a source file that is part of the active project, or one of its dependent projects.
2. In the editor, move the insertion point within the name of the function, variable, method, or macro to
find.
3. Choose Search > Find References or press Alt+R.
4. CrossStudio shows the References window, without moving focus, and searches your project in the
background.
You can also find references directly from the text editor's context menu: right-click the item to find and choose
Find References. As a convenience, CrossStudio is configured to also run Find References when you Alt+Rightclick in the text editorsee Mouse-click accelerators.

To search within the results:
Type the text to search for in the Reference window's search box. As you type, the search results are
narrowed.
Click the close button to clear the search text and show all references.

To replace within the results:
Type the replacement text in the Reference window's replace box.
Use the buttons to navigate and replace the text.
The documents that have had replaced text will appear unsaved in the text editor.
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Symbol browser window
The Symbol Browser shows useful information about your linked application and complements the information
displayed in the Project Explorer window. You can select different ways to filter and group the information in
the Symbol Browser to provide an at-a-glance overview of your application. You can use the Symbol Browser
to drill down to see the size and location of each part of your program. The way symbols are sorted and grouped
is saved between runs; so, when you rebuild an application, CrossStudio automatically updates the Symbol
Browser so you can see the effect of your changes on the memory layout of your program.

User interface
Button

Description
Group symbols by source filename.
Group symbols by symbol type (equates, functions,
labels, sections, and variables).
Group symbols by the section where they are defined.
Move the insertion point to the statement that defined
the symbol.
Select columns to display.

The main part of the Symbol Browser displays each symbol (both external and static) that is linked into an
application. CrossStudio displays the following icons to the left of each symbol:
Icon

Description
Private Equate A private symbol not defined relative to
a section.
Public Equate A public symbol that is not defined
relative to a section.
Private Function A private function symbol.
Public Function A public function symbol.
Private Label A private data symbol, defined relative to
a section.
Public Label A public data symbol, defined relative to a
section.
Section A program section.
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Choosing what to show
To activate the Symbol Browser window:
Choose Navigate > Symbol Browser or press Ctrl+Alt+Y.
You can choose to display the following fields for each symbol:
Value:The value of the symbol. For labels, code, and data symbols, this will be the address of the symbol.
For absolute or symbolic equates, this will be the value of the symbol.
Range:The range of addresses the code or data item covers. For code symbols that correspond to highlevel functions, the range is the range of addresses used for that function's code. For data addresses that
correspond to high-level static or extern variables, the range is the range of addresses used to store that
data item. These ranges are only available if the corresponding source file was compiled with debugging
information turned on: if no debugging information is available, the range will simply be the first address
of the function or data item.
Size:The size, in bytes, of the code or data item. The Size column is derived from the Range of the symbol:
if the symbol corresponds to a high-level code or data item and has a range, Size is calculated as the
difference between the start and end addresses of the range. If a symbol has no range, the size column is
blank.
Section:The section in which the symbol is defined. If the symbol is not defined within a section, the
Section column is blank.
Type:The high-level type for the data or code item. If the source file that defines the symbol is compiled
with debugging information turned off, type information is not available and the Type column is blank.
Frame Size:The amount of stack space used by a call to the function symbol. If the source file that defines
the symbol is compiled with debugging information turned off, frame size information is not available
and the Type column is blank.
Initially the Range and Size columns are shown in the Symbol Browser. To select which columns to display, use
the Field Chooser button on the Symbol Browser toolbar.

To select the fields to display:
1. Click the Field Chooser button on the Symbol Browser toolbar.
2. Select the fields you wish to display and deselect the fields you wish to hide.

Organizing and sorting symbols
When you group symbols by section, each symbol is grouped underneath the section in which it is defined.
Symbols that are absolute or are not defined within a section are grouped beneath (No Section).

To group symbols by section:
1. On the Symbol Browser toolbar, click the arrow next to the Cycle Grouping button.
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2. From the pop-up menu, choose Group By Section.
The Cycle Grouping icon will change to indicate that the Symbol Browser is grouping symbols by section.
When you group symbols by type, each symbol is classified as one of the following:
An Equate has an absolute value and is not defined as relative to, or inside, a section.
A Function is defined by a high-level code sequence.
A Variable is defined by a high-level data declaration.
A Label is defined by an assembly language module. Label is also used when high-level modules are
compiled with debugging information turned off.
When you group symbols by source file, each symbol is grouped underneath the source file in which it is
defined. Symbols that are absolute, are not defined within a source file, or are compiled without debugging
information, are grouped beneath (Unknown).

To group symbols by type:
1. On the Symbol Browser toolbar, click the arrow next to the Cycle Grouping button.
2. Choose Group By Type from the pop-up menu.
The Cycle Grouping icon will change to indicate that the Symbol Browser is grouping symbols by type.

To group symbols by source file:
1. On the Symbol Browser toolbar, click the arrow next to the Cycle Grouping button.
2. Choose Group By Source File.
The Cycle Grouping icon will change to indicate that the Symbol Browser is grouping symbols by source file.
When you sort symbols alphabetically, all symbols are displayed in a single list in alphabetical order.

To list symbols alphabetically:
1. On the Symbol Browser toolbar, click the arrow next to the Cycle Grouping button.
2. Choose Sort Alphabetically.
The Cycle Grouping icon will change to indicate that the Symbol Browser is grouping symbols alphabetically.

Filtering and finding symbols
When you're dealing with big projects with hundreds, or even thousands, of symbols, a way to filter those
symbols in order to isolate just the ones you need is very useful. The Symbol Browser's toolbar provides an
editable combobox} you can use to specify the symbols you'd like displayed. You can type * to match a sequence
of zero or more characters and ? to match exactly one character.
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The symbols are filtered and redisplayed as you type into the combo box. Typing the first few characters of a
symbol name is usually enough to narrow the display to the symbol you need. Note: the C compiler prefixes all
high-level language symbols with an underscore character, so the variable extern int u or the function
void fn(void) have low-level symbol names _u and _fn. The Symbol Browser uses the low-level symbol
name when displaying and filtering, so you must type the leading underscore to match high-level symbols.

To display symbols that start with a common prefix:
Type the desired prefix text into the combo box, optionally followed by a "*".
For instance, to display all symbols that start with "i2c_", type "i2c_" and all matching symbols are displayedyou
don't need to add a trailing "*" in this case, because it is implied.

To display symbols that end with a common suffix:
Type * into the combo box, followed by the required suffix.
For instance, to display all symbols that end in _data, type *_data and all matching symbols are displayedin this
case, the leading * is required.
When you have found the symbol you're interested in and your source files have been compiled with debugging
information turned on, you can jump to a symbol's definition using the Go To Definition button.

To jump to the definition of a symbol:
1. Select the symbol from the list of symbols.
2. On the Symbol Browser toolbar, click Go To Definition.
or
1. Right-click the symbol in the list of symbols.
2. Choose Go To Definition from the shortcut menu.

Watching symbols
If a symbol's range and type is known, you can add it to the most recently opened Watch window or Memory
window.

To add a symbol to the Watch window:
1. In the Symbol Browser, right-click the symbol you wish to add to the Watch window.
2. On the shortcut menu, choose Add To Watch.

To add a symbol to the Memory window:
1. In the Symbol Browser, right-click the symbol you wish to add to the Memory window.
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2. Choose Locate Memory from the shortcut menu.

Using size information
Here are a few common ways to use the Symbol Browser:

What function uses the most code space? What requires the most data space?
1. Choose Navigate > Symbol Browser or press Ctrl+Alt+Y.
2. In the Grouping button menu on the Symbol Browser toolbar, select Group By Type.
3. Ensure the Size field is checked in the Field Chooser button's menu.
4. Ensure that the filter on the Symbol Browser toolbar is empty.
5. Click on the Size field in the header to sort by data size.
6. The sizes of variables and of functions are shown in separate lists.

What's the overall size of my application?
1. Choose Navigate > Symbol Browser or press Ctrl+Alt+Y.
2. In the Grouping button menu on the Symbol Browser toolbar, select Group By Section.
3. Ensure the Range and Size fields are checked in the Field Chooser button's menu.
4. Read the section sizes and ranges of each section in the application.
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Stack usage window
The Stack Usage Window finds the call paths of your linked application and displays them as a call tree
together with their minimal stack requirements. A call path of your application is any function that has been
linked in but has no direct call made to it but will make calls to other functions. The main function is the most
obvious example of a call path, an interrupt handler or a function that is called only as a function pointer are
other examples. To use the stack usage window your linked application must be compiled with debugging
information enabled.

User interface
Button

Description
Move the insertion point to the statement that defined
the symbol.
Collapse the selected open call tree.
Open the selected open call tree.
Show only the deepest call path through the selected
call tree.

168

CrossWorks for MSP430 Reference Manual

CrossStudio User Guide

Memory usage window
The Memory Usage window displays a graphical summary of how memory has been used in each memory
segment of a linked application.

Each bar represents an entire memory segment. Green represents the area of the segment that contains code or
data.

To activate the Memory Usage window:
Choose View > Memory Usage or press Ctrl+Alt+Z.
The memory-usage graph will only be visible if your active project's target is an executable file and the file exists.
If the executable file has not been linked by CrossStudio, memory-usage information may not be available.

Displaying section information
The Memory Usage window can also be used to visualize how program sections have been placed in memory.
To display the program sections, simply click the memory segment to expand it; or, alternatively, right-click and
choose Show Memory Sections from the shortcut menu.
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Each bar represents an entire memory segment. Green represents the area of the segment that contains the
program section.

Displaying segment overflow
The Memory Usage window also displays segment overflows when the total size of the program sections placed
in a segment is larger than the segment size. When this happens, the segment and section bars represents the
total memory used, green areas represent the code or data within the segment, and red areas represent code or
data placed outside the segment.
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Getting more-detailed information
If you require more-detailed information than that provided by the Memory Usage window, such as the location
of specific objects within memory, use the Symbol browser window.
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Bookmarks window
The Bookmarks window contains a list of bookmarks that are set in the project. The bookmarks are stored in the
session file associated with the project and persist across runs of CrossStudioif you remove the session file, the
bookmarks associated with the project are lost.

User interface
Button

Description
Toggle a bookmark at the insertion point in the active
editor. Equivalent to choosing Edit > Bookmarks >
Toggle Bookmark or pressing Ctrl+F2.
Go to the previous bookmark in the bookmark list.
Equivalent to choosing Edit > Bookmarks > Previous
Bookmark or pressing Alt+Shift+F2.
Go to the next next bookmark in the bookmark list.
Equivalent to choosing Edit > Bookmarks > Next
Bookmark or pressing Alt+F2.
Clear all bookmarksyou confirm the action using a
dialog. Equivalent to choosing Edit > Bookmarks >
Clear All Bookmarks or pressing Ctrl+K, Alt+F2.
Selects the fill color for newly created bookmarks.

Double-clicking a bookmark in the bookmark list moves focus to the the bookmark.
You can set bookmarks with the mouse or using keystrokessee Using bookmarks.
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Code Outline Window
The Code Outline window shows the structure of the text of the focused code editor. For C and C++ documents
the top level symbols and types are displayed, for XML documents the nodes are displayed. For C and C+
+ documents the Preview tab can display documentation on the top level symbols and types. The defacto
standard doxygen commands are supported for example:
/**
* \brief Convert a given full parsed comment to an XML document.
*
* A Relax NG schema for the XML can be found in comment-xml-schema.rng file
* inside clang source tree.
*
* \param Comment a \c CXComment_FullComment AST node.
*
* \returns string containing an XML document.
*/
CINDEX_LINKAGE CXString clang_FullComment_getAsXML(CXComment Comment);
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Analyzing Source Code
The Analyze action is available on the context menu of the project explorer at project, folder and file level. The
analyze action will run the https://clang.llvm.org/extra/clang-tidy linter tool on the C/C++ files selected by
the project explorer node and display warnings in the output window. The default checks will be the same as
the clang analyzer. You can enable additional checks by setting the Clang Tidy Checks project property. For
example you can enable the bugprone code constructs check and disable a specific clang analyzer diagnostic
check as follows
bugprone-*
-clang-diagnostic-parentheses-equality

You can also set the project property Analyze After Compile which will run the analyzer each time the compiler
is run.
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Editing your code
CrossStudio has a built-in editor that allows you to edit text, but some features make it particularly well suited to
editing code.
You can open multiple code editors to browse or edit project source code, and you can copy and paste among
them. The Windows menu contains a list of all open code editors.
The code editor supports the language of the source file it is editing, showing code with syntax highlighting and
offering smart indenting.
You can open a code editor in several ways, some of which are:
By double-clicking a file in the Project Explorer or by right-clicking a file and selecting Open from the
shortcut menu.
Using the File > New File or File > Open commands.

Elements of the code editor
The code editor is composed of several elements, which are described here.
Code pane:The area where you edit code. You can set options that affect the code pane's text indents,
tabs, drag-and-drop behavior, and so forth.
Margin gutter:A gray area on the left side of the code editor where margin indicators such as breakpoints,
bookmarks, and shortcuts are displayed. Clicking this area sets a breakpoint on the corresponding line of
code.
Horizontal and vertical scroll bars:You can scroll the code pane horizontally and vertically to view code that
extends beyond the edges of the pane.
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Basic editing
This section is a whirlwind tour of the basic editing features CrossStudio's code editor provides.
Whether you are editing code, HTML, or plain text, the code editor is just like many other text editors or word
processors. For code that is part of a project, the project's programming language support provides syntax
highlighting (colorization), indentation, and so on.
This section is not a reference for everything the code editor provides; for that, look in the following sections.
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Moving the insertion point
The most common way to navigate through text is to use use the mouse or the keyboard's cursor keys.

Using the mouse
You can move the insertion point within a document by clicking the mouse inside the editor window.

Using the keyboard
The keystrokes most commonly used to navigate through a document are:
Keystroke

Description

Up

Move the insertion point up one line

Down

Move the insertion point down one line

Left

Move the insertion point left one character

Right

Move the insertion point right one character

Home

Move the insertion point to the first non-whitespace
character on the line pressing Home a second time
moves the insertion point to the leftmost column

End

Move the insertion point to the end of the line

PageUp

Move the insertion point up one page

PageDown

Move the insertion point down one page

Ctrl+Home

Move the insertion point to the start of the document

Ctrl+End

Move the insertion point to the end of the document

Ctrl+Left

Move the insertion point left one word

Ctrl+Right

Move the insertion point right one word

CrossStudio offers additional movement keystrokes, though most users are more comfortable using repeated
simple keystrokes to accomplish the same thing:
Keystroke

Description

Alt+Up

Move the insertion point up five lines

Alt+Down

Move the insertion point down five lines

Alt+Home

Move the insertion point to the top of the window

Alt+End

Move the insertion point to the bottom of the window

Ctrl+Up

Scroll the document up one line in the window
without moving the insertion point
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Scroll the document down one line in the window
without moving the insertion point

If you are editing source code, the are source-related keystrokes too:
Keystroke

Description

Ctrl+PgUp

Move the insertion point backwards to the previous
function or method.

Ctrl+PgDn

Move the insertion point forwards to the next function
or method.
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Adding text
The editor has two text-input modes:
Insertion mode:As you type on the keyboard, text is entered at the insertion point and any text to the right
of the insertion point is shifted along. A visual indication of insertion mode is that the cursor is a flashing
line.
Overstrike mode:As you type on the keyboard, text at the insertion point is replaced with your typing. A
visual indication of insertion mode is that the cursor is a flashing block.
Insert and overstrike modes are common to all editors: if one editor is in insert mode, all editors are in insert
mode. To configure the cursor appearance, choose Tools > Options.

To toggle between insertion and overstrike mode:
Click Insert.
When overstrike mode is enabled, the mode indicator changes from INS to OVR and the cursor will change to
the overstrike cursor.

To add or insert text:
1. Move the insertion point to the place text is to be inserted.
2. Enter the text using the keyboard.
To overwrite characters in an existing line, press the Insert key to place the editor into overstrike mode.

To add or insert text on multiple lines:
1. Hold down the Alt key and use block selection to mark the place text is to be inserted.
2. Enter the text using the keyboard.
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Deleting text
The text editor supports the following common editing keystrokes:
Keystroke

Description

Backspace

Delete the character before the insertion point

Delete

Delete the character after the insertion point

Ctrl+Backspace

Delete one word before the insertion point

Ctrl+Delete

Delete one word after the insertion point

To delete characters or words:
1. Place the insertion point before the word or letter you want to delete.
2. Press Delete as many times as needed.
or
1. Place the insertion point after the letter or word you want to delete.
2. Press Backspace as many times as needed.

To delete text that spans more than a few characters:
1. Select the text you want to delete.
2. Press Delete or Backspace to delete it.

To delete a text block:
1. Hold down the Alt key and use block selection to mark the text you want to delete.
2. Press Delete or Backspace to delete it.

To delete characters on multiple lines:
1. Hold down the Alt key and use block selection to mark the lines.
2. Press Delete or Backspace as many times as needed to delete the characters.
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Using the clipboard
You can select text by using the keyboard or the mouse.

To select text with the keyboard:
Hold down the Shift key while using the cursor keys.

To select text with the mouse:
1. Click the start of the selection.
2. Drag the mouse to mark the selection.
3. Release the mouse to end selecting.

To select a block of text with the keyboard:
Hold down the Shift+Alt keys while using the cursor keys.

To select a block of text with the mouse:
1. Hold down the Alt key.
2. Click the start of the selection.
3. Drag the mouse to mark the selection.
4. Release the mouse to end selecting.

To copy selected text to the clipboard:
Choose Edit > Copy or press Ctrl+C.
The standard Windows key sequence Ctrl+Ins also copies text to the clipboard.

To cut selected text to the clipboard:
Choose Edit > Cut or press Ctrl+X.
The standard Windows key sequence Shift+Del also cuts text to the clipboard.

To insert the clipboard content at the insertion point:
Choose Edit > Paste or press Ctrl+V.
The standard Windows key sequence Shift+Ins also inserts the clipboard content at the insertion point.
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Undo and redo
The editor has an undo facility to undo previous editing actions. The redo feature can be used to re-apply
previously undone actions.

To undo one editing action:
Choose Edit > Undo or press Ctrl+Z.
The standard Windows key sequence Alt+Backspace also undoes an edit.

To undo multiple editing actions:
1. On the Standard toolbar, click the arrow next to the Undo button.
2. Select the editing operations to undo.

To undo all edits:
Choose Edit > Others > Undo All or press Ctrl+K, Ctrl+Z.

To redo one editing action:
Choose Edit > Redo or press Ctrl+Y.
The standard Windows key sequence Alt+Shift+Backspace also redoes an edit.

To redo multiple editing actions:
1. On the Standard toolbar, click the arrow next to the Redo tool button.
2. From the pop-up menu, select the editing operations to redo.

To redo all edits:
Choose Edit > Others > Redo All or press Ctrl+K, Ctrl+Y.
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Drag and drop
You can select text, then drag it to another location. You can drop the text at a different location in the same
window or in another one.

To drag and drop text:
1. Select the text you want to move.
2. Press and hold the mouse button to drag the selected text to where you want to place it.
3. Release the mouse button to drop the text.
Dragging text moves it to the new location. To copy it to a new location, hold down the Ctrl key while dragging
the text: the mouse pointer changes to indicate a copy operation. Press the Esc key while dragging text to cancel
the drag-and-drop edit.
By default, drag-and drop-editing is disabled and you must enable it if you want to use it.

To enable or disable drag-and-drop editing:
1. Choose Tools > Options or press Alt+,.
2. Click Text Editor.
3. Set Allow Drag and Drop Editing to Yes to enable or to No to disable drag-and-drop editing.
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Searching
To find text in the current file:
1. Press Ctrl+F.
2. Enter the string to search for.
As you type, the editor searches the file for a match. The pop-up shows how many matches are in the current file.
To move through the matches while the Find box is still active, press Tab or F3 to move to the next match and
Shift+Tab or Shift+F3 to move to the previous match.
If you press Ctrl+F a second time, CrossStudio pops up the standard Find dialog to search the file. If you wish to
bring up the Find dialog without pressing Ctrl+F twice, choose Search > Find.
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Advanced editing
You can do anything using its basic code-editing features, but the CrossStudio text editor has a host of laborsaving features that make editing programs a snap.
This section describes the code-editor features intended to make editing source code easier.
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Indenting source code
The editor uses the Tab key to increase or decrease the indentation level of the selected text.

To increase indentation:
Select the text to indent.
Choose Selection > Increase Line Indent or press Tab.

To decrease indentation:
Select the text to indent.
Choose Selection > Decrease Line Indent or press Shift+Tab.
The indentation size can be changed in the Language Properties pane of the editor's Properties window, as can
all the indent-related features listed below.

To change indentation size:
Choose Tools > Options or press Alt+,.
Select the Languages page.
Set the Indent Size property for the required language.
You can choose to use spaces or tab tab characters to fill whitespace when indenting.

To set tab or space fill when indenting:
Choose Tools > Options or press Alt+,.
Select the Languages page.
Set the Use Tabs property for the required language. Note: changing this setting does not add or remove
existing tabs from files, the change will only affect new indents.
The editor can assist with source code indentation while inserting text. There are three levels of indentation
assistance:
None:The indentation of the source code is left to the user.
Indent:This is the default. The editor maintains the current indentation level. When you press Return or
Enter, the editor moves the insertion point down one line and indented to the same level as the nowprevious line.
Smart:The editor analyzes the source code to compute the appropriate indentation level for each line.
You can change how many lines before the insertion point will be analyzed for context. The smart-indent
mode can be configured to indent either open and closing braces or the lines following the braces.

Changing indentation options:
To change the indentation mode:
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Set the Indent Mode property for the required language.
To change whether opening braces are indented in smart-indent mode:
Set the Indent Opening Brace property for the required language.
To change whether closing braces are indented in smart-indent mode:
Set the Indent Closing Brace property for the required language.
To change the number of previous lines used for context in smart-indent mode:
Set the Indent Context Lines property for the required language.
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Commenting out sections of code
To comment selected text:
Choose Selection > Comment or press Ctrl+/.

To uncomment selected text:
Choose Selection > Uncomment or press Ctrl+Shift+/.
You can also toggle the commenting of a selection by typing /. This has no menu equivalent.
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Adjusting letter case
The editor can change the case of the current word or the selection. The editor will change the case of the
selection, if there is a selection, otherwise it will change the case of word at the insertion point.

To change text to uppercase:
Choose Selection > Make Uppercase or press Ctrl+K, U.
This changes, for instance, Hello to HELLO.

To change text to lowercase:
Choose Selection > Make Lowercase or press Ctrl+U.
This changes, for instance, Hello to hello.

To switch between uppercase and lowercase:
Choose Selection > Switch Case.
This changes, for instance, Hello to hELLO.
With large software teams or imported source code, sometimes identifiers don't conform to your local coding
style. To assist in conversion between two common coding styles for identifiers, CrossStudio's editor offers the
following two shortcuts:

To change from split case to camel case:
Choose Selection > Camel Case or press Ctrl+K, Ctrl+Shift+U.
This changes, for instance, this_is_wrong to thisIsWrong.

To change from camel case to split case:
Choose Selection > Split Case or press Ctrl+K, Ctrl+U.
This changes, for instance, thisIsWrong to this_is_wrong.
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Using bookmarks
To edit a document elsewhere and then return to your current location, add a bookmark. The Bookmarks
window maintains a list of the bookmarks set in source files see Bookmarks window.

To place a bookmark:
1. Move the insertion point to the line you wish to bookmark.
2. Choose Edit > Bookmarks > Toggle Bookmark or press Ctrl+F2.
A bookmark symbol appears next to the line in the indicator margin to show the bookmark is set.

To place a bookmark using the mouse:
1. Right-click the margin gutter where the bookmark should be set.
2. Choose Toggle Bookmark.
The default color to use for new bookmarks is configured in the Bookmarks window. You can choose a specific
color for the bookmark as follows:
1. Press and hold the Alt key.
2. Click the margin gutter where the bookmark should be set.
3. From the palette, click the bookmark color to use for the bookmark.

To navigate forward through bookmarks:
1. Choose Edit > Bookmarks > Next Bookmark In Document or press F2.
2. The editor moves the insertion point to the next bookmark in the document.
If there is no following bookmark, the insertion point moves to the first bookmark in the document.

To navigate backward through bookmarks:
1. Choose Edit > Bookmarks > Previous Bookmark In Document or press Shift+F2.
2. The editor moves the insertion point to the previous bookmark in the document.
If there is no previous bookmark, the insertion point moves to the last bookmark in the document.

To remove a bookmark:
1. Move the insertion point to the line containing the bookmark.
2. Choose Edit > Bookmarks > Toggle Bookmark or press Ctrl+F2.
The bookmark symbol disappears, indicating the bookmark is no longer set.

To remove all bookmarks in a document:
Choose Edit > Bookmarks > Clear Bookmarks In Document or press Ctrl+K, F2.
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Quick reference for bookmark operations
Keystroke

Menu

Description

Ctrl+F2

Edit > Bookmarks > Toggle
Bookmark

Toggle a bookmark at the insertion
point.

Ctrl+K, 0

Clear the bookmark at the insertion
point.

F2

Edit > Bookmarks > Next
Bookmark In Document

Move the insertion point to next
bookmark in the document.

Shift+F2

Edit > Bookmarks > Previous
Bookmark In Document

Move the insertion point to
previous bookmark in the
document.

Ctrl+Q, F2

Edit > Bookmarks > First
Bookmark In Document

Move the insertion point to the first
bookmark in the document.

Ctrl+Q, Shift+F2

Edit > Bookmarks > Last Bookmark Move the insertion point to the last
In Document
bookmark in the document.

Ctrl+K, F2

Edit > Bookmarks > Clear
Bookmarks In Document

Clear all bookmarks in the
document.

Alt+F2

Edit > Bookmarks > Next
Bookmark

Move the insertion point to the next
bookmark in the Bookmarks list.

Alt+Shift+F2

Edit > Bookmarks > Previous
Bookmark

Move the insertion point to
the previous bookmark in the
Bookmarks list.

Ctrl+Q, Alt+F2

Edit > Bookmarks > First
Bookmark

Move the insertion point to the first
bookmark in the Bookmarks list.

Ctrl+Q, Alt+Shift+F2

Edit > Bookmarks > Last Bookmark Move the insertion point to the last
bookmark in the Bookmarks list.

Ctrl+K, Alt+F2

Edit > Bookmarks > Clear All
Bookmarks
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Find and Replace window
The Find and Replace window allows you to search for and replace text in the current document or in a range of
specified files.

To activate the Find and Replace window:
Choose Search > Find And Replace or press Ctrl+Alt+F.

To find text in a single file:
Select Current Document in the context combo box.
Enter the string to be found in the text edit input.
If the search will be case sensitive, set the Match case option.
If the search will be for a whole wordi.e., there will be whitespace, such as spaces or the beginning or end
of the line, on both sides of the string being searched forset the Whole word option.
If the search string is a regular expression, set the Use regexp option.
Click the Find button to find all occurrences of the string in the current document.

To find and replace text in a single file:
Click the Replace button on the toolbar.
Enter the string to search for into the Find what input.
Enter the replacement string into the Replace with input. If the search string is a regular expression, the n
back-reference can be used in the replacement string to reference captured text.
If the search will be case sensitive, set the Match case option.
If the search will be for a whole wordi.e., there will be whitespace, such as spaces or the beginning or end
of the line, on both sides of the string being searched forset the Match whole word option.
If the search string is a regular expression, set the Use regular expression option.
Click the Find Next button to find next occurrence of the string, then click the Replace button to replace
the found string with the replacement string; or click Replace All to replace all occurrences of the search
string without prompting.

To find text in multiple files:
Click the Find In Files button on the toolbar.
Enter the string to search for into the Find what input.
Select the appropriate option in the Look in input to select whether to carry out the search in all open
documents, all documents in the current project, all documents in the current solution, or all files in a
specified folder.
If you have specified that you want to search in a folder, select the folder you want to search by entering
its path in the Folder input and use the Look in files matching input to specify the type of files you want
to search.
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If the search will be case sensitive, set the Match case option.
If the search will be for a whole wordi.e., there will be whitespace, such as spaces or the beginning or end
of the line, on both sides of the string being searched forset the Match whole word option.
If the search string is a regular expression, set the Use regular expression option.
Click the Find All button to find all occurrences of the string in the specified files, or click the Bookmark
All button to bookmark all the occurrences of the string in the specified files.

To replace text in multiple files:
Click the Replace In Files button on the toolbar.
Enter the string to search for into the Find what input.
Enter the replacement string into the Replace with input. If the search string is a regular expression, the n
back-reference can be used in the replacement string to reference captured text.
Select the appropriate option in the Look in input to select whether you want to carry out the search and
replace in the current or in all open documents.
If you have specified that you want to search in a folder, select the folder you want to search by entering
its path in the Folder input and use the Look in files matching input to specify the type of files you want
to search.
If the search will be case sensitive, set the Match case option.
If the search will be for a whole wordi.e., there will be whitespace, such as spaces or the beginning or end
of the line, on both sides of the string being searched forset the Match whole word option.
If the search string is a regular expression, set the Use regular expression option.
Click the Replace All button to replace all occurrences of the string in the specified files.
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Clipboard Ring window
The code editor captures all cut and copy operations, and stores the cut or copied item on the clipboard ring. The
clipboard ring stores the last 20 cut or copied text items, but you can configure the maximum number by using
the environment options dialog. The clipboard ring is an excellent place to store scraps of text when you're
working with many documents and need to cut and paste between them.

To activate the clipboard ring:
Choose Edit > Clipboard Ring > Clipboard Ring or press Ctrl+Alt+C.

To paste from the clipboard ring:
1. Cut or copy some text from your code. The last item you cut or copy into the clipboard ring is the current
item for pasting.
2. Press Ctrl+Shift+V to paste the clipboard ring's current item into the current document.
3. Repeatedly press Ctrl+Shift+V to cycle through the entries in the clipboard ring until you get to the one
you want to permanently paste into the document. Each time you press Ctrl+Shift+V, the editor replaces
the last entry you pasted from the clipboard ring, so you end up with just the last one you selected. The
item you stop on then becomes the current item.
4. Move to another location or cancel the selection. You can use Ctrl+Shift+V to paste the current item
again or to cycle the clipboard ring to a new item.
Clicking an item in the clipboard ring makes it the current item.

To paste a specific item from the clipboard ring:
1. Move the insertion point to the position to paste the item in the document.
2. Click the arrow at the right of the item to paste.
3. Choose Paste from the pop-up menu.
or
1. Click the item to paste to make it the current item.
2. Move the insertion point to the position to paste the item in the document.
3. Press Ctrl+Shift+V.

To paste all items into a document:
To paste all items on the clipboard ring into the current document, move the insertion point to where you want
to paste the items and do one of the following:
Choose Edit > Clipboard Ring > Paste All.
or
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On the Clipboard Ring toolbar, click the Paste All button.

To remove an item from the clipboard ring:
1. Click the arrow at the right of the item to remove.
2. Choose Delete from the pop-up menu.

To remove all items from the clipboard ring:
Choose Edit > Clipboard Ring > Clear Clipboard Ring.
or
On the Clipboard Ring toolbar, click the Clear Clipboard Ring button.

To configure the clipboard ring:
1. Choose Tools > Options or press Alt+,.
2. Click the Windows category to show the Clipboard Ring Options group.
3. Select Preserve Contents Between Runs to save the content of the clipboard ring between runs, or
deselect it to start with an empty clipboard ring.
4. Change Maximum Items Held In Ring to configure the maximum number of items stored on the
clipboard ring.
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Mouse-click accelerators
CrossStudio provides a number of mouse-click accelerators in the editor that speed access to commonly used
functions. The mouse-click accelerators are user configurable using Tools > Options.

Default mouse-click assignments
Click

Default

Left

Not configurable start selection.

Shift+Left

Not configurable extend selection.

Ctrl+Left

Select word.

Alt+Left

Execute Go To Definition.

Middle

No action.

Shift+Middle

Display Go To Include menu.

Ctrl+Middle

No action.

Alt+Middle

Display Go To Method menu.

Right

Not configurable show context menu.

Shift+Right

No action.

Ctrl+Right

No action.

Alt+Right

Execute Find References.

Each accelerator can be assigned one of the following actions:
Default:The system default for that click.
Go To Definition:Go to the definition of the item clicked, equivalent to choosing Navigate > Go To
Definition or pressing Alt+G.
Find References:Find references to the item clicked, equivalent to choosing Search > Find References or
pressing Alt+R.
Find in Solution:Textually find the item clicked in all the files in the solution, equivalent to choosing Search
> Find Extras > Find in Solution or pressing Alt+U.
Find Help:Use F1-help on the item clicked, equivalent to choosing Help > Help or pressing F1.
Go To Method:Display the Go To Method menu, equivalent to choosing Navigate > Find Method or
pressing Ctrl+M.
Go To Include:Display the Go To Include menu, equivalent to choosing Navigate > Find Include or
pressing Ctrl+Shift+M.
Paste:Paste the clipboard at the position clicked, equivalent to choosing Edit > Paste or pressing Ctrl+V.

Configuring Mac OS X
On Mac OS X you must configure the mouse to pass middle clicks and right clicks to the application if you wish
to use mouse-click accelerators in CrossStudio. Configure the mouse preferences in the Mouse control panel in
Mac OS X System Preferences to the following:
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Right mouse button set to Secondary Button.
Middle mouse button set to Button 3.
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Regular expressions
The editor can search and replace text using regular expressions. A regular expression is a string that uses
special characters to describe and reference patterns of text. The regular expression system used by the editor
is modeled on Perl's regexp language. For more information on regular expressions, see Mastering Regular
Expressions, Jeffrey E F Freidl, ISBN 0596002890.

Summary of special characters
The following table summarizes the special characters the CrossStudio editor supports
Pattern

Description

\d

Match a numeric character.

\D

Match a non-numeric character.

\s

Match a whitespace character.

\S

Match a non-whitespace character.

\w

Match a word character.

\W

Match a non-word character.

[c]

Match set of characters; e.g., [ch] matches characters
c or h. A range can be specified using the - character;
e.g., [0-27-9] matches if the character is 0, 1, 2, 7 8, or
9. A range can be negated using the ^ character; e.g.,
[^a-z] matches if the character is anything other than a
lowercase alphabetic character.

\c

Match the literal character c. For example, you would
use \\* to match the character *.

\a

Match ASCII bell character (ASCII code 7).

\f

Match ASCII form feed character (ASCII code 12).

\t

Match ASCII horizontal tab character (ASCII code 9).

\v

Match ASCII vertical tab character.

\xhhhh

Match Unicode character specified by hexadecimal
number hhhh.

.

Match any character.

*

Match zero or more occurrences of the preceding
expression.

+

Match one or more occurrences of the preceding
expression.

?

Match zero or one occurrences of the preceding
expression.
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{n}

Match n occurrences of the preceding expression.

{n,}

Match at least n occurrences of the preceding
expression.

{,m}

Match at most m occurrences of the preceding
expression.

{n,m}

Match at least n and at most m occurrences of the
preceding expression.

^

Beginning of line.

$

End of line.

\b

Word boundary.

\B

Non-word boundary.

(e)

Capture expression e.

\n

Back-reference to nth captured text.

Examples
The following regular expressions can be used with the editor's search-and-replace operations. To use the
regular expression mode, the Use regular expression checkbox must be set in the search-and-replace dialog.
Once enabled, regular expressions can be used in the Find what search string. The Replace With strings can use
the "n" back-reference string to reference any captured strings.
"Find what"

"Replace With"

Description
Search for any-length string
containing one or more word
characters beginning with the
character u and ending in the
character d.

u\w.d

^.*;$
(typedef.+\s+)(\S+);

Search for any lines ending in a
semicolon.
\1TEST_\2;

Find C type definition and insert the
string TEST onto the beginning of
the type name.
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Locals window
The Locals window displays a list of all variables that are in scope of the selected stack frame in the Call Stack.
The Locals window has a toolbar and a main data display.
Button

Description
Display the selected item in binary.
Display the selected item in octal.
Display the selected item in decimal.
Display the selected item in hexadecimal.
Display the selected item as a signed decimal.
Display the selected item as a character or Unicode
character.
Set the range displayed in the active Memory window
to span the memory allocated to the selected item.
Sort variables alphabetically by name.
Sort variables numerically by address or register
number (default).

Using the Locals window
The Locals window shows the local variables of the active function when the debugger is stopped. The contents
of the Locals window changes when you use the Debug Location toolbar items or select a new frame in the Call
Stack window. When the program stops at a breakpoint, or is stepped, the Locals window updates to show the
active stack frame. Items that have changed since they were previously displayed are highlighted in red.

To activate the Locals window:
Choose Debug > Locals or press Ctrl+Alt+L.
When you select a variable in the main part of the display, the display-format button highlighted on the Locals
window toolbar changes to show the selected item's display format.

To change the display format of a local variable:
Right-click the item to change.
From the shortcut menu, choose the desired display format.
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or
Click the item to change.
On the Locals window toolbar, select the desired display format.

To modify the value of a local variable:
Click the value of the local variable to modify.
Enter the new value for the local variable. Prefix hexadecimal numbers with 0x, binary numbers with 0b,
and octal numbers with 0.
or
Right-click the value of the local variable to modify.
From the shortcut menu, select one of the commands to modify the local variable's value.
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Globals window
The Globals window displays a list of all variables that are global to the program. The operations available on the
entries in this window are the same as the Watch window, except you cannot add or delete variables from the
Globals window.

Globals window user interface
The Globals window consists of a toolbar and main data display.
Globals toolbar
Button

Description
Display the selected item in binary.
Display the selected item in octal.
Display the selected item in decimal.
Display the selected item in hexadecimal.
Display the selected item as a signed decimal.
Display the selected item as a character or Unicode
character.
Set the range displayed in the active Memory window
to span the memory allocated to the selected item.
Sort variables alphabetically by name.
Sort variables numerically by address or register
number (default).

Using the Globals window
The Globals window shows the global variables of the application when the debugger is stopped. When the
program stops at a breakpoint, or is stepped, the Globals window updates to show the active stack frame and
new variable values. Items that have changed since they were previously displayed are highlighted in red.

To activate the Globals window:
Choose Debug > Other Windows > Globals or press Ctrl+Alt+G.
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Changing the display format
When you select a variable in the main part of the display, the display-format button highlighted on the Globals
window toolbar changes to show the item's display format.

To change the display format of a global variable:
Right-click the item to change.
From the shortcut menu, choose the desired display format.
or
Click the item to change.
On the Globals window toolbar, select the desired display format.

To modify the value of a global variable:
Click the value of the global variable to modify.
Enter the new value for the global variable. Prefix hexadecimal numbers with 0x, binary numbers with 0b,
and octal numbers with 0.
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Watch window
The Watch window provides a means to evaluate expressions and to display the results of those expressions.
Typically, expressions are just the name of a variable to be displayed, but they can be considerably more
complex; see Debug expressions. Note: expressions are always evaluated when your program stops, so the
expression you are watching is the one that is in scope of the stopped program position.
The Watch window is divided into a toolbar and the main data display.
Button

Description
Display the selected item in binary.
Display the selected item in octal.
Display the selected item in decimal.
Display the selected item in hexadecimal.
Display the selected item as a signed decimal.
Display the selected item as a character or Unicode
character.
Set the range displayed in the active Memory window
to span the memory allocated to the selected item.
Remove the selected watch item.
Remove all the watches.

Right-clicking a watch item shows a shortcut menu with commands that are not available from the toolbar.
Button

Description
View pointer or array as a null-terminated string.
View pointer or array as an array.
View pointer value.
Set watch value to zero.
Set watch value to one.
Increment watched variable by one.
Decrement watched variable by one.
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Negated watched variable.
Invert watched variable.
View the properties of the watch value.
You can view details of the watched item using the Properties window.

Filename
The filename context of the watch item.

Line number
The line number context of the watch item.

(Name)
The name of the watch item.

Address
The address or register of the watch item.

Expression
The debug expression of the watch item.

Previous Value
The previous watch value.

Size In Bytes
The size of the watch item in bytes.

Type
The type of the watch item.

Value
The value of the watch item.

Using the Watch window
Each expression appears as a row in the display. Each row contains the expression and its value. If the value of an
expression is structured (for example, an array), you can open the structure to see its contents.
The display updates each time the debugger locates to source code. So it will update each time your program
stops on a breakpoint, or single steps, and whenever you traverse the call stack. Items that have changed since
they were previously displayed are highlighted in red.

To activate the Watch window:
Choose Debug > Other Windows > Watch > Watch 1 or press Ctrl+T, W, 1.
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You can show other Watch windows similarly.
You can add a new expression to be watched by clicking and typing into the last entry in the Watch window.
You can change an expression by clicking its entry and editing its contents.
When you select a variable in the main part of the display, the display format button highlighted on the Watch
window toolbar changes to show the item's display format.

To change the display format of an expression:
Right-click the item to change.
From the shortcut menu, choose the desired display format.
or
Click the item to change.
On the Watch window toolbar, select the desired display format.
The selected display format will then be used for all subsequent displays and will be preserved after the debug
session stops.
For C programs, the interpretation of pointer types can be changed by right-clicking and selecting from the
shortcut menu. A pointer can be interpreted as:
a null-terminated ASCII string
an array
an integer
dereferenced

To modify the value of an expression:
Click the value of the local variable to modify.
Enter the new value of the local variable. Prefix hexadecimal numbers with 0x, binary numbers with 0b,
and octal numbers with 0.
or
Right-click the value of the local variable to modify.
From the shortcut menu, choose one of the commands to modify the variable's value.
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Register window
The Register windows show the values of both CPU registers and the processor's special function or peripheral
registers. Because microcontrollers are becoming very highly integrated, it's not unusual for them to have
hundreds of special function registers or peripheral registers, so CrossStudio provides four register windows. You
can configure each register window to display one or more register groups for the processor being debugged.
A Register window has a toolbar and a main data display.
Button

Description
Display the CPU, special function register, and
peripheral register groups.
Display the CPU registers.
Hide the CPU registers.
Force-read a register, ignoring the access property of
the register.
Update the selected register group.
Set the active memory window to the address and size
of the selected register group.

Using the registers window
Both CPU registers and special function registers are shown in the main part of the Registers window. When the
program stops at a breakpoint, or is stepped, the Registers windows update to show the current values of the
registers. Items that have changed since they were previously displayed are highlighted in red.

To activate the first register window:
Choose Debug > Other Windows > Registers > Registers 1 or press Ctrl+T, R, 1.
Other register windows can be similarly activated.

Displaying CPU registers
The values of the CPU registers displayed in the Registers window depend up upon the selected context. The
selected context can be:
The register state the CPU stopped in.
The register state when a function call occurred using the Call Stack window.
The register state of the currently selected thread using the the Threads window.

207

CrossWorks for MSP430 Reference Manual

CrossStudio User Guide

The register state you supplied with the Debug > Locate operation.

To display a group of CPU registers:
On the Registers window toolbar, click the Groups button.
From the pop-up menu, select the register groups to display and deselect the ones to hide.
You can deselect all CPU register groups to allow more space in the display for special function registers or
peripheral registers. So, for instance, you can have one register window showing the CPU registers and other
register windows showing different peripheral registers.

Displaying special function or peripheral registers
The Registers window shows the set of register groups defined in the memory-map file the application was built
with. If there is no memory-map file associated with a project, the Registers window will show only the CPU
registers.

To display a special function or peripheral register:
On the Registers toolbar, click the Groups button.
From the pop-up menu, select the register groups to display and deselect the ones to hide.

Changing display format
When you select a register in the main part of the display, the display-format button highlighted on the
Registers window toolbar changes to show the item's display format.

To change the display format of a register:
Right-click the item to change.
From the shortcut menu, choose the desired display format.
or
Click the item to change.
On the Registers window toolbar, select the desired display format.

Modifying register values
To modify the value of a register:
Click the value of the register to modify.
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Enter the new value for the register. Prefix hexadecimal numbers with 0x, binary numbers with 0b, and
octal numbers with 0.
or
Right-click the value of the register to modify.
From the shortcut menu, choose one of the commands to modify the register value.
Modifying the saved register value of a function or thread may not be supported.
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Memory window
The Memory window shows the contents of the connected target's memory areas and allows the memory to
be edited. CrossStudio provides four memory windows, you can configure each memory window to display
different memory ranges.
The Memory window has a toolbar and a data display/edit area
Field/Button

Description

Address

Address to display. This can be a numeric value or a
debug expression.

Size

Number of bytes to display. This can be a number or
a debug expression. If unspecified, the number of
bytes required to fill the window will be automatically
calculated.

Columns

Number of columns to display. If unspecified, the
number of columns required to fill the window will be
automatically calculated.
Select binary display.
Select octal display.
Select unsigned decimal display.
Select signed decimal display.
Select hexadecimal display (default).
Select byte display (default).
Select 2-byte display.
Select 4-byte display.
Display both data and text (default).
Display data only.
Display text only.
Display an incrementing address range that starts from
the selected address (default).
Display a decrementing address range that starts from
the selected address.
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Display an incrementing address range that ends at
the selected address.
Display a decrementing address range that ends at the
selected address.
Evaluate the address and size expressions, and update
the Memory window.

Using the memory window
The memory window does not show the complete address space of the target, instead you must enter both the
address and the number of bytes to display. You can specify the address and size using numeric values or debug
expressions which enable you to position the memory display at the address of a variable or at the value of a
register. You can also specify whether you want the expressions to be evaluated each time the memory window
is updated, or you can re-evaluate them yourself with the press of a button. Memory windows update each time
your program stops on a breakpoint, after a single step and whenever you traverse the call stack. If any values
that were previously displayed have changed, they are highlighted in red.

To activate the first Memory window:
Choose Debug > Other Windows > Memory > Memory 1 or press Ctrl+T, M, 1.
Other register windows can be similarly activated.

Using the mouse
You can move the memory window's edit cursor by clicking on a data or text entry.
The vertical scroll bar can be used to modify the address being viewed by clicking the up and down buttons, the
page up and down areas or using the vertical scroll wheel when the scroll bar is at it's furthest extent. Holding
down the Shift key while scrolling will prevent the address being modified.

Using the keyboard
Keystroke

Description

Up

Move the cursor up one line, or if the cursor is on the
first line, move the address up one line.

Down

Move the cursor down one line, or if the cursor is on
the last line, move the address down line line.

Left

Move the cursor left one character.

Right

Move the cursor right one character.

Home

Move the cursor to the first entry.

End

Move the cursor to the last entry.
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PageUp

Move the cursor up one page, or if the cursor is on first
page, move the address up one page.

PageDown

Move the cursor down one page, or if the cursor is on
the last page, move the address down one page.

Ctrl+E

Toggle the cursor between data and text editing.

Editing memory
To edit memory, simply move the cursor to the data or text entry you want to modify and start typing. The
memory entry will be written and read back as you type.

Shortcut menu commands
The shortcut menu contains the following commands:
Action

Description

Access Memory By Display Width

Access memory in terms of the display width.

Address Order

Specify whether the address range shown uses
Address as the start or end address and whether
addresses should increment or decrement.

Auto Evaluate

Re-evaluate Address and Size each time the Memory
window is updated.

Auto Refresh

Specify how frequently the memory window should
automatically refresh.

Export To Binary Editor

Create a binary editor with the current Memory
window contents.

Save As

Save the current Memory window contents to a file.
Supported file formats are Binary File, Motorola SRecord File, Intel Hex File, TI Hex File, and Hex File.

Load From

Load the current Memory window from a file.
Supported file formats are Binary File, Motorola SRecord File, Intel Hex File, TI Hex File, and Hex File.

Display formats
You can set the Memory window to display 8-bit, 16-bit, and 32-bit values that are formatted as hexadecimal,
decimal, unsigned decimal, octal, or binary. You can also specify how many columns to display.

Saving memory contents
You can save the displayed contents of the memory window to a file in various formats. Alternatively, you can
export the contents to a binary editor to work on them.
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You can save the displayed memory values as a binary file, Motorola S-record file, Intel hex file, or a Texas
Instruments TXT file.

To save the current state of memory to a file:
Select the start address and number of bytes to save by editing the Start Address and Size fields in the
Memory window toolbar.
Right-click the main memory display.
From the shortcut menu, select Save As, then choose the format from the submenu.

To export the current state of memory to a binary editor:
Select the start address and number of bytes to save by editing the Start Address and Size fields in the
Memory window toolbar.
Right-click the main memory display.
Choose Export to Binary Editor from the shortcut menu.
Note that subsequent modifications in the binary editor will not modify memory in the target.

Copying to clipboard
You can copy the contents of the memory window to the clipboard as text. If an address range is selected, the
data or text of the selected range will be copied to the clipboard depending on whether the selection has been
made in the data or text view. If no address range is selected, the current memory window view will be copied to
the clipboard.
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Breakpoints window
The Breakpoints window manages the list of currently set breakpoints on the solution. Using the Breakpoints
window, you can:
Enable, disable, and delete existing breakpoints.
Add new breakpoints.
Show the status of existing breakpoints.
Breakpoints are stored in the session file, so they will be remembered each time you work on a particular
project. When running in the debugger, you can set breakpoints on assembly code addresses. These low-level
breakpoints appear in the Breakpoints window for the duration of the debug run but are not saved when you
stop debugging.
When a breakpoint is reached, the matching breakpoint is highlighted in the Breakpoints window.

Breakpoints window layout
The Breakpoints window has a toolbar and a main breakpoint display.
Button

Description
Create a new breakpoint using the New Breakpoint
dialog.
Toggle the selected breakpoint between enabled and
disabled states.
Remove the selected breakpoint.
Move the insertion point to the statement where the
selected breakpoint is set.
Delete all breakpoints.
Disable all breakpoints.
Enable all breakpoints.
Create a new breakpoint group and makes it active.

The main part of the Breakpoints window shows what breakpoints are set and the state they are in. You can
organize breakpoints into folders, called breakpoint groups.
CrossStudio displays these icons to the left of each breakpoint:
Icon

Description

214

CrossWorks for MSP430 Reference Manual

CrossStudio User Guide

Enabled breakpoint An enabled breakpoint will stop
your program running when the breakpoint condition
is met.
Disabled breakpoint A disabled breakpoint will not
stop the program when execution passes through it.
Invalid breakpoint An invalid breakpoint is one
where the breakpoint cannot be set; for example, no
executable code is associated with the source code
line where the breakpoint is set or the processor does
not have enough hardware breakpoints.

Showing the Breakpoints window
To activate the Breakpoints window:
Choose Breakpoints > Breakpoints or press Ctrl+Alt+B.

Managing single breakpoints
You can manage breakpoints in the Breakpoint window.

To delete a breakpoint:
In the Breakpoints window, click the breakpoint to delete.
From the Breakpoints window toolbar, click the Delete Breakpoint} button.

To edit the properties of a breakpoint:
In the Breakpoints window, right-click the breakpoint to edit.
Choose Edit Breakpoint from the shortcut menu.
Edit the breakpoint in the New Breakpoint dialog.
To toggle the enabled state of a breakpoint:
In the Breakpoints window, right-click the breakpoint to enable or disable.
Choose Enable/Disable Breakpoint from the shortcut menu.
or
In the Breakpoints window, click the breakpoint to enable or disable.
Press Ctrl+F9.
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Breakpoint groups
Breakpoints are divided into breakpoint groups. You can use breakpoint groups to specify sets of breakpoints
that are applicable to a particular project in the solution or for a particular debug scenario. Initially, there is a
single breakpoint group, named Default, to which all new breakpoints are added.

To create a new breakpoint group:
From the Breakpoints window toolbar, click the New Breakpoint Group button.
or
From the Debug menu, choose Breakpoints then New Breakpoint Group.
or
Right-click anywhere in the Breakpoints window.
Choose New Breakpoint Group from the shortcut menu.
In the New Breakpoint Group dialog, enter the name of the breakpoint group.
When you create a breakpoint, it is added to the active breakpoint group.

To make a group the active group:
In the Breakpoints window, right-click the breakpoint group to make active.
Choose Set as Active Group from the shortcut menu.

To delete a breakpoint group:
In the Breakpoints window, right-click the breakpoint group to delete.
Choose Delete Breakpoint Group from the shortcut menu.
You can enable all breakpoints within a group at once.

To enable all breakpoints in a group:
In the Breakpoints window, right-click the breakpoint group to enable.
Choose Enable Breakpoint Group from the shortcut menu.
You can disable all breakpoints within a group at once.

To disable all breakpoints in a group:
In the Breakpoints window, right-click the breakpoint group to disable.
Choose Disable Breakpoint Group from the shortcut menu.

Managing all breakpoints
You can delete, enable, or disable all breakpoints at once.
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To delete all breakpoints:
Choose Breakpoints > Clear All Breakpoints or press Ctrl+Shift+F9.
or
On the Breakpoints window toolbar, click the Delete All Breakpoints button.

To enable all breakpoints:
Choose Breakpoints > Enable All Breakpoints or press Ctrl+B, N.
or
On the Breakpoints window toolbar, click the Enable All Breakpoints button.

To disable all breakpoints:
Choose Breakpoints > Disable All Breakpoints or press Ctrl+B, X.
or
On the Breakpoints window toolbar, click the Disable All Breakpoints button.

217

CrossWorks for MSP430 Reference Manual

CrossStudio User Guide

Call Stack window
The Call Stack window displays the list of function calls (stack frames) that were active when program execution
halted. When execution halts, CrossStudio populates the call-stack window from the active (currently executing)
task. For simple, single-threaded applications not using the CrossWorks tasking library, there is only a single
task; but for multi-tasking programs that use the CrossWorks Tasking Library, there may be any number of tasks.
CrossStudio updates the Call Stack window when you change the active task in the Threads window.
The Call Stack window has a toolbar and a main call-stack display.
Button

Description
Move the insertion point to where the call was made
to the selected frame.
Set the debugger context to the selected stack frame.
Move the debugger context down one stack to the
called function.
Move the debugger context up one stack to the calling
function.
Select the fields to display for each entry in the call
stack.
Set the debugger context to the most recent stack
frame and move the insertion point to the currently
executing statement.

The main part of the Call Stack window displays each unfinished function call (active stack frame) at the point
when program execution halted. The most recent stack frame is displayed at the bottom of the list and the
oldest is displayed at the top of the list.
CrossStudio displays these icons to the left of each function name:
Icon

Description
Indicates the stack frame of the current task.
Indicates the stack frame selected for the debugger
context.
Indicates that a breakpoint is active and when the
function returns to its caller.

These icons can be overlaid to show, for instance, the debugger context and a breakpoint on the same stack
frame.
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Showing the call-stack window
To activate the Call Stack window:
Choose Debug > Call Stack or press Ctrl+Alt+S.

Configuring the call-stack window
Each entry in the Call Stack window displays the function name and, additionally, parameter names, types, and
values. You can configure the Call Stack window to show varying amounts of information for each stack frame.
By default, CrossStudio displays all information.

To show or hide a field:
1. On the Call Stack toolbar, click the Options button on the far right.
2. Select the fields to show, and deselect the ones that should be hidden.

Changing the debugger context
You can select the stack frame for the debugger context from the Call Stack window.

To move the debugger context to a specific stack frame:
In the Call Stack window, double-click the stack frame to move to.
or
In the Call Stack window, select the stack frame to move to.
On the Call Stack window's toolbar, click the Switch To Frame button.
or
In the Call Stack window, right-click the stack frame to move to.
Choose Switch To Frame from the shortcut menu.
The debugger moves the insertion point to the statement where the call was made. If there is no debug
information for the statement at the call location, CrossStudio opens a disassembly window at the instruction.

To move the debugger context up one stack frame:
On the Call Stack window's toolbar, click the Up One Stack Frame button.
or

219

CrossWorks for MSP430 Reference Manual

CrossStudio User Guide

On the Debug Location toolbar, click the Up One Stack Frame button.
or
Press Alt+-.
The debugger moves the insertion point to the statement where the call was made. If there is no debug
information for the statement at the call location, CrossStudio opens a disassembly window at the instruction.

To move the debugger context down one stack frame:
On the Call Stack window's toolbar, click the Down One Stack Frame button.
or
On the Debug Location toolbar, click the Down One Stack Frame button.
or
Press Alt++.
The debugger moves the insertion point to the statement where the call was made. If there is no debug
information for the statement at the call location, CrossStudio opens a disassembly window at the instruction.

Setting a breakpoint on a return to a function
To set a breakpoint on return to a function:
In the Call Stack window, click the stack frame on the function to stop at on return.
On the Build toolbar, click the Toggle Breakpoint button.
or
In the Call Stack window, click the stack frame on the function to stop at on return.
Press F9.
or
In the Call Stack window, right-click the function to stop at on return.
Choose Toggle Breakpoint from the shortcut menu.
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Threads window
The Threads window displays the set of executing contexts on the target processor structured as a set of
queues.

To activate the Threads window:
Choose Debug > Threads or press Ctrl+Alt+H.
The window is populated using the threads script, which is a JavaScript program store in a file whose file-type
property is "Threads Script" (or is called threads.js) and is in the project that is being debugged.
When debugging starts the function init() is called to determine which columns are displayed in the Threads
window.
When the application stops on a breakpoint, the function update() is called to create entries in the Threads
window corresponding to the columns that have been created together with the saved execution context
(register state) of the thread. By double-clicking one of the entries, the debugger displays its saved execution
contextto put the debugger back into the default execution context, use Show Next Statement.

Writing the threads script
The threads script controls the Threads window with the Threads object.
The methods Threads.setColumns, Threads.setSortByNumber and Threads.setColor can be called from the
function init().
function init()
{
Threads.setColumns("Name", "Priority", "State", "Time");
Threads.setSortByNumber("Time");
Threads.setColor("State", "Ready", "Executing", "Waiting");
}

The above example creates the named columns Name, Priority, State, and Time in the Threads window, with
the Time column sorted numerically rather than alphabetically. The states Ready, Executing and Waiting will
have yellow, green and red colored pixmaps respectively.
If you don't supply the function init() in the threads script, the Threads window will create the default columns
Name, Priority, and State.
The methods Threads.clear(), Threads.newqueue(), and Threads.add() can be called from the function
update().
The Threads.clear() method clears the Threads window.
The Threads.newqueue() function takes a string argument and creates a new, top-level entry in the Threads
window. Subsequent entries added to this window will go under this entry. If you don't call this, new entries will
all be at the top level of the Threads window.
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The Threads.add() function takes a variable number of string arguments, which should correspond to the
number of columns displayed by the Threads window. The last argument to the Threads.add() function
should be an array (possibly empty) containing the registers of the thread or, alternatively, a handle that can
be supplied a call to the threads script function getregs(handle), which will return an array when the thread is
selected in the Threads window. The array containing the registers should have elements in the same order in
which they are displayed in the CPU Registers displaytypically this will be in register-number order, e.g., r0, r1,
and so on.
function update()
{
Threads.clear();
Threads.newqueue("My Tasks");
Threads.add("Task1", "0", "Executing", "1000", [0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16]);
Threads.add("Task2", "1", "Waiting", "2000", [0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16]);
}

The above example will create a fixed output on the Threads window and is here to demonstrate how to call the
methods.
To get real thread state, you need to access the debugger from the threads script. To do this, you can use
the JavaScript method Debug.evaluate("expression"), which will evaluate the string argument as a debug
expression and return the result. The returned result will be an object if you evaluate an expression that denotes
a structure or an array. If the expression denotes a structure, each field can be accessed by using its field name.
So, if you have structs in the application as follows
struct task {
char *name;
unsigned char priority;
char *state;
unsigned time;
struct task *next;
unsigned registers[17];
unsigned thread_local_storage[4];
};
struct task task2 =
{
"Task2",
1,
"Waiting",
2000,
0,
{ 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16 },
{ 0,1,2,3 }
};
struct task task1 =
{
"Task1",
0,
"Executing",
1000,
&task2,
{ 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16 },
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{ 0,1,2,3 }
};

you can update() the Threads window using the following:
task1 = Debug.evaluate("task1");
Threads.add(task1.name, task1.priority, task1.state, task1.time, task1.registers);

You can use pointers and C-style cast to enable linked-list traversal.
var next = Debug.evaluate("&task1");
while (next)
{
var xt = Debug.evaluate("*(struct task*)"+next);
Threads.add(xt.name, xt.priority, xt.state, xt.time, xt.registers);
next = xt.next;
}

Note that, if the threads script goes into an endless loop, the debuggerand consequently CrossStudiowill
become unresponsive and you will need to kill CrossStudio using a task manager. Therefore, the above loop is
better coded as follows:
var next = Debug.evaluate("&task1");
var count = 0;
while (next && count < 10)
{
var xt = Debug.evaluate("*(struct task*)"+next);
Threads.add(xt.name, xt.priority, xt.state, xt.time, xt.registers);
next = xt.next;
count++;
}

You can speed up the Threads window update by not supplying the registers of the thread to the Threads.add()
function. To do this, you should supply a handle/pointer to the thread as the last argument to the Threads.add()
function. For example:
var next = Debug.evaluate("&task1");
var count = 0;
while (next && count < 10)
{
var xt = Debug.evaluate("*(struct task*)"+next);
Threads.add(xt.name, xt.priority, xt.state, xt.time, next);
next=xt.next;
count++;
}

When the thread is selected, the Threads window will call getregs(x) in the threads script. That function should
return the array of registers, for example:
function getregs(x)
{
return Debug.evaluate("((struct task*)"+x+")->registers");
}
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If you use thread local storage, implementing the gettls(x) function enables you to return the base address of
the thread local storage, for example:
function gettls(x)
{
return Debug.evaluate("((struct task*)"+x+")->thread_local_storage");
}

The gettls(x) function can also be called with null as a parameter. In this case you will have to evaluate an
expression that returns the current thread local storage, for example:
function gettls(x)
{
if (x==null)
x = Debug.evaluate("&currentTask");
return Debug.evaluate("((struct task*)"+x+")->thread_local_storage");
}

The debugger may require the name of a thread which you can provide by implementing the getname(x)
function, for example:
function getname(x)
{
return Debug.evaluate("((struct task*)"+x+")->name");
}

Adding extra queues to the threads window
You can add extra information to the threads window to display other RTOS queues. In the function init() you
can use Threads.setColumns2 to create an additional display in the threads window, for example:
function init()
{
...
Threads.setColumns2("Timers", "Id(Timers)", "Name", "Hook", "Timeout", "Period", "Active");

The first argument is identifier of the queue which is also supplied to Threads.add2 in the function update() as
follows
function update()
{
...
Threads.add2("Timers", "0x1FF0A30", "MyTimer", "0x46C8 (Timer50)", "50(550)", "50", "1");

You can avoid updating queues that aren't displayed using the Threads.shown function as follows
function update()
{
...
if (Threads.shown("Timers"))
Threads.add2("Timers", "0x1FF0A30", "MyTimer", "0x46C8
(Timer50)", "50(550)", "50", "1");
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Execution Profile window
The Execution Profile window shows a list of source locations and the number of times those source locations
have been executed. This window is only available for targets that support the collection of jump trace
information.

To activate the Execution Profile window:
Choose Debug > Other Windows > Execution Profile or press Ctrl+T, P.
The count value displayed is the number of times the first instruction of the source code location has been
executed. The source locations displayed are target dependent: they could represent each statement of the
program or each jump target of the program. If however the debugger is in intermixed or disassembly mode
then the count values will be displayed on a per instruction basis.
The execution counts window is updated each time your program stops and the window is visible so if you have
this window displayed then single stepping may be slower than usual.
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Execution Trace window
The trace window displays historical information on the instructions executed by the target.

To activate the Trace window:
Choose Debug > Other Windows > Execution Trace or press Ctrl+T, T.
The type and number of the trace entries depends upon the target that is connected when gathering trace
information. Some targets may trace all instructions, others may trace jump instructions, and some may trace
modifications to variables. You'll find the trace capabilities of your target on the shortcut menu.
Each entry in the trace window has a unique number, and the lower the number the earlier the trace. You can
click on the header to show earliest to latest or the latest to earliest trace entries. If a trace entry can have source
code located to it then double-clicking the trace entry will show the appropriate source display.
Some targets may provide timing information which will be displayed in the ticks column.
The trace window is updated each time the debugger stops when it is visible so single stepping is likely to be
slower if you have this window displayed.
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Debug file search editor
When a program is built with debugging enabled, the debugging information contains the paths and filenames
of all the source files for the program in order to allow the debugger to find them. If a program or library linked
into the program is on a different machine than the one on which it was compiled, or if the source files were
moved after the program was compiled, the debugger will not be able to find the source files.
In this situation, the simplest way to help CrossStudio find the source files is to add the directory containing
the source files to one of its source-file search paths. Alternatively, if CrossStudio cannot find a source file, it will
prompt you for its location and will record its new location in the source-file map.

Debug source-file search paths
Debug's source-file search paths can be used to help the debugger locate source files that are no longer located
where they were at compile time. When a source file cannot be found, the search-path directories will be
checked, in turn, to see if they contain the source file. CrossStudio maintains two debug source-file search paths:
Project-session search path:This path is for the current project session and does not apply to all projects.
The global search path:This system-wide path applies to all projects.
The project-session search path is checked before the global search path.

To edit the debug search paths:
Choose Debug > Options > Search Paths.

Debug source file map
If a source file cannot be found while debugging and the debugger has to prompt the user for its location,
the results are stored in the debug source file map. The debug source file map simply correlates, or maps, the
original pathnames to the new locations. When a file cannot be found at its original location or in the debug
search paths, the debug source file map is checked to see if a new location has been recorded for the file or if the
user has specified that the file does not exist. Each project session maintains its own source file map, the map is
not shared by all projects.

To view the debug source file map:
Choose Debug > Options > Search Paths.

To remove individual entries from the debug source file map:
Choose Debug > Options > Search Paths.
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Right-click the mapping to delete.
Choose Delete Mapping from the shortcut menu.

To remove all entries from the debug source file map:
Choose Debug > Options > Search Paths.
Right-click any mapping.
Choose Delete All Mappings from the shortcut menu.
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Debug Terminal window
The Debug Terminal window displays debug output from the target application and can also be used to be
provide debug input to the target application.

To activate the Debug Terminal window:
Choose Debug > Debug Terminal or press Ctrl+Alt+D.
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Debug Immediate window
The Debug Immediate window allows you to type in debug expressions and display the results. All results are
displayed in the format specified by the Default Display Mode property found in the Debugging group in the
Environment Options dialog.

To activate the Envronment Options dialog:
Choose Tools > Options or press Alt+,.

To activate the Debug Immediate window:
Choose Debug > Other Windows > Debug Immediate.
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Breakpoint expressions
The debugger can set breakpoints by evaluating simple C-like expressions. Note that the exact capabilities
offered by the hardware to assist in data breakpointing will vary from target to target; please refer to the
particular target interface you are using and the capabilities of your target silicon for exact details. The simplest
expression supported is a symbol name. If the symbol name is a function, a breakpoint occurs when the first
instruction of the symbol is about to be executed. If the symbol name is a variable, a breakpoint occurs when the
symbol has been accessed; this is termed a data breakpoint. For example, the expression x will breakpoint when
x is accessed. You can use a debug expression (see Debug expressions) as a breakpoint expression. For example,
x[4] will breakpoint when element 4 of array x is accessed, and @sp will breakpoint when the sp register is
accessed.
Data breakpoints can be specified, using the == operator, to occur when a symbol is accessed with a specific
value. The expression x == 4 will breakpoint when x is accessed and its value is 4. The operators <, >=, >;, >=,
==, and != can be used similarly. For example, @sp <= 0x1000 will breakpoint when register sp is accessed
and its value is less than or equal to 0x1000.
You can use the operator & to mask the value you wish to break on. For example, (x & 1) == 1 will
breakpoint when x is accessed and has an odd value.
You can use the operator && to combine comparisons. For example
(x >= 2) && (x <= 14)

will breakpoint when x is accessed and its value is between 2 and 14.
You can specify an arbitrary memory range using an array cast expression. For example, (char[256])
(0x1000) will breakpoint when the memory region 0x10000x10FF is accessed.
You can specify an inverse memory range using the ! operator. For example !(char[256])(0x1000) will
breakpoint when memory outside the range 0x10000x10FF is accessed.

231

CrossWorks for MSP430 Reference Manual

CrossStudio User Guide

Debug expressions
The debugger can evaluate simple expressions that can be displayed in the Watch window or as a tool-tip in the
code editor.
The simplest expression is an identifier the debugger tries to interpret in the following order:
an identifier that exists in the scope of the current context.
the name of a global identifier in the program of the current context.
Numbers can be used in expressions. Hexadecimal numbers must be prefixed with 0x.
Registers can be referenced by prefixing the register name with @.
The standard C and C++ operators !, ~, *, /, %, +, -, >>, <<, <, <=, >, >=, ==, |, &, ^, &&, and || are supported
on numeric types.
The standard assignment operators =, +=, -=, *=, /=, %=, >>, >>=, <<=, &=, |=, ^= are supported on numeric
types.
The array subscript operator [] is supported on array and pointer types.
The structure access operator . is supported on structured types (this also works on pointers to structures), and > works similarly.
The dereference operator (prefix *) is supported on pointers, the address-of (prefix &) and sizeof operators are
supported.
The addressof(filename, linenumber) operator will return the address of the specified source code line
number.
Function calling with parameters and return results.
Casting to basic pointer types is supported. For example, (unsigned char *)0x300 can be used to display the
memory at a given location.
Casting to basic array types is supported. For example, (unsigned char[256])0x100 can be used to reference a
memory region.
Arrays can be sliced using [a:b] where a is the first element and b is the last element to display.
Operators have the precedence and associativity one expects of a C-like programming language.
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Output window
The Output window contains logs and transcripts from various systems within CrossStudio. Most notably, it
contains the Transcript and Source Navigator Log.

Transcript
The Transcript contains the results of the last build or target operation. It is cleared on each build. Errors
detected by CrossStudio are shown in red and warnings are shown in yellow. Double-clicking an error
or warning in the build log will open the offending file at the error position. The commands used for the
build can be echoed to the build log by setting the Echo Build Command Lines environment option. The
transcript also shows a trace of the high-level loading and debug operations carried out on the target. For
downloading, uploading, and verification operations, it displays the time it took to carry out each operation.
The log is cleared for each new download or debug session.

Navigator Log
The Source Navigator Log displays a list of files the Source Navigator has parsed and the time it took to
parse each file.

To activate the Output window:
Choose View > Output or press Ctrl+Alt+O.

To show a specific log:
On the Output window toolbar, click the log combo box.
From the list, click the log to display.
or
Choose View > Logs and select the log to display.
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Properties window
The Properties window displays properties of the current CrossStudio object. Using the Properties window, you
can set the build properties of your project, modify the editor defaults, and change target settings.

To activate the Properties window:
Choose View > Properties Window or press Ctrl+Alt+Enter.
The Properties window is organized as a set of keyvalue pairs. As you select one of the keys, help text explains
the purpose of the property. Because properties are numerous and can be specific to a particular product build,
consider this help to be the definitive help on the property.
You can divide the properties display into categories or, alternatively, display it as a flat list that is sorted
alphabetically.
A combo-box enables you to change the properties and explains which properties you are looking at.
Some properties have actions associated with themyou can find these by right-clicking the property key. Most
properties that represent filenames can be opened this way.
When the Properties window is displaying project properties, you'll find some properties displayed in bold. This
means the property value hasn't been inherited. If you wish to inherit rather than define such a property, rightclick the property and select Inherit from the shortcut menu.
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Targets window
The Targets window (and its associated menu) displays the set of target interfaces you can connect to in order
to download and debug your programs. Using the Targets window in conjunction with the Properties window
enables you to define new targets based on the specific target types supported by the particular CrossStudio
release.

To activate the Targets window:
Choose View > Targets or press Ctrl+Alt+T.
You can connect, disconnect, and reconnect to a target system. You can also use the Targets window to reset
and load programs.

Targets window layout
Button

Description
Connect the target interface selected in the Targets
window.
Disconnect the connected target interface.
Reconnect the connected target interface.
Reset the connected target interface.
Display the properties of the selected target interface.

Managing connections to target devices
To connect a target:
In the Targets window, double-click the target to connect.
or
Choose Target > Connect and click the target to connect.
or
1. In the Targets window, click the target to connect.
2. On the Targets window toolbar, click the Connect button
or
1. In the Targets window, right-click the target to connect.
2. Choose Connect.
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To disconnect a target:
Choose Target > Disconnect or press Ctrl+T, D.
or
On the Targets window toolbar, click the Disconnect button.
or
1. Right-click the connected target in the Targets window.
2. Choose Disconnect from the shortcut menu.
Alternatively, connecting a different target will disconnect the current target connection.
You can disconnect and reconnect a target in a single operation using the reconnect feature. This may be useful
if the target board has been power cycled, or reset manually, because it forces CrossStudio to resynchronize with
the target.

To reconnect a target:
Choose Target > Reconnect or press Ctrl+T, E.
or
On the Targets window toolbar, click the Reconnect button.
or
1. In the Targets window, right-click the target to reconnect.
2. Choose Reconnect from the shortcut menu.

Automatic target connection
You can configure CrossStudio to automatically connect to the last-used target interface when loading a
solution.

To enable or disable automatic target connection:
1. Choose View > Targets or press Ctrl+Alt+T.
2. Click the disclosure arrow on the Targets window toolbar.
3. Select or deselect Unknown property Target/Auto Connect.

Resetting the target
Reset of the target is typically handled by the system when you start debugging. However, you can manually
reset the target from the Targets window.

To reset the connected target:
Choose Project > Reset And Debug or press Ctrl+Alt+F5.
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or
On the Targets window toolbar, click the Reset button.

Creating a new target interface
To create a new target interface:
1. From the Targets window shortcut menu, click New Target Interface. A menu will display the types of
target interface that can be created.
2. Select the type of target interface to create.

Setting target interface properties
All target interfaces have a set of properties. Some properties are read-only and provide information about the
target, but others are modifiable and allow the target interface to be configured. Target interface properties can
be viewed and edited using CrossStudio's property system.

To view or edit target properties:
Select a target.
Select the Properties option from the target's shortcut menu.
The Targets window provides the facility to restore the target definitions to the default set. Restoring the default
target definitions will undo any of the changes you have made to the targets and their properties, therefore it
should be used with care.

To restore the default target definitions:
1. Select Restore Default Targets from the Targets window shortcut menu.
2. Click Yes when the systems asks whether you want to restore the default targets.

Importing and exporting target definitions
You can import and export your target-interface definitions. This may be useful if you make a change to the
default set of target definitions and want to share it with another user or use it on another machine.

To export the current set of target-interface definitions:
Choose Export Target Definitions To XML from the Targets window shortcut menu.
Specify the location and name of the file to which you want to save the target definitions and click Save.

To import an existing set of target-interface definitions:
Select Import Target Definitions From XML from the Targets window shortcut menu.
Select the file from which you want to load the target definitions and click Open.
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Downloading programs
Program download is handled automatically by CrossStudio when you start debugging. However, you can
download arbitrary programs to a target using the Targets window.

To download a program to the currently selected target:
In the Targets window, right-click the selected target.
Choose Download File.
From the Download File menu, select the type of file to download.
In the Open File dialog, select the executable file to download and click Open to download the file.
CrossStudio supports the following file formats when downloading a program:
Binary
Intel Hex
Motorola S-record
CrossWorks native object file
Texas Instruments text file

Verifying downloaded programs
You can verify a target's contents against arbitrary programs on disk using the Targets window.

To verify a target's contents against a program:
1. In the Targets window, right-click the selected target.
2. Choose Verify File.
3. From the Verify File menu, select the type of file to verify.
4. In the Open File dialog, select the executable file to verify and click Open to verify the file.
CrossStudio supports the same file types for verification as for downloading.

Erasing target memory
Usually, erasing target memory is done when CrossStudio downloads a program, but you can erase a target's
memory manually.

To erase all target memory:
1. In the Targets window, right-click the target to erase.
2. Choose Erase All from the shortcut menu.

To erase part of target memory:
1. In the Targets window, right-click the target to erase.
2. Choose Erase Range from the shortcut menu.
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Terminal emulator window
The Terminal Emulator window contains a basic serial-terminal emulator that allows you to receive and transmit
data over a serial interface.

To activate the Terminal Emulator window:
Choose Tools > Terminal Emulator > Terminal Emulator or press Ctrl+Alt+M.

To use the terminal emulator:
1. Set the required terminal emulator properties.
2. Connect the terminal emulator to the communications port by clicking the button on the toolbar or by
selecting Connect from the shortcut menu.
Once connected, any input in the Terminal Emulator window is sent to the communications port and any data
received from the communications port is displayed on the terminal.
Connection may be refused if the communication port is in use by another application or if the port doesn't
exist.

To disconnect the terminal emulator:
1. Disconnect the communications port by clicking the Disconnect icon on the toolbar or by right-clicking
to select Disconnect from the shortcut menu.
This will release the communications port for use in other applications.

Supported control codes
The terminal supports a limited set of control codes:
Control code

Description

<BS>

Backspace

<CR>

Carriage return

<LF>

Linefeed

<ESC>[{attr1};...;{attrn}m

Set display attributes. The attributes 2-Dim, 5-Blink, 7Reverse, and 8-Hidden are not supported.
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Script Console window
The Script Console window provides interactive access to the JavaScript interpreter and JavaScript classes that
are built into CrossStudio. The interpreter is an implementation of the 3rd edition of the ECMAScript standard.
The interpreter has an additional function property of the global object that enable files to be loaded into the
interpreter.
The JavaScript method load(filepath) loads and executes the JavaScript contained in filepath returns a Boolean
indicating success.

To activate the Script Console window:
Choose View > Script Console or press Ctrl+Alt+J.

240

CrossWorks for MSP430 Reference Manual

CrossStudio User Guide

Downloads window
The Downloads Window displays a historical list of files downloaded over the Internet by CrossStudio.

To activate the Downloads window:
Choose Tools > Downloads Window.
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Latest News window
The Latest News window displays a historical list of news articles from the Rowley Associates website.

To activate the Latest News window:
Choose Help > Latest News.
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Command-line options
This section describes the command-line options accepted by CrossStudio.

Usage
crossstudio [options] [files]
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-D (Define macro)
Syntax
-D macro=value

Description
Define a CrossWorks macro value.
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-noclang (Disable Clang support)
Syntax
-noclang

Description
Disable Clang support.
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-noload (Disable loading of last project)
Syntax
-noload

Description
Disable loading of last project on startup.
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-packagesdir (Specify packages directory)
Syntax
-packagesdir dir

Description
Override the default value of the $(PackagesDir) macro.
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-permit-multiple-studio-instances (Permit multiple
studio instances)
Syntax
-permit-multiple-studio-instances

Description
Allow multiple instances of CrossStudio to run at the same time. This behaviour can also be enabled using the
Environment > Startup Options > Allow Multiple CrossStudios environment option.
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-rootuserdir (Set the root user data directory)
Syntax
-rootuserdir dir

Description
Set the CrossWorks root user data directory.
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-save-settings-off (Disable saving of environment
settings)
Syntax
-save-settings-off

Description
Disable the saving of modified environment settings.
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-set-setting (Set environment setting)
Syntax
-set-setting environment_setting=value

Description
Sets an environment setting to a specified value. For example:
-set-setting "Environment/Build/Show Command Lines=Yes"
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-templatesfile (Set project templates path)
Syntax
-templatesfile path

Description
Sets the search path for finding project template files.
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Uninstalling CrossWorks for MSP430
This section describes how to completely uninstall CrossWorks for MSP430 for each supported operating system:
Uninstalling CrossWorks for MSP430 from Windows
Uninstalling CrossWorks for MSP430 from Mac OS X
Uninstalling CrossWorks for MSP430 from Linux

Uninstalling CrossWorks for MSP430 from Windows
Removing user data and settings
The uninstaller does not remove any user data such as settings or installed packages. To completely remove the
user data you will need to carry out the following operations for each user that has used CrossWorks for MSP430
on your system.
To remove user data using CrossStudio:
1. Start CrossStudio.
2. Click Tools > Admin > Remove All User Data...
Alternatively, if CrossWorks for MSP430 has already been uninstalled you can manually remove the user data as
follows:
1. Click the Windows Start button.
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2. Type %LOCALAPPDATA% in the search field and press enter to open the local application data folder.
3. Open the Rowley Associates Limited folder.
4. Open the CrossWorks for MSP430 folder.
5. Delete the v3 folder.
6. If you want to delete user data for all versions of the software, delete the CrossWorks for MSP430 folder as
well.

Uninstalling CrossWorks for MSP430
To uninstall CrossWorks for MSP430:
1. If CrossStudio is running, click File > Exit to shut it down.
2. Click the Start Menu and select Control Panel. The Control Panel window will open.
3. In the Control Panel window, click the Uninstall a program link under the Programs section.
4. From the list of currently installed programs, select CrossWorks for MSP430 3.2.
5. To begin the uninstall, click the Uninstall button at the top of the list.

Uninstalling CrossWorks for MSP430 from Mac OS X
Removing user data and settings
Uninstalling does not remove any user data such as settings or installed packages. To completely remove the
user data you will need to carry out the following operations for each user that has used CrossWorks for MSP430
on your system.
To remove user data using CrossStudio:
1. Start CrossStudio.
2. Click Tools > Admin > Remove All User Data...
Alternatively, if CrossWorks for MSP430 has already been uninstalled you can manually remove the user data as
follows:
1. Open Finder.
2. Go to the $HOME/Library/Rowley Associates Limited/CrossWorks for MSP430 directory.
3. Drag the v3 folder to the Trash.
4. If you want to delete user data for all versions of the software, drag the CrossWorks for MSP430 folder to
the Trash as well.

Uninstalling CrossWorks for MSP430
To uninstall CrossWorks for MSP430:

254

CrossWorks for MSP430 Reference Manual

Uninstalling CrossWorks for MSP430

1. If CrossStudio is running, shut it down.
2. Open the Applications folder in Finder.
3. Drag the CrossWorks for MSP430 3.2 folder to the Trash.

Uninstalling CrossWorks for MSP430 from Linux
Removing user data and settings
The uninstaller does not remove any user data such as settings or installed packages. To completely remove the
user data you will need to carry out the following operations for each user that has used CrossWorks for MSP430
on your system.
To remove user data using CrossStudio:
1. Start CrossStudio.
2. Click Tools > Admin > Remove All User Data...
Alternatively, if CrossWorks for MSP430 has already been uninstalled you can manually remove the user data as
follows:
1. Open a terminal window or file browser.
2. Go to the $HOME/.rowley_associates_limited/CrossWorks for MSP430 directory.
3. Delete the v3 directory.
4. If you want to delete user data for all versions of the software, delete the CrossWorks for MSP430 directory
as well.

Uninstalling CrossWorks for MSP430
To uninstall CrossWorks for MSP430:
1. If CrossStudio is running, click File > Exit to shut it down.
2. Open a terminal window.
3. Go to the CrossWorks for MSP430 bin directory (this is /usr/share/crossworks_for_msp430_3.2/bin by
default).
4. Run sudo ./uninstall to start the uninstaller.
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Target interfaces
A target interface is a mechanism for communicating with, and controlling, a target. A target can be either a
physical hardware device or a software simulation of a device. CrossStudio has a Targets window for viewing
and manipulating target interfaces. For more information, see Targets window.
Before you can use a target interface, you must connect to it. You can only connect to one target interface at a
time. For more information, see Connecting to a target.
All target interfaces have a set of properties. The properties provide information on the connected target and
allow the target interface to be configured. For more information, see Viewing and editing target properties.

MSP430 Debug Capabilities
The debug capabilities provided by CrossWorks for MSP430 are implemented using the MSP430 Enhanced
Emulation Module (EEM). At the time of this writing, SLAA393 is the only publicly available document that
details the capabilities of the EEM. Refer to this document to learn about the debug capabilities of a particular
device.

Software breakpoints
If the project property Implement Software Breakpoints is set to Yes when the target is connected then the
opcode 0x4343 (mov.b r3, r3) is treated as a software-breakpoint instruction and, as such, when you set a
code breakpoint, this opcode is written to the address at which you want execution to break. Using this feature
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provides an unlimited number of code breakpoints but will use one hardware breakpoint (EEM combination
trigger) to implement the software breakpoint.

EEM triggers
CrossWorks for MSP430 implements breakpoint expressions (see Breakpoint expressions) using EEM triggers.
Breakpoint expressions provide a simple interface for setting complex breakpoints. Additionally, using the
breakpoint dialogs and breakpoint property window with CrossWorks for MSP430, you can specify
the EEM trigger type, by using Breakpoint Trigger Type.
the EEM reaction (Stop, Trace, or Sequencer), by using Action.
the EEM combination trigger number, by using Use Hardware Breakpoint. You should only need to use
this if you are using the Trigger Sequencer or the MSP430F5xx variable-watch capability.

EEM state storage
The Debug > Control > State Storage Control dialog allows you to configure the state-storage block of the EEM,
and the Debug > Debug Windows > EEM State Storage window allows you to see the contents of the EEMstate-storage block. You can specify that breakpoints are to be used for state-storage control and are stored
into the storage block by setting their breakpoint property Action to Trace. To implement a real-time trace on
a variable, you can set a data breakpoint on a variable with the breakpoint property Action set to Trace, and
set the state storage control to Store Mode: Triggers. You can refresh the EEM State Storage window without
stopping the processor by right-clicking the window and choosing Refresh from the shortcut menu.

Variable watch (MSP430F5xx only)
On MSP430F5xx devices, you can configure the state-storage block to store variable values to fixed EEM storage
locations and do instruction tracing with the remaining storage locations. For example, you can set statestorage locations 0 and 1 to contain the data-watch values corresponding to the EEM combination triggers 0
and 1. If you want to do this, you need to assign the appropriate EEM trigger combination number to the data
breakpoint. Note that the EEM combination trigger number 0 is used to implement software breakpoints so, if
you want to use this feature, you should disable software breakpoints.

EEM trigger sequencer
The EEM trigger sequencer enables EEM combination triggers 47 to be used as inputs to the trigger sequencer
and, optionally, the EEM combination trigger 3 to be used to reset the trigger sequencer. The breakpoints you
want as inputs to the sequencer should have the EEM combination trigger numbers 47 assigned to them and
should have the breakpoint property Action set to Sequencer. You can set up the trigger sequencer using the
Debug > Control > Sequencer Control dialog, and you can use the Debug > Debug Windows > EEM Trigger
Sequencer window to see the current state of the trigger sequencer. The trigger sequencer starts in State0 and
executes the specified action when it enters State3. On each state, there can be two transitions (A and B) to any
of the other states.
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Clock control
When you are connected to a target, you can use the ClockControl} dialogfrom the Debug > Control > Clock
Control menuto specify the clock behavior when the CPU stops on a breakpoint. The desired clock-control
settings are programmed when you start debugging, they cannot be changed while you are debugging. The
settings reported by the Clock Control dialog are specific to a particular device.

Examples from SLAA393
See SLAA393 on the TI website.

Break on write to address
Using the New Data Breakpoint dialog, the breakpoint expression wLoopCounter==50 will break when
wLoopCounter is written with the value 50.

Break on Write to Register
Using the New Data Breakpoint dialog, the breakpoint expression @sp\<=0x09A0 will break when the stack
pointer is written with a value less than 0x09A0.

Break on Write to Flash
Using the New Data Breakpoint dialog, entering the breakpoint expression (char[0xF000])0x1000 and setting
the "Breakpoint Trigger Type" to "Write" will break when a write is made to flash memory.

Break on Access of Invalid Memory
Using the New Data Breakpoint dialog, entering the breakpoint expression (char[0x400])0x0C00 and setting
the "Breakpoint Trigger Type" to "No IFetch" will break when an access is made to BSL memory.

Break if Fetch is Out of Allowed Area
Using the New Data Breakpoint dialog, entering the breakpoint expression !(char[0xF000])0x1000 and setting
the "Breakpoint Trigger Type" to "IFetch" will break when a fetch is made from outside flash memory.

CrossConnect for MSP430
Describes the Rowley CrossConnect for MSP430 target interface. This target interface is applicable to
CrossConnect for ARM when used with a suitable ARM 20-pin to MSP430 14-pin JTAG converter. The
converter should map the ARM nTRST signal to the MSP430 TEST signal, and the ARM nSRST, TDI, TMS, TCK,
TDO, VCC, and GND signals map to the equivalent MSP430 signals.

TI MSP430 DLL Interface
Describes the MSP430 DLL interface, which is used to connect to a variety of devices, including the TI MSPFET430UIF and Olimex MSP430-JTAG-TINY.
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MSP430 core simulator
Describes the core simulator provided by CrossStudio, which you can use to develop software without
access to hardware.
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CrossConnect Target Interface
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MSP430 DLL Target Interface
Connection
Property

Description

Check Firmware Version

Check firmware version and upgrade with firmware in
the MSP430.dll

upgradeFWBoolean

Interface Type
interfaceTypeEnumeration

Target Driver DLL Path
targetDllPathFileName

Vcc
vccInteger

Version
versionString

The target interface type to use.
Specifies the path to use to load the MSP430 target
driver DLL.
Set the desired supply voltage (specified in millivolts).
MSP430 target driver DLL version number.

Target
Property

Description

Device Type

The detected type of the currently connected target
device.

String

Host Connection
ConnectionEnumeration
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MSP430 Core Simulator Target Interface
Target
Property

Description

Device Type

The detected type of the currently connected target
device.

String

263

CrossWorks for MSP430 Reference Manual

Target interfaces

264

CrossWorks for MSP430 Reference Manual

C Compiler User Guide

C Compiler User Guide
CrossWorks C is a faithful implementation of the ANSI and ISO standards for the programming language C. This
manual describes the C language as implemented by the CrossWorks C compiler.
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Command line options
This section describes the command line options accepted by the CrossWorks C compiler.
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-ansi (Warn about potential ANSI problems)
Syntax
-ansi

Description
Warn about potential problems that conflict with the relevant ANSI or ISO standard for the files that are
compiled.

Project property
Compiler Options > Enforce ANSI Checking
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-D (Define macro symbol)
Syntax
-Dname
-Dname=value

Description
You can define preprocessor macros using the -D option. The macro definitions are passed on to the respective
language compiler which is responsible for interpreting the definitions and providing them to the programmer
within the language.
The first form above defines the macro name but without an associated replacement value, and the second
defines the same macro with the replacement value value.

Project property
Preprocessor Options > Preprocessor Definitions

Example
The following defines two macros, SUPPORT_FLOAT with a value of 1 and LITTLE_ENDIAN with no replacement
value.
-DSUPPORT_FLOAT=1 -DLITTLE_ENDIAN
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-g (Generate debugging information)
Syntax
-g

Description
The -g option instructs the compiler to generate debugging information (line numbers and data type
information) for the debugger to use.

Project property
Build Options > Include Debug Information
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-I (Define user include directories)
Syntax
-Idirectory

Description
In order to find include files the compiler driver arranges for the compilers to search a number of standard
directories. You can add directories to the search path using the -I switch which is passed on to each of the
language processors.

Project property
Preprocessor Options > User Include Directories
You can specify more than one include directory by separating each directory component with either a comma
or semicolon.
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-J (Define system include directories)
Syntax
-Jdirectory

Description
The -J option adds directory to the end of the list of directories to search for source files included (using
triangular brackets) by the #include preprocessor command.

Project property
Preprocessor Options > System Include Directories
You can specify more than one include directory by separating each directory component with either a comma
or semicolon in the property
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-m (Set MSP430 code memory size)
Syntax
-m64k
-m1m

Description
This option instructs the compiler to generate code for an MSP430 with with 64 kilobytes of code memory (a
compact model) or up to 1 megabyte of code memory (a large model). If you generate code for a standard
MSP430 processor that cannot support a large address space, this option is ignored.
For some processors, such as the CC430, although they have an MSP430X core, they do not have code memory
that extends beyond the first 64 kilobytes of the address space. In this case it is beneficial, in terms of code space,
data space, and execution time, to use the compact memory model which limits the total address space to 64
kilobytes.
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-mcpux (Enable MSP430X processor)
Syntax
-mcpux

Description
This option instructs the compiler to generate code for the 20-bit MSP430X CPU core rather than a 16-bit
MSP430 core. Note that it is not possible, in general, to mix code generated for the MSP430X with code
generated for the MSP430.
By default the compiler selects large model when compiling code for an MSP430X. If your target processor
has an MSP430X core with a total memory space of less than 64K, you will use less code and data space, and
decrease execution time, if you select the compact memory model with the -m64k switch.

Project property
The correct CPU type is selected when you select or change your project's target processor. You can override this
but we strongly discourage you from doing this.
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-mmpy (Enable hardware multiplier)
Syntax
-mmpy

Description
This option instructs the compiler to generate code that can use the MSP430 hardware multiplier. By default,
the hardware multiplier is not used and all integer and floating-point multiplications are carried out by software
loops.
When using the hardware multiplier, the compiler ensures that no interrupts occur during the time the
multiplier is in use. Global interrupts are disabled during a multiplication to prevent, for instance, an interrupt
being taken immediately after the multiplication is complete but before the result has been loaded which could
possibly corrupt the result of the multiplication. Because interrupts are disabled during hardware-assisted
multiplication, interrupt latency is increasedif you wish to have the lowest possible interrupt latency, then do not
enable the hardware multiplier and use soft multiplication instead.
The CrossWorks compiler generates inline code to use the hardware multiplier for 16-bit multiplications and
calls out-of-line subroutines for all other multiplications. The runtime library also uses the hardware multiplier to
accelerate multiplication of floating-point values.

Project property
Compiler Options > Use Hardware Multiplier
It is not possible to set this option on a per-file basis.

Note
There is no means to prevent a non-maskable interrupt from occurring, so you must be very careful not to use
the hardware multiplier in an NMI interrupt service routine.
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-msd (Treat double as float)
Syntax
-msd

Description
This option directs the compiler to treat double as float and not to support 64-bit floating point arithmetic.

Project property
Compiler Options > Treat 'double' as 'float'
It is not possible to set this option on a per-file basis.

275

CrossWorks for MSP430 Reference Manual

C Compiler User Guide

-o (Set output file name)
Syntax
-o filename

Description
The -o option instructs the compiler to write its object file to filename.
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-O (Optimize code generation)
Syntax
-Olevel

Description
Optimize at level level which must be between -9 and +9. Negative values of level optimize code space at the
expense of speed, whereas positive values of level optimize for speed at the expense of code space. The + sign
for positive optimization levels is accepted but not required.
The exact strategies used by the compiler to perform the optimization will vary from release to release and are
not described here.

Project property
Code Generation Options > Optimization Strategy
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-Or (Optimize register allocation)
Syntax
-Or{g | l | -}

Description
This selects the way that registers are allocated:
-Org enables allocation of local variables and addresses of global variables and functions to processor
registers for the lifetime of a function. This form of register allocation will always reduce code size but
may reduce execution speed for some paths through the function.
-Orl enables allocation of local variables (but not addresses of global variables and functions) to processor
registers for the lifetime of a function. Register allocation of locals to processor registers will always
reduce code size and increase execution speed.
-Or- disables all allocation of values and addresses to processor registers.

Project property
Code Generation Options > Register Allocation
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-Rc (Set default code section name)
Syntax
-Rc,name

Description
The -Rc command line option sets the name of the section that the compiler emits code into. If no other options
are given, the default name for the section is CODE.
You can control the name of the code section used by the compiler within a source file using the #pragma
codeseg or by using CrossStudio to set the Code Section Name property of the file or project.

Project property
Section Options > Code Section Name
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-Rd (Set default initialized data section name)
Syntax
-Rd,name

Description
The -Rd command line option sets the name of the section that the compiler emits code into. If no other options
are given, the default name for the section is IDATA0.
You can control the name of the code section used by the compiler within a source file using the #pragma
dataseg or by using CrossStudio to set the Data Section Name property of the file or project.

Project property
Section Options > Data Section Name
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-Ri (Set default ISR section name)
Syntax
-Ri,name

Description
The -Ri command line option sets the name of the section that the compiler emits interrupt service routine (ISR)
code into. If no other options are given, the default name for the section is ISR.
You can control the name of the code section used by the compiler within a source file using the #pragma
isrseg or by using CrossStudio to set the ISR Section Name property of the file or project.

Project property
Section Options > ISR Section Name
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-Rk (Set default read-only section name)
Syntax
-Rk,name

Description
The -Rk command line option sets the name of the section that the compiler emits read-only data into. If no
other options are given, the default name for the section is CONST.
You can control the name of the code section used by the compiler within a source file using the #pragma
constseg or by using CrossStudio to set the Constant Section Name property of the file or project.

Project property
Section Options > Constant Section Name
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-Rv (Set default vector section name)
Syntax
-Rv,name

Description
The -Rv command line option sets the name of the section that the compiler emits interrupt vectors into. If no
other options are given, the default name for the section is INTVEC.
You can control the name of the code section used by the compiler within a source file using the #pragma
vectorseg or by using CrossStudio to set the Vector Section Name property of the file or project.

Project property
Section Options > Vector Section Name
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-Rz (Set default zeroed section name)
Syntax
-Rz,name

Description
The -Rz command line option sets the name of the section that the compiler emits zero-initialized data into. If no
other options are given, the default name for the section is UDATA0.
You can control the name of the code section used by the compiler within a source file using the #pragma
zeroedseg or by using CrossStudio to set the Zeroed Section Name property of the file or project.

Project property
Section Options > Zeroed Section Name

284

CrossWorks for MSP430 Reference Manual

C Compiler User Guide

-V (Version information)
Syntax
-V

Description
The -V switch instructs the compiler to display its version information.
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-w (Suppress warnings)
Syntax
-w

Description
This option instructs the compiler not to issue any warnings.

Project property
Build Options > Suppress Warnings
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-we (Treat warnings as errors)
Syntax
-we

Description
This option directs the compiler to treat all warnings as errors.

Project property
Build Options > Treat Warnings as Errors
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Preprocessor predefined symbols
Standard pre-processor symbols
The C preprocessor defines the following macro names:

__DATE__
The date of translation of the program unit. This expands to a string constant of the form "Mmm dd yy".

__FILE__
The name of the current source file. __FILE__ expands to a string constant.

__LINE__
The line number of the current source line in the current source file. __LINE__ expands to an integer
constant.

__STDC__
The integer constant 1 as CrossWorks C conforms to the ISO/IEC 9899 standard. The integer constant 0
denotes that the implementation does not conform to the relevant standard.

__STDC_HOSTED__
The integer constant 0 as CrossWorks C is not a hosted implementation. The integer constant 1 denotes
that the implementation is a hosted implementation.

__STDC_VERSION__
The integer constant 199409L as CrossWorks C conforms to ISO/IEC 9899:1990 with the changes required
by ISO/IEC 9899/AMD1:1995. For standard C compilers conforming to ISO/IEC 9899:1999, this constant is
199901L.

__TIME__
The time of translation of the program unit. This expands to a string constant of the form "hh:mm:ss".
The following macro names are not defined by CrossWorks C as the implementation is still in the process of
being upgraded to the 1999 standard.
__STDC_IEC_599__
__STDC_IEC_599_COMPLEX__
__STDC_ISO_10646__

Architecture-dependent pre-processor symbols
The following symbols are set by the compiler (and, in fact, the assembler also) so that you can conditionallycompile your code.

288

CrossWorks for MSP430 Reference Manual

C Compiler User Guide

-m64k only
__MSP430_CPUX undefined.
__MSP430_CODE_ADDRESS_BITS defined as 16

-mcpux and -m1m
__MSP430_CPUX defined.
__MSP430_CODE_ADDRESS_BITS defined as 20

-m64k and
-mcpux
__MSP430_CPUX defined.
__MSP430_CODE_ADDRESS_BITS defined as 16

289

CrossWorks for MSP430 Reference Manual

C Compiler User Guide

Pragmas
The C #pragma mechanism allows vendors to provide additional capabilities that extend or enhance the C
standard. CrossWorks offers a number of pragmas to control section placement and compatibility with other
products.

#pragma codeseg
Set the section name used for code.

#pragma dataseg
Set the section name used for initialized data.

#pragma constseg
Set the section name used for read-only data.

#pragma zeroedseg
Set the section name used for uninitialized, zeroed data.

#pragma vectorseg
Set the section name used for interrupt vector tables.

#pragma isrseg
Set the section name used for interrupt service routine code.

#pragma vector
Define a vector for an interrupt function.
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#pragma codeseg
Synopsis
#pragma codeseg("name" | default)

Description
The codeseg pragma sets the name of the section that the compiler emits code into. If the argument to the
codeseg pragma is a string, a section of that name is created and the compiler emits code for all function
definitions following the pragma into that section. If the argument to codeseg is the reserved word default, the
compiler selects the default code section name.
The default code section name, if no other directives have been given, is CODE. You can change the default code
section name for the whole compilation unit by using the -Rc (Set default code section name) command-line
option or by setting the Code Section Name property of the file or project.
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#pragma dataseg
Synopsis
#pragma dataseg("name" | default)

Description
The dataseg pragma sets the name of the section that the compiler emits initialized data into. If the argument
to the dataseg pragma is a string, a section of that name is created and the compiler emits initialized data for all
following initialized statics or externals following the pragma into that section. If the argument to dataseg is the
reserved word default, the compiler selects the default data section name.
The default data section name, if no other directives have been given, is IDATA0. You can change the default
data section name for the whole compilation unit by using the -Rd (Set default initialized data section name)
command-line option or by setting the Data Section Name property of the file or project.
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#pragma constseg
Synopsis
#pragma constseg("name" | default)

Description
The constseg pragma sets the name of the section that the compiler emits read-only data into. If the argument
to the constseg pragma is a string, a section of that name is created and the compiler emits all following readonly data into that section. If the argument to constseg is the reserved word default, the compiler selects the
default read-only section name.
The default read-only data section name, if no other directives have been given, is CONST. You can change the
default read-only data section name for the whole compilation unit by using the -Rk (Set default read-only
section name) command-line option or by setting the Const Section Name property of the file or project.
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#pragma zeroedseg
Synopsis
#pragma zeroedseg("name" | default)

Description
The zeroedseg pragma sets the name of the section that the compiler emits zero-initialized data into. If the
argument to the zeroedseg pragma is a string, a section of that name is created and the compiler emits zeroinitialized data for all uninitialized statics or externals following the pragma into that section. If the argument to
zeroedseg is the reserved word default, the compiler selects the default zeroed data section name.
The default zeroed data section name, if no other directives have been given, is UDATA0. You can change the
default zeroed data section name for the whole compilation unit by using the -Rz (Set default zeroed section
name) command-line option or by setting the Zeroed Section Name property of the file or project.
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#pragma vectorseg
Synopsis
#pragma vectorseg("name" | default)

Description
The zeroedseg pragma sets the name of the section that the compiler emits interrupt vector tables into. If the
argument to the vectorseg pragma is a string, a section of that name is created and the compiler emits interrupt
vector tables for all following interrupt functions into that section. If the argument to vectorseg is the reserved
word default, the compiler selects the default interrupt vector table section name.
The default interrupt vector table section name, if no other directives have been given, is INTVEC. You can
change the default interrupt vector tables section name for the whole compilation unit by using the -Rv (Set
default vector section name) command-line option or by setting the Vector Section Name property of the file
or project.

295

CrossWorks for MSP430 Reference Manual

C Compiler User Guide

#pragma isrseg
Synopsis
#pragma isrseg("name" | default)

Description
The isrseg pragma sets the name of the section that the compiler emits interrupt service routine code into. If
the argument to the isrseg pragma is a string, a section of that name is created and the compiler emits code
for all interrupt functions following the pragma into that section. If the argument to isrseg is the reserved word
default, the compiler selects the default code section name.
The default ISR code section name, if no other directives have been given, is ISR. You can change the default
interrupt code section name for the whole compilation unit by using the -Ri (Set default ISR section name)
command-line option or by setting the ISR Section Name property of the file or project.
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#pragma vector
Synopsis
#pragma vector=expr

Description
The vector pragma sets the interrupt service routine vector for the following function definition, if that function
is an interrupt function.

Example
#pragma vector=14*2
void isr(void) __interrupt
{
// Interrupt service routine code
}

This form of providing an interrupt vector makes CrossWorks C compatible with IAR's C compiler and the vast
range of example code written for that compiler.
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Section control
The CrossWorks C compiler separates generated code and data into sections so that they can be individually
placed by the linker. It's the linker's job to combine, and make contiguous, sections of the same name from
multiple object files.
You can change the sections that the compiler uses for individual data objects or functions using appropriate
pragmas. The default section names and their use by the compiler are:
CODE contains code generated for functions. See -Rc (Set default code section name).
ISR contains code generated for interrupt service routines that may need special placement. See -Ri (Set
default ISR section name).
IDATA0 contains static initialized data. See -Rd (Set default initialized data section name).
UDATA0 contains static zeroed (uninitialized) data. See -Rz (Set default zeroed section name).
CONST contains read-only constant data. See -Rk (Set default read-only section name).
INTVEC contains interrupt vector tables data. See -Rv (Set default vector section name).
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Section overrides
The pragmas that allow you to change the default section names may well be a little cumbersome for some
uses. The CrossWorks C compiler allows you to specify the section name to use for both data items and functions
using the __at keyword.

Placing data objects in sections
To define the variable config and place it in the section CONFIGVARS, you would use:
int config __at "CONFIGVARS";

This will allocate space for the variable config in the CONFIGVARS section.

Placing functions in sections
To define the function startup and place it in section BOOTSTRAP, you would use:
void startup(void) __at "BOOTSTRAP"
{
// Bootstrap code
}
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Absolute data object placement
In addition to placing data into sections, the CrossWorks C compiler allows you to specify an absolute address for
a variable using __at:
int version __at 0x200;

Note that this form of declaration does not allocate space for the variable. That is, the variable is not passed to the
linker for placement and data will not flow around the variable using the linker's intelligent placement schemes.
This syntax is provided only as a way to make code more readable and is somewhat equivalent to
#define version (*(int *)0x200)

but without using the C preprocessor.
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Type-based enumerations
CrossWorks offers type-based enumerations, an extension to the ISO standard to set the size of enumeration
types. You can use type-based enumerations to select the base type for your enumeration. Using type-based
enumeration you can reduce the size of your application by using enumerations that match the size of the
underlying data rather than using the default int-based enumeration.

Syntax
enum [base-type]
Where base-type is either a plain, signed, or unsigned variant of char, int, long, or long long.

Example
Use an 8-bit unsigned character to define an enumeration that maps onto a single byte and map that onto a
byte at location 10016:
enum unsigned char T0CN_t {
M0
= 1<<0,
M1
= 1<<1,
CT
= 1<<2,
GATE = 1<<3,
TR0 = 1<<4,
TF0 = 1<<5,
T0M = 1<<6,
ET0 = 1<<7
};
enum T0CN_t T0CN __at 0x100;
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Special functions
This section describes the way in which code is generated and the models that the CrossWorks compiler uses.
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Interrupt functions
It's common for embedded systems to be real time systems which need to process information as it arrives
and take some action immediately. Processors provide interrupts specifically for this, where normal program
execution is suspended whilst an interrupt service routine is executed, finally returning to normal program
execution when the interrupt is finished.
Interrupt sources are chip-specific and you can find the exact interrupt sources from each processor's data sheet.
You define an interrupt function just like a standard C function, but in addition you tell the compiler that it is an
interrupt function and optionally which vectors to use. The compiler generates the correct return sequence for
the interrupt and saves any registers that are used by the function. Note that the name of the interrupt function
is not significant in any way.

Initializing a single interrupt vector
This constructs an interrupt function called handle_timer_interrupt and initializes TIMER_VECTOR in the
processor's interrupt vector table to point to handle_timer_interrupt.
void handle_timer_interrupt(void) __interrupt[TIMER_VECTOR]
{
/* Handle interrupt here */
}

Initializing multiple interrupt vectors
This constructs an interrupt function called handle_spurious_interrupt and initializes the three vectors
UART0RX_VECTOR, UART0_TX_VECTOR, and ACCVIO_VECTOR in the processor's interrupt vector table to
point to handle_spurious_interrupt.
void
handle_spurious_interrupt(void) __interrupt[UART0_RX_VECTOR,
UART0_TX_VECTOR,
ACCVIO_VECTOR]
{
/* Handle interrupt here */
}

A plain interrupt handler
This constructs an interrupt function called handle_pluggable_interrupt but does not initialize the interrupt
vector table. This style of interrupt function is useful when you plug different interrupt routines into a RAMbased table to dynamically change interrupt handlers when the application runs.
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void handle_pluggable_interrupt(void) __interrupt
{
/* Handle interrupt here */
}

Alternative form
The CrossWorks C compiler provides an alternative form to specify interrupt vectors; see #pragma vector.

304

CrossWorks for MSP430 Reference Manual

C Compiler User Guide

Monitor functions
In embedded systems it's common for access to critical system structures to be protected by disabling and the
enabling interrupts so that interrupt service routines are not executed during the update. You can write your
own code to do this using the __disable_interrupt and __set_interrupt intrinsic functions like this:
void update_critical_resource(void)
{
// Disable interrupts and save previous interrupt enable state
unsigned state = __disable_interrupt();
// Update your critical resource here...
task_list = task_list->next; // just an example
// Restore interrupt state on entry
__set_interrupt(state);
}

If you disabled and enabled interrupts using __disable_interrupt and __enable_interrupt, rather than using
__disable_interrupt and __set_interrupt as above, calling the function with interrupts disabled would reenable interrupts on return which is usually not what you want. If you write your code in the same fashion as
above you can call the function and be sure that it's run with interrupts disabled and that on return the interrupt
enable state is as it was before the call.
Because this type of function is so common, CrossWorks provides the __monitor keyword. Using __monitor the
example above becomes:
void update_critical_resource(void) __monitor
{
// Update your critical resource here...
task_list = task_list->next; // just an example
}
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Top-level functions
Usually the compiler saves and restores registers in a function according to the calling convention and, in almost
all cases, this is exactly what you want. However, there are some cases where it's just not necessary to save
registers on entry to a function as it is a top-level function and will not be called directly from code. The compiler
can't easily detect these cases so you can point them out using the __toplevel attribute.
The most common function, main, is a good example of a top-level function: it's only called by the runtime
startup code, runs, and usually never terminates in an embedded system. As such, CrossWorks automatically
marks main as a top-level function which instructs the code generator not to save and restore registers on entry
and exit because their values are not required.
Another good example is top-level task functions when you're using the CrossWorks tasking library; in this case,
you can safely declare all your task functions with the top-level attribute because none of their registers are
unimportant on entry and exit. Using the top-level attribute in this way will reduce the stack requirement of the
task.

Example
void task1(void *p) __toplevel
{
// task code
}
void task2(void *p) __toplevel
{
// task code
}
void main(void)
{
ctl_task_run(&task1Task, 1, task1, 0, "task1", sizeof(task1Stack)/sizeof(unsigned),
task1Stack);
ctl_task_run(&task2Task, 1, task2, 0, "task2", sizeof(task2Stack)/sizeof(unsigned),
task2Stack);
}
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External naming convention
CrossWorks makes a distinction between the low-level symbol names used for C objects and the names of the
C objects themselves. The CrossWorks compiler always prepends an underscore character _ to the name of any
externally visible C function or variable when constructing its low-level symbol name.
For example, an external variable declared at the C level extern int x will be accessible at the assembly level
using the name _x.
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Data representation
All data items are held in the native byte order of the MSP430 processor. The plain character type is signed by
default. The floating-point types float and double are implemented as 32-bit and 64-bit IEEE floating-point.
Data Type

Size in bytes

Alignment in bytes

char, signed char, and unsigned
char

1

1

int and unsigned int

2

2

short and unsigned short

2

2

long and unsigned long

4

2

long long and unsigned long long

8

2

float and double (compiled with msd)

4

2

double and long double

8

2

type * (pointer)

2

2

enum (enumeration)

2

2

When compiling for the MSP430X in the 1MB addressing mode using -m1m, function pointers are still
represented in a 16-bit pointer but are thunked. That is, the compiler uses an indirect call through the 16-bit
address to anywhere in the 20-bit address range.
As a C programmer this has no impact on the way that you write your code, but if you are passing function
pointers to assembly code or are dealing with function pointers at a low-level, such as porting an RTOS, then you
need to be aware that function pointers are not held as 20-bit addresses.
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Register use
The compiler partitions the MSP430 general purpose registers into two sets.
The registers in the first set, R12 through R15, are used for parameter passing and returning function results and
are not preserved across functions calls.
The registers in the second set, R4 through R11, are used for register-allocated variables, working storage, and
temporary results and must be preserved across function calls.

Parameter passing
The compiler uses the scratch registers to pass values to the called routine for all parameters of simple data type.
If there are not enough scratch registers to hold all parameter data to be passed to the called routine, the excess
data are passed on the stack.
Simple data types which require more than a single word of storage are passed in register pairs or register
quads. The register requirement for the basic data types are:
Eight-bit and 16-bit types require one register.
32-bit types require two registers.
64-bit types require four registers.
Allocation of the scratch registers for function calls proceeds in a left-to-right fashion, starting with register R15
and progressing in reverse order to R12. The compiler tries to fit each parameter into the scratch registers and,
if it can, allocates those registers to the incoming parameter. If the parameter requires more scratch registers
than are free, it is noted and is passed on the stack. All parameters which are passed on the stack are pushed in
reverse order.

Function return values
The compiler uses the scratch registers to return values to the caller.
The eight-bit and 16-bit type char, int, short, enumerations, and any pointer type are returned in R15
The 32-bit types long and float (and double if compiled with double equivalent to float) are returned
in the register pair R15R14, with R15 holding the most-significant word of the result and R14 the leastsignificant word.
The 64-bit types long long and double are returned in the register quad R15R12 with R15 holding the
most-significant word of the result and R12 the least-significant word.

Examples
This section contains some examples of the calling convention in use.
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Example #1
void fun1(int u, int v);

Reading from left to right, the parameter u is passed in register R15 and v is passed in R14. The scratch registers
R12 and R13 are not used to pass parameters and can be used in fun1 without needing to be preserved.

Example #2
void fun1(int u, long v, int w);

The parameter u is passed in register R15. Because v requires two registers to hold its value it is passed in the
register pair R14R13 with R14 holding the high part of v and R13 the low part. The final parameter w is passed in
R12.

Example #3
void fun1(int u, long v, int w, int x);

The parameter u is passed in register R15. Because v requires two registers to hold its value it is passed in the
register pair R14R13 with R14 holding the high part of v and R13 the low part. The final parameter w is passed in
R12. As all scratch registers are now used, x is passed by placing it on the stack.

Example #4
void fun1(int u, long v, long w);

The parameter u is passed in register R15. Because v requires two registers to hold its value it is passed in the
register pair R14R13 with R14 holding the high part of v and R13 the low part. When considering w, there is only
one free scratch register left, which is R12. The compiler cannot fit w into a single register and therefore places
the argument onto the stackthe compiler does not split the value into two and pass half in a register and half on
the stack.

Example #5
void fun1(int u, long v, long w, int x, int y);

The parameter u is passed in register R15. Because v requires two registers to hold its value it is passed in the
register pair R14R13 with R14 holding the high part of v and R13 the low part. When considering w, there is only
one free scratch register left, which is R12. The compiler cannot fit w into a single register and therefore places
the argument onto the stackthe compiler does not split the value into two and pass half in a register and half on
the stack.
When considering x the compiler sees that R12 is unused and so passes x in R12. All scratch registers are used
when considering y, so the argument is placed onto the stack. The parameters w and x are pushed onto the
stack before the call and are pushed in reverse order, with y pushed before w.
This example shows two parameters, w and y, that are passed to the called routine on the stack, but they are
separated by a parameter x that is passed in a register.
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Assembler User Guide
This manual is a reference for the CrossWorks assembler. It does not explain the architecture of the process
machine or teach how to construct an application in assembly code.
The assembler converts assembly source code to relocatable object code in object code files. The linker combines
object code files to form an application containing the final instructions.
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Command-line syntax
To invoke the assembler, use the following syntax:
has [option] file
file is the source file to assemble and option is a command-line option. Options are case sensitive and cannot be
abbreviated.

In this section
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-D (Define macro symbol)
Syntax
-Dname
-Dname=value

Description
This option instructs the assembler to define a symbol for the compilation unit. If no value is given, the symbol is
assigned the value -1.
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-g (Generate debugging information)
Syntax
-g

Description
The -g option instructs the assembler to insert debugging information into the output file. This allows you to
single step through assembly language files at the source level, with all its annotation, rather than studying a
disassembly of the code. And declared, typed data is displayed rather than simply its addresses.

314

CrossWorks for MSP430 Reference Manual

Assembler User Guide

-I (Define user include directories)
Syntax
-Idirectory
The -I option adds directory to the end of the list of directories, to search for source files included (using
quotation marks) by the INCLUDE and INCLUDEBIN directives.
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-J (Define system include directories)
Syntax
-Jdirectory
The -J option adds directory to the end of the list of directories, to search for source files included (using
triangular brackets) by the INCLUDE and INCLUDEBIN directives.
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-o (Set output file name)
Syntax
-o filename

Description
The -o option instructs the assembler to write its object file to filename.
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-Rc (Set default code section name)
Syntax
-Rc,name

Description
The -Rc command-line option sets the name of the section the assembler uses with the TEXT directive. If it is not
specified, the default name for the section is CODE.

Project property
Section Options > Code Section Name
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-Rd (Set default initialized data section name)
Syntax
-Rd,name

Description
The -Rd command-line option sets the name of the section the assembler uses for the DATA directive. If it is not
specified, the default name for the section is IDATA0.

Project property
Section Options > Data Section Name
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-Ri (Set default ISR section name)
Syntax
-Ri,name

Description
The -Ri command-line option sets the name of the section the assembler uses for the ISR directive. If it is not
specified, the default name for the section is ISR.

Project property
Section Options > ISR Section Name
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-Rk (Set default read-only section name)
-Rk,name

Description
The -Rk command-line option sets the name of the section the assembler uses for the CONST directive. If it is not
specified, the default name for the section is CONST.

Project property
Section Options > Constant Section Name
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-Rv (Set default vector section name)
-Rv,name

Description
The -Rv command-line option sets the name of the section the assembler uses for the VECTORS directive. If it is
not specified, the default name for the section is INTVEC.

Project property
Section Options > Vector Section Name
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-Rz (Set default zeroed section name)
-Rz,name

Description
The -Rz command-line option sets the name of the section the assembler uses for the BSS directive. If it is not
specified, the default name for the section is UDATA0.

Project property
Section Options > Zeroed Section Name
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-V (Version information)
Syntax
-V

Description
The -V switch instructs the assembler to display its version information.
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-w (Suppress warnings)
Syntax
-w

Description
This option instructs the assembler not to issue any warnings.

Project property
General Options > Suppress Warnings
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-we (Treat warnings as errors)
Syntax
-we

Description
This option directs the assembler to treat all warnings as errors.

Project property
General Options > Treat Warnings as Errors
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Source format
A statement is a combination of mnemonics, operands, and comments that defines the object code to be
created at assembly time. Each line of source code contains a single statement.

Assembler source lines
Assembler statements take the form:
[label] [operation] [operands] [comment]
All fields are optional, although the operand or label fields may be required if certain directives or instructions
are used in the operation field.

Label Field
The label field starts at the left of the line, with no preceding spaces. A label name is a sequence of alphanumeric
characters, starting with a letter. You can also use the dollar sign '$' and underline character '_' in label names. A
colon may be placed directly after the label, or it can be omitted. If a colon is placed after a label, it defines that
label to have the value of the location counter in the current section.

Operation field
The operation field contains either a machine instruction or an assembler directive. You must write these in
either all uppercase or all lowercasemixed case is not allowed. The operation field must not start at the leftmost
position of the line; at least one space must precede it, if there is no label field. At least one space must separate
the label field and the operation field.

Operand field
The contents of the operand depend upon the instruction or directive in the operation field. Different
instructions and directives have different operand field formats. Please refer to the specific directive
documentation for details of the operand field.

Comment field
The comment field is optional. It contains information that is not essential to the assembler but is useful for
documentation. The comment field must be separated from any preceding fields by at least one space.

Comments
To help others better understand some particularly tricky piece of code, you can insert comments into the
source code. Comments are informational and have no significance for the assembler. They come in two forms:
single-line comments and multi-line comments.
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Single-line comments
A single-line comment is introduced either by the single character ; or by the two consecutive characters //.

Syntax
// character
; character
The assembler ignores all characters from the comment introducer to the end of the line. This type of comment
is particularly good when you want to comment a single assembler line.

Multi-line coomments
A multi-line comment resembles a standard C comment, it is introduced by the characters /* and is terminated
by */.

Syntax
/* character */
Anything between these delimiters is ignored by the assembler. You can use this type of comment to place large
amounts of commentary, such as copyright notices or functional descriptions, into your code.
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Types
In contrast to most assemblers, the CrossWorks assembler fully understands data types. The most well-known
and widely used assembler that uses data typing extensively is Microsoft's MASM and its many clones. If you've
used MASM, you should be comfortable with the concept of data types in an assembler and with the CrossWorks
implementation of data typing.
If you haven't used MASM, you may wonder why data typing should be put into an assembler, given that many
assembly programs are written without the help of data types. But there are many good reasons to do so, even
without the precedent set by Microsoft, and the two most valuable benefits are:
The ability to catch potential or real errors at assembly time rather than letting them go undetected until
applications are deployed.
Data typing is an additional and effective source of program documentation, describing the way data are
grouped and represented.
We don't expect you to fully appreciate the usefulness of assembly-level data typing until you use it in an
application and gain first-hand experience of both the benefits mentioned above. Of course, it's still possible to
write (almost) typeless assembly code using the CrossWorks assembler, if you should wish to do so, but effective
use of data typing is a real programmer aid when writing code. Lastly, we should mention another important
benefit data typing brings: the interaction between properly typed assembly code and the debugger. If you
correctly type your data, the debugger will present the values held in memory, using a format based on the type
of the object rather than as a string of hexadecimal bytes. Having source-level debugging information displayed
in a human-readable format is another way to improve productivity.
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Built-in types
The CrossWorks assembler provides a number of built-in or predefined data types. They correspond to those in
a high-level language such as C. You can use them to allocate data storage; for instance, the following allocates
one byte of data for the count symbol:
count

DV

BYTE

The directive DV allocates one byte of space for count in the current section and sets count's type to BYTE.
Type name

Size in bytes

Description

BYTE

1

Unsigned 8-bit byte

WORD

processor-dependent

Unsigned word, dependent upon
processor word size

LONG

4

Unsigned 32-bit word

CHAR

1

8-bit character

ADDR

processor-dependent

Address
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Array types
You can declare arrays of any predefined or user-defined type. Arrays are used extensively in high-level
languages; therefore, we decided they should be available in the CrossWorks assembler for easier integration
with C.
An array type is constructed by specifying the number of array elements in brackets after the data type.

Syntax
type [ array-size ]
This declares an array of array-size elements, each of data type type. The array size must be an absolute constant
known at assembly time.

Example
The type
BYTE[8]

declares an array of eight bytes.
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Pointer types
You can declare pointers to types, as in most high-level languages.

Syntax
type PTR
This declares a pointer to the data type type.

Example
The type
CHAR PTR

declares a pointer to a character. The built-in type ADDR is identical to the type BYTE PTR.
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Structure types
Using the STRUC, UNION, and FIELD directives, you can define data items that are grouped together. Such a
group is called a structure and can be thought of in the same way as a structure or union in C. Structured types
are bracketed between STRUC and ENDSTRUC, and should contain only FIELD directives; similarly, unions are
bracketed between UNION and ENDUNION, and should only contain FIELD directives.

Example
We could declare a structure type called Amount that has two members, Dollars and Cents, like this:
Amount STRUC
Dollars FIELD
LONG
Centse FIELD
BYTE
ENDSTRUC

The field Dollars is declared to be of type LONG and Cents is of type BYTE (so we can count lots of Dollars, and a
small amount of loose change).
In structures, fields are allocated one after another, increasing the size of the structure for each field added. For a
union, all fields are overlaid, and the size of the union is the size of the largest field within the union.

Example
For a 32-bit, big-endian machine, we could overlay four bytes over a 32-bit word like this:
Word
UNION
asWord FIELD WORD
asBytes FIELD BYTE[4]
ENDUNION

The most useful thing about user-defined structures is that they act like any built-in data type, so you can
allocate space for variables of the structure type:
Balance DV

Amount

Here we've declared enough storage for the variable Balance to hold an Amount, and the assembler (and
debugger) knows that Balance is of type Amount.
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Compilation units and libraries
When applications grow large, they are usually broken into smaller, manageable pieces called compilation
units. Each piece is compiled separately, then the pieces are stitched together by the linker to produce the final
application.
When you partition a application into separate compilation units, you will need to indicate how a symbol
defined in one unit is referenced by the code in other units. This section will show how to declare exported and
imported symbols that can be used in more than one unit.
When building applications, you often find pieces of code that can be reused in other applications. Rather than
duplicating such source code, you can package these units into a library.
The CrossWorks tools were designed to be flexible and let you to easily write space-efficient programs using
libraries and separate compilation. To that end, the assembler-and-linker combination provides a number of
features not found in many compilation systems.
Optimum-sized branches The linker automatically resizes branches to labels too far away to be reached
by a branch instruction. This is completely transparent to the programmerwhen you use branch
instructions, your linked program will always use the smallest possible branch. This capability is deferred
to the linker so even branches across compilation units are optimized.
Removing dead code and data The most important feature of the linker is its ability to leave unreferenced
code and data out of the final application. The linker discards all code and data fragments that cannot be
reached from any entry symbols.
Whole-program optimization The linker can optimize the application as a whole, rather than on a perfunction or per-compilation-unit basis.
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Directive reference
This section describes the directives supported by the assembler.

335

CrossWorks for MSP430 Reference Manual

Assembler User Guide

ALIGN
Syntax
ALIGN type | number
The operand given after the directive defines the alignment requirement. If a type is given, the location counter
is adjusted to be divisible by the size of the type with no remainder. If a number is given, the location counter is
adjusted to be divisible by 2number with no remainder.

Example
ALIGN LONG

This aligns the location counter to lie on a 4-byte boundary (because the type LONG is 4 bytes in size).

Example
ALIGN 3

This aligns the location counter to lie on an 8-byte boundary (because 23 equals 8).
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BREAK
Syntax
BREAK
SEGEND

Description
The SEGEND and BREAK directives start a new fragment within the current section. A fragment is set of
instructions the linker will elect to include in its output if a reference is made to one of the instructionsin the
fragment}. If no reference is made to a fragment, the linker will not include that fragment in the output.
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BSS
Syntax
BSS

Description
The BSS and ZDATA directives select the default, zeroed data section. The section is named UDATA0 unless it
has been renamed via the -Rz command-line option.
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CODE
Syntax
CODE

Description
The CODE and TEXT directives select the default code section. The section is named CODE unless it has been
renamed via the -Rc command-line option.
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CONST
Syntax
CONST

Description
The CONST directive selects the default, read-only data section. The section is named CONST unless it has been
renamed via the -Rk command-line option.
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DATA
Syntax
DATA

Description
The DATA directive selects the default, initialized-data section. The section is named IDATA0 unless it has been
renamed via the -Rk command-line option.

341

CrossWorks for MSP430 Reference Manual

Assembler User Guide

DB
Syntax
DB initializer [, initializer]

Description
A synonym for DC.B, see DC.B.
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DC.B
Syntax
DC.B initializer [, initializer]

Description
The DC.B directive defines an object as an initialized array of bytes. If the directive is labeled, the label is assigned
the location counter of the current section before the data is placed in that section. If a single initializer is
present, the label's data type is set to BYTE; otherwise, it is set to be a fixed array of BYTE, the bounds of which
are set by the number of elements defined.

Example
Mask DC.B 0x01, 0x03, 0x07, 0x0f, 0x1f, 0x3f, 0x7f, 0xff

This defines the label Mask and allocates eight bytes with the given values. The type of Mask is set to BYTE[8],
an array of eight bytes, because eight values are listed.
You use the DB directive to define string data. When the assembler sees a string, it expands it into a series of
bytes and places those into the current section.

Example
BufOvfl DC.B 13, 10, "WARNING: buffer overflow", 0

This emits the bytes 13 and 10 into the current section, followed by the ASCII bytes comprising the string, and
finally a trailing zero byte.
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DC.W
Syntax
DC.W initializer [, initializer]
DW initializer [, initializer]

Description
The DC.W directive defines an object as an initialized array of words i.e. 2 bytes. If the directive is labeled, the
label is assigned the location counter of the current section before the data is placed in that section. If a single
initializer is present, the label's data type is set to WORD; otherwise, it is set to be a fixed array of WORD, the
bounds of which are set by the number of elements defined.

Note
The location counter is not aligned before allocating space.
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DC.L
Syntax
DC.L initializer [, initializer]
DL initializer [, initializer]

Description2
The {DC.L} directive defines an object as an initialized array of longs i.e. 4 bytes. If the directive is labeled, the
label is assigned the location counter of the current section before the data is placed in that section. If a single
initializer is present, the label's data type is set to LONG; otherwise, it is set to be a fixed array of LONG values,
the bounds of which are set by the number of elements defined.

Note
The location counter is not aligned before allocating space.
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DL
Syntax
DL initializer [, initializer]

Description
A synonym for DC.L, see DC.L.
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DS.B
Syntax
DS.B n
RMB n

Description
These directives generate n bytes of zeros into the current section and adjusts the location counter accordingly.
If the directive is labeled, the label is assigned the location counter of the current section before the space is
allocated in that section. If n is one, the label's data type is set to BYTE; otherwise, it is set to be a fixed array of
BYTE[n] elements.
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DSECT
Syntax
DSECT "section-name"

Description
The DSECT directive creates a new, initialized-data section named section-name. Subsequent data-allocation
directives are directed to this section.

Example
DSECT "CALIBRATION"
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DS.L
Syntax
DS.L n

Description
These directives generate n long words of zeros in the current section and adjust the location counter
accordingly. If the directive is labeled, the label is assigned the location counter of the current section before
the space is allocated. If n is one, the label's data type is set to LONG; otherwise, it is set to be a fixed array of
LONG[n] elements.

Note
The location counter is not aligned before allocating space.

349

CrossWorks for MSP430 Reference Manual

Assembler User Guide

DS.W
Syntax
DS.W n
RMW n

Description
These directives generate n words of zeros in the current section and adjust the location counter accordingly.
If the directive is labeled, the label is assigned the location counter of the current section before the space is
allocated. If n is one, the label's data type is set to WORD; otherwise, it is set to be a fixed array of WORD[n]
elements.
The number of bytes per word is determined by the target processor. For 32-bit processors, one word is four
bytes; for 8-bit and 16-bit processors, one word is two bytes.

Note
The location counter is not aligned before allocating space.
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DV
Syntax
DV datatype [=initializer]

Description
This directive reserves space for a data item of type datatype and, optionally, initializes it to a value. The initializer
is a comma-separated list of numbers and strings.

Note
The location counter is not aligned before allocating space.
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DW
Syntax
DW initializer [, initializer]

Description
A synonym for DC.W, see DC.W.
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ELSE
Syntax
ELSE

Description
The ELSE directive introduces the else part of an IF construct. See IF for more information.
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END
Syntax
END

Description
The optional END directive indicates the end of assemblyno text beyond END is processed.
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ENDIF
Syntax
ENDIF

Description
The ENDIF directive closes the innermost IF construct. See IF for more information.
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EQU
Syntax
symbol EQU expression symbol = expression

Description
The assembler evaluates the expression and assigns its value to the symbol. The expression need not be
constant or even known at assembly time; it can be any value and may include complex operations involving
external symbols.
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EVEN
Syntax
EVEN

Description
The EVEN directive is equivalent to ALIGN 1 and aligns the location counter to the next even address.
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EXPORT
Syntax
EXPORT symbol
PUBLIC symbol

Description
The EXPORT and PUBLIC directives export the definition of symbol, making it available to other compilation
units.
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FILL
Syntax
FILL size, value

Description
The FILL directive generates size bytes of value into the current section and adjusts the location counter
accordingly.

Example
FILL 5, ' '

This generates five spaces in the current section.
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IF
Syntax
IF expression
The IF directive provides a conditional-assembly feature.
The structure of conditional assembly is much like that used by high-level language conditional constructs and
by the C pre-processor. The directives IF, IFDEF, IFNDEF, ELIF, and ENDIF are available.
These directives may be prefixed with a # and can start in the first column, thus enabling them to look like C preprocessor directives.
The controlling expression must be an absolute assembly-time constant. When the expression is non-zero, the
true conditional arm is assembled; when the expression is zero, the false conditional body, if any, is assembled.
The IFDEF and IFNDEF directives are specialized forms of the IF directive. IFDEF tests for the existence of the
supplied symbol, IFNDEF tests for the non-existence of the supplied symbol.

Example
IF type == 1
CALL type1
ELSE
IF type == 2
CALL type2
ELSE
CALL type3
ENDIF
ENDIF

The nested conditional can be replaced by using the ELIF directive, which acts like ELSE IF:
IF type == 1
CALL type1
ELIF type == 2
CALL type2
ELSE
CALL type3
ENDIF

Example
The usual practice is to use a symbol, DEBUG, as a flag to either include or exclude debugging code. Now you
can use IFDEF to conditionally assemble some parts of your application, depending on whether the _DEBUG
symbol is defined.
IFDEF _DEBUG
CALL DumpAppState
ENDIF
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IMPORT
Syntax
IMPORT symbol, symbol,
EXTERN symbol, symbol,
EXTRN symbol, symbol,

Description
The IMPORT directive defines symbol as being external, that is, defined by another compilation unit.
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INCLUDE
Syntax
INCLUDE "filename"
INCLUDE <filename>

Description
The INCLUDE directive inserts the contents of the source file filename into the assembly. If filename is enclosed
in quotation marks, the user include directories are searched; if filename is enclosed in triangular brackets, the
system include directories are searched.
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INCLUDEBIN
Syntax
INCLUDEBIN "filename"
INCLUDEBIN <filename>

Description
The INCLUDEBIN directive inserts the contents of the file filename into the current section as binary data. If
filename is enclosed in quotation marks, the user include directories are searched; if filename is enclosed in
triangular brackets, the system include directories are searched.
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INIT
Syntax
INIT "section-name"

Description
The INIT directive places a copy of the section denoted by name into the current section. This directive can be
used, for example, to copy initialized-data sections from read-only memory into writable memory.
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ISR
Syntax
ISR

Description
The ISR directive selects the default ISR section. The section is named ISR unless it has been renamed via the -Ri
command-line option.
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KEEP
Syntax
KEEP

Description
A synonym for ROOT, see ROOT.

366

CrossWorks for MSP430 Reference Manual

Assembler User Guide

PSECT
Syntax
PSECT "section-name"

Description
The PSECT directive creates a new program section with the name section-name. Subsequent instructions and
data-allocation directives are directed to this section.

Example
PSECT "BOOT"
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RMB
Syntax
RMB n

Description
A synonym for DS.B, see DS.B.
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RML
Syntax
RML n

Description
A synonym for DS.L, see DS.L.
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RMW
Syntax
RMW n

Description
A synonym for DS.W, see DS.W.
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RODATA
Syntax
RODATA

Description
A synonym for CONST, see CONST.
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ROOT
Syntax
ROOT

Description
The ROOT directive instructs the linker that this is a root fragment and must not be discarded when constructing
the output file. Normally, only startup code and vector sections use this facility.
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RSEG
Syntax
RSEG name [:type] [(alignment)]

Description
The RSEG directive creates a named section called name, with an optional type, and aligns the section at the
optional alignment. The section type can be one of CODE, DATA, BSS, CONST, or UNTYPED. The alignment value
is an assemble-time constant expression that is the power of 2 upon which to align the section: an alignment
value of 1 will cause the section to be aligned on even byte locations.
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SET
Syntax
symbol SET expression

Description
SET evaluates the expression, which must be an assemble-time constant. The SET directive allows redefinition of
an existing symbol, whereas the EQU directive does not.
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TEXT
Syntax
TEXT

Description
A synonym for CODE, see CODE.
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USECT
Syntax
USECT "section-name"

Description
The USECT directive creates a new, uninitialized-data section with the name section-name. Subsequent data
allocation directives are directed to this section.

Example
USECT "SCRATCHPAD"

376

CrossWorks for MSP430 Reference Manual

Assembler User Guide

VECTORS
Syntax
VECTORS

Description
The VECTORS directive selects the default, interrupt-vector section. The section is named INTVEC, unless it has
been renamed by the -Rv command-line option.
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ZDATA
Syntax
ZDATA

Description
A synonym for BSS, see BSS.
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Expressions
The assembler can manipulate constants and relocatable values at assembly time. If the assembler cannot
resolve these to a constant value (for example, an expression involving the value of an external symbol cannot
be resolved at assembly time), the expression is passed to the linker to resolve.

Integer constants
Integer constants represent integer values and can be represented in binary, octal, decimal, or hexadecimal. You
can specify the radix for the integer constant by adding a radix, specified as a suffix to the number. If no radix
specifier is given, the constant is decimal.

Syntax
decimal-digit digit [B | O | Q | D | H]
The radix suffix B denotes binary, O and Q denote octal, D denotes decimal, and H denotes hexadecimal. Radix
suffixes can be given either in lowercase or uppercase letters.
Hexadecimal constants must always start with a decimal digit (0 to 9), otherwise the assembler will mistake the
constant for a symbolfor example, 0FCH is interpreted as a hexadecimal constant but FCH is interpreted as a
symbol.
You can specify hexadecimal constants in two other formats common with many assemblers:

Syntax
0x digit digit
$ digit digit
The 0x notation is exactly how hexadecimal constants are written in C, and the $ notation is common in many
assemblers for Motorola parts.

String constants
A string constant consists of one or more ASCII characters enclosed in single or double quotation marks.

Syntax
"character"
You can specify non-printable characters in string constants using escape sequences. An escape sequence is
introduced by the backslash character '\'.
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The following escape sequences are supported:
Sequence

Description

\"

Double quotation mark

\'

Single quotation mark

\\

Backslash

\b

Backspace, ASCII code 8

\f

Form feed, ASCII code 12

\n

New line, ASCII code 10

\r

Carriage return, ASCII code 13

\v

Vertical tab, ASCII code 11

\ooo

Octal code of character where o is an octal digit

\xhh

Hexadecimal code of character where h is a
hexadecimal digit
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Labels
Use labels to give symbolic names to addresses of instructions or data. The most common form are code labels,
which can be usedas the operands of call, branch, and jump instructionsto transfer program control to a new
instruction. Also common are data labels that label data-storage areas.

Syntax
label [: | ::] [directive | instruction]
The label field starts at the leftmost position of the line, with no preceding spaces. The colon after the label
is optional; if it is present, the assembler immediately defines the label as a code label or data label. Some
directives, such as EQU, require that you do not place a colon after the label.

Example
ExitPt: RET

This defines ExitPt as a code label for the RET instruction.
A label followed by a double colon makes the label public.
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Operators
Each operator has a precedence, and the following table lists the precedence of the operators, from highest to
lowest:
Operator

Group

DEFINED SIZEOF
HBYTE LBYTE HWORD LWORD
STARTOF ENDOF
SFB SFE NOT ! LNOT !! THIS $

Monadic prefix operators

*/%

Multiplicative operators

+-

Additive operators

SHL SHR ASHR << >>

Shifting operators

LT GT LE GE < > <= >=

Relational operators

EQ NE == !=

Equality operators

AND &

Bit-wise and

XOR ^

Bit-wise exclusive-or

OR |

Bit-wise inclusive-or

LAND &&

Logical and

LOR ||

Logical or

All integer operands are considered as unsigned 64-bit values.
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!
Syntax
! expression

Description
True if expression is false, and false if expression is true.

Example
! 3

; evaluates to false, 0
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$
Syntax
$

Description
The $ operator returns an expression that denotes the location counter at the start of the source line.

Note
The location counter returned by $ does not change, even if code is emitted for the source line.

Example
A typical use of $ is to compute the size of a string or of a block of memory:
MyString
MyStringLen

DB
DB
EQU

"Why would you count the number of characters"
"in a string when the assembler can do it?"
$-MyString
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+
Syntax
expression-1 + expression-2

Description
Add expression-1 to expression-2.

Example
1 + 2

; evaluates to 3
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Syntax
expression-1 expression-2

Description
Add expression-1 to expression-2.

Example
1 - 5

; evaluates to -4
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*
Syntax
expression-1 * expression-2

Description
Multiplies expression-1 by expression-2.

Example
7 * 5

; evaluates to 35
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/
Syntax
expression-1 / expression-2

Description
Divides expression-1 by expression-2, producing an integer quotient. If expression-2 is zero, the quotient is
defined to be zero.

Example
7 / 5

; evaluates to 1
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%
Syntax
expression-1 % expression-2

Description
Produces the remainder after division of expression-1 by expression-2. If expression-2 is zero, the remainder is
defined to be zero.

Example
7 % 5

; evaluates to 2
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^
Syntax
expression-1 ^ expression-2

Description
Produces the bit-wise exclusive-or of expression-1 and expression-2.

Example
0AAH

0F0H

; evaluates to 05AH
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&
Syntax
expression-1 & expression-2

Description
Produces the bit-wise conjunction (and) of expression-1 and expression-2.

Example
0AAH & 0F0H

; evaluates to 0A0H
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&&
Syntax
expression-1 && expression-2

Description
True if both expression-1 and expression-2 are true.

Example
1 && 0

; evaluates to false (0)
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==
Syntax
expression-1 = expression-2

Description
True if expression-1 and expression-2 are equal.

Example
1 == 3

; evaluates to false, 0
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!=
Syntax
expression-1 == expression-2

Description
True expression-1 and expression-2 are not equal.

Example
1 != 3

; evaluates to true, 1
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<
Syntax
expression-1 < expression-2

Description
True if expression-1 is less than expression-2.

Example
1 < 3

; evaluates to true, 1
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<=
Syntax
expression-1 <= expression-2

Description
True if expression-1 is less than or equal to expression-2.

Example
3 <= 3

; evaluates to true, 1
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<<
Syntax
expression-1 << expression-2

Description
Shifts expression-1 left by expression-2 bits.

Example
1 << 7

; evaluates to 128
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>
Syntax
expression-1 > expression-2

Description
True if expression-1 is greater than expression-2.

Example
1 > 3

; evaluates to false, 0
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>=
Syntax
expression-1 >= expression-2

Description
True if expression-1 is greater than or equal to expression-2.

Example
3 >= 3

; evaluates to true, 1
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>>
Syntax
expression-1 >> expression-2

Description
Shifts expression-1 right by expression-2 bits.

Example
128 >> 7

; evaluates to 1
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|
Syntax
expression-1 | expression-2

Description
Produces the bit-wise disjunction (or) of expression-1 and expression-2.

Example
0AAH | 0F0H

; evaluates to 0FAH
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||
Syntax
expression-1 || expression-2

Description
True if either expression-1 or expression-2 is true.

Example
1 || 0

; evaluates to true (1)
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ASHR
Syntax
expression-1 ASHR expression-2

Description
Shifts expression-1 arithmetically right (propagating the sign bit) by expression-2 bits.

Example
-3 ASHR 4

; evaluates to -1 as sign bit is propagated
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DEFINED
Syntax
DEFINED symbol
You can use the DEFINED operator to see whether a symbol is defined. Typically, this is used with conditional
directives to control whether a portion of a file will be assembled.
The DEFINED operator returns a Boolean result which is true if the symbol is defined at that point in the file,
and is false otherwise. Note that this operator only inquires whether the symbol is known to the assembler, not
whether it has a known value: imported symbols are considered to be defined even though the assembler does
not know their value.
DEFINED cannot detect whether a macro has been defined.

Example
The following shows how DEFINED works in a number of cases.

Y
B1
B2
B3
B4
Z

.IMPORT X
EQU
10
EQU
DEFINED
EQU
DEFINED
EQU
DEFINED
EQU
DEFINED
EQU
100

X
Y
Z
U

;
;
;
;

true (1)
true (1)
false (0)
false (0)

not defined yet
never defined
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ENDOF
Syntax
ENDOF section-name
SFE section-name

Description
If the argument to ENDOF is a section name, the result of ENDOF is a link-time expression representing the start
of the given section. It is an error if the section name is not known to the assembler.
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EQ
Syntax
expression-1 EQ expression-2

Description
A synonym for ==, see ==.
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GE
Syntax
expression-1 GE expression-2

Description
A synonym for >=, see >=.
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GT
Syntax
expression-1 GT expression-2

Description
A synonym for >, see >.
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HBYTE
Syntax
HBYTE expression

Description
Extract bits 8 to 15 of expression.

Example
HBYTE $FEDCBA98

; evaluates to $BA
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HIGH
Syntax
HIGH expression

Description
A synonym for HBYTE, see HBYTE.
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HWORD
Syntax
HWORD expression

Description
Extract bits 16 to 31 of expression.

Example
HWORD $FEDCBA98

; evaluates to $FEDC
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LAND
Syntax
expression-1 LAND expression-2

Description
A synonym for &&, see &&.
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LBYTE
Syntax
LBYTE expression

Description
Extract the low-order 8 bits bits of expression.

Example
LBYTE $FEDCBA98

; evaluates to $98
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LE
Syntax
expression-1 LE expression-2

Description
A synonym for <=, see <=.
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LNOT
Syntax
LNOT expression

Description
A synonym for !, see !.
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LOR
Syntax
expression-1 LOR expression-2

Description
A synonym for ||, see ||.
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LT
Syntax
expression-1 LT expression-2

Description
A synonym for <, see <.
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LHALF
Syntax
LHALF expression

Description
Synonym for LWORD, LWORD.

418

CrossWorks for MSP430 Reference Manual

Assembler User Guide

LOW
Syntax
LOW expression

Description
A synonym for LBYTE, see LBYTE.

419

CrossWorks for MSP430 Reference Manual

Assembler User Guide

LWORD
Syntax
LWORD expression

Description
Extract the low-order 16 bits of expression.

Example
LWORD $FEDCBA98

; evaluates to $BA98
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NE
Syntax
expression-1 NE expression-2

Description
A synonym for !=, see !=.
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OR
Syntax
expression-1 OR expression-2

Description
A synonym for |, see OR.
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SHL
Syntax
expression-1 SHL expression-2

Description
A synonym for <<, see <<.

423

CrossWorks for MSP430 Reference Manual

Assembler User Guide

SHR
Syntax
expression-1 SHR expression-2

Description
A synonym for >>, see >>.
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SIZEOF
Syntax
SIZEOF (expression)
SIZEOF section-name

Description
If the argument to SIZEOF is a parenthesized expression, the result of SIZEOF is an integer value that is the size
of the type associated with the expression. The assembler reports an error if the expression has no type.
If the argument to SIZEOF is a section name, the result of SIZEOF is a link-time expression representing the size
of the given section. It is an error if the section name is not known to the assembler.

Example
X
XSIZE
X0SIZE

VAR
EQU
EQU

LONG[100]
SIZEOF X
SIZEOF X[0]

; 400, 100 four byte elements
; 4, size of LONG
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STARTOF
Syntax
STARTOF section-name
SFB section-name

Description
If the argument to STARTOF is a section name, the result of STARTOF is a link-time expression representing the
start of the given section. It is an error if the section name is not known to the assembler.
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THIS
Syntax
THIS

Description
A synonym for $, see $.
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UHALF
Syntax
UHALF expression

Description
Synonym for HWORD, HWORD.
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XOR
Syntax
expression-1 XOR expression-2

Description
A synonym for ^, see ^.
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Macros
The structure of a macro definition consists of a name, some optional arguments, the body of the macro, and a
termination keyword. The syntax to define a macro is:

Syntax
{name} MACRO arg1, arg2, , argn
{macro-body}
ENDMACRO | ENDM
The name of the macro has the same requirements as a label name (in particular, it must start in the first
column). The arguments are a comma-separated list of identifiers. The body of the macro can have arbitrary
assembly-language text, including other macro definitions and invocations, and conditional and file-inclusion
directives. A macro is instantiated by using its name together with optional, actual argument values. A macro
instantiation has to occur on its own lineit cannot be used within an expression or as an argument to an
assembly-code mnemonic or directive. The syntax to invoke a macro is:

Syntax
name actual1, actual2, , actualn // comment
When a macro is instantiated, the macro body is inserted into the assembly text with actual values replacing the
arguments that were in the body of the macro definition.

Labels in macros
When labels are used in macros, they must be unique for each instantiation to avoid duplicate-label-definition
errors. The assembler provides a label-generation mechanism, for situations where the label name isn't
significant, and a mechanism for constructing specific label names.
If a macro definition contains a jump to other instructions in the macro definition, it is likely that the actual name
of the label isn't important. To facilitate this, a label of the form name? can be used.
In some instances, invoking a macro should result in the definition of a label. In the simplest case, the label can
be passed as an argument to the macro; however, there are cases when the label name should be constructed
from other tokens. The macro definition facility provides two constructs to enable this:
Tokens can be concatenated by putting ## between them.
The value of a constant symbol can be used by prefixing the label with $$.

Loops
If multiple definitions are required, a loop structure can be used. This can be achieved either by recursive macro
definitions or by the use of the LOOP directive.
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Example
P2TAB

MACRO
N
IF
N
P2TAB
N-1
ENDIF
DW
1<<N
ENDMACRO

POWERS: POWER2TAB 10

This creates a table of ten powers of 2that is: 1, 2, 4, 8, and so on, up to 1024.
If the loop counter is a large number, a recursive macro may consume considerable machine resources. Use the
LOOP directive to avoid this, because it is an iterative rather than recursive solution.

Syntax
LOOP expression
loop-body
ENDLOOP

The loop-control expression must be a compile-time constant. The loop body can contain any assembly text
(including further loop constructs) except macro definitions (because that would result in multiple definitions of
the same macro). The above recursive definition can be recast in an iterative style:

Example
POWERS:
x
SET
LOOP
x

0
x <= 10
DC.W
1<<x
SET
x+1
ENDLOOP

Note that the label-naming capabilities using ?, $$, and ## are not available within the body of a loop. If the loop
body is to declare labels, a recursive macro definition should be used; or use a combination of macro invocation
to define the labels and use the loops to define the text of the label.
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The linker hld is responsible for linking together the object files which make up your application together with
some run-time startup code and any support libraries.
Although the compiler driver usually invokes the linker for you, we fully describe how the linker can be used
stand-alone. If you are maintaining your project with a make-like program, you may wish to use this information
to invoke the linker directly rather than using the compiler driver.
The linker performs the following functions:
resolves references between object modules;
extracts object modules from archives to resolve unsatisfied references
combines all fragments belonging to the same section into a contiguous region
removes all unreferenced code and data
runs an architecture-specific optimizer to improve the object code
fixes the size of span-dependent instructions
computes all relocatable values
produces a linked application and writes it in a number of formats
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Command line syntax
You invoke the linker using the following syntax:
hld [ option | file ]...

Files
file is either an object file or library file to include in the link and it must be in CrossWorks object or library format.

Options
option is a command-line option. Options are case sensitive and cannot be abbreviated.
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Command line options
This section describes the command line options accepted by the CrossWorks linker.
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-D (Define linker symbol)
Syntax
-Dname=[symbol | number]

Description
This option instructs the linker to define the symbol name as either the value number or the low-level symbol
symbol. You can specify number in either decimal or hexadecimal notation using a 0x prefix.

Project property
Linker Options > Linker Symbol Definitions
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-F (Set output format)
Syntax
-Fformat

Description
The -F option instructs the linker to write its output in the format fmt. The linker supports the following formats:
-Fsrec Motorola S-record format
-Fhex Intel extended hex format
-Ttxt Texas Instruments hex format
-Flst Hexadecimal listing
-Fbin Binary format
-Fhzx Rowley native format
The default format, if no other format is specified, is -Fhzx.
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-g (Propagate debugging information)
Syntax
-g

Description
The -g option instructs the linker to propagate debugging information contained in the individual object files
into the linked image. If you intend to debug your application at the source level, you must use this option when
linking your program.
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-K (Keep linker symbol)
Syntax
-Kname

Description
The CrossWorks linker removes unused code and data from the output file. This process is called deadstripping.
To prevent the linker from deadstripping unreferenced code and data you wish to keep, you must use the -K
command line option to force inclusion of symbols.

Project property
Linker Options > Keep Symbols

Example
If you have a C function, contextSwitch that must be kept in the output file (and which the linker will normally
remove), you can force its inclusion using:
-K_contextSwitch
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-l- (Do not link standard libraries)
Syntax
-l-

Description
The -l option instructs the linker not to link standard libraries automatically included by the compiler or by the
assembler INCLUDELIB directive. If you use this options you must supply your own library functions or provide
the names of alternative sets of libraries to use.

Project property
Linker Options > Include Standard Libraries
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-l (Link library)
Syntax
-lx

Description
Link the library libx.hza from the library directory. The library directory is, by default $(InstallDir)/lib, but can be
changed with the -L option.
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-L (Set library directory path)
Syntax
-Ldir

Description
Sets the library directory to dir. If -L is not specified on the command line, the default location to search for
libraries is set to $(InstallDir)/lib.
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-M (Display linkage map)
Syntax
-M
-Mfile

Description
The -M option prints a linkage map to standard output; -Mfile prints a linkage map to filename.
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-m (Generate for 64K part)
Syntax
-m64k

Description
This option instructs the linker to generate code for an MSP430 with at most 64 kilobytes of code memory (a
compact model). Some of the code transformations performed by the linker are code-model-dependent, in
particular whether CALL or CALLA should be used for procedure abstraction and how the stack is modified.
For some processors, such as the CC430, although they have an MSP430X core, they do not have code memory
that extends beyond the first 64 kilobytes of the address space. In this case, it is beneficial, in terms of code
space, data space, and execution time, to use the compact memory model which limits the total address space
to 64 kilobytes.
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-m (Generate for 1M part)
Syntax
-m1m

Description
This option instructs the linker to generate code for an MSP430 with at up to 1 megabyte of code memory
(a large model). Some of the code transformations performed by the linker are code-model-dependent, in
particular whether CALL or CALLA should be used for procedure abstraction and how the stack is modified.
For some processors, such as the CC430, although they have an MSP430X core, they do not have code memory
that extends beyond the first 64 kilobytes of the address space. In this case, it is beneficial, in terms of code
space, data space, and execution time, to use the compact memory model which limits the total address space
to 64 kilobytes.
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-mcpux (Enable MSP430X processor)
Syntax
-mcpux

Description
This option instructs the linker to generate code for the 20-bit MSP430X CPU core rather than a 16-bit MSP430
core. Note that it is not possible to mix code generated for the MSP430X with code generated for the MSP430.
By default the linker selects large model when compiling code for an MSP430X. If your target processor has an
MSP430X core with a total memory space of less than 64K, you will use less code and data space, and decrease
execution time, if you select the compact memory model with the -m64k switch.
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-o (Set output file name)
Syntax
-o filename

Description
The -o option instructs the linker to write its linked output to filename.
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-Obl (Enable block locality optimization)
Syntax
-Obl

Description
Enables the block locality improvement optimization. This optimization moves blocks of code in order reduce
span-dependent jump sizes on many architectures.
This optimization is extremely compute intensive but delivers very good results on many applications. It will
always reduce code size and execution time because the size of span-dependent jumps are reduced.
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-Ocm (Enable code motion optimization)
Syntax
-Ocm

Description
Enables the code motion optimization. Code motion moves blocks of instructions from one place to another
to reduce the number of jump instructions in the final program. Code motion will always reduce code size and
increase execution speed.
It is extremely difficult to debug a program which has been linked with code motion enabled because parts of
functions will be moved around the program and merged with other functions.
Code Generation Options > Code Motion Optimization
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-Oxc (Enable code factoring optimization)
Syntax
-Oxc[=n]

Description
Enables the code factoring optimization. Code factoring is also commonly called common block subroutine
packing, cross calling, and procedure abstraction. Code factoring finds common instruction sequences and
replaces each common sequence with a subroutine call to one instance of that sequence.
Code factoring will always reduce the size of a program at the expense of execution speed as there is an
overhead for the additional subroutine call and return instructions.
The option parameter n defines the number of bytes that must the common instruction sequence must contain
before it is abstracted into a subroutine. Smaller values of n are likely to find more common sequences and will
transform the code into a smaller, but slower, program. Larger values of n will find fewer common sequences,
where each of those sequences are longer and will transform the code in to a slightly larger, and slightly faster,
program.
The time complexity of the algorithm use depends upon n. Smaller values of n require more time for
optimization to find and transform the small code sequences, whereas larger values of n requires less time to
run as fewer common code sequences will be identified. You can also limit the number of code factoring passes
using the -Oxcp option.
It is extremely difficult to debug a program which has been linked with code factoring enabled because parts of
functions will be extracted and placed into their own subroutine.

Project properties
Code Generation Options > Code Factoring Optimization
Code Generation Options > Code Subroutine Size
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-Oxcp (Set code factoring passes)
Syntax
-Oxcp[=n]

Description
Sets the maximum number of code factoring passes to n, or sets unlimited code factoring if n is omitted.
Each pass of the code factoring optimization may increase the maximum subroutine depth required by the
linked application by one call. If stack space is at a premium, you can limit the additional subroutine depth
introduced by the code factoring optimization to n. For instance, specifying -Oxcp=1 will cause the application
to use only a single depth of subroutines, with no other calls, when performing code factoring; specifying Oxcp=2 will introduce up to two additional subroutines (mainline code calls a subroutine which then calls
another subroutine) and will require up to two additional return addresses on the call stack.
Setting n higher leads to higher code compression but introduces more subroutines and makes the code slower
to executeyou may wish to limit the number of subroutines, their size, and the subroutine depth to strike a
balance between speed, code space, and stack requirements.
For processors with a small hardware stack, it may be appropriate to limit the code factoring optimization to
only a few levels of subroutines so that the hardware stack does not overflow, or even to disable code factoring
completely if stack space is at a premium.

Project property
Code Generation Options > Code Factoring Passes
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-Oxcx (Enable extreme code factoring optimization)
Syntax
-Oxcx}[=n]

Description
This optimization is identical to the Code Factoring optimization except that it works much harder to find
common code sequences and, consequently, is much slower than the standard cross calling optimization. We
recommend that you do not use this optimization unless you wish to reduce code size to the smallest possible as
this optimization takes a long time to run for large programs.

452

CrossWorks for MSP430 Reference Manual

Linker User Guide

-Oph (Enable peephole optimization)
Syntax
-Oph

Description
Enables peephole optimizations. Peephole optimizations transform local code sequences into more efficient
code sequences using a collection of common idioms. Peephole optimization will always reduce code size and
increase execution speed.

Project property
Code Generation Options > Peephole Optimization
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-Oxj (Cross jumping optimization)
Syntax
-Oxj

Description
Enables the cross jumping optimization. Cross jumping finds identical code sequences that can be shared,
deletes all copies and reroutes control flow to exactly one instance of the code sequence. Cross jumping will
always reduce code size at the expense of executing an additional jump instruction.

Project property
Code Generation Options > Cross Jumping Optimization
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-Osf (Enable subroutine flattening optimizations)
Syntax
-Osf

Description
Enables flattening optimizations. Calls to subroutines immediately followed by an unconditional return
instruction are converted into jumps to the subroutine.
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-Ojc (Enable jump chaining optimization)
Syntax
-Ojc

Description
Enables the jump chaining optimization. Jump chaining reduces the size of span-dependent jumps by
finding a closer jump instruction to the same target address and reroutes the original jump to that jump.
This optimization always reduces code size at the expense of execution speed because of the jump chains
introduced.

Project property
Code Generation Options > Jumping Chaining Optimization
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-Ojt (Enable jump threading optimization)
Syntax
-Ojt

Description
Enables the jump threading optimization. Jump threading finds jumps to jump instructions and reroutes the
original jump instruction to the final destination. Jump threading will always increase execution speed and may
reduce code size. A jump will not be rerouted if, in doing so, the size of the jump instruction increases.

Project property
Code Generation Options > Jumping Threading Optimization
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-Ojt (Enable tail merge optimization)
Syntax
-Otm

Description
Enables the tail merging optimization. Tail merging finds identical code sequences at the end of functions that
can be shared, deletes all copies and reroutes control flow to exactly one instance of the code sequence. Tail
merging will always reduce code size at the expense of executing an additional jump instruction.

Project property
Code Generation Options > Tail Merging Optimization
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-Oz (Optimize Sections)
Syntax
-Oz=section,section,...

Description
The options allows specific sections to be optimized. By default the Code section will be optimized.

Project property
Linker Options > Optimize Sections

Example
To optimize the CODE and BOOTCODE sections:
-Oz=CODE,BOOTCODE
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-R (Rename sections)
Syntax
-Rsection=new

Description
This option renames the input modules in section to be new.

Project property
Linker Options > Rename Sections

Example
To rename the input modules in section LIB_CODE to LR_CODE:
-RLIBC_CODE=LR_CODE

460

CrossWorks for MSP430 Reference Manual

Linker User Guide

-T (Locate sections)
Syntax
-Tsection,...=start[-end]...

Description
This option sets the way that sections are aggregated and laid out in memory. The start and end addresses are
inclusive and define the memory segments into which sections in the list are placed. Sections are allocated in the
order that they are specified in the list.

Project property
Section layout is configured using the XML-format memory map file so this option cannot be set directly in the
CrossStudio IDE.

Example
To aggregate and place the CODE and CONST sections into the memory segment 0x1000 through 0xffef
inclusive and 0x10000 through 0xfffff inclusive and with CONST placed before CODE:
-TCONST,CODE=0x1000-0xffef+0x10000-0xfffff
To aggregate the IDATA0 and UDATA0 sections into the memory segment 0x200 through 0xaff placing IDATA0
before UDATA0:
-TIDATA0,UDATA0=0x200-0xaff
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-we (Treat warnings as errors)
Syntax
-we

Description
This option directs the linker to treat all warnings as errors.

Project property
General Options > Treat Warnings as Errors
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-w (Suppress warnings)
Syntax
-w

Description
This option instructs the linker not to issue any warnings.

Project property
General Options > Suppress Warnings
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-v (Verbose execution)
Syntax
-v

Description
This option instructs the linker to issue progress messages.
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-V (Display version)
Syntax
-V

Description
This option instructs the linker to display its version information.
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C Library User Guide
This section describes the library and how to use and customize it.
The libraries supplied with CrossWorks have all the support necessary for input and output using the standard C
functions printf and scanf, support for the assert function, both 32-bit and 64-bit floating point, and are capable
of being used in a multi-threaded environment. However, to use these facilities effectively you will need to
customize the low-level details of how to input and output characters, what to do when an assertion fails, how
to provide protection in a multithreaded environment, and how to use the available hardware to the best of its
ability.
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Floating point
The CrossWorks C library uses IEEE floating point format as specified by the ISO 60559 standard with restrictions.
This library favors code size and execution speed above absolute precision. It is suitable for applications
that need to run quickly and not consume precious resources in limited environments. The library does not
implement features rarely used by simple applications: floating point exceptions, rounding modes, and
subnormals.
NaNs and infinities are supported and correctly generated. The only rounding mode supported is round-tonearest. Subnormals are always flushed to a correctly-signed zero. The mathematical functions use stable
approximations and do their best to cater ill-conditioned inputs.
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Single and double precision
CrossWorks C allows you to choose whether the double data type uses the IEC 60559 32-bit or 64-bit format. The
following sections describe the details of why you would want to choose a 32-bit double rather than a 64-bit
double in many circumstances.

Why choose 32-bit doubles?
Many users are surprised when using float variables exclusively that sometimes their calculations are compiled
into code that calls for double arithmetic. They point out that the C standard allows float arithmetic to be carried
out only using float operations and not to automatically promote to the double data type of classic K&R C.
This is valid point. However, upon examination, even the simplest calculations can lead to double arithmetic.
Consider:
// Compute sin(2x)
float sin_two_x(float x)
{
return sinf(2.0 * x);
}

This looks simple enough. We're using the sinf function which computes the sine of a float and returns a float
result. There appears to be no mention of a double anywhere, yet the compiler generates code that calls double
support routinesbut why?
The answer is that the constant 2.0 is a double constant, not a float constant. That is enough to force the
compiler to convert both operands of the multiplication to double format, perform the multiplication in double
precision, and then convert the result back to float precision. To avoid this surprise, the code should have been
written:
// Compute sin(2x)
float sin_two_x(float x)
{
return sinf(2.0F * x);
}

This uses a single precision floating-point constant 2.0F. It's all too easy to forget to correctly type your floatingpoint constants, so if you compile your program with double meaning the same as float, you can forget all
about adding the 'F' suffix to your floating point constants.
As an aside, the C99 standard is very strict about the way that floating-point is implemented and the latitude the
compiler has to rearrange and manipulate expressions that have floating-point operands. The compiler cannot
second-guess user intention and use a number of useful mathematical identities and algebraic simplifications
because in the world of IEC 60559 arithmetic many algebraic identities, such as x * 1 = x, do not hold when x
takes one of the special values NaN, infinity, or negative zero.
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More reasons to choose 32-bit doubles
Floating-point constants are not the only silent way that double creeps into your program. Consider this:
void write_results(float x)
{
printf("After all that x=%f\\n", x);
}

Again, no mention of a double anywhere, but double support routines are now required. The reason is that ISO
C requires that float arguments are promoted to double when they are passed to the non-fixed part of variadic
functions such as printf. So, even though your application may never mention double, double arithmetic may
be required simply because you use printf or one of its near relatives.
If, however, you compile your code with 32-bit doubles, then there is no requirement to promote a float to a
double as they share the same internal format.

Why choose 64-bit doubles?
If your application requires very accurate floating-point, more precise than the seven decimal digits supported
by the float format, then you have little option but to use double arithmetic as there is no simple way to
increase the precision of the float format. The double format delivers approximately 15 decimal digits of
precision.
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Multithreading
The CrossWorks libraries support multithreading, for example, where you are using CTL or a third-party real-time
operating system (RTOS).
Where you have single-threaded processes, there is a single flow of control. However, in multithreaded
applications there may be several flows of control which access the same functions, or the same resources,
concurrently. To protect the integrity of resources, any code you write for multithreaded applications must be
reentrant and thread-safe.
Reentrancy and thread safety are both related to the way functions in a multithreaded application handle
resources.

Reentrant functions
A reentrant function does not hold static data over successive calls and does not return a pointer to static data.
For this type of function, the caller provides all the data that the function requires, such as pointers to any
workspace. This means that multiple concurrent calls to the function do not interfere with each other, that the
function can be called in mainline code, and that the function can be called from an interrupt service routine.

Thread-safe functions
A thread-safe function protects shared resources from concurrent access using locks. In C, local variables are
held in processor registers or are on the stack. Any function that does not use static data, or other shared
resources, is thread-safe. In general, thread-safe functions are safe to call from any thread but cannot be called
directly, or indirectly, from an interrupt service routine.
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Thread safety in the CrossWorks library
In the CrossWorks C library:
some functions are inherently thread-safe, for example strcmp.
some functions, such as malloc, are not thread-safe by default but can be made thread-safe by
implementing appropriate lock functions.
other functions are only thread-safe if passed appropriate arguments, for example tmpnam.
some functions are never thread-safe, for example setlocale.
We define how the functions in the C library can be made thread-safe if needed. If you use a third-party library
in a multi-threaded system and combine it with the CrossWorks C library, you will need to ensure that the thirdparty library can be made thread-safe in just the same way that the CrossWorks C library can be made threadsafe.
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Implementing mutual exclusion in the C library
The CrossWorks C library ships as standard with callouts to functions that provide thread-safety in a
multithreaded application. If your application has a single thread of execution, the default implementation of
these functions does nothing and your application will run without modification.
If your application is intended for a multithreaded environment and you wish to use the CrossWorks C library,
you must implement the following locking functions:
__heap_lock and __heap_unlock to provide thread-safety for all heap operations such as malloc, free,
and realloc.
__printf_lock and __printf_unlock to provide thread-safety for printf and relatives.
__scanf_lock and __scanf_unlock to provide thread-safety for scanf and relatives.
__debug_io_lock and __debug_io_unlock to provide thread-safety for semi-hosting support in the
CrossStudio I/O function.
If you create a CTL project using the New Project wizard, CrossWorks provides implementations of these using
CTL event sets. You're free to reimplement them as you see fit.
If you use a third-party RTOS with the CrossWorks C library, you will need to use whatever your RTOS provides for
mutual exclusion, typically a semaphore, a mutex, or an event set.
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Input and output
The C library provides all the standard C functions for input and output except for the essential items of where to
output characters printed to stdout and where to read characters from stdin.
If you want to output to a UART, to an LCD, or input from a keyboard using the standard library print and scan
functions, you need to customize the low-level input and output functions.
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Customizing putchar
To use the standard output functions putchar, puts, and printf, you need to customize the way that characters
are written to the standard output device. These output functions rely on a function __putchar that outputs a
character and returns an indication of whether it was successfully written.
The prototype for __putchar is
int __putchar(int ch);

Sending all output to the CrossStudio virtual terminal
You can send all output to the CrossStudio virtual terminal by supplying the following implementation of
the__putchar function in your code:
#include <debugio.h>
int __putchar(int ch)
{
return debug_putchar(ch);
}

This hands off output of the character ch to the low-level debug output routine, debug_putchar.
Whilst this is an adequate implementation of __putchar, it does consume stack space for an unnecessary nested
call and associated register saving. A better way of achieving the same result is to define the low-level symbol for
__putchar to be equivalent to the low-level symbol for debug_putchar. To do this, we need to instruct the linker
to make the symbols equivalent.
Select the project node in the Project Explorer.
Display the Properties Window.
Enter the text -D___putchar=_debug_putchar into the Additional Options property of the Linker
Options group.
Note that there are three leading underscores in ___putchar and a single leading underscore in
_debug_putchar because the C compiler automatically prepends an underscore to all global symbols.

Sending all output to another device
If you need to output to a physical device, such as a UART, the following notes will help you:
If the character cannot be written for any reason, putchar must return EOF. Just because a character can't
be written immediately is not a reason to return EOF: you can busy-wait or tasking (if applicable) to wait
until the character is ready to be written.
The higher layers of the library do not translate C's end of line character '\\n' before passing it to putchar.
If you are directing output to a serial line connected to a terminal, for instance, you will most likely need
to output a carriage return and line feed when given the character '\\n' (ASCII code 10).

475

CrossWorks for MSP430 Reference Manual

C Library User Guide

The standard functions that perform input and output are the printf and scanf functions.These functions
convert between internal binary and external printable data. In some cases, though, you need to read and write
formatted data on other channels, such as other RS232 ports. This section shows how you can extend the I/O
library to best implement these function.

Classic custom printf-style output
Assume that we need to output formatted data to two UARTs, numbered 0 and 1, and we have a functions
uart0_putc and uart1_putc that do just that and whose prototypes are:
int uart0_putc(int ch, __printf_t *ctx);
int uart1_putc(int ch, __printf_t *ctx);

These functions return a positive value if there is no error outputting the character and EOF if there was an
error. The second parameter, ctx, is the context that the high-level formatting routines use to implement the C
standard library functions.
Using a classic implementation, you would use sprintf to format the string for output and then output it:
void uart0_printf(const char *fmt, ...)
{
char buf[80], *p;
va_list ap;
va_start(ap, fmt);
vsnprintf(buf, sizeof(buf), fmt, ap);
for (p = buf; *p; ++p)
uart0_putc(*p, 0); // null context
va_end(ap);
}

We would, of course, need an identical routine for outputting to the other UART. This code is portable, but it
requires an intermediate buffer of 80 characters. On small systems, this is quite an overhead, so we could reduce
the buffer size to compensate. Of course, the trouble with that means that the maximum number of characters
that can be output by a single call to uart0_printf is also reduced. What would be good is a way to output
characters to one of the UARTs without requiring an intermediate buffer.

CrossWorks printf-style output
CrossWorks provides a solution for just this case by using some internal functions and data types in the
CrossWorks library. These functions and types are define in the header file <__vfprintf.h>.
The first thing to introduce is the __printf_t type which captures the current state and parameters of the format
conversion:
typedef struct __printf_tag
{
size_t charcount;
size_t maxchars;
char *string;
int (*output_fn)(int, struct __printf_tag *ctx);
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} __printf_t;

This type is used by the library functions to direct what the formatting routines do with each character they need
to output. If string is non-zero, the character is appended is appended to the string pointed to by string; if
output_fn is non-zero, the character is output through the function output_fn with the context passed as the
second parameter.
The member charcount counts the number of characters currently output, and maxchars defines the maximum
number of characters output by the formatting routine __vfprintf.
We can use this type and function to rewrite uart0_printf:
int uart0_printf(const char *fmt, ...)
{
int n;
va_list ap;
__printf_t iod;
va_start(ap, fmt);
iod.string = 0;
iod.maxchars = INT_MAX;
iod.output_fn = uart0_putc;
n = __vfprintf(\&iod, fmt, ap);
va_end(ap);
return n;
}

This function has no intermediate buffer: when a character is ready to be output by the formatting routine, it
calls the output_fn function in the descriptor iod to output it immediately. The maximum number of characters
isn't limited as the maxchars member is set to INT_MAX. if you wanted to limit the number of characters output
you can simply set the maxchars member to the appropriate value before calling __vfprintf.
We can adapt this function to take a UART number as a parameter:
int uart_printf(int uart, const char *fmt, ...)
{
int n;
va_list ap;
__printf_t iod;
va_start(ap, fmt);
iod.is_string = 0;
iod.maxchars = INT_MAX;
iod.output_fn = uart ? uart1_putc : uart0_putc;
n = __vfprintf(\&iod, fmt, ap);
va_end(ap);
return n;
}

Now we can use:
uart_printf(0, "This is uart %d\n...", 0);
uart_printf(1, "..and this is uart %d\n", 1);

__vfprintf returns the actual number of characters printed, which you may wish to dispense with and make the
uart_printf routine return void.
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Extending input functions
The formatted input functions would be implemented in the same manner as the output functions: read a
string into an intermediate buffer and parse using sscanf. However, we can use the low-level routines in the
CrossWorks library for formatted input without requiring the intermediate buffer.
The type __stream_scanf_t is:
typedef struct
{
char is_string;
int (*getc_fn)(void);
int (*ungetc_fn)(int);
} __stream_scanf_t;

The function getc_fn reads a single character from the UART, and ungetc_fn pushes back a character to the
UART. You can push at most one character back onto the stream.
Here's an implementation of functions to read and write from a single UART:
static int uart0_ungot = EOF;
int uart0_getc(void)
{
if (uart0_ungot)
{
int c = uart0_ungot;
uart0_ungot = EOF;
return c;
}
else
return read_char_from_uart(0);
}
int uart0_ungetc{int c)
{
uart0_ungot = c;
}

You can use these two functions to perform formatted input using the UART:
int uart0_scanf(const char *fmt, ...)
{
__stream_scanf_t iod;
va_list a;
int n;
va_start(a, fmt);
iod.is_string = 0;
iod.getc_fn = uart0_getc;
iod.ungetc_fn = uart0_ungetc;
n = __vfscanf((__scanf_t *)\&iod, (const unsigned char *)fmt, a);
va_end(a);
return n;
}

Using this template, we can add functions to do additional formatted input from other UARTs or devices, just as
we did for formatted output.
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Locales
The CrossWorks C library supports wide characters, multi-byte characters and locales. However, as not all
programs require full localization, you can tailor the exact support provided by the CrossWorks C library to suit
your application. These sections describe how to add new locales to your application and customize the runtime
footprint of the C library.
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Unicode, ISO 10646, and wide characters
The ISO standard 10646 is identical to the published Unicode standard and the CrossWorks C library uses the
Unicode 6.2 definition as a base. Hence, whenever you see the term Unicode in this document, it is equivalent to
Unicode 6.2 and ISO/IEC 10646:2011.
The CrossWorks C library supports both 16-bit and 32-bit wide characters, depending upon the setting of wide
character width in the project.
When compiling with 16-bit wide characters, all characters in the Basic Multilingual Plane are representable
in a single wchar_t (values 0 through 0xFFFF). When compiling with 32-bit wide characters, all characters in
the Basic Multilingual Plane and planes 1 through 16 are representable in a single wchar_t (values 0 through
0x10FFFF).
The wide character type will hold Unicode code points in a locale that is defined to use Unicode and character
type functions such as iswalpha will work correctly on all Unicode code points.
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Multi-byte characters
CrossWorks supports multi-byte encoding and decoding of characters. Most new software on the desktop uses
Unicode internally and UTF-8 as the external, on-disk encoding for files and for transport over 8-bit mediums
such as network connections.
However, in embedded software there is still a case to use code pages, such as ISO-Latin1, to reduce the
footprint of an application whilst also providing extra characters that do not form part of the ASCII character set.
The CrossWorks C library can support both models and you can choose a combination of models, dependent
upon locale, or construct a custom locale.
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The standard C and POSIX locales
The standard C locale is called simply C. In order to provide POSIX compatibility, the name POSIX is a synonym
for C.
The C locale is fixed and supports only the ASCII character set with character codes 0 through 127. There is no
multi-byte character support, so the character encoding between wide and narrow characters is simply oneto-one: a narrow character is converted to a wide character by zero extension. Thus, ASCII encoding of narrow
characters is compatible with the ISO 10646 (Unicode) encoding of wide characters in this locale.
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Additional locales in source form
The CrossWorks C library provides only the C locale; if you need other locales, you must provide those by linking
them into your application. We have constructed a number of locales from the Unicode Common Locale Data
Repository (CLDR) and provided them in source form in the $(StudioDir)/src folder for you to include in
your application.
A C library locale is divided into two parts:
the locale's date, time, numeric, and monetary formatting information
how to convert between multi-byte characters and wide characters by the functions in the C library.
The first, the locale data, is independent of how characters are represented. The second, the code set in use,
defines how to map between narrow, multi-byte, and wide characters.
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Installing a locale
If the locale you request using setlocale is neither C nor POSIX, the C library calls the function
__user_find_locale to find a user-supplied locale. The standard implementation of this function is to return a
null pointer which indicates that no additional locales are installed and, hence, no locale matches the request.
The prototype for __user_find_locale is:
const __RAL_locale_t *__user_find_locale(const char *locale);

The parameter locale is the locale to find; the locale name is terminated either by a zero character or by a
semicolon. The locale name, up to the semicolon or zero, is identical to the name passed to setlocale when you
select a locale.
Now let's install the Hungarian locale using both UTF-8 and ISO 8859-2 encodings. The UTF-8 codecs are
included in the CrossWorks C library, but the Hungarian locale and the ISO 8859-2 codec are not.
You will find the file locale_hu_HU.c in the source directory as described in the previous section. Add this file to
your project.
Although this adds the data needed for the locale, it does not make the locale available for the C library: we need
to write some code for __user_find_locale to return the appropriate locales.
To create the locales, we need to add the following code and data to tie everything together:
#include <__crossworks.h>
static const __RAL_locale_t hu_HU_utf8 = {
"hu_HU.utf8",
&__RAL_hu_HU_locale,
&__RAL_codeset_utf8
};
static const __RAL_locale_t hu_HU_iso_8859_2 = {
"hu_HU.iso_8859_2",
&__RAL_hu_HU_locale,
&codeset_iso_8859_2
};
const __RAL_locale_t *
__user_find_locale(const char *locale)
{
if (__RAL_compare_locale_name(locale, hu_HU_utf8.name) == 0)
return &hu_HU_utf8;
else if (__RAL_compare_locale_name(locale, hu_HU_iso_8859_2.name) == 0)
return &hu_HU_iso_8859_2;
else
return 0;
}

The function __RAL_compare_locale_name matches locale names up to a terminating null character, or
a semicolon (which is required by the implementation of setlocale in the C library when setting multiple
locales using LC_ALL).
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In addition to this, you must provide a buffer, __user_locale_name_buffer, for locale names encoded
by setlocale. The buffer must be large enough to contain five locale names, one for each category. In the
above example, the longest locale name is hu_HU.iso_8859_2 which is 16 characters in length. Using this
information, buffer must be at least (16+1)5 = 85 characters in size:
const char __user_locale_name_buffer[85];
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Setting a locale directly
Although we support setlocale in its full generality, most likely you'll want to set a locale once and forget about
it. You can do that by including the locale in your application and writing to the instance variables that hold the
underlying locale data for the CrossWorks C library.
For instance, you might wish to use Czech locale with a UTF codeset:
static __RAL_locale_t cz_locale =
{
"cz_CZ.utf8",
&__RAL_cs_CZ_locale,
&__RAL_codeset_utf8
};

You can install this directly into the locale without using setlocale:
__RAL_global_locale.__category[LC_COLLATE]
__RAL_global_locale.__category[LC_CTYPE]
__RAL_global_locale.__category[LC_MONETARY]
__RAL_global_locale.__category[LC_NUMERIC]
__RAL_global_locale.__category[LC_TIME]

=
=
=
=
=

&cz_locale;
&cz_locale;
&cz_locale;
&cz_locale;
&cz_locale;
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Complete API reference
This section contains a complete reference to the CrossWorks C library API.
File

Description

<assert.h>

Describes the diagnostic facilities which you can build
into your application.

<debugio.h>

Describes the virtual console services and semihosting support that CrossStudio provides to help you
when developing your applications.

<cruntime.h>

Defines the interface to functions that the C compiler
calls when generating code. For instance, it contains
the runtime routines for all floating point operators
and conversion, and shifts, multiplies, and divides.for
each of the integer types. In general, you do not need
to call these routines yourself directly, but they are
documented here should you need to call them from
assembly language. These functions abide by the
standard calling conventions of the compiler.

<ctype.h>

Describes the character classification and
manipulation functions.

<errno.h>

Describes the macros and error values returned by the
C library.

<float.h>

Defines macros that expand to various limits and
parameters of the standard floating point types.

<in430.h>

Describes the intrinsic functions that are mainly
compatible with IAR's EW430 v2 product.

<inmsp.h>

Describes the intrinsic functions that are mainly
compatible with IAR's EW430 v3 product.

<limits.h>

Describes the macros that define the extreme values of
underlying C types.

<locale.h>

Describes support for localization specific settings.

<math.h>

Describes the mathematical functions provided by the
C library.

<setjmp.h>

Describes the non-local goto capabilities of the C
library.

<stdarg.h>

Describes the way in which variable parameter lists are
accessed.

<stddef.h>

Describes standard type definitions.

<stdio.h>

Describes the formatted input and output functions.

<stdlib.h>

Describes the general utility functions provided by the
C library.
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<string.h>

Describes the string handling functions provided by
the C library.

<time.h>

Describes the functions to get and manipulate date
and time information provided by the C library.

<wchar.h>

Describes the facilities you can use to manipulate wide
characters.
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<assert.h>
API Summary
Macros
assert

Allows you to place assertions and diagnostic tests into
programs

Functions
__assert

User defined behaviour for the assert macro
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__assert
Synopsis
void __assert(const char *expression,
const char *filename,
int line);

Description
There is no default implementation of __assert. Keeping __assert out of the library means that you can can
customize its behaviour without rebuilding the library. You must implement this function where expression
is the stringized expression, filename is the filename of the source file and line is the linenumber of the failed
assertion.

490

CrossWorks for MSP430 Reference Manual

C Library User Guide

assert
Synopsis
#define assert(e) ...

Description
If NDEBUG is defined as a macro name at the point in the source file where <assert.h> is included, the assert
macro is defined as:
#define assert(ignore) ((void)0)

If NDEBUG is not defined as a macro name at the point in the source file where <assert.h> is included, the assert
macro expands to a void expression that calls __assert.
#define assert(e) ((e) ? (void)0 : __assert(#e, __FILE__, __LINE__))

When such an assert is executed and e is false, assert calls the __assert function with information about the
particular call that failed: the text of the argument, the name of the source file, and the source line number.
These are the stringized expression and the values of the preprocessing macros __FILE__ and __LINE__.

Note
The assert macro is redefined according to the current state of NDEBUG each time that <assert.h> is included.
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<cruntime.h>
The header file <cruntime.h> defines the interface to functions that the C compiler calls when generating
code. For instance, it contains the runtime routines for floating point operations and conversion, with shifts,
multiplies, and divides for each of the integer types. In general, you do not need to call these routines directly
from your own C code. These functions are are documented here should you need to call them from assembly
language. These functions abide by the standard calling conventions of the compiler. Not every implementation
of CrossWorks will provide all these functions.

API Summary
Integer multiplication
__int16_mul

Multiply two 16-bit signed or unsigned integers
forming a 16-bit product

__int16_mul_8x8

Multiply two 8-bit signed integers forming a 16-bit
signed product

__int16_mul_asgn

Multiply a 16-bit signed or unsigned integer in
memory by a 16-bit integer

__int32_mul

Multiply two 32-bit signed or unsigned integers
forming a 32-bit product

__int32_mul_16x16

Multiply two 16-bit signed integers forming a 32-bit
signed product

__int32_mul_asgn

Multiply a 32-bit signed or unsigned integer in
memory by a 32-bit integer

__int64_mul

Multiply two 64-bit signed or unsigned integers
forming a 64-bit product

__int64_mul_32x32

Multiply two 32-bit signed integers forming a 64-bit
signed product

__int64_mul_asgn

Multiply a 64-bit signed or unsigned integer in
memory by a 64-bit integer

__uint16_mul_8x8

Multiply two 8-bit unsigned integers forming a 16-bit
unsigned product

__uint32_mul_16x16

Multiply two 16-bit unsigned integers forming a 32-bit
unsigned product

__uint64_mul_32x32

Multiply two 32-bit unsigned integers forming a 64-bit
unsigned product

Integer division
__int16_div

Divide two 16-bit signed integers and return the 16-bit
signed quotient
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__int16_div_asgn

Divide a 16-bit signed integer in memory by a 16-bit
signed integer

__int16_mod

Divide two 16-bit signed integers and return the 16-bit
signed remainder after division

__int16_mod_asgn

Divide a 16-bit signed integer in memory by a 16-bit
signed integer and assign it the 16-bit remainder

__int32_div

Divide two 32-bit signed integers and return the 32-bit
signed quotient

__int32_div_asgn

Divide a 32-bit signed integer in memory by a 32-bit
signed integer

__int32_mod

Divide two 32-bit signed integers and return the 32-bit
signed remainder after division

__int32_mod_asgn

Divide a 32-bit signed integer in memory by a 32-bit
signed integer and assign it the 32-bit remainder

__int64_div

Divide two 64-bit signed integers and return the 64-bit
signed quotient

__int64_div_asgn

Divide a 64-bit signed integer in memory by a 64-bit
signed integer

__int64_mod

Divide two 64-bit signed integers and return the 64-bit
signed remainder after division

__int64_mod_asgn

Divide a 64-bit signed integer in memory by a 64-bit
signed integer and assign it the 64-bit remainder

__uint16_div

Divide two 16-bit unsigned integers and return the 16bit unsigned quotient

__uint16_div_asgn

Divide a 16-bit unsigned integer in memory by a 16-bit
unsigned integer

__uint16_mod

Divide two 16-bit unsigned integers and return the 16bit unsigned remainder after division

__uint16_mod_asgn

Divide a 16-bit unsigned integer in memory by a 16-bit
unsigned integer and assign it the 16-bit remainder

__uint32_div

Divide two 32-bit unsigned integers and return the 32bit unsigned quotient

__uint32_div_asgn

Divide a 32-bit unsigned integer in memory by a 32-bit
unsigned integer

__uint32_mod

Divide two 32-bit unsigned integers and return the 32bit unsigned remainder after division

__uint32_mod_asgn

Divide a 32-bit unsigned integer in memory by a 32-bit
unsigned integer and assign it the 32-bit remainder

__uint64_div

Divide two 64-bit unsigned integers and return the 64bit unsigned quotient
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__uint64_div_asgn

Divide a 64-bit unsigned integer in memory by a 64-bit
unsigned integer

__uint64_mod

Divide two 64-bit unsigned integers and return the 64bit unsigned remainder after division

__uint64_mod_asgn

Divide a 64-bit unsigned integer in memory by a 64-bit
unsigned integer and assign it the 64-bit remainder

Integer shifts
__int16_asr

Shift a 16-bit signed integer arithmetically right by a
variable number of bit positions

__int16_asr_asgn

Shift a 16-bit signed integer in memory arithmetically
right by a variable number of bit positions

__int16_lsl

Shift a 16-bit signed integer left by a variable number
of bit positions

__int16_lsl_asgn

Shift a 16-bit signed integer in memory left by a
variable number of bit positions

__int16_lsr

Shift a 16-bit unsigned integer logically right by a
variable number of bit positions

__int16_lsr_asgn

Shift a 16-bit unsigned integer in memory logically
right by a variable number of bit positions

__int32_asr

Shift a 32-bit signed integer arithmetically right by a
variable number of bit positions

__int32_asr_asgn

Shift a 32-bit signed integer in memory arithmetically
right by a variable number of bit positions

__int32_lsl

Shift a 32-bit signed integer left by a variable number
of bit positions

__int32_lsl_asgn

Shift a 32-bit signed integer in memory left by a
variable number of bit positions

__int32_lsr

Shift a 32-bit unsigned integer logically right by a
variable number of bit positions

__int32_lsr_asgn

Shift a 32-bit unsigned integer in memory logically
right by a variable number of bit positions

__int64_asr

Shift a 64-bit signed integer arithmetically right by a
variable number of bit positions

__int64_asr_asgn

Shift a 64-bit signed integer in memory arithmetically
right by a variable number of bit positions

__int64_lsl

Shift a 64-bit signed integer left by a variable number
of bit positions

__int64_lsl_asgn

Shift a 64-bit signed integer in memory left by a
variable number of bit positions
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__int64_lsr

Shift a 64-bit unsigned integer logically right by a
variable number of bit positions

__int64_lsr_asgn

Shift a 64-bit unsigned integer in memory logically
right by a variable number of bit positions

Floating-point arithmetic
__float32_add

Add two 32-bit floating point values

__float32_add_1

Add one to a 32-bit floating point value

__float32_add_asgn

Add a 32-bit floating point value to a 32-bit floating
point value in memory

__float32_div

Divide two 32-bit floating point values

__float32_div_asgn

Divide a 32-bit floating point value in memory by a 32bit floating point value

__float32_mul

Multiply two 32-bit floating point values

__float32_mul_asgn

Multiply a 32-bit floating point value in memory by a
32-bit floating point value

__float32_neg

Negate a 32-bit floating point value

__float32_sqr

Square a 32-bit floating point value

__float32_sub

Subtract two 32-bit floating point values

__float32_sub_asgn

Subtract a 32-bit floating point value from a 32-bit
floating point value in memory

__float64_add

Add two 64-bit floating point values

__float64_add_1

Add one to a 64-bit floating point value

__float64_add_asgn

Add a 64-bit floating point value to a 64-bit floating
point value in memory

__float64_div

Divide two 64-bit floating point values

__float64_div_asgn

Divide a 64-bit floating point value in memory by a 64bit floating point value

__float64_mul

Multiply two 64-bit floating point values

__float64_mul_asgn

Multiply a 64-bit floating point value in memory by a
64-bit floating point value

__float64_neg

Negate a 64-bit floating point value

__float64_sqr

Square a 64-bit floating point value

__float64_sub

Subtract two 64-bit floating point values

__float64_sub_asgn

Subtract a 64-bit floating point value from a 64-bit
floating point value in memory

Floating point comparison
__float32_eq

Compare two 32-bit floating point values for equality

__float32_eq_0

Compare 32-bit floating point value to zero
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__float32_lt

Compare two 32-bit floating point values

__float32_lt_0

Compare 32-bit floating point value with zero

__float64_eq

Compare two 64-bit floating point values for equality

__float64_eq_0

Compare 64-bit floating point value to zero

__float64_lt

Compare two 64-bit floating point values

__float64_lt_0

Compare 64-bit floating point value with zero

Integer to floating point conversions
__int16_to_float32

Convert a 16-bit signed integer to a 32-bit floating
point value

__int16_to_float64

Convert a 16-bit signed integer to a 64-bit floating
point value

__int32_to_float32

Convert a 32-bit signed integer to a 32-bit floating
point value

__int32_to_float64

Convert a 32-bit signed integer to a 64-bit floating
point value

__int64_to_float32

Convert a 64-bit signed integer to a 32-bit floating
point value

__int64_to_float64

Convert a 64-bit signed integer to a 64-bit floating
point value

__uint16_to_float32

Convert a 16-bit unsigned integer to a 32-bit floating
point value

__uint16_to_float64

Convert a 16-bit unsigned integer to a 64-bit floating
point value

__uint32_to_float32

Convert a 32-bit unsigned integer to a 32-bit floating
point value

__uint32_to_float64

Convert a 32-bit unsigned integer to a 64-bit floating
point value

__uint64_to_float32

Convert a 64-bit unsigned integer to a 32-bit floating
point value

__uint64_to_float64

Convert a 64-bit unsigned integer to a 64-bit floating
point value

Floating point to integer conversions
__float32_to_int16

Convert a 32-bit floating point value to a 16-bit signed
integer

__float32_to_int32

Convert a 32-bit floating point value to a 32-bit signed
integer

__float32_to_int64

Convert a 32-bit floating point value to a 64-bit signed
integer
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__float32_to_uint16

Convert a 32-bit floating point value to a 16-bit
unsigned integer

__float32_to_uint32

Convert a 32-bit floating point value to a 32-bit
unsigned integer

__float32_to_uint64

Convert a 32-bit floating point value to a 64-bit
unsigned integer

Floating point conversions
__float32_to_float64

Convert a 32-bit floating point value to a 64-bit
floating point value

__float64_to_float32

Convert a 64-bit floating point value to a 32-bit
floating point value
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__float32_add
Synopsis
float32_t __float32_add(float32_t augend,
float32_t addend);

Description
__float32_add adds addend to augend and returns the sum as the result.
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__float32_add_1
Synopsis
float32_t __float32_add_1(float32_t augend);

Description
__float32_add_1 adds one to augend and returns the sum as the result.
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__float32_add_asgn
Synopsis
float32_t __float32_add_asgn(float32_t *augend,
float32_t addend);

Description
__float32_add_asgn updates the floating-point value pointed to by augend by adding addend to it. The stored
sum is returned as the result.
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__float32_div
Synopsis
float32_t __float32_div(float32_t dividend,
float32_t divisor);

Description
__float32_div divides dividend by divisor and returns the quotient as the result.
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__float32_div_asgn
Synopsis
float32_t __float32_div_asgn(float32_t *dividend,
float32_t divisor);

Description
__float32_div_asgn updates the floating-point value pointed to by dividend by dividing it by divisor. The
stored quotient is returned as the result.
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__float32_eq
Synopsis
int __float32_eq(float32_t arg0,
float32_t arg1);

Description
__float32_eq compares arg0 to arg1. __float32_eq returns zero if arg0 is different from arg1, and a non-zero
value if arg0 is equal to arg1.
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__float32_eq_0
Synopsis
int __float32_eq_0(float32_t arg);

Description
__float32_eq_0 compares arg to zero. __float32_eq_0 returns a non-zero value if arg is zero, and a zero value if
arg is non-zero.
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__float32_lt
Synopsis
int __float32_lt(float32_t arg0,
float32_t arg1);

Description
__float32_lt compares arg0 to arg1. __float32_lt returns a non-zero value if arg0 is less than arg1, and zero if
arg0 is equal to or greater than arg1.
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__float32_lt_0
Synopsis
int __float32_lt_0(float32_t arg0,
float32_t arg1);

Description
__float32_lt_0 compares arg to zero. __float32_lt_0 returns a non-zero value if arg is less than zero, and zero if
arg0 is equal to or greater than zero.
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__float32_mul
Synopsis
float32_t __float32_mul(float32_t muliplicand,
float32_t multiplier);

Description
__float32_mul multiplies multiplicand by multiplier and returns the product as the result.
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__float32_mul_asgn
Synopsis
float32_t __float32_mul_asgn(float32_t *multiplicand,
float32_t multiplier);

Description
__float32_mul_asgn updates the floating-point value pointed to by multiplicand by multiplying it by
multiplier. The stored product is returned as the result.
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__float32_neg
Synopsis
float32_t __float32_neg(float32_t arg);

Description
__float32_neg negates arg and returns the result.
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__float32_sqr
Synopsis
float32_t __float32_sqr(float32_t arg);

Description
__float32_sqr squares arg by multiplying arg by itself.
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__float32_sub
Synopsis
float32_t __float32_sub(float32_t minuend,
float32_t subtrahend);

Description
__float32_sub subtracts subtrahend from minuend and returns the difference as the result.
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__float32_sub_asgn
Synopsis
float32_t __float32_sub_asgn(float32_t *minuend,
float32_t subtrahend);

Description
__float32_sub_asgn updates the floating-point value pointed to by minuend by subtracting subtrahend from
it. The stored difference is returned as the result.
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__float32_to_float64
Synopsis
float64_t __float32_to_float64(float32_t arg);

Description
__float32_to_float64 converts the 32-bit floating value arg to a 64-bit floating point value and returns the
converted value as the result.
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__float32_to_int16
Synopsis
int16_t __float32_to_int16(float32_t arg);

Description
__float32_to_int16 converts the floating value arg> to a 16-bit signed integer, truncating towards zero, and
returns the truncated value as the result.
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__float32_to_int32
Synopsis
int32_t __float32_to_int32(float32_t arg);

Description
__float32_to_int32 converts the floating value arg> to a 32-bit signed integer, truncating towards zero, and
returns the truncated value as the result.
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__float32_to_int64
Synopsis
int64_t __float32_to_int64(float32_t arg);

Description
__float32_to_int64 converts the floating value arg> to a 64-bit signed integer, truncating towards zero, and
returns the truncated value as the result.
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__float32_to_uint16
Synopsis
uint16_t __float32_to_uint16(float32_t arg);

Description
__float32_to_uint16 converts the floating value arg> to a 16-bit unsigned integer, truncating towards zero, and
returns the truncated value as the result.
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__float32_to_uint32
Synopsis
uint32_t __float32_to_uint32(float32_t arg);

Description
__float32_to_uint32 converts the floating value arg> to a 32-bit unsigned integer, truncating towards zero, and
returns the truncated value as the result.
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__float32_to_uint64
Synopsis
uint64_t __float32_to_uint64(float32_t arg);

Description
__float32_to_uint64 converts the floating value arg> to a 64-bit unsigned integer, truncating towards zero, and
returns the truncated value as the result.
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__float64_add
Synopsis
float64_t __float64_add(float64_t augend,
float64_t addend);

Description
__float64_add adds addend to augend and returns the sum as the result.
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__float64_add_1
Synopsis
float64_t __float64_add_1(float64_t augend);

Description
__float64_add_1 adds one to augend and returns the sum as the result.
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__float64_add_asgn
Synopsis
float64_t __float64_add_asgn(float64_t *augend,
float64_t addend);

Description
__float64_add_asgn updates the floating-point value pointed to by augend by adding addend to it. The stored
sum is returned as the result.
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__float64_div
Synopsis
float64_t __float64_div(float64_t dividend,
float64_t divisor);

Description
__float64_div divides dividend by divisor and returns the quotient as the result.
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__float64_div_asgn
Synopsis
float64_t __float64_div_asgn(float64_t *dividend,
float64_t divisor);

Description
__float64_div_asgn updates the floating-point value pointed to by dividend by dividing it by divisor. The
stored quotient is returned as the result.
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__float64_eq
Synopsis
int __float64_eq(float64_t arg0,
float64_t arg1);

Description
__float64_eq compares arg0 to arg1. __float64_eq returns zero if arg0 is different from arg1, and a non-zero
value if arg0 is equal to arg1.
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__float64_eq_0
Synopsis
int __float64_eq_0(float64_t arg);

Description
__float64_eq_0 compares arg to zero. __float64_eq_0 returns a non-zero value if arg is zero, and a zero value if
arg is non-zero.
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__float64_lt
Synopsis
int __float64_lt(float64_t arg0,
float64_t arg1);

Description
__float64_lt compares arg0 to arg1. __float64_lt returns a non-zero value if arg0 is less than arg1, and zero if
arg0 is equal to or greater than arg1.
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__float64_lt_0
Synopsis
int __float64_lt_0(float64_t arg0,
float64_t arg1);

Description
__float64_lt_0 compares arg to zero. __float64_lt_0 returns a non-zero value if arg is less than zero, and zero if
arg0 is equal to or greater than zero.
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__float64_mul
Synopsis
float64_t __float64_mul(float64_t muliplicand,
float64_t multiplier);

Description
__float64_mul multiplies multiplicand by multiplier and returns the product as the result.
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__float64_mul_asgn
Synopsis
float64_t __float64_mul_asgn(float64_t *multiplicand,
float64_t multiplier);

Description
__float64_mul_asgn updates the floating-point value pointed to by multiplicand by multiplying it by
multiplier. The stored product is returned as the result.
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__float64_neg
Synopsis
float64_t __float64_neg(float64_t arg);

Description
__float64_neg negates arg and returns the result.
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__float64_sqr
Synopsis
float64_t __float64_sqr(float64_t arg);

Description
__float64_sqr squares arg by multiplying arg by itself.
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__float64_sub
Synopsis
float64_t __float64_sub(float64_t minuend,
float64_t subtrahend);

Description
__float64_sub subtracts subtrahend from minuend and returns the difference as the result.
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__float64_sub_asgn
Synopsis
float64_t __float64_sub_asgn(float64_t *minuend,
float64_t subtrahend);

Description
__float64_sub_asgn updates the floating-point value pointed to by minuend by subtracting subtrahend from
it. The stored difference is returned as the result.
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__float64_to_float32
Synopsis
float32_t __float64_to_float32(float64_t arg);

Description
__float64_to_float32 converts the 64-bit floating value arg to a 32-bit floating point value and returns the
converted value as the result.
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__int16_asr
Synopsis
int16_t __int16_asr(int16_t arg,
int bits);

Description
__int16_asr shifts arg arithmetically right by bits bit positions, replicating the sign bit, and returns the shifted
result.
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__int16_asr_asgn
Synopsis
int16_t __int16_asr_asgn(int16_t *arg,
int bits);

Description
__int16_asr_asgn updates the 16-bit signed integer pointed to by arg by arithmetically shifting it right by its bit
positions, replicating the sign bit. The shifted value is returned as the result.
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__int16_div
Synopsis
int16_t __int16_div(int16_t dividend,
int16_t divisor);

Description
__int16_div divides dividend by divisor and returns the signed quotient, truncated towards zero, as the result.
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__int16_div_asgn
Synopsis
int16_t __int16_div_asgn(int16_t *dividend,
int16_t divisor);

Description
__int16_div_asgn updates the 16-bit signed integer pointed to by dividend by dividing it by divisor and
truncated towards zero. The quotient is returned as the result.
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__int16_lsl
Synopsis
int16_t __int16_lsl(int16_t arg,
int bits);

Description
__int16_lsl shifts arg left by bits bit positions, shifting zeros in from the left.
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__int16_lsl_asgn
Synopsis
uint16_t __int16_lsl_asgn(uint16_t *arg,
int bits);

Description
__int16_lsl_asgn updates the 16-bit unsigned integer pointed to by arg by shifting it left by bits bit positions,
shifting in zeros in from the right. The shifted value is returned as the result.
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__int16_lsr
Synopsis
uint16_t __int16_lsr(uint16_t arg,
int bits);

Description
__int16_lsr shifts arg logically right by bits bit positions, shifting in zeros fro the left, and returns the shifted
result.
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__int16_lsr_asgn
Synopsis
uint16_t __int16_lsr_asgn(uint16_t *arg,
int bits);

Description
__int16_lsr_asgn updates the 16-bit unsigned integer pointed to by arg by logically shifting it right by bits bit
positions, shifting in zeros from the right. The shifted value is returned as the result.
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__int16_mod
Synopsis
int16_t __int16_mod(int16_t dividend,
int16_t divisor);

Description
__int16_mod divides dividend by divisor and returns the signed remainder after division as the result.

544

CrossWorks for MSP430 Reference Manual

C Library User Guide

__int16_mod_asgn
Synopsis
int16_t __int16_mod_asgn(int16_t *dividend,
int16_t divisor);

Description
__int16_mod_asgn updates the 16-bit signed integer pointed to by dividend by assigning it the remainder
after division of dividend by divisor. The remainder is returned as the result.
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__int16_mul
Synopsis
int16_t __int16_mul(int16_t muliplicand,
int16_t multiplier);

Description
__int16_mul multiplies multiplicand by multiplier and returns the product as the result. As only the lower 16
bits of the product are returned, __int16_mul returns correct products, modulo 16 bits, for both signed and
unsigned arguments.
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__int16_mul_8x8
Synopsis
int16_t __int16_mul_8x8(int8_t muliplicand,
int8_t multiplier);

Description
__int16_mul_8x8 multiplies multiplicand by multiplier and returns the 16-bit signed product as the result.
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__int16_mul_asgn
Synopsis
int16_t __int16_mul_asgn(int16_t *muliplicand,
int16_t multiplier);

Description
__int16_mul_asgn updates the 16-bit signed integer pointed to by multiplicand by multiplying it by multiplier.
The product is returned as the result. As only the lower 16 bits of the product are returned, __int16_mul_asgn
returns correct products, modulo 16 bits, for both signed and unsigned arguments.
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__int16_to_float32
Synopsis
float32_t __int16_to_float32(int16_t arg);

Description
__int16_to_float32 converts the 16-bit signed integer arg to a 32-bit floating value and returns the floating
value as the result. As all 16-bit integers can be represented exactly in 32-bit floating point format, rounding is
never necessary.
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__int16_to_float64
Synopsis
float64_t __int16_to_float64(int16_t arg);

Description
__int16_to_float64 converts the 16-bit signed integer arg to a 64-bit floating value and returns the floating
value as the result. As all 16-bit integers can be represented exactly in 64-bit floating point format, rounding is
never necessary.
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__int32_asr
Synopsis
int32_t __int32_asr(int32_t arg,
int bits);

Description
__int32_asr shifts arg arithmetically right by bits bit positions, replicating the sign bit, and returns the shifted
result.
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__int32_asr_asgn
Synopsis
int32_t __int32_asr_asgn(int32_t *arg,
int bits);

Description
__int32_asr_asgn updates the 32-bit signed integer pointed to by arg by arithmetically shifting it right by its bit
positions, replicating the sign bit. The shifted value is returned as the result.
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__int32_div
Synopsis
int32_t __int32_div(int32_t dividend,
int32_t divisor);

Description
__int32_div divides dividend by divisor and returns the signed quotient, truncated towards zero, as the result.
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__int32_div_asgn
Synopsis
int32_t __int32_div_asgn(int32_t *dividend,
int32_t divisor);

Description
__int32_div_asgn updates the 32-bit signed integer pointed to by dividend by dividing it by divisor and
truncated towards zero. The quotient is returned as the result.
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__int32_lsl
Synopsis
int32_t __int32_lsl(int32_t arg,
int bits);

Description
__int32_lsl shifts arg left by bits bit positions, shifting zeros in from the left.
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__int32_lsl_asgn
Synopsis
uint32_t __int32_lsl_asgn(uint32_t *arg,
int bits);

Description
__int32_lsl_asgn updates the 32-bit unsigned integer pointed to by arg by shifting it left by bits bit positions,
shifting in zeros in from the right. The shifted value is returned as the result.
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__int32_lsr
Synopsis
uint32_t __int32_lsr(uint32_t arg,
int bits);

Description
__int32_lsr shifts arg logically right by bits bit positions, shifting in zeros fro the left, and returns the shifted
result.
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__int32_lsr_asgn
Synopsis
uint32_t __int32_lsr_asgn(uint32_t *arg,
int bits);

Description
__int32_lsr_asgn updates the 32-bit unsigned integer pointed to by arg by logically shifting it right by bits bit
positions, shifting in zeros from the right. The shifted value is returned as the result.
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__int32_mod
Synopsis
int32_t __int32_mod(int32_t dividend,
int32_t divisor);

Description
__int32_mod divides dividend by divisor and returns the signed remainder after division as the result.
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__int32_mod_asgn
Synopsis
int32_t __int32_mod_asgn(int32_t *dividend,
int32_t divisor);

Description
__int32_mod_asgn updates the 32-bit signed integer pointed to by dividend by assigning it the remainder
after division of dividend by divisor. The remainder is returned as the result.
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__int32_mul
Synopsis
int32_t __int32_mul(int32_t muliplicand,
int32_t multiplier);

Description
__int32_mul multiplies multiplicand by multiplier and returns the product as the result. As only the lower 32
bits of the product are returned, __int32_mul returns correct products, modulo 32 bits, for both signed and
unsigned arguments.
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__int32_mul_16x16
Synopsis
int32_t __int32_mul_16x16(int16_t muliplicand,
int16_t multiplier);

Description
this multiplies multiplicand by multiplier and returns the 32-bit signed product as the result.
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__int32_mul_asgn
Synopsis
int32_t __int32_mul_asgn(int32_t *muliplicand,
int32_t multiplier);

Description
__int32_mul_asgn updates the 32-bit signed integer pointed to by multiplicand by multiplying it by multiplier.
The product is returned as the result. As only the lower 32 bits of the product are returned, __int32_mul_asgn
returns correct products, modulo 32 bits, for both signed and unsigned arguments.
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__int32_to_float32
Synopsis
float32_t __int32_to_float32(int32_t arg);

Description
__int32_to_float32 converts the 32-bit signed integer arg to a 32-bit floating value, rounding if required, and
returns the appropriately rounded value as the result.
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__int32_to_float64
Synopsis
float64_t __int32_to_float64(int32_t arg);

Description
__int32_to_float64 converts the 32-bit signed integer arg to a 64-bit floating value and returns the floating
value as the result. As all 32-bit integers can be represented exactly in 64-bit floating point format, rounding is
never necessary.
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__int64_asr
Synopsis
int64_t __int64_asr(int64_t arg,
int bits);

Description
__int64_asr shifts arg arithmetically right by bits bit positions, replicating the sign bit, and returns the shifted
result.
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__int64_asr_asgn
Synopsis
int64_t __int64_asr_asgn(int64_t *arg,
int bits);

Description
__int64_asr_asgn updates the 64-bit signed integer pointed to by arg by arithmetically shifting it right by its bit
positions, replicating the sign bit. The shifted value is returned as the result.
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__int64_div
Synopsis
int64_t __int64_div(int64_t dividend,
int64_t divisor);

Description
__int64_div divides dividend by divisor and returns the signed quotient, truncated towards zero, as the result.
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__int64_div_asgn
Synopsis
int64_t __int64_div_asgn(int64_t *dividend,
int64_t divisor);

Description
__int64_div_asgn updates the 64-bit signed integer pointed to by dividend by dividing it by divisor and
truncated towards zero. The quotient is returned as the result.
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__int64_lsl
Synopsis
int64_t __int64_lsl(int64_t arg,
int bits);

Description
__int64_lsl shifts arg left by bits bit positions, shifting zeros in from the left.
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__int64_lsl_asgn
Synopsis
uint64_t __int64_lsl_asgn(uint64_t *arg,
int bits);

Description
__int64_lsl_asgn updates the 64-bit unsigned integer pointed to by arg by shifting it left by bits bit positions,
shifting in zeros in from the right. The shifted value is returned as the result.
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__int64_lsr
Synopsis
uint64_t __int64_lsr(uint64_t arg,
int bits);

Description
__int64_lsr shifts arg logically right by bits bit positions, shifting in zeros fro the left, and returns the shifted
result.
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__int64_lsr_asgn
Synopsis
uint64_t __int64_lsr_asgn(uint64_t *arg,
int bits);

Description
__int64_lsr_asgn updates the 64-bit unsigned integer pointed to by arg by logically shifting it right by bits bit
positions, shifting in zeros from the right. The shifted value is returned as the result.
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__int64_mod
Synopsis
int64_t __int64_mod(int64_t dividend,
int64_t divisor);

Description
__int64_mod divides dividend by divisor and returns the signed remainder after division as the result.
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__int64_mod_asgn
Synopsis
int64_t __int64_mod_asgn(int64_t *dividend,
int64_t divisor);

Description
__int64_mod_asgn updates the 64-bit signed integer pointed to by dividend by assigning it the remainder
after division of dividend by divisor. The remainder is returned as the result.
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__int64_mul
Synopsis
int64_t __int64_mul(int64_t muliplicand,
int64_t multiplier);

Description
__int64_mul multiplies multiplicand by multiplier and returns the product as the result. As only the lower 64
bits of the product are returned, __int64_mul returns correct products, modulo 64 bits, for both signed and
unsigned arguments.

576

CrossWorks for MSP430 Reference Manual

C Library User Guide

__int64_mul_32x32
Synopsis
int64_t __int64_mul_32x32(int32_t muliplicand,
int32_t multiplier);

Description
this multiplies multiplicand by multiplier and returns the 64-bit signed product as the result.
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__int64_mul_asgn
Synopsis
int64_t __int64_mul_asgn(int64_t *muliplicand,
int64_t multiplier);

Description
__int64_mul_asgn updates the 64-bit signed integer pointed to by multiplicand by multiplying it by multiplier.
The product is returned as the result. As only the lower 64 bits of the product are returned, __int64_mul_asgn
returns correct products, modulo 64 bits, for both signed and unsigned arguments.
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__int64_to_float32
Synopsis
float32_t __int64_to_float32(int64_t arg);

Description
__int64_to_float32 converts the 64-bit signed integer arg to a 32-bit floating value, rounding if required, and
returns the appropriately rounded value as the result.
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__int64_to_float64
Synopsis
float64_t __int64_to_float64(int64_t arg);

Description
__int64_to_float64 converts the 64-bit signed integer arg to a 64-bit floating value, rounding if required, and
returns the appropriately rounded value as the result.
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__uint16_div
Synopsis
uint16_t __uint16_div(uint16_t dividend,
uint16_t divisor);

Description
__uint16_div divides dividend by divisor and returns the unsigned quotient, truncated towards zero, as the
result.
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__uint16_div_asgn
Synopsis
uint16_t __uint16_div_asgn(uint16_t *dividend,
uint16_t divisor);

Description
__uint16_div_asgn updates the 16-bit unsigned integer pointed to by dividend by dividing it by divisor and
truncated towards zero. The quotient is returned as the result.

582

CrossWorks for MSP430 Reference Manual

C Library User Guide

__uint16_mod
Synopsis
uint16_t __uint16_mod(uint16_t dividend,
uint16_t divisor);

Description
__uint16_mod divides dividend by divisor and returns the unsigned remainder after division as the result.
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__uint16_mod_asgn
Synopsis
uint16_t __uint16_mod_asgn(uint16_t *dividend,
uint16_t divisor);

Description
__uint16_mod_asgn updates the 16-bit unsigned integer pointed to by dividend by assigning it the remainder
after division of dividend by divisor. The remainder is returned as the result.
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__uint16_mul_8x8
Synopsis
uint16_t __uint16_mul_8x8(uint8_t muliplicand,
uint8_t multiplier);

Description
__uint16_mul_8x8 multiplies multiplicand by multiplier and returns the 16-bit unsigned product as the result.
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__uint16_to_float32
Synopsis
float32_t __uint16_to_float32(uint16_t arg);

Description
__uint16_to_float32 converts the 16-bit unsigned integer arg to a 32-bit floating value and returns the floating
value as the result. As all 16-bit unsigned integers can be represented exactly in 32-bit floating point format,
rounding is never necessary.
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__uint16_to_float64
Synopsis
float64_t __uint16_to_float64(uint16_t arg);

Description
__uint16_to_float64 converts the 16-bit unsigned integer arg to a 64-bit floating value and returns the floating
value as the result. As all 16-bit unsigned integers can be represented exactly in 64-bit floating point format,
rounding is never necessary.
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__uint32_div
Synopsis
uint32_t __uint32_div(uint32_t dividend,
uint32_t divisor);

Description
__uint32_div divides dividend by divisor and returns the unsigned quotient, truncated towards zero, as the
result.
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__uint32_div_asgn
Synopsis
uint32_t __uint32_div_asgn(uint32_t *dividend,
uint32_t divisor);

Description
__uint32_div_asgn updates the 32-bit unsigned integer pointed to by dividend by dividing it by divisor and
truncated towards zero. The quotient is returned as the result.
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__uint32_mod
Synopsis
uint32_t __uint32_mod(uint32_t dividend,
uint32_t divisor);

Description
__uint32_mod divides dividend by divisor and returns the unsigned remainder after division as the result.
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__uint32_mod_asgn
Synopsis
uint32_t __uint32_mod_asgn(uint32_t *dividend,
uint32_t divisor);

Description
__uint32_mod_asgn updates the 32-bit unsigned integer pointed to by dividend by assigning it the remainder
after division of dividend by divisor. The remainder is returned as the result.
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__uint32_mul_16x16
Synopsis
uint32_t __uint32_mul_16x16(uint16_t muliplicand,
uint16_t multiplier);

Description
__uint32_mul_16x16 multiplies multiplicand by multiplier and returns the 32-bit unsigned product as the
result.
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__uint32_to_float32
Synopsis
float32_t __uint32_to_float32(uint32_t arg);

Description
__uint32_to_float32 converts the 32-bit unsigned integer arg to a 32-bit floating value, rounding if required,
and returns the appropriately rounded value as the result.
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__uint32_to_float64
Synopsis
float64_t __uint32_to_float64(uint32_t arg);

Description
__uint32_to_float64 converts the 32-bit unsigned integer arg to a 64-bit floating value and returns the floating
value as the result. As all 32-bit unsigned integers can be represented exactly in 64-bit floating point format,
rounding is never necessary.
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__uint64_div
Synopsis
uint64_t __uint64_div(uint64_t dividend,
uint64_t divisor);

Description
__uint64_div divides dividend by divisor and returns the unsigned quotient, truncated towards zero, as the
result.
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__uint64_div_asgn
Synopsis
uint64_t __uint64_div_asgn(uint64_t *dividend,
uint64_t divisor);

Description
__uint64_div_asgn updates the 64-bit unsigned integer pointed to by dividend by dividing it by divisor and
truncated towards zero. The quotient is returned as the result.

596

CrossWorks for MSP430 Reference Manual

C Library User Guide

__uint64_mod
Synopsis
uint64_t __uint64_mod(uint64_t dividend,
uint64_t divisor);

Description
__uint64_mod divides dividend by divisor and returns the unsigned remainder after division as the result.
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__uint64_mod_asgn
Synopsis
uint64_t __uint64_mod_asgn(uint64_t *dividend,
uint64_t divisor);

Description
__uint64_mod_asgn updates the 64-bit unsigned integer pointed to by dividend by assigning it the remainder
after division of dividend by divisor. The remainder is returned as the result.
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__uint64_mul_32x32
Synopsis
uint64_t __uint64_mul_32x32(uint32_t muliplicand,
uint32_t multiplier);

Description
__uint64_mul_32x32 multiplies multiplicand by multiplier and returns the 64-bit unsigned product as the
result.
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__uint64_to_float32
Synopsis
float32_t __uint64_to_float32(uint64_t arg);

Description
__uint64_to_float32 converts the 64-bit unsigned integer arg to a 32-bit floating value, rounding if required,
and returns the appropriately rounded value as the result.
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__uint64_to_float64
Synopsis
float64_t __uint64_to_float64(uint64_t arg);

Description
__uint64_to_float64 converts the 64-bit unsigned integer arg to a 64-bit floating value, rounding if required,
and returns the appropriately rounded value as the result.
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<ctype.h>
API Summary
Classification functions
isalnum

Is character alphanumeric?

isalpha

Is character alphabetic?

isblank

Is character a space or horizontal tab?

iscntrl

Is character a control?

isdigit

Is character a decimal digit?

isgraph

Is character any printing character except space?

islower

Is character a lowercase letter?

isprint

Is character printable?

ispunct

Is character a punctuation mark?

isspace

Is character a whitespace character?

isupper

Is character an uppercase letter?

isxdigit

Is character a hexadecimal digit?

Conversion functions
tolower

Convert uppercase character to lowercase

toupper

Convert lowercase character to uppercase

Classification functions (extended)
isalnum_l

Is character alphanumeric?

isalpha_l

Is character alphabetic?

isblank_l

Is character a space or horizontal tab?

iscntrl_l

Is character a control character?

isdigit_l

Is character a decimal digit?

isgraph_l

Is character any printing character except space?

islower_l

Is character a lowercase letter?

isprint_l

Is character printable?

ispunct_l

Is character a punctuation mark?

isspace_l

Is character a whitespace character?

isupper_l

Is character an uppercase letter?

isxdigit_l

Is character a hexadecimal digit?

Conversion functions (extended)
tolower_l

Convert uppercase character to lowercase
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Convert lowercase character to uppercase
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isalnum
Synopsis
int isalnum(int c);

Description
isalnum returns nonzero (true) if and only if the value of the argument c is an alphabetic or numeric character.
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isalnum_l
Synopsis
int isalnum_l(int c,
locale_t loc);

Description
isalnum_l returns nonzero (true) if and only if the value of the argument c is a alphabetic or numeric character in
locale loc.
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isalpha
Synopsis
int isalpha(int c);

Description
isalpha returns true if the character c is alphabetic. That is, any character for which isupper or islower returns
true is considered alphabetic in addition to any of the locale-specific set of alphabetic characters for which none
of iscntrl, isdigit, ispunct, or isspace is true.
In the C locale, isalpha returns nonzero (true) if and only if isupper or islower return true for value of the
argument c.
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isalpha_l
Synopsis
int isalpha_l(int c,
locale_t loc);

Description
isalpha_l returns nonzero (true) if and only if isupper or islower return true for value of the argument c in locale
loc.
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isblank
Synopsis
int isblank(int c);

Description
isblank returns nonzero (true) if and only if the value of the argument c is either a space character (' ') or the
horizontal tab character ('\\t').

608

CrossWorks for MSP430 Reference Manual

C Library User Guide

isblank_l
Synopsis
int isblank_l(int c,
locale_t loc);

Description
isblank_l returns nonzero (true) if and only if the value of the argument c is either a space character (' ') or the
horizontal tab character ('\\t') in locale loc.
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iscntrl
Synopsis
int iscntrl(int c);

Description
iscntrl returns nonzero (true) if and only if the value of the argument c is a control character. Control characters
have values 0 through 31 and the single value 127.
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iscntrl_l
Synopsis
int iscntrl_l(int c,
locale_t loc);

Description
iscntrl_l returns nonzero (true) if and only if the value of the argument c is a control character in locale loc.
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isdigit
Synopsis
int isdigit(int c);

Description
isdigit returns nonzero (true) if and only if the value of the argument c is a digit.
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isdigit_l
Synopsis
int isdigit_l(int c,
locale_t loc);

Description
isdigit_l returns nonzero (true) if and only if the value of the argument c is a decimal digit in locale loc.
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isgraph
Synopsis
int isgraph(int c);

Description
isgraph returns nonzero (true) if and only if the value of the argument c is any printing character except space ('
').
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isgraph_l
Synopsis
int isgraph_l(int c,
locale_t loc);

Description
isgraph_l returns nonzero (true) if and only if the value of the argument c is any printing character except space
(' ') in locale loc.
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islower
Synopsis
int islower(int c);

Description
islower returns nonzero (true) if and only if the value of the argument c is an lowercase letter.
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islower_l
Synopsis
int islower_l(int c,
locale_t loc);

Description
islower_l returns nonzero (true) if and only if the value of the argument c is an lowercase letter in locale loc.
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isprint
Synopsis
int isprint(int c);

Description
isprint returns nonzero (true) if and only if the value of the argument c is any printing character including space
(' ').
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isprint_l
Synopsis
int isprint_l(int c,
locale_t loc);

Description
isprint_l returns nonzero (true) if and only if the value of the argument c is any printing character including
space (' ') in locale loc.
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ispunct
Synopsis
int ispunct(int c);

Description
ispunct returns nonzero (true) for every printing character for which neither isspace nor isalnum is true.
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ispunct_l
Synopsis
int ispunct_l(int c,
locale_t loc);

Description
ispunct_l returns nonzero (true) for every printing character for which neither isspace nor isalnum is true in in
locale loc.
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isspace
Synopsis
int isspace(int c);

Description
isspace returns nonzero (true) if and only if the value of the argument c is a standard white-space character.
The standard white-space characters are space (' '), form feed ('\\f'), new-line ('\\n'), carriage return ('\
\r'), horizontal tab ('\\t'), and vertical tab ('\v').
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isspace_l
Synopsis
int isspace_l(int c,
locale_t loc);

Description
isspace_l returns nonzero (true) if and only if the value of the argument c is a standard white-space character in
in locale loc..
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isupper
Synopsis
int isupper(int c);

Description
isupper returns nonzero (true) if and only if the value of the argument c is an uppercase letter.
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isupper_l
Synopsis
int isupper_l(int c,
locale_t loc);

Description
isupper_l returns nonzero (true) if and only if the value of the argument c is an uppercase letter in locale loc.
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isxdigit
Synopsis
int isxdigit(int c);

Description
isxdigit returns nonzero (true) if and only if the value of the argument c is a hexadecimal digit.
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isxdigit_l
Synopsis
int isxdigit_l(int c,
locale_t loc);

Description
isxdigit_l returns nonzero (true) if and only if the value of the argument c is a hexadecimal digit in locale loc.
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tolower
Synopsis
int tolower(int c);

Description
tolower converts an uppercase letter to a corresponding lowercase letter. If the argument c is a character for
which isupper is true and there are one or more corresponding characters, as specified by the current locale, for
which islower is true, the tolower function returns one of the corresponding characters (always the same one for
any given locale); otherwise, the argument is returned unchanged.
Note that even though isupper can return true for some characters, tolower may return that uppercase
character unchanged as there are no corresponding lowercase characters in the locale.
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tolower_l
Synopsis
int tolower_l(int c,
locale_t loc);

Description
tolower_l converts an uppercase letter to a corresponding lowercase letter in locale loc. If the argument c is a
character for which isupper is true in locale loc, tolower_l returns the corresponding lowercase letter; otherwise,
the argument is returned unchanged.
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toupper
Synopsis
int toupper(int c);

Description
toupper converts a lowercase letter to a corresponding uppercase letter. If the argument is a character for
which islower is true and there are one or more corresponding characters, as specified by the current locale, for
which isupper is true, toupper returns one of the corresponding characters (always the same one for any given
locale); otherwise, the argument is returned unchanged. Note that even though islower can return true for some
characters, toupper may return that lowercase character unchanged as there are no corresponding uppercase
characters in the locale.
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toupper_l
Synopsis
int toupper_l(int c,
locale_t loc);

Description
toupper_l converts a lowercase letter to a corresponding uppercase letter in locale loc. If the argument c
is a character for which islower is true in locale loc, toupper_l returns the corresponding uppercase letter;
otherwise, the argument is returned unchanged.
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<debugio.h>
API Summary
File Functions
debug_clearerr

Clear error indicator

debug_fclose

Closes an open stream

debug_feof

Check end of file condition

debug_ferror

Check error indicator

debug_fflush

Flushes buffered output

debug_fgetc

Read a character from a stream

debug_fgetpos

Return file position

debug_fgets

Read a string

debug_filesize

Return the size of a file

debug_fopen

Opens a file on the host PC

debug_fprintf

Formatted write

debug_fprintf_c

Formatted write

debug_fputc

Write a character

debug_fputs

Write a string

debug_fread

Read data

debug_freopen

Reopens a file on the host PC

debug_fscanf

Formatted read

debug_fscanf_c

Formatted read

debug_fseek

Set file position

debug_fsetpos

Teturn file position

debug_ftell

Return file position

debug_fwrite

Write data

debug_remove

Deletes a file on the host PC

debug_rename

Renames a file on the host PC

debug_rewind

Set file position to the beginning

debug_tmpfile

Open a temporary file

debug_tmpnam

Generate temporary filename

debug_ungetc

Push a character

debug_vfprintf

Formatted write

debug_vfscanf

Formatted read

632

CrossWorks for MSP430 Reference Manual

C Library User Guide

Debug Terminal Output Functions
debug_printf

Formatted write

debug_printf_c

Formatted write

debug_putchar

Write a character

debug_puts

Write a string

debug_vprintf

Formatted write

Debug Terminal Input Functions
debug_getch

Blocking character read

debug_getchar

Line-buffered character read

debug_getd

Line-buffered double read

debug_getf

Line-buffered float read

debug_geti

Line-buffered integer read

debug_getl

Line-buffered long read

debug_getll

Line-buffered long long read

debug_gets

String read

debug_getu

Line-buffered unsigned integer

debug_getul

Line-buffered unsigned long read

debug_getull

Line-buffered unsigned long long read

debug_kbhit

Polled character read

debug_scanf

Formatted read

debug_scanf_c

Formatted read

debug_vscanf

Formatted read

Debugger Functions
debug_abort

Stop debugging

debug_break

Stop target

debug_enabled

Test if debug input/output is enabled

debug_evaluate

Evaluate debug expression

debug_exit

Stop debugging

debug_getargs

Get arguments

debug_loadsymbols

Load debugging symbols

debug_runtime_error

Stop and report error

debug_unloadsymbols

Unload debugging symbols

Misc Functions
debug_getenv

Get environment variable value

debug_perror

Display error
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debug_system

Execute command

debug_time

get time
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debug_abort
Synopsis
void debug_abort(void);

Description
debug_abort causes the debugger to exit and a failure result is returned to the user.
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debug_break
Synopsis
void debug_break(void);

Description
debug_break causes the debugger to stop the target and position the cursor at the line that called
debug_break.
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debug_clearerr
Synopsis
void debug_clearerr(DEBUG_FILE *stream);

Description
debug_clearerr clears any error indicator or end of file condition for the stream.
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debug_enabled
Synopsis
int debug_enabled(void);

Description
debug_enabled returns non-zero if the debugger is connected - you can use this to test if a debug input/output
functions will work. For this to work correctly, the Startup Completion Breakpoint project property needs to be
set to a point in the program where the startup code has finished initialising, this is typically main.
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debug_evaluate
Synopsis
void debug_evaluate(const char *expression);

Description
debug_evaluate instructs the debugger to evaluate the expression and display it in the debug terminal.
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debug_exit
Synopsis
void debug_exit(int result);

Description
debug_exit causes the debugger to exit and result is returned to the user.
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debug_fclose
Synopsis
int debug_fclose(DEBUG_FILE *stream);

Description
debug_fclose flushes any buffered output of the stream and then closes the stream.
debug_fclose returns 0 on success or -1 if there was an error.
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debug_feof
Synopsis
int debug_feof(DEBUG_FILE *stream);

Description
debug_feof returns non-zero if the end of file condition is set for the stream.
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debug_ferror
Synopsis
int debug_ferror(DEBUG_FILE *stream);

Description
debug_ferror returns non-zero if the error indicator is set for the stream.
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debug_fflush
Synopsis
int debug_fflush(DEBUG_FILE *stream);

Description
debug_fflush flushes any buffered output of the stream.
debug_fflush returns 0 on success or -1 if there was an error.
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debug_fgetc
Synopsis
int debug_fgetc(DEBUG_FILE *stream);

Description
debug_fgetc reads and returns the next character on stream or -1 if no character is available.
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debug_fgetpos
Synopsis
int debug_fgetpos(DEBUG_FILE *stream,
long *pos);

Description
debug_fgetpos is equivalent to debug_fseek .
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debug_fgets
Synopsis
char *debug_fgets(char *s,
int n,
DEBUG_FILE *stream);

Description
debug_fgets reads at most n-1 characters or the characters up to (and including) a newline from the input
stream into the array pointed to by s. A null character is written to the array after the input characters.
debug_fgets returns s on success, or 0 on error or end of file.
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debug_filesize
Synopsis
int debug_filesize(DEBUG_FILE *stream);

Description
debug_filesize returns the size of the file associated with the stream in bytes.
debug_filesize returns -1 on error.
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debug_fopen
Synopsis
DEBUG_FILE *debug_fopen(const char *filename,
const char *mode);

Description
debug_fopen opens the filename on the host PC and returns a stream or 0 if the open fails. The filename is a
host PC filename which is opened relative to the debugger working directory. The mode is a string containing
one of:
r open file for reading.
w create file for writing.
a open or create file for writing and position at the end of the file.
r+ open file for reading and writing.
w+ create file for reading and writing.
a+ open or create text file for reading and writing and position at the end of the file.
followed by one of:
t for a text file.
b for a binary file.
debug_fopen returns a stream that can be used to access the file or 0 if the open fails.
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debug_fprintf
Synopsis
int debug_fprintf(DEBUG_FILE *stream,
const char *format,
...);

Description
debug_fprintf writes to stream, under control of the string pointed to by format that specifies how subsequent
arguments are converted for output. The format string is a standard C printf format string. The actual formatting
is performed on the host by the debugger and therefore debug_fprintf consumes only a very small amount of
code and data space, only the overhead to call the function.
If there are insufficient arguments for the format, the behavior is undefined. If the format is exhausted while
arguments remain, the excess arguments are evaluated but are otherwise ignored.
debug_fprintf returns the number of characters transmitted, or a negative value if an output or encoding error
occurred.
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debug_fprintf_c
Synopsis
int debug_fprintf_c(DEBUG_FILE *stream,
__code const char *format,
...);

Description
debug_fprintf_c is equivalent to debug_fprintf with the format string in code memory.
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debug_fputc
Synopsis
int debug_fputc(int c,
DEBUG_FILE *stream);

Description
debug_fputc writes the character c to the output stream.
debug_fputc returns the character written or -1 if an error occurred.
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debug_fputs
Synopsis
int debug_fputs(const char *s,
DEBUG_FILE *stream);

Description
debug_fputs writes the string pointed to by s to the output stream and appends a new-line character. The
terminating null character is not written.
debug_fputs returns -1 if a write error occurs; otherwise it returns a nonnegative value.
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debug_fread
Synopsis
int debug_fread(void *ptr,
int size,
int nobj,
DEBUG_FILE *stream);

Description
debug_fread reads from the input stream into the array ptr at most nobj objects of size size.
debug_fread returns the number of objects read. If this number is different from nobj then debug_feof and
debug_ferror can be used to determine status.
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debug_freopen
Synopsis
DEBUG_FILE *debug_freopen(const char *filename,
const char *mode,
DEBUG_FILE *stream);

Description
debug_freopen is the same as debug_open except the file associated with the stream is closed and the opened
file is then associated with the stream.
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debug_fscanf
Synopsis
int debug_fscanf(DEBUG_FILE *stream,
const char *format,
...);

Description
debug_fscanf reads from the input stream, under control of the string pointed to by format, that specifies how
subsequent arguments are converted for input. The format string is a standard C scanf format string. The actual
formatting is performed on the host by the debugger and therefore debug_fscanf consumes only a very small
amount of code and data space, only the overhead to call the function.
If there are insufficient arguments for the format, the behavior is undefined. If the format is exhausted while
arguments remain, the excess arguments are evaluated but are otherwise ignored.
debug_fscanf returns number of characters read, or a negative value if an output or encoding error occurred.
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debug_fscanf_c
Synopsis
int debug_fscanf_c(DEBUG_FILE *stream,
__code const char *format,
...);

Description
debug_fscanf_c is equivalent to debug_fscanf with the format string in code memory.
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debug_fseek
Synopsis
int debug_fseek(DEBUG_FILE *stream,
long offset,
int origin);

Description
debug_fseek sets the file position for the stream. A subsequent read or write will access data at that position.
The origin can be one of:
0 sets the position to offset bytes from the beginning of the file.
1 sets the position to offset bytes relative to the current position.
2 sets the position to offset bytes from the end of the file.
Note that for text files offset must be zero. debug_fseek returns zero on success, non-zero on error.
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debug_fsetpos
Synopsis
int debug_fsetpos(DEBUG_FILE *stream,
const long *pos);

Description
debug_fsetpos is equivalent to debug_fseek with 0 as the origin.
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debug_ftell
Synopsis
long debug_ftell(DEBUG_FILE *stream);

Description
debug_ftell returns the current file position of the stream.
debug_ftell returns -1 on error.
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debug_fwrite
Synopsis
int debug_fwrite(const void *ptr,
int size,
int nobj,
DEBUG_FILE *stream);

Description
debug_fwrite write to the output stream from the array ptr at most nobj objects of size size.
debug_fwrite returns the number of objects written. If this number is different from nobj then debug_feof and
debug_ferror can be used to determine status.
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debug_getargs
Synopsis
int debug_getargs(unsigned bufsize,
unsigned char *buf);

Description
debug_getargs stores the debugger command line arguments into the memory pointed at by buf up to a
maximum of bufsize bytes. The command line is stored as a C argc array of null terminated string and the
number of entries is returned as the result.
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debug_getch
Synopsis
int debug_getch(void);

Description
debug_getch reads one character from the Debug Terminal. This function will block until a character is
available.
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debug_getchar
Synopsis
int debug_getchar(void);

Description
debug_getchar reads one character from the Debug Terminal. This function uses line input and will therefore
block until characters are available and ENTER has been pressed.
debug_getchar returns the character that has been read.
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debug_getd
Synopsis
int debug_getd(double *);

Description
debug_getd reads a double from the Debug Terminal. The number is written to the double object pointed to
by d.
debug_getd returns zero on success or -1 on error.
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debug_getenv
Synopsis
char *debug_getenv(char *name);

Description
debug_getenv returns the value of the environment variable name or 0 if the environment variable cannot be
found.
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debug_getf
Synopsis
int debug_getf(float *f);

Description
debug_getf reads an float from the Debug Terminal. The number is written to the float object pointed to by f.
debug_getf returns zero on success or -1 on error.
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debug_geti
Synopsis
int debug_geti(int *i);

Description
debug_geti reads an integer from the Debug Terminal. If the number starts with 0x it is interpreted as a
hexadecimal number, if it starts with 0 it is interpreted as an octal number, if it starts with 0b it is interpreted as
a binary number, otherwise it is interpreted as a decimal number. The number is written to the integer object
pointed to by i.
debug_geti returns zero on success or -1 on error.

668

CrossWorks for MSP430 Reference Manual

C Library User Guide

debug_getl
Synopsis
int debug_getl(long *l);

Description
debug_getl reads a long from the Debug Terminal. If the number starts with 0x it is interpreted as a
hexadecimal number, if it starts with 0 it is interpreted as an octal number, if it starts with it is interpreted as
a binary number, otherwise it is interpreted as a decimal number. The number is written to the long object
pointed to by l.
debug_getl returns zero on success or -1 on error.
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debug_getll
Synopsis
int debug_getll(long long *ll);

Description
debug_getll reads a long long from the Debug Terminal. If the number starts with 0x it is interpreted as a
hexadecimal number, if it starts with 0 it is interpreted as an octal number, if it starts with 0b it is interpreted as
a binary number, otherwise it is interpreted as a decimal number. The number is written to the long long object
pointed to by ll.
debug_getll returns zero on success or -1 on error.
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debug_gets
Synopsis
char *debug_gets(char *s);

Description
debug_gets reads a string from the Debug Terminal in memory pointed at by s. This function will block until
ENTER has been pressed.
debug_gets returns the value of s.
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debug_getu
Synopsis
int debug_getu(unsigned *u);

Description
debug_getu reads an unsigned integer from the Debug Terminal. If the number starts with 0x it is interpreted
as a hexadecimal number, if it starts with 0 it is interpreted as an octal number, if it starts with 0b it is interpreted
as a binary number, otherwise it is interpreted as a decimal number. The number is written to the unsigned
integer object pointed to by u.
debug_getu returns zero on success or -1 on error.
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debug_getul
Synopsis
int debug_getul(unsigned long *ul);

Description
debug_getul reads an unsigned long from the Debug Terminal. If the number starts with 0x it is interpreted as
a hexadecimal number, if it starts with 0 it is interpreted as an octal number, if it starts with 0b it is interpreted
as a binary number, otherwise it is interpreted as a decimal number. The number is written to the long object
pointed to by ul.
debug_getul returns zero on success or -1 on error.
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debug_getull
Synopsis
int debug_getull(unsigned long long *ull);

Description
debug_getull reads an unsigned long long from the Debug Terminal. If the number starts with 0x it is
interpreted as a hexadecimal number, if it starts with 0 it is interpreted as an octal number, if it starts with 0b it
is interpreted as a binary number, otherwise it is interpreted as a decimal number. The number is written to the
long long object pointed to by ull.
debug_getull returns zero on success or -1 on error.
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debug_kbhit
Synopsis
int debug_kbhit(void);

Description
debug_kbhit polls the Debug Terminal for a character and returns a non-zero value if a character is available or 0
if not.
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debug_loadsymbols
Synopsis
void debug_loadsymbols(const char *filename,
const void *address,
const char *breaksymbol);

Description
debug_loadsymbols instructs the debugger to load the debugging symbols in the file denoted by filename.
The filename is a (macro expanded) host PC filename which is relative to the debugger working directory. The
address is the load address which is required for debugging position independent executables, supply NULL for
regular executables. The breaksymbol is the name of a symbol in the filename to set a temporary breakpoint on
or NULL.
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debug_perror
Synopsis
void debug_perror(const char *s);

Description
debug_perror displays the optional string s on the Debug Terminal together with a string corresponding to the
errno value of the last Debug IO operation.
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debug_printf
Synopsis
int debug_printf(const char *format,
...);

Description
debug_printf writes to the Debug Terminal, under control of the string pointed to by format that specifies
how subsequent arguments are converted for output. The format string is a standard C printf format string. The
actual formatting is performed on the host by the debugger and therefore debug_printf consumes only a very
small amount of code and data space, only the overhead to call the function.
If there are insufficient arguments for the format, the behavior is undefined. If the format is exhausted while
arguments remain, the excess arguments are evaluated but are otherwise ignored.
debug_printf returns the number of characters transmitted, or a negative value if an output or encoding error
occurred.
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debug_printf_c
Synopsis
int debug_printf_c(__code const char *format,
...);

Description
debug_printf_c is equivalent to debug_printf with the format string in code memory.
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debug_putchar
Synopsis
int debug_putchar(int c);

Description
debug_putchar write the character c to the Debug Terminal.
debug_putchar returns the character written or -1 if a write error occurs.
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debug_puts
Synopsis
int debug_puts(const char *);

Description
debug_puts writes the string s to the Debug Terminal followed by a new-line character.
debug_puts returns -1 if a write error occurs, otherwise it returns a nonnegative value.
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debug_remove
Synopsis
int debug_remove(const char *filename);

Description
debug_remove removes the filename denoted by filename and returns 0 on success or -1 on error. The
filename is a host PC filename which is relative to the debugger working directory.
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debug_rename
Synopsis
int debug_rename(const char *oldfilename,
const char *newfilename);

Description
debug_rename renames the file denoted by oldpath to newpath and returns zero on success or non-zero on
error. The oldpath and newpath are host PC filenames which are relative to the debugger working directory.
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debug_rewind
Synopsis
void debug_rewind(DEBUG_FILE *stream);

Description
debug_rewind sets the current file position of the stream to the beginning of the file and clears any error and
end of file conditions.
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debug_runtime_error
Synopsis
void debug_runtime_error(const char *error);

Description
debug_runtime_error causes the debugger to stop the target, position the cursor at the line that called
debug_runtime_error, and display the null-terminated string pointed to by error.
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debug_scanf
Synopsis
int debug_scanf(const char *format,
...);

Description
debug_scanf reads from the Debug Terminal, under control of the string pointed to by format that specifies
how subsequent arguments are converted for input. The format string is a standard C scanf format string. The
actual formatting is performed on the host by the debugger and therefore debug_scanf consumes only a very
small amount of code and data space, only the overhead to call the function.
If there are insufficient arguments for the format, the behavior is undefined. If the format is exhausted while
arguments remain, the excess arguments are evaluated but are otherwise ignored.
debug_scanf returns number of characters read, or a negative value if an output or encoding error occurred.
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debug_scanf_c
Synopsis
int debug_scanf_c(__code const char *format,
...);

Description
debug_scanf_c is equivalent to debug_scanf with the format string in code memory.
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debug_system
Synopsis
int debug_system(char *command);

Description
debug_system executes the command with the host command line interpreter and returns the commands exit
status.
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debug_time
Synopsis
long debug_time(long *ptr);

Description
debug_time returns the number of seconds elapsed since midnight (00:00:00), January 1, 1970, coordinated
universal time (UTC), according to the system clock of the host computer. The return value is stored in *ptr if ptr
is not NULL.
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debug_tmpfile
Synopsis
DEBUG_FILE *debug_tmpfile(void);

Description
debug_tmpfile creates a temporary file on the host PC which is deleted when the stream is closed.
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debug_tmpnam
Synopsis
char *debug_tmpnam(char *str);

Description
debug_tmpnam returns a unique temporary filename. If str is NULL then a static buffer is used to store the
filename, otherwise the filename is stored in str. On success a pointer to the string is returned, on failure 0 is
returned.
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debug_ungetc
Synopsis
int debug_ungetc(int c,
DEBUG_FILE *stream);

Description
debug_ungetc pushes the character c onto the input stream. If successful c is returned, otherwise -1 is returned.
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debug_unloadsymbols
Synopsis
void debug_unloadsymbols(const char *filename);

Description
debug_unloadsymbols instructs the debugger to unload the debugging symbols (previously loaded by a call to
debug_loadsymbols) in the file denoted by filename. The filename is a host PC filename which is relative to the
debugger working directory.
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debug_vfprintf
Synopsis
int debug_vfprintf(DEBUG_FILE *stream,
const char *format,
__va_list);

Description
debug_vfprintf is equivalent to debug_fprintf with arguments passed using stdarg.h rather than a variable
number of arguments.
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debug_vfscanf
Synopsis
int debug_vfscanf(DEBUG_FILE *stream,
const char *format,
__va_list);

Description
debug_vfscanf is equivalent to debug_fscanf with arguments passed using stdarg.h rather than a variable
number of arguments.
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debug_vprintf
Synopsis
int debug_vprintf(const char *format,
__va_list);

Description
debug_vprintf is equivalent to debug_printf with arguments passed using stdarg.h rather than a variable
number of arguments.
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debug_vscanf
Synopsis
int debug_vscanf(const char *format,
__va_list);

Description
debug_vscanf is equivalent to debug_scanf with arguments passed using stdarg.h rather than a variable
number of arguments.
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<errno.h>
API Summary
Error numbers
EDOM

Domain error

EILSEQ

Illegal byte sequence

EINVAL

Invalid argument

ENOMEM

No memory available

ERANGE

Result too large or too small

Macros
errno

Last-set error condition
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EDOM
Synopsis
#define EDOM

...

Description
EDOM - an input argument is outside the defined domain of a mathematical function.
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EILSEQ
Synopsis
#define EILSEQ

...

Description
EILSEQ - A wide-character code has been detected that does not correspond to a valid character, or a byte
sequence does not form a valid wide-character code.
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EINVAL
Synopsis
#define EINVAL

0x06

Description
EINVAL - An argument was invalid, or a combination of arguments was invalid.

701

CrossWorks for MSP430 Reference Manual

C Library User Guide

ENOMEM
Synopsis
#define ENOMEM

0x05

Description
ENOMEM - no memory can be allocated by a function in the library. Note that malloc, calloc, and realloc do not
set errno to ENOMEM on failure, but other library routines (such as duplocale) may set errno to ENOMEM when
memory allocation fails.
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ERANGE
Synopsis
#define ERANGE

...

Description
ERANGE - the result of the function is too large (overflow) or too small (underflow) to be represented in the
available space.
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errno
Synopsis
int errno;

Description
errno is treated as an writable l-value, but the implementation of how the l-value is read an written is hidden
from the user.
The value of errno is zero at program startup, but is never set to zero by any library function. The value of errno
may be set to a nonzero value by a library function, and this effect is documented in each function that does so.

Note
The ISO standard does not specify whether errno is a macro or an identifier declared with external linkage.
Portable programs must not make assumptions about the implementation of errno.
In this implementation, errno expands to a function call to __errno (MSP430, AVR, MAXQ) or
__aeabi_errno_addr (ARM) that returns a pointer to a volatile int. This function can be implemented by the
application to provide a thread-specific errno.

704

CrossWorks for MSP430 Reference Manual

C Library User Guide

<float.h>
API Summary
Double exponent minimum and maximum values
DBL_MAX_10_EXP

The maximum exponent value in base 10 of a double

DBL_MAX_EXP

The maximum exponent value of a double

DBL_MIN_10_EXP

The minimal exponent value in base 10 of a double

DBL_MIN_EXP

The minimal exponent value of a double

Implementation
DBL_DIG

The number of digits of precision of a double

DBL_MANT_DIG

The number of digits in a double

DECIMAL_DIG

The number of decimal digits that can be rounded
without change

FLT_DIG

The number of digits of precision of a float

FLT_EVAL_METHOD

The evaluation format

FLT_MANT_DIG

The number of digits in a float

FLT_RADIX

The radix of the exponent representation

FLT_ROUNDS

The rounding mode

Float exponent minimum and maximum values
FLT_MAX_10_EXP

The maximum exponent value in base 10 of a float

FLT_MAX_EXP

The maximum exponent value of a float

FLT_MIN_10_EXP

The minimal exponent value in base 10 of a float

FLT_MIN_EXP

The minimal exponent value of a float

Double minimum and maximum values
DBL_EPSILON

The difference between 1 and the least value greater
than 1 of a double

DBL_MAX

The maximum value of a double

DBL_MIN

The minimal value of a double

Float minimum and maximum values
FLT_EPSILON

The difference between 1 and the least value greater
than 1 of a float

FLT_MAX

The maximum value of a float

FLT_MIN

The minimal value of a float
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DBL_DIG
Synopsis
#define DBL_DIG

15

Description
DBL_DIG specifies The number of digits of precision of a double.
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DBL_EPSILON
Synopsis
#define DBL_EPSILON 2.2204460492503131E-16

Description
DBL_EPSILON the minimum positive number such that 1.0 + DBL_EPSILON != 1.0.
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DBL_MANT_DIG
Synopsis
#define DBL_MANT_DIG

53

Description
DBL_MANT_DIG specifies the number of base FLT_RADIX digits in the mantissa part of a double.
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DBL_MAX
Synopsis
#define DBL_MAX

1.7976931348623157E+308

Description
DBL_MAX is the maximum value of a double.
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DBL_MAX_10_EXP
Synopsis
#define DBL_MAX_10_EXP

+308

Description
DBL_MAX_10_EXP is the maximum value in base 10 of the exponent part of a double.
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DBL_MAX_EXP
Synopsis
#define DBL_MAX_EXP

+1024

Description
DBL_MAX_EXP is the maximum value of base FLT_RADIX in the exponent part of a double.
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DBL_MIN
Synopsis
#define DBL_MIN

2.2250738585072014E-308

Description
DBL_MIN is the minimum value of a double.
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DBL_MIN_10_EXP
Synopsis
#define DBL_MIN_10_EXP

-307

Description
DBL_MIN_10_EXP is the minimum value in base 10 of the exponent part of a double.
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DBL_MIN_EXP
Synopsis
#define DBL_MIN_EXP

-1021

Description
DBL_MIN_EXP is the minimum value of base FLT_RADIX in the exponent part of a double.
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DECIMAL_DIG
Synopsis
#define DECIMAL_DIG

17

Description
DECIMAL_DIG specifies the number of decimal digits that can be rounded to a floating-point number without
change to the value.
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FLT_DIG
Synopsis
#define FLT_DIG

6

Description
FLT_DIG specifies The number of digits of precision of a float.
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FLT_EPSILON
Synopsis
#define FLT_EPSILON 1.19209290E-07F // decimal constant

Description
FLT_EPSILON the minimum positive number such that 1.0 + FLT_EPSILON != 1.0.
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FLT_EVAL_METHOD
Synopsis
#define FLT_EVAL_METHOD 0

Description
FLT_EVAL_METHOD specifies that all operations and constants are evaluated to the range and precision of the
type.
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FLT_MANT_DIG
Synopsis
#define FLT_MANT_DIG

24

Description
FLT_MANT_DIG specifies the number of base FLT_RADIX digits in the mantissa part of a float.
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FLT_MAX
Synopsis
#define FLT_MAX

3.40282347E+38F

Description
FLT_MAX is the maximum value of a float.
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FLT_MAX_10_EXP
Synopsis
#define FLT_MAX_10_EXP

+38

Description
FLT_MAX_10_EXP is the maximum value in base 10 of the exponent part of a float.
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FLT_MAX_EXP
Synopsis
#define FLT_MAX_EXP

+128

Description
FLT_MAX_EXP is the maximum value of base FLT_RADIX in the exponent part of a float.
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FLT_MIN
Synopsis
#define FLT_MIN

1.17549435E-38F

Description
FLT_MIN is the minimum value of a float.

723

CrossWorks for MSP430 Reference Manual

C Library User Guide

FLT_MIN_10_EXP
Synopsis
#define FLT_MIN_10_EXP

-37

Description
FLT_MIN_10_EXP is the minimum value in base 10 of the exponent part of a float.
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FLT_MIN_EXP
Synopsis
#define FLT_MIN_EXP

-125

Description
FLT_MIN_EXP is the minimum value of base FLT_RADIX in the exponent part of a float.
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FLT_RADIX
Synopsis
#define FLT_RADIX

2

Description
FLT_RADIX specifies the radix of the exponent representation.
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FLT_ROUNDS
Synopsis
#define FLT_ROUNDS 1

Description
FLT_ROUNDS specifies the rounding mode of floating-point addition is round to nearest.
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<inmsp.h>
The header file <inmsp.h> defines a number of intrinsic functions of general use for the MSP430 processor. This
file is written to be compatible, and in some cases an enhancement of, the <in430.> file in version 3 of IAR's
Embedded Workbench for MSP430 (EW430) product.

API Summary
Status register manipulation
__bic_SR_register

Clear bits in status register

__bic_SR_register_on_exit

Clear bits in stacked status register

__bis_SR_register

Set bits in status register

__bis_SR_register_on_exit

Set bits in stacked status register

__disable_interrupt

Disable global interrupts

__enable_interrupt

Enable global interrupts

__low_power_mode_0

Enter low power mode 0

__low_power_mode_1

Enter low power mode 1

__low_power_mode_2

Enter low power mode 2

__low_power_mode_3

Enter low power mode 3

__low_power_mode_4

Enter low power mode 4

__low_power_mode_off_on_exit

Enter active mode when interrupt return

__set_interrupt

Restore global interrupts

Byte order manipulation
__swap_bytes

Swap order of bytes in a word

__swap_long_bytes

Swap order of bytes in a long

__swap_words

Swap order of words in a long

Bit order manipulation
__bit_reverse_char

Reverse the order of bits in a char

__bit_reverse_long

Reverse the order of bits in a long

__bit_reverse_long_long

Reverse the order of bits in a long long

__bit_reverse_short

Reverse the order of bits in a short

Bit counting
__bit_count_leading_zeros_char

Count the number of leading zero bits in a char

__bit_count_leading_zeros_long

Count the number of leading zero bits in a long

__bit_count_leading_zeros_long_long

Count the number of leading zero bits in a long long

__bit_count_leading_zeros_short

Count the number of leading zero bits in a short
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Register manipulation
__get_register

Read from processor register

__set_register

Write to processor register

Binary coded decimal arithmetic
__bcd_add_long

Add two 32-bit values using decimal arithmetic

__bcd_add_long_long

Add two 64-bit values using decimal arithmetic

__bcd_add_short

Add two 16-bit values using decimal arithmetic

__bcd_negate_long

Negate a 32-bit value using decimal arithmetic

__bcd_negate_long_long

Negate a 64-bit value using decimal arithmetic

__bcd_negate_short

Negate a 16-bit value using decimal arithmetic

__bcd_subtract_long

Subtract two 32-bit values using decimal arithmetic

__bcd_subtract_long_long

Subtract two 64-bit values using decimal arithmetic

__bcd_subtract_short

Subtract two 16-bit values using decimal arithmetic

Miscellaneous functions
__delay_cycles

Delay execution for a number of cycles

__even_in_range

Assert value is a restricted range

__insert_opcode

Insert an opcode

__no_operation

Insert a NOP instruction

Extended memory functions
__read_extended_byte

Read a byte from extend memory

__read_extended_long

Read a long from extended memory

__read_extended_word

Read a word from extended memory

__write_extended_byte

Write a byte to extended memory

__write_extended_long

Write a long to extended memory

__write_extended_word

Write a word to extended memory
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__bcd_add_long
Synopsis
unsigned long __bcd_add_long(unsigned long x,
unsigned long y);

Description
__bcd_add_long adds x to y using decimal arithmetic. Both x and y must be binary coded decimal numbers and
the result is a binary coded decimal number.
__bcd_add_long is an intrinsic function and produces inline code.
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__bcd_add_long_long
Synopsis
unsigned long long __bcd_add_long_long(unsigned long long x,
unsigned long long y);

Description
__bcd_add_long_long adds x to y using decimal arithmetic. Both x and y must be binary coded decimal
numbers and the result is a binary coded decimal number.
__bcd_add_long_long is an intrinsic function and produces inline code.
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__bcd_add_short
Synopsis
unsigned __bcd_add_short(unsigned x,
unsigned y);

Description
__bcd_add_short adds x to y using decimal arithmetic. Both x and y must be binary coded decimal numbers
and the result is a binary coded decimal number.
__bcd_add_short is an intrinsic function and produces inline code.
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__bcd_negate_long
Synopsis
unsigned long __bcd_negate_long(unsigned long x);

Description
__bcd_negate_long negates (computes the 9's complement of) x using decimal arithmetic. x must be a binary
coded decimal number and the result is a binary coded decimal number.
__bcd_negate_long is an intrinsic function and produces inline code.
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__bcd_negate_long_long
Synopsis
unsigned long long __bcd_negate_long_long(unsigned long long x);

Description
__bcd_negate_long_long negates (computes the 9's complement of) x using decimal arithmetic. x must be a
binary coded decimal number and the result is a binary coded decimal number.
__bcd_negate_long_long is an intrinsic function and produces inline code.
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__bcd_negate_short
Synopsis
unsigned __bcd_negate_short(unsigned x);

Description
__bcd_negate_short negates (computes the 9's complement of) x using decimal arithmetic. x must be a binary
coded decimal number and the result is a binary coded decimal number.
__bcd_negate_short is an intrinsic function and produces inline code.
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__bcd_subtract_long
Synopsis
unsigned long __bcd_subtract_long(unsigned long x,
unsigned long y);

Description
__bcd_subtract_long subtracts y from x using decimal arithmetic. Both x and y must be binary coded decimal
numbers and the result is a binary coded decimal number.
__bcd_subtract_long is an intrinsic function and produces inline code.
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__bcd_subtract_long_long
Synopsis
unsigned long long __bcd_subtract_long_long(unsigned long long x,
unsigned long long y);

Description
__bcd_subtract_long_long subtracts y from x using decimal arithmetic. Both x and y must be binary coded
decimal numbers and the result is a binary coded decimal number.
__bcd_subtract_long_long is an intrinsic function and produces inline code.
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__bcd_subtract_short
Synopsis
unsigned __bcd_subtract_short(unsigned x,
unsigned y);

Description
__bcd_subtract_short subtracts y from x using decimal arithmetic. Both x and y must be binary coded decimal
numbers and the result is a binary coded decimal number.
__bcd_subtract_short is an intrinsic function and produces inline code.
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__bic_SR_register
Synopsis
unsigned __bic_SR_register(unsigned mask);

Description
__bic_SR_register clears the bits specified in mask in the MSP430 status register (i.e. it bitwise ands the
complement of mask into the status register).
__bic_SR_register returns the value of the MSP430 status register before the update.
__bic_SR_register is an intrinsic function and produces inline code.
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__bic_SR_register_on_exit
Synopsis
unsigned __bic_SR_register_on_exit(unsigned mask);

Description
__bic_SR_register_on_exit clears the bits specified in mask in the saved status register of an interrupt function
(i.e. it bitwise ands the complement of mask into the saved status register). This allows you to change the
operating mode of the MSP430 on return from the interrupt service routine, such as changing the low power
mode.
__bic_SR_register_on_exit returns the value of the saved MSP430 status register before the update.
__bic_SR_register_on_exit is an intrinsic function and produces inline code.

Note
__bic_SR_register_on_exit can only be used in interrupt functionsan error is reported if it is used outside an
interrupt function.
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__bis_SR_register
Synopsis
unsigned __bis_SR_register(unsigned mask);

Description
__bis_SR_register sets the bits specified in mask in the MSP430 status register (i.e. it bitwise-ors mask into the
status register).
__bis_SR_register returns the value of the MSP430 status register before the update.
__bis_SR_register is an intrinsic function and produces inline code.
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__bis_SR_register_on_exit
Synopsis
unsigned __bis_SR_register_on_exit(unsigned);

Description
__bis_SR_register_on_exit sets the bits specified in mask in the saved status register of an interrupt function
(i.e. it bitwise ands the complement of mask into the saved status register). This allows you to change the
operating mode of the MSP430 on return from the interrupt service routine, such as changing the low power
mode.
__bis_SR_register_on_exit returns the value of the saved MSP430 status register before the update.
__bis_SR_register_on_exit is an intrinsic function and produces inline code.

Note
__bis_SR_register_on_exit can only be used in interrupt functionsan error is reported if it is used outside an
interrupt function.
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__bit_count_leading_zeros_char
Synopsis
int __bit_count_leading_zeros_char(unsigned char x);

Description
__bit_count_leading_zeros_char counts the number of leading binary zero bits in x.
__bit_count_leading_zeros_char is an intrinsic function and produces inline code.
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__bit_count_leading_zeros_long
Synopsis
int __bit_count_leading_zeros_long(unsigned long x);

Description
__bit_count_leading_zeros_long counts the number of leading binary zero bits in x.
__bit_count_leading_zeros_long is an intrinsic function and produces inline code.
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__bit_count_leading_zeros_long_long
Synopsis
int __bit_count_leading_zeros_long_long(unsigned long long x);

Description
__bit_count_leading_zeros_long_long counts the number of leading binary zero bits in x.
__bit_count_leading_zeros_long_long is an intrinsic function and produces inline code.
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__bit_count_leading_zeros_short
Synopsis
int __bit_count_leading_zeros_short(unsigned short x);

Description
__bit_count_leading_zeros_short counts the number of leading binary zero bits in x.
__bit_count_leading_zeros_short is an intrinsic function and produces inline code.

746

CrossWorks for MSP430 Reference Manual

C Library User Guide

__bit_reverse_char
Synopsis
unsigned char __bit_reverse_char(unsigned char x);

Description
__bit_reverse_char swaps the order of all bits of x and returns that as its result.
__bit_reverse_char is an intrinsic function and produces inline code.
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__bit_reverse_long
Synopsis
unsigned long __bit_reverse_long(unsigned long x);

Description
__bit_reverse_long swaps the order of all bits of x and returns that as its result.
__bit_reverse_long is an intrinsic function and produces inline code.
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__bit_reverse_long_long
Synopsis
unsigned long long __bit_reverse_long_long(unsigned long long x);

Description
__bit_reverse_long_long swaps the order of all bits of x and returns that as its result.
__bit_reverse_long_long is an intrinsic function and produces inline code.
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__bit_reverse_short
Synopsis
unsigned short __bit_reverse_short(unsigned int x);

Description
__bit_reverse_short swaps the order of all bits of x and returns that as its result.
__bit_reverse_short is an intrinsic function and produces inline code.
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__delay_cycles
Synopsis
void __delay_cycles(unsigned long n);

Description
__delay_cycles delays program execution for exactly n processor cycles.
n must be a compile-time constant.
__delay_cycles is an intrinsic function and produces inline code.
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__disable_interrupt
Synopsis
void __disable_interrupt(void);

Description
__disable_interrupt disables global interrupts by clearing the GIE bit in the status register.
__disable_interrupt returns the value of the status register before the GIE bit is cleared.
__disable_interrupt is an intrinsic function and produces inline code.
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__enable_interrupt
Synopsis
void __enable_interrupt(void);

Description
__enable_interrupt enables global interrupts by setting the GIE bit in the status register.
__enable_interrupt returns the value of the status register before the GIE bit is set.
__enable_interrupt is an intrinsic function and produces inline code.
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__even_in_range
Synopsis
void __even_in_range(unsigned x,
unsigned r);

Description
__even_in_range is provided for IAR compatibility. __even_in_range returns x.
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__get_register
Synopsis
unsigned __get_register(unsigned reg);

Description
__get_register reads CPU register reg and returns its contents. __get_register should be used for writing small
wrapper routines in C that can be hand checked for correctness.
__get_register is an intrinsic function and produces inline code.
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__insert_opcode
Synopsis
void __insert_opcode(const unsigned op);

Description
__insert_opcode inserts op into the code stream and can be used to insert special instructions directly into
function code. op must be a compile-time constant.
__insert_opcode is an intrinsic function and produces inline code.
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__low_power_mode_0
Synopsis
void __low_power_mode_0(void);

Description
__low_power_mode_0 enters MSP430 low power mode 0. In this mode the CPU and MCLK are disabled; SMCLK
and ACLK are active.
__low_power_mode_0 is an intrinsic function and produces inline code.
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__low_power_mode_1
Synopsis
void __low_power_mode_1(void);

Description
__low_power_mode_1 enters MSP430 low power mode 1. In this mode the CPU, MCLK, and DCO are disabled;
SMCLK and ACLK are active; the DC generator is disabled if the DCO is not used for MCLK or SMCLK in active
mode.
__low_power_mode_1 is an intrinsic function and produces inline code.
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__low_power_mode_2
Synopsis
void __low_power_mode_2(void);

Description
__low_power_mode_2 enters MSP430 low power mode 1. In this mode the CPU, MCLK, SMCLK, and DCO are
disabled; ACLK is active and the DC generator is enabled.
__low_power_mode_2 is an intrinsic function and produces inline code.
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__low_power_mode_3
Synopsis
void __low_power_mode_3(void);

Description
__low_power_mode_3 enters MSP430 low power mode 3. In this mode the CPU, MCLK, SMCLK, and DCO are
disabled; ACLK is active and the DC generator is disabled.
__low_power_mode_3 is an intrinsic function and produces inline code.
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__low_power_mode_4
Synopsis
void __low_power_mode_4(void);

Description
__low_power_mode_4 enters MSP430 low power mode 4. In this mode the CPU and all clocks are disabled.
__low_power_mode_4 is an intrinsic function and produces inline code.
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__low_power_mode_off_on_exit
Synopsis
void __low_power_mode_off_on_exit(void);

Description
__low_power_mode_off_on_exit turns low power mode off when an interrupt returns, causing the halted CPU
to resume in active mode with all clocks enabled.

Note
__low_power_mode_off_on_exit can only be used in interrupt functionsan error is reported if it is used outside
an interrupt function.
__low_power_mode_off_on_exit is an intrinsic function and produces inline code.
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__no_operation
Synopsis
void __no_operation(void);

Description
__no_operation inserts a NOP instruction into the code stream.
__no_operation is an intrinsic function and produces inline code.
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__read_extended_byte
Synopsis
unsigned __read_extended_byte(unsigned long addr);

Description
__read_extended_byte reads a byte from the 20-bit extended address addre and returns it as its result.

Note
__read_extended_byte can only be used on MSP430X devices.
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__read_extended_long
Synopsis
unsigned long __read_extended_long(unsigned long addr);

Description
__read_extended_long reads a long from the 20-bit extended address addr and returns it as its result.

Note
__read_extended_long can only be used on MSP430X devices.
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__read_extended_word
Synopsis
unsigned __read_extended_word(unsigned long addr);

Description
__read_extended_word reads a word from the 20-bit extended address addr and returns it as its result.

Note
__read_extended_word can only be used on MSP430X devices.
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__set_interrupt
Synopsis
void __set_interrupt(unsigned state);

Description
__set_interrupt copies the GIE flag stores held in (by a call to __disable_interrupt) into the status register.
__set_interrupt is an intrinsic function and produces inline code.
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__set_register
Synopsis
void __set_register(unsigned reg,
unsigned value);

Description
__set_register sets CPU register reg to value. reg must be a compile-time constant, and value can be any
expression. Note that the compiler emits a MOVW instruction to move value to reg and does not save reg in
the function entry nor restore it on function exit, so you must ensure that you respect the calling conventions of
the compiler. Also, using reg does not reserve reg from the compiler register allocator, so you must be careful
not to overwrite a local. __set_register should be used for writing small wrapper routines in C that can be hand
checked for correctness.
__set_register returns value.
__set_register is an intrinsic function and produces inline code.
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__swap_bytes
Synopsis
unsigned __swap_bytes(unsigned x);

Description
__swap_bytes swaps the order of high and low bytes of x and returns that as its result.
__swap_bytes is an intrinsic function and produces inline code.
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__swap_long_bytes
Synopsis
unsigned long __swap_long_bytes(unsigned long x);

Description
__swap_long_bytes swaps the order of all bytes of x and returns that as its result.
__swap_long_bytes is an intrinsic function and produces inline code.
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__swap_words
Synopsis
unsigned long __swap_words(unsigned long x);

Description
__swap_words swaps the order of the high and low words of x and returns that as its result.
__swap_words is an intrinsic function and produces inline code.
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__write_extended_byte
Synopsis
void __write_extended_byte(unsigned long addr,
unsigned value);

Description
__write_extended_byte writes the byte value to the 20-bit extended address addr.

Note
__write_extended_byte can only be used on MSP430X devices.

772

CrossWorks for MSP430 Reference Manual

C Library User Guide

__write_extended_long
Synopsis
void __write_extended_long(unsigned long addr,
unsigned long value);

Description
__write_extended_long writes the long value to the 20-bit extended address addr.

Note
__write_extended_long can only be used on MSP430X devices.
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__write_extended_word
Synopsis
void __write_extended_word(unsigned long addr,
unsigned value);

Description
__write_extended_word writes the word value to the 20-bit extended address addr.

Note
__write_extended_word can only be used on MSP430X devices.

774

CrossWorks for MSP430 Reference Manual

C Library User Guide

<In430.h>
The header file <in430.h> defines a number of intrinsic functions of general use for the MSP430 processor. This
file is written to be compatible, and in some cases an enhancement of, the corresponding file in version 2 of IAR's
Embedded Workbench for MSP430 (EW430) product.

API Summary
Binary coded decimal arithmetic
_DADD16

Add two 16-bit values using decimal arithmetic

_DADD32

Add two 32-bit values using decimal arithmetic

_DADD64

Add two 64-bit values using decimal arithmetic

_DNEG16

Negate a 16-bit value using decimal arithmetic

_DNEG32

Negate a 32-bit value using decimal arithmetic

_DNEG64

Negate a 64-bit value using decimal arithmetic

_DSUB16

Subtract two 16-bit values using decimal arithmetic

_DSUB32

Subtract two 32-bit values using decimal arithmetic

_DSUB64

Subtract two 64-bit values using decimal arithmetic

Byte order manipulation
_LSWPB

Swap order of bytes in a long

_LSWPW

Swap order of words in a long

_SWPB

Swap order of bytes in a word

Miscellaneous functions
_NOP

Insert a NOP instruction

_OPC

Insert an opcode

Status register manipulation
_BIC_SR

Clear bits in status register

_BIC_SR_IRQ

Clear bits in stacked status register

_BIS_SR

Set bits in status register

_BIS_SR_IRQ

Set bits in stacked status register

_DINT

Disable global interrupts

_EINT

Enable global interrupts
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_BIC_SR
Synopsis
#define _BIC_SR(X) __bic_SR_register(X)

Description
A synonym for __bic_SR_register.
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_BIC_SR_IRQ
Synopsis
#define _BIC_SR_IRQ(X) __bic_SR_register_on_exit(X)

Description
A synonym for __bic_SR_register_on_exit.
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_BIS_SR
Synopsis
#define _BIS_SR(X) __bis_SR_register(X)

Description
A synonym for __bis_SR_register.

778

CrossWorks for MSP430 Reference Manual

C Library User Guide

_BIS_SR_IRQ
Synopsis
#define _BIS_SR_IRQ(X) __bis_SR_register_on_exit(X)

Description
A synonym for __bis_SR_register_on_exit.
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_DADD16
Synopsis
#define _DADD16(X, Y) __bcd_add_short(X, Y)

Description
A synonym for __bcd_add_short.
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_DADD32
Synopsis
#define _DADD32(X, Y) __bcd_add_long(X, Y)

Description
A synonym for __bcd_add_long.
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_DADD64
Synopsis
#define _DADD64(X, Y) __bcd_add_long_long(X, Y)

Description
A synonym for __bcd_add_long_long.
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_DINT
Synopsis
#define _DINT()

__disable_interrupt()

Description
A synonym for __disable_interrupt.
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_DNEG16
Synopsis
#define _DNEG16(X) __bcd_negate_short(X)

Description
A synonym for __bcd_negate_short.
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_DNEG32
Synopsis
#define _DNEG32(X) __bcd_negate_long(X)

Description
A synonym for __bcd_negate_long.
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_DNEG64
Synopsis
#define _DNEG64(X) __bcd_negate_long_long(X)

Description
A synonym for __bcd_negate_long_long.
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_DSUB16
Synopsis
#define _DSUB16(X, Y) __bcd_subtract_short(X, Y)

Description
A synonym for __bcd_subtract_short.
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_DSUB32
Synopsis
#define _DSUB32(X, Y) __bcd_subtract_long(X, Y)

Description
A synonym for __bcd_subtract_long.
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_DSUB64
Synopsis
#define _DSUB64(X, Y) __bcd_subtract_long_long(X, Y)

Description
A synonym for __bcd_subtract_long_long.
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_EINT
Synopsis
#define _EINT()

__enable_interrupt()

Description
A synonym for __enable_interrupt.
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_LSWPB
Synopsis
#define _LSWPB(X) __swap_long_bytes(X)

Description
A synonym for __swap_long_bytes.
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_LSWPW
Synopsis
#define _LSWPW(X) __swap_words(X)

Description
A synonym for __swap_words.
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_NOP
Synopsis
#define _NOP() __no_operation()

Description
A synonym for __no_operation.
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_OPC
Synopsis
#define _OPC(X) __insert_opcode(X)

Description
A synonym for __insert_opcode.
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_SWPB
Synopsis
#define _SWPB(X) __swap_bytes(X)

Description
A synonym for __swap_bytes.
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<iso646.h>
Overview
The header <iso646.h> defines macros that expand to the corresponding tokens to ease writing C programs
with keyboards that do not have keys for frequently-used operators.

API Summary
Macros
and

Alternative spelling for logical and operator

and_eq

Alternative spelling for logical and-equals operator

bitand

Alternative spelling for bitwise and operator

bitor

Alternative spelling for bitwise or operator

compl

Alternative spelling for bitwise complement operator

not

Alternative spelling for logical not operator

not_eq

Alternative spelling for not-equal operator

or

Alternative spelling for logical or operator

or_eq

Alternative spelling for bitwise or-equals operator

xor

Alternative spelling for bitwise exclusive or operator

xor_eq

Alternative spelling for bitwise exclusive-or-equals
operator
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and
Synopsis
#define and

&&

Description
and defines the alternative spelling for &&.
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and_eq
Synopsis
#define and_eq

&=

Description
and_eq defines the alternative spelling for &=.
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bitand
Synopsis
#define bitand

&

Description
bitand defines the alternative spelling for &.
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bitor
Synopsis
#define bitor

|

Description
bitor defines the alternative spelling for |.
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compl
Synopsis
#define compl

~

Description
compl defines the alternative spelling for ~.
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not
Synopsis
#define not

!

Description
not defines the alternative spelling for !.
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not_eq
Synopsis
#define not_eq

!=

Description
not_eq defines the alternative spelling for !=.
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or
Synopsis
#define or

||

Description
or defines the alternative spelling for ||.
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or_eq
Synopsis
#define or_eq

|=

Description
or_eq defines the alternative spelling for |=.
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xor
Synopsis
#define xor

^

Description
xor defines the alternative spelling for ^.
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xor_eq
Synopsis
#define xor_eq

^=

Description
xor_eq defines the alternative spelling for ^=.
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<limits.h>
API Summary
Long integer minimum and maximum values
LONG_MAX

Maximum value of a long integer

LONG_MIN

Minimum value of a long integer

ULONG_MAX

Maximum value of an unsigned long integer

Character minimum and maximum values
CHAR_MAX

Maximum value of a plain character

CHAR_MIN

Minimum value of a plain character

SCHAR_MAX

Maximum value of a signed character

SCHAR_MIN

Minimum value of a signed character

UCHAR_MAX

Maximum value of an unsigned char

Long long integer minimum and maximum values
LLONG_MAX

Maximum value of a long long integer

LLONG_MIN

Minimum value of a long long integer

ULLONG_MAX

Maximum value of an unsigned long long integer

Short integer minimum and maximum values
SHRT_MAX

Maximum value of a short integer

SHRT_MIN

Minimum value of a short integer

USHRT_MAX

Maximum value of an unsigned short integer

Integer minimum and maximum values
INT_MAX

Maximum value of an integer

INT_MIN

Minimum value of an integer

UINT_MAX

Maximum value of an unsigned integer

Type sizes
CHAR_BIT

Number of bits in a character

Multi-byte values
MB_LEN_MAX

maximum number of bytes in a multi-byte character
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CHAR_BIT
Synopsis
#define CHAR_BIT

8

Description
CHAR_BIT is the number of bits for smallest object that is not a bit-field (byte).
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CHAR_MAX
Synopsis
#define CHAR_MAX

255

Description
CHAR_MAX is the maximum value for an object of type char.
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CHAR_MIN
Synopsis
#define CHAR_MIN

0

Description
CHAR_MIN is the minimum value for an object of type char.
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INT_MAX
Synopsis
#define INT_MAX

2147483647

Description
INT_MAX is the maximum value for an object of type int.
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INT_MIN
Synopsis
#define INT_MIN

(-2147483647 - 1)

Description
INT_MIN is the minimum value for an object of type int.
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LLONG_MAX
Synopsis
#define LLONG_MAX

9223372036854775807LL

Description
LLONG_MAX is the maximum value for an object of type long long int.
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LLONG_MIN
Synopsis
#define LLONG_MIN

(-9223372036854775807LL - 1)

Description
LLONG_MIN is the minimum value for an object of type long long int.
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LONG_MAX
Synopsis
#define LONG_MAX

2147483647L

Description
LONG_MAX is the maximum value for an object of type long int.
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LONG_MIN
Synopsis
#define LONG_MIN

(-2147483647L - 1)

Description
LONG_MIN is the minimum value for an object of type long int.
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MB_LEN_MAX
Synopsis
#define MB_LEN_MAX

4

Description
MB_LEN_MAX is the maximum number of bytes in a multi-byte character for any supported locale. Unicode (ISO
10646) characters between 0 and 10FFFF inclusive are supported which convert to a maximum of four bytes in
the UTF-8 encoding.
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SCHAR_MAX
Synopsis
#define SCHAR_MAX

127

Description
SCHAR_MAX is the maximum value for an object of type signed char.
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SCHAR_MIN
Synopsis
#define SCHAR_MIN

(-128)

Description
SCHAR_MIN is the minimum value for an object of type signed char.
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SHRT_MAX
Synopsis
#define SHRT_MAX

32767

Description
SHRT_MAX is the maximum value for an object of type short int.

821

CrossWorks for MSP430 Reference Manual

C Library User Guide

SHRT_MIN
Synopsis
#define SHRT_MIN

(-32767 - 1)

Description
SHRT_MIN is the minimum value for an object of type short int.
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UCHAR_MAX
Synopsis
#define UCHAR_MAX

255

Description
UCHAR_MAX is the maximum value for an object of type unsigned char.
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UINT_MAX
Synopsis
#define UINT_MAX

4294967295U

Description
UINT_MAX is the maximum value for an object of type unsigned int.
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ULLONG_MAX
Synopsis
#define ULLONG_MAX 18446744073709551615ULL

Description
ULLONG_MAX is the maximum value for an object of type unsigned long long int.
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ULONG_MAX
Synopsis
#define ULONG_MAX

4294967295UL

Description
ULONG_MAX is the maximum value for an object of type unsigned long int.
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USHRT_MAX
Synopsis
#define USHRT_MAX

65535

Description
USHRT_MAX is the maximum value for an object of type unsigned short int.
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<locale.h>
API Summary
Structures
lconv

Formatting info for numeric values

Functions
localeconv

Get current locale data

setlocale

Set Locale
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lconv
Synopsis
typedef struct {
char *decimal_point;
char *thousands_sep;
char *grouping;
char *int_curr_symbol;
char *currency_symbol;
char *mon_decimal_point;
char *mon_thousands_sep;
char *mon_grouping;
char *positive_sign;
char *negative_sign;
char int_frac_digits;
char frac_digits;
char p_cs_precedes;
char p_sep_by_space;
char n_cs_precedes;
char n_sep_by_space;
char p_sign_posn;
char n_sign_posn;
char int_p_cs_precedes;
char int_n_cs_precedes;
char int_p_sep_by_space;
char int_n_sep_by_space;
char int_p_sign_posn;
char int_n_sign_posn;
} lconv;

Description
lconv structure holds formatting information on how numeric values are to be written. Note that the order of
fields in this structure is not consistent between implementations, nor is it consistent between C89 and C99
standards.
The members decimal_point, grouping, and thousands_sep are controlled by LC_NUMERIC, the remainder by
LC_MONETARY.
The members int_n_cs_precedes, int_n_sep_by_space, int_n_sign_posn, int_p_cs_precedes,
int_p_sep_by_space. and int_p_sign_posn are added by the C99 standard.
We have standardized on the ordering specified by the ARM EABI for the base of this structure. This ordering is
neither that of C89 nor C99.
Member

Description

currency_symbol

Local currency symbol.

decimal_point

Decimal point separator.

frac_digits

Amount of fractional digits to the right of the decimal
point for monetary quantities in the local format.
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grouping

Specifies the amount of digits that form each of the
groups to be separated by thousands_sep separator
for non-monetary quantities.

int_curr_symbol

International currency symbol.

int_frac_digits

Amount of fractional digits to the right of the decimal
point for monetary quantities in the international
format.

mon_decimal_point

Decimal-point separator used for monetary quantities.

mon_grouping

Specifies the amount of digits that form each of the
groups to be separated by mon_thousands_sep
separator for monetary quantities.

mon_thousands_sep

Separators used to delimit groups of digits to the left
of the decimal point for monetary quantities.

negative_sign

Sign to be used for negative monetary quantities.

n_cs_precedes

Whether the currency symbol should precede negative
monetary quantities.

n_sep_by_space

Whether a space should appear between the currency
symbol and negative monetary quantities.

n_sign_posn

Position of the sign for negative monetary quantities.

positive_sign

Sign to be used for nonnegative (positive or zero)
monetary quantities.

p_cs_precedes

Whether the currency symbol should precede
nonnegative (positive or zero) monetary quantities.

p_sep_by_space

Whether a space should appear between the currency
symbol and nonnegative (positive or zero) monetary
quantities.

p_sign_posn

Position of the sign for nonnegative (positive or zero)
monetary quantities.

thousands_sep

Separators used to delimit groups of digits to the left
of the decimal point for non-monetary quantities.
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localeconv
Synopsis
localeconv(void);

Description
localeconv returns a pointer to a structure of type lconv with the corresponding values for the current locale
filled in.
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setlocale
Synopsis
char *setlocale(int category,
const char *locale);

Description
setlocale sets the current locale. The category parameter can have the following values:
Name

Locale affected

LC_ALL

Entire locale

LC_COLLATE

Affects strcoll and strxfrm

LC_CTYPE

Affects character handling

LC_MONETARY

Affects monetary formatting information

LC_NUMERIC

Affects decimal-point character in I/O and string
formatting operations

LC_TIME

Affects strftime

The locale parameter contains the name of a C locale to set or if NULL is passed the current locale is not
changed.

Return Value
setlocale returns the name of the current locale.
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<math.h>
API Summary
Comparison Macros
isgreater

Is greater

isgreaterequal

Is greater or equal

isless

Is less

islessequal

Is less or equal

islessgreater

Is less or greater

isunordered

Is unordered

Classification Macros
fpclassify

Classify floating type

isfinite

Test for a finite value

isinf

Test for infinity

isnan

Test for NaN

isnormal

Test for a normal value

signbit

Test sign

Trigonometric functions
cos

Compute cosine of a double

cosf

Compute cosine of a float

sin

Compute sine of a double

sinf

Compute sine of a float

tan

Compute tangent of a double

tanf

Compute tangent of a double

Inverse trigonometric functions
acos

Compute inverse cosine of a double

acosf

Compute inverse cosine of a float

asin

Compute inverse sine of a double

asinf

Compute inverse sine of a float

atan

Compute inverse tangent of a double

atan2

Compute inverse tangent of a ratio of doubles

atan2f

Compute inverse tangent of a ratio of floats

atanf

Compute inverse tangent of a float

Exponential and logarithmic functions
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exp

Compute exponential of a double

exp2

Compute binary exponential of a double

exp2f

Compute binary exponential of a float

expf

Compute exponential of a float

expm1

Compute exponential minus one of a double

expm1f

Compute exponential minus one of a float

frexp

Set exponent of a double

frexpf

Set exponent of a float

ilogb

Compute integer binary logarithm of a double

ilogbf

Compute integer binary logarithm of a float

ldexp

Adjust exponent of a double

ldexpf

Adjust exponent of a float

log

Compute natural logarithm of a double

log10

Compute common logarithm of a double

log10f

Compute common logarithm of a float

log1p

Compute natural logarithm plus one of a double

log1pf

Compute natural logarithm plus one of a float

log2

Compute binary logarithm of a double

log2f

Compute binary logarithm of a float

logb

Compute floating-point base logarithm of a double

logbf

Compute floating-point base logarithm of a float

logf

Compute natural logarithm of a float

scalbln

Scale a double

scalblnf

Scale a float

scalbn

Scale a double

scalbnf

Scale a float

Rounding and remainder functions
ceil

Compute smallest integer not greater than a double

ceilf

Compute smallest integer not greater than a float

floor

Compute largest integer not greater than a double

floorf

Compute largest integer not greater than a float

fmod

Compute remainder after division of two doubles

fmodf

Compute remainder after division of two floats

llrint

Round and cast double to long long

llrintf

Round and cast float to long long
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llround

Round and cast double to long long

llroundf

Round and cast float to long long

lrint

Round and cast double to long

lrintf

Round and cast float to long

lround

Round and cast double to long

lroundf

Round and cast float to long

modf

Break a double into integer and fractional parts

modff

Break a float into integer and fractional parts

nearbyint

Round double to nearby integral value

nearbyintf

Round float to nearby integral value

remainder

Compute remainder of a double

remainderf

Compute remainder of a float

remquo

Compute remainder and quotient of a double

remquof

Compute remainder and quotient of a float

rint

Round a double to an integral value

rintf

Round a float to an integral value

round

Round a double to the nearest integral value

roundf

Round a float to the nearest integral value

trunc

Truncate a double value

truncf

Truncate a float value

Power functions
cbrt

Compute cube root of a double

cbrtf

Compute cube root of a float

hypot

Compute complex magnitude of two doubles

hypotf

Compute complex magnitude of two floats

pow

Raise a double to a power

powf

Raise a float to a power

sqrt

Compute square root of a double

sqrtf

Compute square root of a float

Absolute value functions
fabs

Compute absolute value of a double

fabsf

Compute absolute value of a float

Maximum, minimum, and positive difference functions
fdim

Compute positive difference of two doubles

fdimf

Compute positive difference of two floats
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fmax

Compute maximum of two doubles

fmaxf

Compute maximum of two floats

fmin

Compute minimum of two doubles

fminf

Compute minimum of two floats

Hyperbolic functions
cosh

Compute hyperbolic cosine of a double

coshf

Compute hyperbolic cosine of a float

sinh

Compute hyperbolic sine of a double

sinhf

Compute hyperbolic sine of a float

tanh

Compute hyperbolic tangent of a double

tanhf

Compute hyperbolic tangent of a float

Inverse hyperbolic functions
acosh

Compute inverse hyperbolic cosine of a double

acoshf

Compute inverse hyperbolic cosine of a float

asinh

Compute inverse hyperbolic sine of a double

asinhf

Compute inverse hyperbolic sine of a float

atanh

Compute inverse hyperbolic tangent of a double

atanhf

Compute inverse hyperbolic tangent of a float

Fused multiply functions
fma

Compute fused multiply-add of doubles

fmaf

Compute fused multiply-add of floats

Floating-point manipulation functions
copysign

Copy magnitude and sign of a double

copysignf

Copy magnitude and sign of a float

nextafter

Next representable double value

nextafterf

Next representable float value

Error and Gamma functions
erf

Compute error function of a double

erfc

Compute complementary error function of a double

erfcf

Compute complementary error function of a float

erff

Compute error function of a float

lgamma

Compute log-gamma function of a double

lgammaf

Compute log-gamma function of a float

tgamma

Compute gamma function of a double

tgammaf

Compute gamma function of a float
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acos
Synopsis
double acos(double x);

Description
acos returns the principal value, in radians, of the inverse circular cosine of x. The principal value lies in the
interval [0, PI] radians.
If |x| > 1, errno is set to EDOM and acos returns HUGE_VAL.
If x is NaN, acos returns x. If |x| > 1, acos returns NaN.
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acosf
Synopsis
float acosf(float x);

Description
acosf returns the principal value, in radians, of the inverse circular cosine of x. The principal value lies in the
interval [0, PI] radians.
If |a| 1, errno is set to EDOM and acosf returns HUGE_VAL.
If x is NaN, acosf returns x. If |x| > 1, acosf returns NaN.
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acosh
Synopsis
double acosh(double x);

Description
acosh returns the non-negative inverse hyperbolic cosine of x.
acosh(x) is defined as log(x + sqrt(x^2 1)), assuming completely accurate computation.
If x < 1, errno is set to EDOM and acosh returns HUGE_VAL.
If x < 1, acosh returns NaN.
If x is NaN, acosh returns NaN.

839

CrossWorks for MSP430 Reference Manual

C Library User Guide

acoshf
Synopsis
float acoshf(float x);

Description
acoshf returns the non-negative inverse hyperbolic cosine of x.
acosh(x) is defined as log(x + sqrt(x^2 1)), assuming completely accurate computation.
If x < 1, errno is set to EDOM and acoshf returns HUGE_VALF.
If x < 1, acoshf returns NaN.
If x is NaN, acoshf returns that NaN.
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asin
Synopsis
double asin(double x);

Description
asin returns the principal value, in radians, of the inverse circular sine of x. The principal value lies in the interval
[, +] radians.
If |x| > 1, errno is set to EDOM and asin returns HUGE_VAL.
If x is NaN, asin returns x. If |x| > 1, asin returns NaN.
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asinf
Synopsis
float asinf(float x);

Description
asinf returns the principal value, in radians, of the inverse circular sine of val. The principal value lies in the
interval [, +] radians.
If |x| > 1, errno is set to EDOM and asinf returns HUGE_VALF.
If x is NaN, asinf returns x. If |x| > 1, asinf returns NaN.
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asinh
Synopsis
double asinh(double x);

Description
asinh calculates the hyperbolic sine of x.
If |x| > ~709.782, errno is set to EDOM and asinh returns HUGE_VAL.
If x is +, , or NaN, asinh returns |x|. If |x| > ~709.782, asinh returns + or depending upon the sign of x.
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asinhf
Synopsis
float asinhf(float x);

Description
asinhf calculates the hyperbolic sine of x.
If |x| > ~88.7228, errnois set to EDOM and asinhf returns HUGE_VALF.
If x is +, , or NaN, asinhf returns |x|. If |x| > ~88.7228, asinhf returns + or depending upon the sign of x.
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atan
Synopsis
double atan(double x);

Description
atan returns the principal value, in radians, of the inverse circular tangent of x. The principal value lies in the
interval [, +] radians.
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atan2
Synopsis
double atan2(double y,
double x);

Description
atan2 returns the value, in radians, of the inverse circular tangent of y divided by x using the signs of x and y to
compute the quadrant of the return value. The principal value lies in the interval [, +] radians. If x = y = 0, errno is
set to EDOM and atan2 returns HUGE_VAL.
atan2(x, NaN) is NaN.
atan2(NaN, x) is NaN.
atan2(0, +(anything but NaN)) is 0.
atan2(0, (anything but NaN)) is .
atan2((anything but 0 and NaN), 0) is .
atan2((anything but and NaN), +) is 0.
atan2((anything but and NaN), ) is .
atan2(, +) is .
atan2(, ) is .
atan2(, (anything but 0, NaN, and )) is .

846

CrossWorks for MSP430 Reference Manual

C Library User Guide

atan2f
Synopsis
float atan2f(float y,
float x);

Description
atan2f returns the value, in radians, of the inverse circular tangent of y divided by x using the signs of x and y to
compute the quadrant of the return value. The principal value lies in the interval [, +] radians.
If x = y = 0, errno is set to EDOM and atan2f returns HUGE_VALF.
atan2f(x, NaN) is NaN.
atan2f(NaN, x) is NaN.
atan2f(0, +(anything but NaN)) is 0.
atan2f(0, (anything but NaN)) is .
atan2f((anything but 0 and NaN), 0) is .
atan2f((anything but and NaN), +) is 0.
atan2f((anything but and NaN), ) is .
atan2f(, +) is .
atan2f(, ) is .
atan2f(, (anything but 0, NaN, and )) is .
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atanf
Synopsis
float atanf(float x);

Description
atanf returns the principal value, in radians, of the inverse circular tangent of x. The principal value lies in the
interval [, +] radians.
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atanh
Synopsis
double atanh(double x);

Description
atanh returns the inverse hyperbolic tangent of x.
If |x| 1, errno is set to EDOM and atanh returns HUGE_VAL.
If |x| > 1 atanh returns NaN.
If x is NaN, atanh returns that NaN.
If x is 1, atanh returns .
If x is 1, atanh returns .
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atanhf
Synopsis
float atanhf(float x);

Description
atanhf returns the inverse hyperbolic tangent of x.
If |x| > 1 atanhf returns NaN. If x is NaN, atanhf returns that NaN. If x is 1, atanhf returns . If x is 1, atanhf returns .
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cbrt
Synopsis
double cbrt(double x);

Description
cbrt computes the cube root of x.
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cbrtf
Synopsis
float cbrtf(float x);

Description
cbrtf computes the cube root of x.
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ceil
Synopsis
double ceil(double x);

Description
ceil computes the smallest integer value not less than x.
ceil (0) is 0. ceil ( ) is .
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ceilf
Synopsis
float ceilf(float x);

Description
ceilf computes the smallest integer value not less than x.
ceilf (0) is 0. ceilf ( ) is .
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copysign
Synopsis
double copysign(double x,
double y);

Description
copysign returns a value with the magnitude of x and the sign of y.
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copysignf
Synopsis
float copysignf(float x,
float y);

Description
copysignf returns a value with the magnitude of x and the sign of y.
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cos
Synopsis
double cos(double x);

Description
cos returns the radian circular cosine of x.
If |x| > 10^9, errno is set to EDOM and cos returns HUGE_VAL.
If x is NaN, cos returns x. If |x| is , cos returns NaN.
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cosf
Synopsis
float cosf(float x);

Description
cosf returns the radian circular cosine of x.
If |x| > 10^9, errno is set to EDOM and cosf returns HUGE_VALF.
If x is NaN, cosf returns x. If |x| is , cosf returns NaN.
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cosh
Synopsis
double cosh(double x);

Description
cosh calculates the hyperbolic cosine of x.
If |x| > ~709.782, errno is set to EDOM and cosh returns HUGE_VAL.
If x is +, , or NaN, cosh returns |x|.> If |x| > ~709.782, cosh returns + or depending upon the sign of x.
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coshf
Synopsis
float coshf(float x);

Description
coshf calculates the hyperbolic sine of x.
If |x| > ~88.7228, errno is set to EDOM and coshf returns HUGE_VALF.
If x is +, , or NaN, coshf returns |x|.
If |x| > ~88.7228, coshf returns + or depending upon the sign of x.
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erf
Synopsis
double erf(double x);

Description
erf returns the error function for x.
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erfc
Synopsis
double erfc(double x);

Description
erfc returns the complementary error function for x.
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erfcf
Synopsis
float erfcf(float x);

Description
erfcf returns the complementary error function for x.
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erff
Synopsis
float erff(float x);

Description
erff returns the error function for x.

864

CrossWorks for MSP430 Reference Manual

C Library User Guide

exp
Synopsis
double exp(double x);

Description
exp computes the base-e exponential of x.
If |x| > ~709.782, errno is set to EDOM and exp returns HUGE_VAL.
If x is NaN, exp returns NaN.
If x is , exp returns .
If x is , exp returns 0.

865

CrossWorks for MSP430 Reference Manual

C Library User Guide

exp2
Synopsis
double exp2(double x);

Description
exp2 returns 2 raised to the power of x.
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exp2f
Synopsis
float exp2f(float x);

Description
exp2f returns 2 raised to the power of x.
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expf
Synopsis
float expf(float x);

Description
expf computes the base-e exponential of x.
If |x| > ~88.722, errno is set to EDOM and expf returns HUGE_VALF. If x is NaN, expf returns NaN.
If x is , expf returns .
If x is , expf returns 0.
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expm1
Synopsis
double expm1(double x);

Description
expm1 returns e raised to the power of x minus one.
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expm1f
Synopsis
float expm1f(float x);

Description
expm1f returns e raised to the power of x minus one.
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fabs
Synopsis
double fabs(double x);
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fabsf
Synopsis
float fabsf(float x);

Description
fabsf computes the absolute value of the floating-point number x.
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fdim
Synopsis
double fdim(double x,
double y);

Description
fdim returns the positive difference between x and y.
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fdimf
Synopsis
float fdimf(float x,
float y);

Description
fdimf returns the positive difference between x and y.
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floor
Synopsis
double floor(double);

floor computes the largest integer value not greater than x.
floor (0) is 0. floor () is .
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floorf
Synopsis
float floorf(float);

floorf computes the largest integer value not greater than x.
floorf(0) is 0. floorf() is .
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fma
Synopsis
double fma(double x,
double y,
double z);

Description
fma computes x y + z with a single rounding.
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fmaf
Synopsis
float fmaf(float x,
float y,
float z);

Description
fmaf computes x y + z with a single rounding.
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fmax
Synopsis
double fmax(double x,
double y);

Description
fmax determines the maximum of x and y.
fmax (NaN, y) is y. fmax (x, NaN) is x.
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fmaxf
Synopsis
float fmaxf(float x,
float y);

Description
fmaxf determines the maximum of x and y.
fmaxf (NaN, y) is y. fmaxf(x, NaN) is x.

880

CrossWorks for MSP430 Reference Manual

C Library User Guide

fmin
Synopsis
double fmin(double x,
double y);

Description
fmin determines the minimum of x and y.
fmin (NaN, y) is y. fmin (x, NaN) is x.
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fminf
Synopsis
float fminf(float x,
float y);

Description
fminf determines the minimum of x and y.
fminf (NaN, y) is y. fminf (x, NaN) is x.
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fmod
Synopsis
double fmod(double x,
double y);

Description
fmod computes the floating-point remainder of x divided by y. #b #this returns the value x n y, for some integer
n such that, if y is nonzero, the result has the same sign as x and magnitude less than the magnitude of y.
fmod (NaN, y) is NaN. fmod (x, NaN) is NaN. fmod ( 0, y) is 0 for y not zero.
fmod (, y) is NaN.
fmod (x, 0) is NaN.
fmod (x, ) is x for x not infinite.
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fmodf
Synopsis
float fmodf(float x,
float y);

Description
fmodf computes the floating-point remainder of x divided by y. fmodf returns the value x n y, for some integer n
such that, if y is nonzero, the result has the same sign as x and magnitude less than the magnitude of y.
fmodf (NaN, y) is NaN. fmodf (x, NaN) is NaN. fmodf ( 0, y) is 0 for y not zero.
fmodf (, y) is NaN.
fmodf (x, 0) is NaN.
fmodf (x, ) is x for x not infinite.
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fpclassify
Synopsis
#define fpclassify(x) (__is_float32(x) ? __float32_classify(x) : __float64_classify(x))

Description
fpclassify classifies x as NaN, infinite, normal, subnormal, zero, or into another implementation-defined
category. fpclassify returns one of:
FP_ZERO
FP_SUBNORMAL
FP_NORMAL
FP_INFINITE
FP_NAN
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frexp
Synopsis
double frexp(double x,
int *exp);

Description
frexp breaks a floating-point number into a normalized fraction and an integral power of 2.
frexp stores power of two in the int object pointed to by exp and returns the value x, such that x has a
magnitude in the interval [1/2, 1) or zero, and value equals x * 2^exp.
If x is zero, both parts of the result are zero.
If x is or NaN, frexp returns x and stores zero into the int object pointed to by exp.
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frexpf
Synopsis
float frexpf(float x,
int *exp);

Description
frexpf breaks a floating-point number into a normalized fraction and an integral power of 2.
frexpf stores power of two in the int object pointed to by frexpf and returns the value x, such that x has a
magnitude in the interval [, 1) or zero, and value equals x * 2^exp.
If x is zero, both parts of the result are zero.
If x is or NaN, frexpf returns x and stores zero into the int object pointed to by exp.
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hypot
Synopsis
double hypot(double x,
double y);

Description
hypot computes the square root of the sum of the squares of x and y, sqrt(x*x + y*y), without undue overflow or
underflow. If x and y are the lengths of the sides of a right-angled triangle, then hypot computes the length of
the hypotenuse.
If x or y is + or , hypot returns .
If x or y is NaN, hypot returns NaN.
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hypotf
Synopsis
float hypotf(float x,
float y);

Description
hypotf computes the square root of the sum of the squares of x and y, sqrtf(x*x + y*y), without undue overflow
or underflow. If x and y are the lengths of the sides of a right-angled triangle, then hypotf computes the length
of the hypotenuse.
If x or y is + or , hypotf returns . If x or y is NaN, hypotf returns NaN.
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ilogb
Synopsis
int ilogb(double x);

Description
ilogb returns the integral part of the logarithm of x, using FLT_RADIX as the base for the logarithm.
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ilogbf
Synopsis
int ilogbf(float x);

Description
ilogbf returns the integral part of the logarithm of x, using FLT_RADIX as the base for the logarithm.
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isfinite
Synopsis
#define isfinite(x) (sizeof(x) == sizeof(float) ? __float32_isfinite(x) : __float64_isfinite(x))

Description
isfinite determines whether x is a finite value (zero, subnormal, or normal, and not infinite or NaN). isfinite
returns a non-zero value if and only if x has a finite value.
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isgreater
Synopsis
#define isgreater(x,y) (!isunordered(x, y) && (x > y))

Description
isgreater returns whether x is greater than y.
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isgreaterequal
Synopsis
#define isgreaterequal(x,y) (!isunordered(x, y) && (x >= y))

Description
isgreaterequal returns whether x is greater than or equal to y.
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isinf
Synopsis
#define isinf(x) (sizeof(x) == sizeof(float) ? __float32_isinf(x) : __float64_isinf(x))

Description
isinf determines whether x is an infinity (positive or negative). The determination is based on the type of the
argument.
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isless
Synopsis
#define isless(x,y) (!isunordered(x, y) && (x < y))

Description
isless returns whether x is less than y.
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islessequal
Synopsis
#define islessequal(x,y) (!isunordered(x, y) && (x <= y))

Description
islessequal returns whether x is less than or equal to y.
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islessgreater
Synopsis
#define islessgreater(x,y) (!isunordered(x, y) && (x < y || x > y))

Description
islessgreater returns whether x is less than or greater than y.
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isnan
Synopsis
#define isnan(x) (sizeof(x) == sizeof(float) ? __float32_isnan(x) : __float64_isnan(x))

Description
isnan determines whether x is a NaN. The determination is based on the type of the argument.
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isnormal
Synopsis
#define isnormal(x) (sizeof(x) == sizeof(float) ? __float32_isnormal(x) : __float64_isnormal(x))

Description
isnormal determines whether x is a normal value (zero, subnormal, or normal, and not infinite or NaN).. isnormal
returns a non-zero value if and only if x has a normal value.
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isunordered
Synopsis
#define isunordered(a,b) (fpclassify(a) == FP_NAN || fpclassify(b) == FP_NAN)

Description
isunordered returns whether x or y are unordered values.
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ldexp
Synopsis
double ldexp(double x,
int exp);

Description
ldexp multiplies a floating-point number by an integral power of 2.
ldexp returns x * 2^exp.
If the result overflows, errno is set to ERANGE and ldexp returns HUGE_VALF.
If x is or NaN, ldexp returns x. If the result overflows, ldexp returns .

902

CrossWorks for MSP430 Reference Manual

C Library User Guide

ldexpf
Synopsis
float ldexpf(float x,
int exp);

Description
ldexpf multiplies a floating-point number by an integral power of 2.
ldexpf returns x * 2^exp. If the result overflows, errno is set to ERANGE and ldexpf returns HUGE_VALF.
If x is or NaN, ldexpf returns x. If the result overflows, ldexpf returns .
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lgamma
Synopsis
double lgamma(double x);

Description
lgamma returns the natural logarithm of the gamma function for x.
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lgammaf
Synopsis
float lgammaf(float x);

Description
lgammaf returns the natural logarithm of the gamma function for x.
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llrint
Synopsis
long long int llrint(double x);

Description
llrint rounds x to an integral value and returns it as a long long int.
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llrintf
Synopsis
long long int llrintf(float x);

Description
llrintf rounds x to an integral value and returns it as a long long int.
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llround
Synopsis
long long int llround(double x);

Description
llround rounds x to an integral value, with halfway cases rounded away from zero, and returns it as a long long
int.
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llroundf
Synopsis
long long int llroundf(float x);

Description
llroundf rounds x to an integral value, with halfway cases rounded away from zero, and returns it as a long long
int.

909

CrossWorks for MSP430 Reference Manual

C Library User Guide

log
Synopsis
double log(double x);

Description
log computes the base-e logarithm of x.
If x = 0, errno is set to ERANGE and log returns HUGE_VAL. If x < 0, errno is set to EDOM and log returns
HUGE_VAL.
If x < 0 or x = , log returns NaN.
If x = 0, log returns .
If x = , log returns .
If x = NaN, log returns x.
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log10
Synopsis
double log10(double x);

Description
log10 computes the base-10 logarithm of x.
If x = 0, errno is set to ERANGE and log10 returns HUGE_VAL. If x < 0, errno is set to EDOM and log10 returns
HUGE_VAL.
If x < 0 or x = , log10 returns NaN.
If x = 0, log10 returns .
If x = , log10 returns .
If x = NaN, log10 returns x.
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log10f
Synopsis
float log10f(float x);

Description
log10f computes the base-10 logarithm of x.
If x = 0, errno is set to ERANGE and log10f returns HUGE_VALF. If x < 0, errno is set to EDOM and log10f returns
HUGE_VALF.
If x < 0 or x = , log10f returns NaN.
If x = 0, log10f returns .
If x = , log10f returns .
If x = NaN, log10f returns x.
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log1p
Synopsis
double log1p(double x);

Description
log1p computes the base-e logarithm of x plus one.
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log1pf
Synopsis
float log1pf(float x);

Description
log1pf computes the base-e logarithm of x plus one.
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log2
Synopsis
double log2(double x);

Description
log2 computes the base-2 logarithm of x.
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log2f
Synopsis
float log2f(float x);

Description
log2f computes the base-2 logarithm of x.
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logb
Synopsis
double logb(double x);

Description
logb computes the base-FLT_RADIX logarithm of x.
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logbf
Synopsis
float logbf(float x);

Description
logbf computes the base-FLT_RADIX logarithm of x.
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logf
Synopsis
float logf(float x);

Description
logf computes the base-e logarithm of x.
If x = 0, errno is set to ERANGE and logf returns HUGE_VALF. If x < 0, errno is set to EDOM and logf returns
HUGE_VALF.
If x < 0 or x = , logf returns NaN.
If x = 0, logf returns .
If x = , logf returns .
If x = NaN, logf returns x.
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lrint
Synopsis
long int lrint(double x);

Description
lrint rounds x to an integral value and returns it as a long int.
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lrintf
Synopsis
long int lrintf(float x);

Description
lrintf rounds x to an integral value and returns it as a long int.
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lround
Synopsis
long int lround(double x);

Description
lround rounds x to an integral value, with halfway cases rounded away from zero, and returns it as a long int.
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lroundf
Synopsis
long int lroundf(float x);

Description
lroundf rounds x to an integral value, with halfway cases rounded away from zero, and returns it as a long int.
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modf
Synopsis
double modf(double x,
double *iptr);

Description
modf breaks x into integral and fractional parts, each of which has the same type and sign as x.
The integral part (in floating-point format) is stored in the object pointed to by iptr and modf returns the signed
fractional part of x.
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modff
Synopsis
float modff(float x,
float *iptr);

Description
modff breaks x into integral and fractional parts, each of which has the same type and sign as x.
The integral part (in floating-point format) is stored in the object pointed to by iptr and modff returns the signed
fractional part of x.
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nearbyint
Synopsis
double nearbyint(double);

Description
nearbyint Rounds x to an integral value.
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nearbyintf
Synopsis
float nearbyintf(float);

Description
nearbyintf Rounds x to an integral value.
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nextafter
Synopsis
double nextafter(double x,
double y);

Description
nextafter Returns the next representable value after x in the direction of y.

928

CrossWorks for MSP430 Reference Manual

C Library User Guide

nextafterf
Synopsis
float nextafterf(float x,
float y);

Description
nextafterf Returns the next representable value after x in the direction of y.
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pow
Synopsis
double pow(double x,
double y);

Description
pow computes x raised to the power y.
If x < 0 and y 0, errno is set to EDOM and pow returns HUGE_VAL. If x 0 and y is not an integer value, errno is set
to EDOM and pow returns HUGE_VAL.
If y = 0, pow returns 1.
If y = 1, pow returns x.
If y = NaN, pow returns NaN.
If x = NaN and y is anything other than 0, pow returns NaN.
If x < 1 or 1 < x, and y = +, pow returns +.
If x < 1 or 1 < x, and y = , pow returns 0.
If 1 < x < 1 and y = +, pow returns +0.
If 1 < x < 1 and y = , pow returns +.
If x = +1 or x = 1 and y = + or y = , pow returns NaN.
If x = +0 and y > 0 and y NaN, pow returns +0.
If x = 0 and y > 0 and y NaN or y not an odd integer, pow returns +0.
If x = +0 and y and y NaN, pow returns +.
If x = 0 and y > 0 and y NaN or y not an odd integer, pow returns +.
If x = 0 and y is an odd integer, pow returns 0.
If x = + and y > 0 and y NaN, pow returns +.
If x = + and y < 0 and y NaN, pow returns +0.
If x = , pow returns pow(0, y)
If x < 0 and x and y is a non-integer, pow returns NaN.
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powf
Synopsis
float powf(float x,
float y);

Description
powf computes x raised to the power y.
If x < 0 and y 0, errno. is set to EDOM and powf returns HUGE_VALF. If x 0 and y is not an integer value, errno is
set to EDOM and pow returns HUGE_VALF.
If y = 0, powf returns 1.
If y = 1, powf returns x.
If y = NaN, powf returns NaN.
If x = NaN and y is anything other than 0, powf returns NaN.
If x < 1 or 1 < x, and y = +, powf returns +.
If x < 1 or 1 < x, and y = , powf returns 0.
If 1 < x < 1 and y = +, powf returns +0.
If 1 < x < 1 and y = , powf returns +.
If x = +1 or x = 1 and y = + or y = , powf returns NaN.
If x = +0 and y > 0 and y NaN, powf returns +0.
If x = 0 and y > 0 and y NaN or y not an odd integer, powf returns +0.
If x = +0 and y and y NaN, powf returns +.
If x = 0 and y > 0 and y NaN or y not an odd integer, powf returns +.
If x = 0 and y is an odd integer, powf returns 0.
If x = + and y > 0 and y NaN, powf returns +.
If x = + and y < 0 and y NaN, powf returns +0.
If x = , powf returns powf(0, y)
If x < 0 and x and y is a non-integer, powf returns NaN.
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remainder
Synopsis
double remainder(double numer,
double denom);

Description
remainder computes the remainder of numer divided by denom.
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remainderf
Synopsis
float remainderf(float numer,
float denom);

Description
remainderf computes the remainder of numer divided by denom.
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remquo
Synopsis
double remquo(double numer,
double denom,
int *quot);

Description
remquo computes the remainder of numer divided by denom and the quotient pointed by quot.
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remquof
Synopsis
float remquof(float numer,
float denom,
int *quot);

Description
remquof computes the remainder of numer divided by denom and the quotient pointed by quot.
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rint
Synopsis
double rint(double x);

Description
rint rounds x to an integral value.
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rintf
Synopsis
float rintf(float x);

Description
rintf rounds x to an integral value.
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round
Synopsis
double round(double x);

Description
round rounds x to an integral value, with halfway cases rounded away from zero.
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roundf
Synopsis
float roundf(float x);

Description
roundf rounds x to an integral value, with halfway cases rounded away from zero.
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scalbln
Synopsis
double scalbln(double x,
long int exp);

Description
scalbln multiplies x by FLT_RADIX raised to the power exp.
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scalblnf
Synopsis
float scalblnf(float x,
long int exp);

Description
scalblnf multiplies x by FLT_RADIX raised to the power exp.
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scalbn
Synopsis
double scalbn(double x,
int exp);

Description
scalbn multiplies a floating-point number by an integral power of DBL_RADIX.
As floating-point arithmetic conforms to IEC 60559, DBL_RADIX is 2 and scalbn is (in this implementation)
identical to ldexp.
scalbn returns x * DBL_RADIX^exp.
If the result overflows, errno is set to ERANGE and scalbn returns HUGE_VAL.
If x is or NaN, scalbn returns x.
If the result overflows, scalbn returns .

See Also
ldexp
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scalbnf
Synopsis
float scalbnf(float x,
int exp);

Description
scalbnf multiplies a floating-point number by an integral power of FLT_RADIX.
As floating-point arithmetic conforms to IEC 60559, FLT_RADIX is 2 and scalbnf is (in this implementation)
identical to ldexpf.
scalbnf returns x * FLT_RADIX ^exp.
If the result overflows, errno is set to ERANGE and scalbnf returns HUGE_VALF.
If x is or NaN, scalbnf returns x. If the result overflows, scalbnf returns .

See Also
ldexpf
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signbit
Synopsis
#define signbit(x) (sizeof(x) == sizeof(float) ? __float32_signbit(x) : __float64_signbit(x))

Description
signbit macro determines whether the sign of x is negative. signbit returns a non-zero value if and only if x is
negative.
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sin
Synopsis
double sin(double x);

Description
sin returns the radian circular sine of x.
If |x| > 10^9, errno is set to EDOM and sin returns HUGE_VAL.
sin returns x if x is NaN. sin returns NaN if |x| is .
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sinf
Synopsis
float sinf(float x);

Description
sinf returns the radian circular sine of x.
If |x| > 10^9, errno is set to EDOM and sinf returns HUGE_VALF.
sinf returns x if x is NaN. sinf returns NaN if |x| is .
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sinh
Synopsis
double sinh(double x);

Description
sinh calculates the hyperbolic sine of x.
If |x| .782, errno is set to EDOM and sinh returns HUGE_VAL.
If x is +, , or NaN, sinh returns |x|. If |x| > ~709.782, sinh returns + or depending upon the sign of x.
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sinhf
Synopsis
float sinhf(float x);

Description
sinhf calculates the hyperbolic sine of x.
If |x| > ~88.7228, errno is set to EDOM and sinhf returns HUGE_VALF.
If x is +, , or NaN, sinhf returns |x|. If |x| > ~88.7228, sinhf returns + or depending upon the sign of x.
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sqrt
Synopsis
double sqrt(double x);

Description
sqrt computes the nonnegative square root of x. C90 and C99 require that a domain error occurs if the argument
is less than zero sqrt deviates and always uses IEC 60559 semantics.
If x is +0, sqrt returns +0.
If x is 0, sqrt returns 0.
If x is , sqrt returns .
If x < 0, sqrt returns NaN.
If x is NaN, sqrt returns that NaN.
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sqrtf
Synopsis
float sqrtf(float x);

Description
sqrtf computes the nonnegative square root of x. C90 and C99 require that a domain error occurs if the
argument is less than zero sqrtf deviates and always uses IEC 60559 semantics.
If x is +0, sqrtf returns +0.
If x is 0, sqrtf returns 0.
If x is , sqrtf returns .
If x < 0, sqrtf returns NaN.
If x is NaN, sqrtf returns that NaN.
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tan
Synopsis
double tan(double x);

Description
tan returns the radian circular tangent of x.
If |x| > 10^9, errno is set to EDOM and tan returns HUGE_VAL.
If x is NaN, tan returns x. If |x| is , tan returns NaN.
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tanf
Synopsis
float tanf(float x);

Description
tanf returns the radian circular tangent of x.
If |x| > 10^9, errno is set to EDOM and tanf returns HUGE_VALF.
If x is NaN, tanf returns x. If |x| is , tanf returns NaN.
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tanh
Synopsis
double tanh(double x);

Description
tanh calculates the hyperbolic tangent of x.
If x is NaN, tanh returns NaN.
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tanhf
Synopsis
float tanhf(float x);

Description
tanhf calculates the hyperbolic tangent of x.
If x is NaN, tanhf returns NaN.
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tgamma
Synopsis
double tgamma(double x);

Description
tgamma returns the gamma function for x.
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tgammaf
Synopsis
float tgammaf(float x);

Description
tgammaf returns the gamma function for x.
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trunc
Synopsis
double trunc(double x);

Description
trunc rounds x to an integral value that is not larger in magnitude than x.
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truncf
Synopsis
float truncf(float x);

Description
truncf rounds x to an integral value that is not larger in magnitude than x.
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<setjmp.h>
API Summary
Functions
longjmp

Restores the saved environment

setjmp

Save calling environment for non-local jump
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longjmp
Synopsis
void longjmp(jmp_buf env,
int val);

Description
longjmp restores the environment saved by setjmp in the corresponding env argument. If there has been no
such invocation, or if the function containing the invocation of setjmp has terminated execution in the interim,
the behavior of longjmp is undefined.
After longjmp is completed, program execution continues as if the corresponding invocation of setjmp had just
returned the value specified by val.

Note
longjmp cannot cause setjmp to return the value 0; if val is 0, setjmp returns the value 1.
Objects of automatic storage allocation that are local to the function containing the invocation of the
corresponding setjmp that do not have volatile qualified type and have been changed between the setjmp
invocation and this call are indeterminate.
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setjmp
Synopsis
int setjmp(jmp_buf env);

Description
setjmp saves its calling environment in the env for later use by the longjmp function.
On return from a direct invocation setjmp returns the value zero. On return from a call to the longjmp function,
the setjmp returns a nonzero value determined by the call to longjmp.
The environment saved by a call to setjmp consists of information sufficient for a call to the longjmp function to
return execution to the correct block and invocation of that block, were it called recursively.

961

CrossWorks for MSP430 Reference Manual

C Library User Guide

<stdarg.h>
API Summary
Macros
va_arg

Get variable argument value

va_copy

Copy var args

va_end

Finish access to variable arguments

va_start

Start access to variable arguments
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va_arg
Synopsis
type va_arg(va_list ap,
type);

Description
va_arg expands to an expression that has the specified type and the value of the type argument. The ap
parameter must have been initialized by va_start or va_copy, without an intervening invocation of va_end. You
can create a pointer to a va_list and pass that pointer to another function, in which case the original function
may make further use of the original list after the other function returns.
Each invocation of the va_arg macro modifies ap so that the values of successive arguments are returned in
turn. The parameter type must be a type name such that the type of a pointer to an object that has the specified
type can be obtained simply by postfixing a * to type.
If there is no actual next argument, or if type is not compatible with the type of the actual next argument (as
promoted according to the default argument promotions), the behavior of va_arg is undefined, except for the
following cases:
one type is a signed integer type, the other type is the corresponding unsigned integer type, and the
value is representable in both types;
one type is pointer to void and the other is a pointer to a character type.
The first invocation of the va_arg macro after that of the va_start macro returns the value of the argument after
that specified by parmN. Successive invocations return the values of the remaining arguments in succession.
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va_copy
Synopsis
void va_copy(va_list dest,
val_list src);

Description
va_copy initializes dest as a copy of src, as if the va_start macro had been applied to dest followed by the same
sequence of uses of the va_arg macro as had previously been used to reach the present state of src. Neither
the va_copy nor va_start macro shall be invoked to reinitialize dest without an intervening invocation of the
va_end macro for the same dest.
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va_end
Synopsis
void va_end(va_list ap);

Description
va_end indicates a normal return from the function whose variable argument list ap was initialised by va_start
or va_copy. The va_end macro may modify ap so that it is no longer usable without being reinitialized by
va_start or va_copy. If there is no corresponding invocation of va_start or va_copy, or if va_end is not invoked
before the return, the behavior is undefined.
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va_start
Synopsis
void va_start(va_list ap,
paramN);

Description
va_start initializes ap for subsequent use by the va_arg and va_end macros.
The parameter parmN is the identifier of the last fixed parameter in the variable parameter list in the function
definition (the one just before the ', ...').
The behaviour of va_start and va_arg is undefined if the parameter parmN is declared with the register
storage class, with a function or array type, or with a type that is not compatible with the type that results after
application of the default argument promotions.
va_start must be invoked before any access to the unnamed arguments.
va_start and va_copy must not be invoked to reinitialize ap without an intervening invocation of the va_end
macro for the same ap.
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<stddef.h>
API Summary
Macros
NULL

NULL pointer

offsetof

offsetof

Types
max_align_t

max_align_t type

ptrdiff_t

ptrdiff_t type

size_t

size_t type
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NULL
Synopsis
#define NULL 0

Description
NULL is the null pointer constant.

968

CrossWorks for MSP430 Reference Manual

C Library User Guide

max_align_t
Synopsis
typedef long double max_align_t;

Description
max_align_t is a type whose alignment requirement is at least as strict (as large) as that of every scalar type.
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offsetof
Synopsis
#define offsetof(type, member)

Description
offsetof returns the offset in bytes to the structure member, from the beginning of its structure type.
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ptrdiff_t
Synopsis
typedef __RAL_PTRDIFF_T ptrdiff_t;

Description
ptrdiff_t is the signed integral type of the result of subtracting two pointers.
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size_t
Synopsis
typedef __RAL_SIZE_T size_t;

Description
size_t is the unsigned integral type returned by the sizeof operator.
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<stdio.h>
API Summary
Character and string I/O functions
getchar

Read a character from standard input

gets

Read a string from standard input

putchar

Write a character to standard output

puts

Write a string to standard output

Formatted output functions
printf

Write formatted text to standard output

snprintf

Write formatted text to a string with truncation

sprintf

Write formatted text to a string

vprintf

Write formatted text to standard output using variable
argument context

vsnprintf

Write formatted text to a string with truncation using
variable argument context

vsprintf

Write formatted text to a string using variable
argument context

Formatted input functions
scanf

Read formatted text from standard input

sscanf

Read formatted text from string

vscanf

Read formatted text from standard using variable
argument context

vsscanf

Read formatted text from a string using variable
argument context
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getchar
Synopsis
int getchar(void);

Description
getchar reads a single character from the standard input stream.
If the stream is at end-of-file or a read error occurs, getchar returns EOF.
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gets
Synopsis
char *gets(char *s);

Description
gets reads characters from standard input into the array pointed to by s until end-of-file is encountered or a
new-line character is read. Any new-line character is discarded, and a null character is written immediately after
the last character read into the array.
gets returns s if successful. If end-of-file is encountered and no characters have been read into the array, the
contents of the array remain unchanged and gets returns a null pointer. If a read error occurs during the
operation, the array contents are indeterminate and gets returns a null pointer.
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printf
Synopsis
int printf(const char *format,
...);

Description
printf writes to the standard output stream using putchar, under control of the string pointed to by format that
specifies how subsequent arguments are converted for output.
If there are insufficient arguments for the format, the behavior is undefined. If the format is exhausted while
arguments remain, the excess arguments are evaluated but are otherwise ignored.
printf returns the number of characters transmitted, or a negative value if an output or encoding error occurred.

Formatted output control strings
The format is composed of zero or more directives: ordinary characters (not %, which are copied unchanged to
the output stream; and conversion specifications, each of which results in fetching zero or more subsequent
arguments, converting them, if applicable, according to the corresponding conversion specifier, and then
writing the result to the output stream.
Each conversion specification is introduced by the character %. After the % the following appear in sequence:
Zero or more flags (in any order) that modify the meaning of the conversion specification.
An optional minimum field width. If the converted value has fewer characters than the field width, it is
padded with spaces (by default) on the left (or right, if the left adjustment flag has been given) to the field
width. The field width takes the form of an asterisk * or a decimal integer.
An optional precision that gives the minimum number of digits to appear for the d, i, o, u, x, and X
conversions, the number of digits to appear after the decimal-point character for e, E, f, and F conversions,
the maximum number of significant digits for the g and G conversions, or the maximum number of
bytes to be written for s conversions. The precision takes the form of a period . followed either by an
asterisk * or by an optional decimal integer; if only the period is specified, the precision is taken as zero. If
a precision appears with any other conversion specifier, the behavior is undefined.
An optional length modifier that specifies the size of the argument.
A conversion specifier character that specifies the type of conversion to be applied.
As noted above, a field width, or precision, or both, may be indicated by an asterisk. In this case, an int argument
supplies the field width or precision. The arguments specifying field width, or precision, or both, must appear
(in that order) before the argument (if any) to be converted. A negative field width argument is taken as a - flag
followed by a positive field width. A negative precision argument is taken as if the precision were omitted.
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Some library variants do not support width and precision specifiers in order to reduce code and data space
requirements; please ensure that you have selected the correct library in the Printf Width/Precision Support
property of the project if you use these.

Flag characters
The flag characters and their meanings are:

The result of the conversion is left-justified within the field. The default, if this flag is not specified, is that the
result of the conversion is left-justified within the field.

+
The result of a signed conversion always begins with a plus or minus sign. The default, if this flag is not
specified, is that it begins with a sign only when a negative value is converted.

space
If the first character of a signed conversion is not a sign, or if a signed conversion results in no characters, a
space is prefixed to the result. If the space and + flags both appear, the space flag is ignored.

#
The result is converted to an alternative form. For o conversion, it increases the precision, if and only
if necessary, to force the first digit of the result to be a zero (if the value and precision are both zero, a
single 0 is printed). For x or X conversion, a nonzero result has 0x or 0X prefixed to it. For e, E, f, F, g, and G
conversions, the result of converting a floating-point number always contains a decimal-point character,
even if no digits follow it. (Normally, a decimal-point character appears in the result of these conversions
only if a digit follows it.) For g and F conversions, trailing zeros are not removed from the result. As an
extension, when used in p conversion, the results has # prefixed to it. For other conversions, the behavior is
undefined.

0
For d, i, o, u, x, X, e, E, f, F, g, and G conversions, leading zeros (following any indication of sign or base) are
used to pad to the field width rather than performing space padding, except when converting an infinity or
NaN. If the 0 and - flags both appear, the 0 flag is ignored. For d, i, o, u, x, and X conversions, if a precision is
specified, the 0 flag is ignored. For other conversions, the behavior is undefined.

Length modifiers
The length modifiers and their meanings are:

hh
Specifies that a following d, i, o, u, x, or X conversion specifier applies to a signed char or unsigned char
argument (the argument will have been promoted according to the integer promotions, but its value will
be converted to signed char or unsigned char before printing); or that a following n conversion specifier
applies to a pointer to a signed char argument.
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h
Specifies that a following d, i, o, u, x, or X conversion specifier applies to a short int or unsigned short int
argument (the argument will have been promoted according to the integer promotions, but its value is
converted to short int or unsigned short int before printing); or that a following n conversion specifier
applies to a pointer to a short int argument.

l
Specifies that a following d, i, o, u, x, or X conversion specifier applies to a long int or unsigned long int
argument; that a following n conversion specifier applies to a pointer to a long int argument; or has no
effect on a following e, E, f, F, g, or G conversion specifier. Some library variants do not support the l length
modifier in order to reduce code and data space requirements; please ensure that you have selected the
correct library in the Printf Integer Support property of the project if you use this length modifier.

ll
Specifies that a following d, i, o, u, x, or X conversion specifier applies to a long long int or unsigned
long long int argument; that a following n conversion specifier applies to a pointer to a long long int
argument. Some library variants do not support the ll length modifier in order to reduce code and data
space requirements; please ensure that you have selected the correct library in the Printf Integer Support
property of the project if you use this length modifier.
If a length modifier appears with any conversion specifier other than as specified above, the behavior is
undefined. Note that the C99 length modifiers j, z, t, and L are not supported.

Conversion specifiers
The conversion specifiers and their meanings are:

d, i
The argument is converted to signed decimal in the style [-]dddd. The precision specifies the minimum
number of digits to appear; if the value being converted can be represented in fewer digits, it is expanded
with leading spaces. The default precision is one. The result of converting a zero value with a precision of
zero is no characters.

o, u, x, X
The unsigned argument is converted to unsigned octal for o, unsigned decimal for u, or unsigned
hexadecimal notation for x or X in the style dddd the letters abcdef are used for x conversion and the
letters ABCDEF for X conversion. The precision specifies the minimum number of digits to appear; if the
value being converted can be represented in fewer digits, it is expanded with leading spaces. The default
precision is one. The result of converting a zero value with a precision of zero is no characters.

f, F
A double argument representing a floating-point number is converted to decimal notation in the
style [-]ddd.ddd, where the number of digits after the decimal-point character is equal to the precision
specification. If the precision is missing, it is taken as 6; if the precision is zero and the # flag is not specified,
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no decimal-point character appears. If a decimal-point character appears, at least one digit appears before
it. The value is rounded to the appropriate number of digits. A double argument representing an infinity
is converted to inf. A double argument representing a NaN is converted to nan. The F conversion specifier
produces INF or NAN instead of inf or nan, respectively. Some library variants do not support the f and F
conversion specifiers in order to reduce code and data space requirements; please ensure that you have
selected the correct library in the Printf Floating Point Support property of the project if you use these
conversion specifiers.

e, E
A double argument representing a floating-point number is converted in the style [-]d.dddedd, where
there is one digit (which is nonzero if the argument is nonzero) before the decimal-point character and the
number of digits after it is equal to the precision; if the precision is missing, it is taken as 6; if the precision
is zero and the # flag is not specified, no decimal-point character appears. The value is rounded to the
appropriate number of digits. The E conversion specifier produces a number with E instead of e introducing
the exponent. The exponent always contains at least two digits, and only as many more digits as necessary
to represent the exponent. If the value is zero, the exponent is zero. A double argument representing an
infinity is converted to inf. A double argument representing a NaN is converted to nan. The E conversion
specifier produces INF or NAN instead of inf or nan, respectively. Some library variants do not support the
f and F conversion specifiers in order to reduce code and data space requirements; please ensure that you
have selected the correct library in the Printf Floating Point Support} property of the project if you use
these conversion specifiers.

g, G
A double argument representing a floating-point number is converted in style f or e (or in style F or e in
the case of a G conversion specifier), with the precision specifying the number of significant digits. If the
precision is zero, it is taken as one. The style used depends on the value converted; style e (or E) is used only
if the exponent resulting from such a conversion is less than -4 or greater than or equal to the precision.
Trailing zeros are removed from the fractional portion of the result unless the # flag is specified; a decimalpoint character appears only if it is followed by a digit. A double argument representing an infinity is
converted to inf. A double argument representing a NaN is converted to nan. The G conversion specifier
produces INF or NAN instead of inf or nan, respectively. Some library variants do not support the f and F
conversion specifiers in order to reduce code and data space requirements; please ensure that you have
selected the correct library in the Printf Floating Point Support property of the project if you use these
conversion specifiers.

c
The argument is converted to an unsigned char, and the resulting character is written.

s
The argument is be a pointer to the initial element of an array of character type. Characters from the array
are written up to (but not including) the terminating null character. If the precision is specified, no more
than that many characters are written. If the precision is not specified or is greater than the size of the array,
the array must contain a null character.
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p
The argument is a pointer to void. The value of the pointer is converted in the same format as the x
conversion specifier with a fixed precision of 2*sizeof(void *).

n
The argument is a pointer to a signed integer into which is written the number of characters written to the
output stream so far by the call to the formatting function. No argument is converted, but one is consumed.
If the conversion specification includes any flags, a field width, or a precision, the behavior is undefined.

%
A % character is written. No argument is converted.
Note that the C99 width modifier l used in conjunction with the c and s conversion specifiers is not supported
and nor are the conversion specifiers a and A.
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putchar
Synopsis
int putchar(int c);

Description
putchar writes the character c to the standard output stream.
putchar returns the character written. If a write error occurs, putchar returns EOF.
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puts
Synopsis
int puts(const char *s);

Description
puts writes the string pointed to by s to the standard output stream using putchar and appends a new-line
character to the output. The terminating null character is not written.
puts returns EOF if a write error occurs; otherwise it returns a nonnegative value.
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scanf
Synopsis
int scanf(const char *format,
...);

Description
scanf reads input from the standard input stream under control of the string pointed to by format that specifies
the admissible input sequences and how they are to be converted for assignment, using subsequent arguments
as pointers to the objects to receive the converted input.
If there are insufficient arguments for the format, the behavior is undefined. If the format is exhausted while
arguments remain, the excess arguments are evaluated but are otherwise ignored.
scanf returns the value of the macro EOF if an input failure occurs before any conversion. Otherwise, scanf
returns the number of input items assigned, which can be fewer than provided for, or even zero, in the event of
an early matching failure.

Formatted input control strings
The format is composed of zero or more directives: one or more white-space characters, an ordinary character
(neither % nor a white-space character), or a conversion specification.
Each conversion specification is introduced by the character %. After the %, the following appear in sequence:
An optional assignment-suppressing character *.
An optional nonzero decimal integer that specifies the maximum field width (in characters).
An optional length modifier that specifies the size of the receiving object.
A conversion specifier character that specifies the type of conversion to be applied.
The formatted input function executes each directive of the format in turn. If a directive fails, the function
returns. Failures are described as input failures (because of the occurrence of an encoding error or the
unavailability of input characters), or matching failures (because of inappropriate input).
A directive composed of white-space character(s) is executed by reading input up to the first non-white-space
character (which remains unread), or until no more characters can be read.
A directive that is an ordinary character is executed by reading the next characters of the stream. If any of those
characters differ from the ones composing the directive, the directive fails and the differing and subsequent
characters remain unread. Similarly, if end-of-file, an encoding error, or a read error prevents a character from
being read, the directive fails.
A directive that is a conversion specification defines a set of matching input sequences, as described below for
each specifier. A conversion specification is executed in the following steps:
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Input white-space characters (as specified by the isspace function) are skipped, unless the specification
includes a [, c, or n specifier.
An input item is read from the stream, unless the specification includes an n specifier. An input item is
defined as the longest sequence of input characters which does not exceed any specified field width
and which is, or is a prefix of, a matching input sequence. The first character, if any, after the input item
remains unread. If the length of the input item is zero, the execution of the directive fails; this condition is
a matching failure unless end-of-file, an encoding error, or a read error prevented input from the stream,
in which case it is an input failure.
Except in the case of a % specifier, the input item (or, in the case of a %n directive, the count of input
characters) is converted to a type appropriate to the conversion specifier. If the input item is not a
matching sequence, the execution of the directive fails: this condition is a matching failure. Unless
assignment suppression was indicated by a *, the result of the conversion is placed in the object pointed
to by the first argument following the format argument that has not already received a conversion result.
If this object does not have an appropriate type, or if the result of the conversion cannot be represented
in the object, the behavior is undefined.

Length modifiers
The length modifiers and their meanings are:

hh
Specifies that a following d, i, o, u, x, X, or n conversion specifier applies to an argument with type pointer to
signed char or pointer to unsigned char.

h
Specifies that a following d, i, o, u, x, X, or n conversion specifier applies to an argument with type pointer to
short int or unsigned short int.

l
Specifies that a following d, i, o, u, x, X, or n conversion specifier applies to an argument with type pointer to
long int or unsigned long int; that a following e, E, f, F, g, or G conversion specifier applies to an argument
with type pointer to double. Some library variants do not support the l length modifier in order to reduce
code and data space requirements; please ensure that you have selected the correct library in the Printf
Integer Support property of the project if you use this length modifier.

ll
Specifies that a following d, i, o, u, x, X, or n conversion specifier applies to an argument with type pointer to
long long int or unsigned long long int. Some library variants do not support the ll length modifier in order
to reduce code and data space requirements; please ensure that you have selected the correct library in the
Printf Integer Support property of the project if you use this length modifier.
If a length modifier appears with any conversion specifier other than as specified above, the behavior is
undefined. Note that the C99 length modifiers j, z, t, and L are not supported.
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Conversion specifiers
d
Matches an optionally signed decimal integer, whose format is the same as expected for the subject
sequence of the strtol function with the value 10 for the base argument. The corresponding argument
must be a pointer to signed integer.

i
Matches an optionally signed integer, whose format is the same as expected for the subject sequence of the
strtol function with the value zero for the base argument. The corresponding argument must be a pointer
to signed integer.

o
Matches an optionally signed octal integer, whose format is the same as expected for the subject sequence
of the strtol function with the value 18 for the base argument. The corresponding argument must be a
pointer to signed integer.

u
Matches an optionally signed decimal integer, whose format is the same as expected for the subject
sequence of the strtoul function with the value 10 for the base argument. The corresponding argument
must be a pointer to unsigned integer.

x
Matches an optionally signed hexadecimal integer, whose format is the same as expected for the subject
sequence of the strtoul function with the value 16 for the base argument. The corresponding argument
must be a pointer to unsigned integer.

e, f, g
Matches an optionally signed floating-point number whose format is the same as expected for the
subject sequence of the strtod function. The corresponding argument shall be a pointer to floating. Some
library variants do not support the e, f and F conversion specifiers in order to reduce code and data space
requirements; please ensure that you have selected the correct library in the Scanf Floating Point Support
property of the project if you use these conversion specifiers.

c
Matches a sequence of characters of exactly the number specified by the field width (one if no field width
is present in the directive). The corresponding argument must be a pointer to the initial element of a
character array large enough to accept the sequence. No null character is added.

s
Matches a sequence of non-white-space characters The corresponding argument must be a pointer to the
initial element of a character array large enough to accept the sequence and a terminating null character,
which will be added automatically.
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[
Matches a nonempty sequence of characters from a set of expected characters (the scanset). The
corresponding argument must be a pointer to the initial element of a character array large enough to
accept the sequence and a terminating null character, which will be added automatically. The conversion
specifier includes all subsequent characters in the format string, up to and including the matching right
bracket ]. The characters between the brackets (the scanlist) compose the scanset, unless the character after
the left bracket is a circumflex ^, in which case the scanset contains all characters that do not appear in
the scanlist between the circumflex and the right bracket. If the conversion specifier begins with [] or[^],
the right bracket character is in the scanlist and the next following right bracket character is the matching
right bracket that ends the specification; otherwise the first following right bracket character is the one that
ends the specification. If a - character is in the scanlist and is not the first, nor the second where the first
character is a ^, nor the last character, it is treated as a member of the scanset. Some library variants do not
support the [ conversion specifier in order to reduce code and data space requirements; please ensure that
you have selected the correct library in the Scanf Classes Supported property of the project if you use this
conversion specifier.

p
Reads a sequence output by the corresponding %p formatted output conversion. The corresponding
argument must be a pointer to a pointer to void.

n
No input is consumed. The corresponding argument shall be a pointer to signed integer into which is to
be written the number of characters read from the input stream so far by this call to the formatted input
function. Execution of a %n directive does not increment the assignment count returned at the completion
of execution of the fscanf function. No argument is converted, but one is consumed. If the conversion
specification includes an assignment-suppressing character or a field width, the behavior is undefined.

%
Matches a single % character; no conversion or assignment occurs.
Note that the C99 width modifier l used in conjunction with the c, s, and [ conversion specifiers is not supported
and nor are the conversion specifiers a and A.
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snprintf
Synopsis
int snprintf(char *s,
size_t n,
const char *format,
...);

Description
snprintf writes to the string pointed to by s under control of the string pointed to by format that specifies how
subsequent arguments are converted for output.
If n is zero, nothing is written, and s can be a null pointer. Otherwise, output characters beyond the n1st are
discarded rather than being written to the array, and a null character is written at the end of the characters
actually written into the array. A null character is written at the end of the conversion; it is not counted as part of
the returned value.
If there are insufficient arguments for the format, the behavior is undefined. If the format is exhausted while
arguments remain, the excess arguments are evaluated but are otherwise ignored.
If copying takes place between objects that overlap, the behavior is undefined.
snprintf returns the number of characters that would have been written had n been sufficiently large, not
counting the terminating null character, or a negative value if an encoding error occurred. Thus, the nullterminated output has been completely written if and only if the returned value is nonnegative and less than n>.
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sprintf
Synopsis
int sprintf(char *s,
const char *format,
...);

Description
sprintf writes to the string pointed to by s under control of the string pointed to by format that specifies how
subsequent arguments are converted for output. A null character is written at the end of the characters written;
it is not counted as part of the returned value.
If there are insufficient arguments for the format, the behavior is undefined. If the format is exhausted while
arguments remain, the excess arguments are evaluated but are otherwise ignored.
If copying takes place between objects that overlap, the behavior is undefined.
sprintf returns number of characters transmitted (not counting the terminating null), or a negative value if an
output or encoding error occurred.
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sscanf
Synopsis
int sscanf(const char *s,
const char *format,
...);

Description
sscanf reads input from the string s under control of the string pointed to by format that specifies the
admissible input sequences and how they are to be converted for assignment, using subsequent arguments as
pointers to the objects to receive the converted input.
If there are insufficient arguments for the format, the behavior is undefined. If the format is exhausted while
arguments remain, the excess arguments are evaluated but are otherwise ignored.
sscanf returns the value of the macro EOF if an input failure occurs before any conversion. Otherwise, sscanf
returns the number of input items assigned, which can be fewer than provided for, or even zero, in the event of
an early matching failure.
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vprintf
Synopsis
int vprintf(const char *format,
__va_list arg);

Description
vprintf writes to the standard output stream using putchar under control of the string pointed to by format that
specifies how subsequent arguments are converted for output. Before calling vprintf, arg must be initialized by
the va_start macro (and possibly subsequent va_arg calls). vprintf does not invoke the va_end macro.
vprintf returns the number of characters transmitted, or a negative value if an output or encoding error
occurred.

Note
vprintf is equivalent to printf with the variable argument list replaced by arg.
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vscanf
Synopsis
int vscanf(const char *format,
__va_list arg);

Description
vscanf reads input from the standard input stream under control of the string pointed to by format that
specifies the admissible input sequences and how they are to be converted for assignment, using subsequent
arguments as pointers to the objects to receive the converted input. Before calling vscanf, arg must be
initialized by the va_start macro (and possibly subsequent va_arg calls). vscanf does not invoke the va_end
macro.
If there are insufficient arguments for the format, the behavior is undefined.
vscanf returns the value of the macro EOF if an input failure occurs before any conversion. Otherwise, vscanf
returns the number of input items assigned, which can be fewer than provided for, or even zero, in the event of
an early matching failure.

Note
vscanf is equivalent to scanf with the variable argument list replaced arg.
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vsnprintf
Synopsis
int vsnprintf(char *s,
size_t n,
const char *format,
__va_list arg);

Description
vsnprintf writes to the string pointed to by s under control of the string pointed to by format that specifies how
subsequent arguments are converted for output. Before calling vsnprintf, arg must be initialized by the va_start
macro (and possibly subsequent va_arg calls). vsnprintf does not invoke the va_end macro.
If n is zero, nothing is written, and s can be a null pointer. Otherwise, output characters beyond the n1st are
discarded rather than being written to the array, and a null character is written at the end of the characters
actually written into the array. A null character is written at the end of the conversion; it is not counted as part of
the returned value.
If there are insufficient arguments for the format, the behavior is undefined. If the format is exhausted while
arguments remain, the excess arguments are evaluated but are otherwise ignored.
If copying takes place between objects that overlap, the behavior is undefined.
vsnprintf returns the number of characters that would have been written had n been sufficiently large, not
counting the terminating null character, or a negative value if an encoding error occurred. Thus, the nullterminated output has been completely written if and only if the returned value is nonnegative and less than n.

Note
vsnprintf is equivalent to snprintf with the variable argument list replaced by arg.
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vsprintf
Synopsis
int vsprintf(char *s,
const char *format,
__va_list arg);

Description
vsprintf writes to the string pointed to by s under control of the string pointed to by format that specifies how
subsequent arguments are converted for output. Before calling vsprintf, arg must be initialized by the va_start
macro (and possibly subsequent va_arg calls). vsprintf does not invoke the va_end macro.
A null character is written at the end of the characters written; it is not counted as part of the returned value.
If there are insufficient arguments for the format, the behavior is undefined. If the format is exhausted while
arguments remain, the excess arguments are evaluated but are otherwise ignored.
If copying takes place between objects that overlap, the behavior is undefined.
vsprintf returns number of characters transmitted (not counting the terminating null), or a negative value if an
output or encoding error occurred.

Note
vsprintf is equivalent to sprintf with the variable argument list replaced by arg.
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vsscanf
Synopsis
int vsscanf(const char *s,
const char *format,
__va_list arg);

Description
vsscanf reads input from the string s under control of the string pointed to by format that specifies the
admissible input sequences and how they are to be converted for assignment, using subsequent arguments
as pointers to the objects to receive the converted input. Before calling vsscanf, arg must be initialized by the
va_start macro (and possibly subsequent va_arg calls). vsscanf does not invoke the va_end macro.
If there are insufficient arguments for the format, the behavior is undefined.
vsscanf returns the value of the macro EOF if an input failure occurs before any conversion. Otherwise, vsscanf
returns the number of input items assigned, which can be fewer than provided for, or even zero, in the event of
an early matching failure.

Note
vsscanf is equivalent to sscanf with the variable argument list replaced by arg.
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<stdlib.h>
API Summary
Macros
EXIT_FAILURE

EXIT_FAILURE

EXIT_SUCCESS

EXIT_SUCCESS

MB_CUR_MAX

Maximum number of bytes in a multi-byte character in
the current locale

RAND_MAX

RAND_MAX

Types
div_t

Structure containing quotient and remainder after
division of an int

ldiv_t

Structure containing quotient and remainder after
division of a long

lldiv_t

Structure containing quotient and remainder after
division of a long long

Integer arithmetic functions
abs

Return an integer absolute value

div

Divide two ints returning quotient and remainder

labs

Return a long integer absolute value

ldiv

Divide two longs returning quotient and remainder

llabs

Return a long long integer absolute value

lldiv

Divide two long longs returning quotient and
remainder

Memory allocation functions
calloc

Allocate space for an array of objects and initialize
them to zero

free

Frees allocated memory for reuse

malloc

Allocate space for a single object

realloc

Resizes allocated memory space or allocates memory
space

String to number conversions
atof

Convert string to double

atoi

Convert string to int

atol

Convert string to long

atoll

Convert string to long long
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strtod

Convert string to double

strtof

Convert string to float

strtol

Convert string to long

strtoll

Convert string to long long

strtoul

Convert string to unsigned long

strtoull

Convert string to unsigned long long

Pseudo-random sequence generation functions
rand

Return next random number in sequence

srand

Set seed of random number sequence

Search and sort functions
bsearch

Search a sorted array

qsort

Sort an array

Environment
atexit

Set function to be execute on exit

exit

Terminates the calling process

Number to string conversions
itoa

Convert int to string

lltoa

Convert long long to string

ltoa

Convert long to string

ulltoa

Convert unsigned long long to string

ultoa

Convert unsigned long to string

utoa

Convert unsigned to string

Multi-byte/wide character conversion functions
mblen

Determine number of bytes in a multi-byte character

mblen_l

Determine number of bytes in a multi-byte character

Multi-byte/wide string conversion functions
mbstowcs

Convert multi-byte string to wide string

mbstowcs_l

Convert multi-byte string to wide string using
specified locale

mbtowc

Convert multi-byte character to wide character

mbtowc_l

Convert multi-byte character to wide character
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EXIT_FAILURE
Synopsis
#define EXIT_FAILURE

1

Description
EXIT_FAILURE pass to exit on unsuccessful termination.
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EXIT_SUCCESS
Synopsis
#define EXIT_SUCCESS

0

Description
EXIT_SUCCESS pass to exit on successful termination.
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MB_CUR_MAX
Synopsis
#define MB_CUR_MAX

__RAL_mb_max(&__RAL_global_locale)

Description
MB_CUR_MAX expands to a positive integer expression with type size_t that is the maximum number of bytes
in a multi-byte character for the extended character set specified by the current locale (category LC_CTYPE).
MB_CUR_MAX is never greater than MB_LEN_MAX.
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RAND_MAX
Synopsis
#define RAND_MAX 32767

Description
RAND_MAX expands to an integer constant expression that is the maximum value returned by rand.
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abs
Synopsis
int abs(int j);

Description
abs returns the absolute value of the integer argument j.
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atexit
Synopsis
int atexit(void (*func)(void));

Description
atexit registers function to be called when the application has exited. The functions registered with atexit are
executed in reverse order of their registration. atexit returns 0 on success and non-zero on failure.
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atof
Synopsis
double atof(const char *nptr);

Description
atof converts the initial portion of the string pointed to by nptr to a double representation.
atof does not affect the value of errno on an error. If the value of the result cannot be represented, the behavior
is undefined.
Except for the behavior on error, atof is equivalent to strtod(nptr, (char **)NULL).
atof returns the converted value.

See Also
strtod
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atoi
Synopsis
int atoi(const char *nptr);

Description
atoi converts the initial portion of the string pointed to by nptr to an int representation.
atoi does not affect the value of errno on an error. If the value of the result cannot be represented, the behavior
is undefined.
Except for the behavior on error, atoi is equivalent to (int)strtol(nptr, (char **)NULL, 10).
atoi returns the converted value.

See Also
strtol
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atol
Synopsis
long int atol(const char *nptr);

Description
atol converts the initial portion of the string pointed to by nptr to a long int representation.
atol does not affect the value of errno on an error. If the value of the result cannot be represented, the behavior
is undefined.
Except for the behavior on error, atol is equivalent to strtol(nptr, (char **)NULL, 10).
atol returns the converted value.

See Also
strtol
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atoll
Synopsis
long long int atoll(const char *nptr);

Description
atoll converts the initial portion of the string pointed to by nptr to a long long int representation.
atoll does not affect the value of errno on an error. If the value of the result cannot be represented, the behavior
is undefined.
Except for the behavior on error, atoll is equivalent to strtoll(nptr, (char **)NULL, 10).
atoll returns the converted value.

See Also
strtoll
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bsearch
Synopsis
void *bsearch(const void *key,
const void *buf,
size_t num,
size_t size,
int (*compare)(const void *, const void *));

Description
bsearch searches the array *base for the specified *key and returns a pointer to the first entry that matches or
null if no match. The array should have num elements of size bytes and be sorted by the same algorithm as the
compare function.
The compare function should return a negative value if the first parameter is less than second parameter, zero if
the parameters are equal, and a positive value if the first parameter is greater than the second parameter.
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calloc
Synopsis
void *calloc(size_t nobj,
size_t size);

Description
calloc allocates space for an array of nmemb objects, each of whose size is size. The space is initialized to all zero
bits.
calloc returns a null pointer if the space for the array of object cannot be allocated from free memory; if space for
the array can be allocated, calloc returns a pointer to the start of the allocated space.
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div
Synopsis
div_t div(int numer,
int denom);

Description
div computes numer / denom and numer % denom in a single operation.
div returns a structure of type div_t comprising both the quotient and the remainder. The structures contain
the members quot (the quotient) and rem (the remainder), each of which has the same type as the arguments
numer and denom. If either part of the result cannot be represented, the behavior is undefined.

See Also
div_t
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div_t
Description
div_t stores the quotient and remainder returned by div.
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exit
Synopsis
void exit(int exit_code);

Description
exit returns to the startup code and performs the appropriate cleanup process.
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free
Synopsis
void free(void *p);

Description
free causes the space pointed to by ptr to be deallocated, that is, made available for further allocation. If ptr is a
null pointer, no action occurs.
If ptr does not match a pointer earlier returned by calloc, malloc, or realloc, or if the space has been deallocated
by a call to free or realloc, the behavior is undefined.
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itoa
Synopsis
char *itoa(int val,
char *buf,
int radix);

Description
itoa converts val to a string in base radix and places the result in buf.
itoa returns buf as the result.
If radix is greater than 36, the result is undefined.
If val is negative and radix is 10, the string has a leading minus sign (-); for all other values of radix, value is
considered unsigned and never has a leading minus sign.

See Also
ltoa, lltoa, ultoa, ulltoa, utoa
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labs
Synopsis
long int labs(long int j);

Description
labs returns the absolute value of the long integer argument j.
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ldiv
Synopsis
ldiv_t ldiv(long int numer,
long int denom);

Description
ldiv computes numer / denom and numer % denom in a single operation.
ldiv returns a structure of type ldiv_t comprising both the quotient and the remainder. The structures contain
the members quot (the quotient) and rem (the remainder), each of which has the same type as the arguments
numer and denom. If either part of the result cannot be represented, the behavior is undefined.

See Also
ldiv_t
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ldiv_t
Description
ldiv_t stores the quotient and remainder returned by ldiv.
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llabs
Synopsis
long long int llabs(long long int j);

Description
llabs returns the absolute value of the long long integer argument j.
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lldiv
Synopsis
lldiv_t lldiv(long long int numer,
long long int denom);

lldiv computes numer / denom and numer % denom in a single operation.
lldiv returns a structure of type lldiv_t comprising both the quotient and the remainder. The structures contain
the members quot (the quotient) and rem (the remainder), each of which has the same type as the arguments
numer and denom. If either part of the result cannot be represented, the behavior is undefined.

See Also
lldiv_t
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lldiv_t
Description
lldiv_t stores the quotient and remainder returned by lldiv.
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lltoa
Synopsis
char *lltoa(long long val,
char *buf,
int radix);

Description
lltoa converts val to a string in base radix and places the result in buf.
lltoa returns buf as the result.
If radix is greater than 36, the result is undefined.
If val is negative and radix is 10, the string has a leading minus sign (-); for all other values of radix, value is
considered unsigned and never has a leading minus sign.

See Also
itoa, ltoa, ultoa, ulltoa, utoa
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ltoa
Synopsis
char *ltoa(long val,
char *buf,
int radix);

Description
ltoa converts val to a string in base radix and places the result in buf.
ltoa returns buf as the result.
If radix is greater than 36, the result is undefined.
If val is negative and radix is 10, the string has a leading minus sign (-); for all other values of radix, value is
considered unsigned and never has a leading minus sign.

See Also
itoa, lltoa, ultoa, ulltoa, utoa
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malloc
Synopsis
void *malloc(size_t size);

Description
malloc allocates space for an object whose size is specified by 'b size and whose value is indeterminate.
malloc returns a null pointer if the space for the object cannot be allocated from free memory; if space for the
object can be allocated, malloc returns a pointer to the start of the allocated space.
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mblen
Synopsis
int mblen(const char *s,
size_t n);

Description
mblen determines the number of bytes contained in the multi-byte character pointed to by s in the current
locale.
If s is a null pointer, mblen returns a nonzero or zero value, if multi-byte character encodings, respectively, do or
do not have state-dependent encodings
If s is not a null pointer, mblen either returns 0 (if s points to the null character), or returns the number of bytes
that are contained in the multi-byte character (if the next n or fewer bytes form a valid multi-byte character), or
returns 1 (if they do not form a valid multi-byte character).

Note
Except that the conversion state of the mbtowc function is not affected, it is equivalent to
mbtowc((wchar_t *)0, s, n);

Note
It is guaranteed that no library function in the Standard C library calls mblen.

See Also
mblen_l, mbtowc
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mblen_l
Synopsis
int mblen_l(const char *s,
size_t n,
__locale_s *loc);

Description
mblen_l determines the number of bytes contained in the multi-byte character pointed to by s in the locale loc.
If s is a null pointer, mblen_l returns a nonzero or zero value, if multi-byte character encodings, respectively, do
or do not have state-dependent encodings
If s is not a null pointer, mblen_l either returns 0 (if s points to the null character), or returns the number of bytes
that are contained in the multi-byte character (if the next n or fewer bytes form a valid multi-byte character), or
returns 1 (if they do not form a valid multi-byte character).

Note
Except that the conversion state of the mbtowc_l function is not affected, it is equivalent to
mbtowc((wchar_t *)0, s, n, loc);

Note
It is guaranteed that no library function in the Standard C library calls mblen_l.

See Also
mblen_l, mbtowc_l
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mbstowcs
Synopsis
size_t mbstowcs(wchar_t *pwcs,
const char *s,
size_t n);

Description
mbstowcs converts a sequence of multi-byte characters that begins in the initial shift state from the array
pointed to by s into a sequence of corresponding wide characters and stores not more than n wide characters
into the array pointed to by pwcs.
No multi-byte characters that follow a null character (which is converted into a null wide character) will be
examined or converted. Each multi-byte character is converted as if by a call to the mbtowc function, except that
the conversion state of the mbtowc function is not affected.
No more than n elements will be modified in the array pointed to by pwcs. If copying takes place between
objects that overlap, the behavior is undefined.
mbstowcs returns 1 if an invalid multi-byte character is encountered, otherwise mbstowcs returns the number
of array elements modified (if any), not including a terminating null wide character.
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mbstowcs_l
Synopsis
size_t mbstowcs_l(wchar_t *pwcs,
const char *s,
size_t n,
__locale_s *loc);

Description
mbstowcs_l is as mbstowcs except that the local loc is used for the conversion as opposed to the current locale.

See Also
mbstowcs.
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mbtowc
Synopsis
int mbtowc(wchar_t *pwc,
const char *s,
size_t n);

Description
mbtowc converts a single multi-byte character to a wide character in the current locale.
If s is a null pointer, mbtowc returns a nonzero value if multi-byte character encodings are state-dependent in
the current locale, and zero otherwise.
If s is not null and the object that s points to is a wide-character null character, mbtowc returns 0.
If s is not null and the object that points to forms a valid multi-byte character, mbtowc returns the length in
bytes of the multi-byte character.
If the object that points to does not form a valid multi-byte character within the first n characters, it returns 1.

See Also
mbtowc_l
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mbtowc_l
Synopsis
int mbtowc_l(wchar_t *pwc,
const char *s,
size_t n,
__locale_s *loc);

Description
mbtowc_l converts a single multi-byte character to a wide character in locale loc.
If s is a null pointer, mbtowc_l returns a nonzero value if multi-byte character encodings are state-dependent in
the locale loc, and zero otherwise.
If s is not null and the object that s points to is a wide-character null character, mbtowc_l returns 0.
If s is not null and the object that points to forms a valid multi-byte character, mbtowc_l returns the length in
bytes of the multi-byte character.
If the object that s points to does not form a valid multi-byte character within the first n characters, it returns 1.

See Also
mbtowc
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qsort
Synopsis
void qsort(void *buf,
size_t num,
size_t size,
int (*compare)(const void *, const void *));

qsort sorts the array *base using the compare function. The array should have num elements of size bytes. The
compare function should return a negative value if the first parameter is less than second parameter, zero if the
parameters are equal and a positive value if the first parameter is greater than the second parameter.
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rand
Synopsis
int rand(void);

Description
rand computes a sequence of pseudo-random integers in the range 0 to RAND_MAX.
rand returns the computed pseudo-random integer.

1030

CrossWorks for MSP430 Reference Manual

C Library User Guide

realloc
Synopsis
void *realloc(void *p,
size_t size);

Description
realloc deallocates the old object pointed to by ptr and returns a pointer to a new object that has the size
specified by size. The contents of the new object is identical to that of the old object prior to deallocation,
up to the lesser of the new and old sizes. Any bytes in the new object beyond the size of the old object have
indeterminate values.
If ptr is a null pointer, realloc behaves like realloc for the specified size. If memory for the new object cannot be
allocated, the old object is not deallocated and its value is unchanged.
realloc returns a pointer to the new object (which may have the same value as a pointer to the old object), or a
null pointer if the new object could not be allocated.
If ptr does not match a pointer earlier returned by calloc, malloc, or realloc, or if the space has been deallocated
by a call to free or realloc, the behavior is undefined.
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srand
Synopsis
void srand(unsigned int seed);

Description
srand uses the argument seed as a seed for a new sequence of pseudo-random numbers to be returned by
subsequent calls to rand. If srand is called with the same seed value, the same sequence of pseudo-random
numbers is generated.
If rand is called before any calls to srand have been made, a sequence is generated as if srand is first called with
a seed value of 1.

See Also
rand
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strtod
Synopsis
double strtod(const char *nptr,
char **endptr);

Description
strtod converts the initial portion of the string pointed to by nptr to a double representation.
First, strtod decomposes the input string into three parts: an initial, possibly empty, sequence of white-space
characters (as specified by isspace), a subject sequence resembling a floating-point constant, and a final string
of one or more unrecognized characters, including the terminating null character of the input string. strtod then
attempts to convert the subject sequence to a floating-point number, and return the result.
The subject sequence is defined as the longest initial subsequence of the input string, starting with the first nonwhite-space character, that is of the expected form. The subject sequence contains no characters if the input
string is empty or consists entirely of white space, or if the first non-white-space character is other than a sign or
a permissible letter or digit.
The expected form of the subject sequence is an optional plus or minus sign followed by a nonempty sequence
of decimal digits optionally containing a decimal-point character, then an optional exponent part.
If the subject sequence begins with a minus sign, the value resulting from the conversion is negated.
A pointer to the final string is stored in the object pointed to by strtod, provided that endptr is not a null
pointer.
If the subject sequence is empty or does not have the expected form, no conversion is performed, the value of
nptr is stored in the object pointed to by endptr, provided that endptr is not a null pointer.
strtod returns the converted value, if any. If no conversion could be performed, zero is returned. If the correct
value is outside the range of representable values, HUGE_VAL is returned according to the sign of the value, if
any, and the value of the macro errno is stored in errno.
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strtof
Synopsis
float strtof(const char *nptr,
char **endptr);

Description
strtof converts the initial portion of the string pointed to by nptr to a double representation.
First, strtof decomposes the input string into three parts: an initial, possibly empty, sequence of white-space
characters (as specified by isspace), a subject sequence resembling a floating-point constant, and a final string
of one or more unrecognized characters, including the terminating null character of the input string. strtof then
attempts to convert the subject sequence to a floating-point number, and return the result.
The subject sequence is defined as the longest initial subsequence of the input string, starting with the first nonwhite-space character, that is of the expected form. The subject sequence contains no characters if the input
string is empty or consists entirely of white space, or if the first non-white-space character is other than a sign or
a permissible letter or digit.
The expected form of the subject sequence is an optional plus or minus sign followed by a nonempty sequence
of decimal digits optionally containing a decimal-point character, then an optional exponent part.
If the subject sequence begins with a minus sign, the value resulting from the conversion is negated. A pointer
to the final string is stored in the object pointed to by endptr, provided that endptr is not a null pointer.
If the subject sequence is empty or does not have the expected form, no conversion is performed, the value of
nptr is stored in the object pointed to by endptr, provided that endptr is not a null pointer.
strtof returns the converted value, if any. If no conversion could be performed, zero is returned. If the correct
value is outside the range of representable values, HUGE_VALF is returned according to the sign of the value, if
any, and the value of the macro errno is stored in errno.
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strtol
Synopsis
long int strtol(const char *nptr,
char **endptr,
int base);

Description
strtol converts the initial portion of the string pointed to by nptr to a long int representation.
First, strtol decomposes the input string into three parts: an initial, possibly empty, sequence of white-space
characters (as specified by isspace), a subject sequence resembling an integer represented in some radix
determined by the value of base, and a final string of one or more unrecognized characters, including the
terminating null character of the input string. strtol then attempts to convert the subject sequence to an integer,
and return the result.
When converting, no integer suffix (such as U, L, UL, LL, ULL) is allowed.
If the value of base is zero, the expected form of the subject sequence is an optional plus or minus sign followed
by an integer constant.
If the value of base is between 2 and 36 (inclusive), the expected form of the subject sequence is an optional
plus or minus sign followed by a sequence of letters and digits representing an integer with the radix specified
by base. The letters from a (or A) through z (or Z) represent the values 10 through 35; only letters and digits
whose ascribed values are less than that of base are permitted.
If the value of base is 16, the characters 0x or 0X may optionally precede the sequence of letters and digits,
following the optional sign.
The subject sequence is defined as the longest initial subsequence of the input string, starting with the first nonwhite-space character, that is of the expected form. The subject sequence contains no characters if the input
string is empty or consists entirely of white space, or if the first non-white-space character is other than a sign or
a permissible letter or digit.
If the subject sequence has the expected form and the value of base is zero, the sequence of characters starting
with the first digit is interpreted as an integer constant. If the subject sequence has the expected form and the
value of base is between 2 and 36, it is used as the base for conversion.
If the subject sequence begins with a minus sign, the value resulting from the conversion is negated.
A pointer to the final string is stored in the object pointed to by endptr, provided that endptr is not a null
pointer.
If the subject sequence is empty or does not have the expected form, no conversion is performed, the value of
nptr is stored in the object pointed to by endptr, provided that endptr is not a null pointer.
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strtol returns the converted value, if any. If no conversion could be performed, zero is returned. If the correct
value is outside the range of representable values, LONG_MIN or LONG_MAX is returned according to the sign
of the value, if any, and the value of the macro errno is stored in errno.
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strtoll
Synopsis
long long int strtoll(const char *nptr,
char **endptr,
int base);

Description
strtoll converts the initial portion of the string pointed to by nptr to a long int representation.
First, strtoll decomposes the input string into three parts: an initial, possibly empty, sequence of white-space
characters (as specified by isspace), a subject sequence resembling an integer represented in some radix
determined by the value of base, and a final string of one or more unrecognized characters, including the
terminating null character of the input string. strtoll then attempts to convert the subject sequence to an
integer, and return the result.
When converting, no integer suffix (such as U, L, UL, LL, ULL) is allowed.
If the value of base is zero, the expected form of the subject sequence is an optional plus or minus sign followed
by an integer constant.
If the value of base is between 2 and 36 (inclusive), the expected form of the subject sequence is an optional
plus or minus sign followed by a sequence of letters and digits representing an integer with the radix specified
by base. The letters from a (or A) through z (or Z) represent the values 10 through 35; only letters and digits
whose ascribed values are less than that of base are permitted.
If the value of base is 16, the characters 0x or 0X may optionally precede the sequence of letters and digits,
following the optional sign.
The subject sequence is defined as the longest initial subsequence of the input string, starting with the first nonwhite-space character, that is of the expected form. The subject sequence contains no characters if the input
string is empty or consists entirely of white space, or if the first non-white-space character is other than a sign or
a permissible letter or digit.
If the subject sequence has the expected form and the value of base is zero, the sequence of characters starting
with the first digit is interpreted as an integer constant. If the subject sequence has the expected form and the
value of base is between 2 and 36, it is used as the base for conversion.
If the subject sequence begins with a minus sign, the value resulting from the conversion is negated.
A pointer to the final string is stored in the object pointed to by endptr, provided that endptr is not a null
pointer.
If the subject sequence is empty or does not have the expected form, no conversion is performed, the value of
nptr is stored in the object pointed to by endptr, provided that endptr is not a null pointer.
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strtoll returns the converted value, if any. If no conversion could be performed, zero is returned. If the correct
value is outside the range of representable values, LLONG_MIN or LLONG_MAX is returned according to the
sign of the value, if any, and the value of the macro ERANGE is stored in errno.
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strtoul
Synopsis
unsigned long int strtoul(const char *nptr,
char **endptr,
int base);

Description
strtoul converts the initial portion of the string pointed to by nptr to a long int representation.
First, strtoul decomposes the input string into three parts: an initial, possibly empty, sequence of white-space
characters (as specified by isspace), a subject sequence resembling an integer represented in some radix
determined by the value of base, and a final string of one or more unrecognized characters, including the
terminating null character of the input string. strtoul then attempts to convert the subject sequence to an
integer, and return the result.
When converting, no integer suffix (such as U, L, UL, LL, ULL) is allowed.
If the value of base is zero, the expected form of the subject sequence is an optional plus or minus sign followed
by an integer constant.
If the value of base is between 2 and 36 (inclusive), the expected form of the subject sequence is an optional
plus or minus sign followed by a sequence of letters and digits representing an integer with the radix specified
by base. The letters from a (or A) through z (or Z) represent the values 10 through 35; only letters and digits
whose ascribed values are less than that of base are permitted.
If the value of base is 16, the characters 0x or 0X may optionally precede the sequence of letters and digits,
following the optional sign.
The subject sequence is defined as the longest initial subsequence of the input string, starting with the first nonwhite-space character, that is of the expected form. The subject sequence contains no characters if the input
string is empty or consists entirely of white space, or if the first non-white-space character is other than a sign or
a permissible letter or digit.
If the subject sequence has the expected form and the value of base is zero, the sequence of characters starting
with the first digit is interpreted as an integer constant. If the subject sequence has the expected form and the
value of base is between 2 and 36, it is used as the base for conversion.
If the subject sequence begins with a minus sign, the value resulting from the conversion is negated.
A pointer to the final string is stored in the object pointed to by endptr, provided that endptr is not a null
pointer.
If the subject sequence is empty or does not have the expected form, no conversion is performed, the value of
nptr is stored in the object pointed to by endptr, provided that endptr is not a null pointer.
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strtoul returns the converted value, if any. If no conversion could be performed, zero is returned. If the correct
value is outside the range of representable values, LONG_MAX or ULONG_MAX is returned according to the
sign of the value, if any, and the value of the macro ERANGE is stored in errno.
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strtoull
Synopsis
unsigned long long int strtoull(const char *nptr,
char **endptr,
int base);

Description
strtoull converts the initial portion of the string pointed to by nptr to a long int representation.
First, strtoull decomposes the input string into three parts: an initial, possibly empty, sequence of white-space
characters (as specified by isspace), a subject sequence resembling an integer represented in some radix
determined by the value of base, and a final string of one or more unrecognized characters, including the
terminating null character of the input string. strtoull then attempts to convert the subject sequence to an
integer, and return the result.
When converting, no integer suffix (such as U, L, UL, LL, ULL) is allowed.
If the value of base is zero, the expected form of the subject sequence is an optional plus or minus sign followed
by an integer constant.
If the value of base is between 2 and 36 (inclusive), the expected form of the subject sequence is an optional
plus or minus sign followed by a sequence of letters and digits representing an integer with the radix specified
by base. The letters from a (or A) through z (or Z) represent the values 10 through 35; only letters and digits
whose ascribed values are less than that of base are permitted.
If the value of base is 16, the characters 0x or 0X may optionally precede the sequence of letters and digits,
following the optional sign.
The subject sequence is defined as the longest initial subsequence of the input string, starting with the first nonwhite-space character, that is of the expected form. The subject sequence contains no characters if the input
string is empty or consists entirely of white space, or if the first non-white-space character is other than a sign or
a permissible letter or digit.
If the subject sequence has the expected form and the value of base is zero, the sequence of characters starting
with the first digit is interpreted as an integer constant. If the subject sequence has the expected form and the
value of base is between 2 and 36, it is used as the base for conversion.
If the subject sequence begins with a minus sign, the value resulting from the conversion is negated.
A pointer to the final string is stored in the object pointed to by endptr, provided that endptr is not a null
pointer.
If the subject sequence is empty or does not have the expected form, no conversion is performed, the value of
nptr is stored in the object pointed to by endptr, provided that endptr is not a null pointer.
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strtoull returns the converted value, if any. If no conversion could be performed, zero is returned. If the correct
value is outside the range of representable values, LLONG_MAX or ULLONG_MAX is returned according to the
sign of the value, if any, and the value of the macro ERANGE is stored in errno.
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ulltoa
Synopsis
char *ulltoa(unsigned long long val,
char *buf,
int radix);

Description
ulltoa converts val to a string in base radix and places the result in buf.
ulltoa returns buf as the result.
If radix is greater than 36, the result is undefined.

See Also
itoa, ltoa, lltoa, ultoa, utoa
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ultoa
Synopsis
char *ultoa(unsigned long val,
char *buf,
int radix);

Description
ultoa converts val to a string in base radix and places the result in buf.
ultoa returns buf as the result.
If radix is greater than 36, the result is undefined.

See Also
itoa, ltoa, lltoa, ulltoa, utoa
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utoa
Synopsis
char *utoa(unsigned val,
char *buf,
int radix);

Description
utoa converts val to a string in base radix and places the result in buf.
utoa returns buf as the result.
If radix is greater than 36, the result is undefined.

See Also
itoa, ltoa, lltoa, ultoa, ulltoa
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<string.h>
Overview
The header file <string.h> defines functions that operate on arrays that are interpreted as null-terminated
strings.
Various methods are used for determining the lengths of the arrays, but in all cases a char * or void * argument
points to the initial (lowest addressed) character of the array. If an array is accessed beyond the end of an object,
the behavior is undefined.
Where an argument declared as size_t n specifies the length of an array for a function, n can have the value zero
on a call to that function. Unless explicitly stated otherwise in the description of a particular function, pointer
arguments must have valid values on a call with a zero size. On such a call, a function that locates a character
finds no occurrence, a function that compares two character sequences returns zero, and a function that copies
characters copies zero characters.

API Summary
Copying functions
memccpy

Copy memory with specified terminator (POSIX
extension)

memcpy

Copy memory

memcpy_fast

Copy memory

memmove

Safely copy overlapping memory

mempcpy

Copy memory (GNU extension)

strcat

Concatenate strings

strcpy

Copy string

strdup

Duplicate string (POSIX extension)

strlcat

Copy string up to a maximum length with terminator
(BSD extension)

strlcpy

Copy string up to a maximum length with terminator
(BSD extension)

strncat

Concatenate strings up to maximum length

strncpy

Copy string up to a maximum length

strndup

Duplicate string (POSIX extension)

Comparison functions
memcmp

Compare memory

strcasecmp

Compare strings ignoring case (POSIX extension)
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strcmp

Compare strings

strncasecmp

Compare strings up to a maximum length ignoring
case (POSIX extension)

strncmp

Compare strings up to a maximum length

Search functions
memchr

Search memory for a character

strcasestr

Find first case-insensitive occurrence of a string within
string

strchr

Find character within string

strcspn

Compute size of string not prefixed by a set of
characters

strncasestr

Find first case-insensitive occurrence of a string within
length-limited string

strnchr

Find character in a length-limited string

strnlen

Calculate length of length-limited string (POSIX
extension)

strnstr

Find first occurrence of a string within length-limited
string

strpbrk

Find first occurrence of characters within string

strrchr

Find last occurrence of character within string

strsep

Break string into tokens (4.4BSD extension)

strspn

Compute size of string prefixed by a set of characters

strstr

Find first occurrence of a string within string

strtok

Break string into tokens

strtok_r

Break string into tokens, reentrant version (POSIX
extension)

Miscellaneous functions
memset

Set memory to character

strerror

Decode error code

strlen

Calculate length of string
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memccpy
Synopsis
void *memccpy(void *s1,
const void *s2,
int c,
size_t n);

Description
memccpy copies at most n characters from the object pointed to by s2 into the object pointed to by s1. The
copying stops as soon as n characters are copied or the character c is copied into the destination object pointed
to by s1. The behavior of memccpy is undefined if copying takes place between objects that overlap.
memccpy returns a pointer to the character immediately following c in s1, or NULL if c was not found in the first
n characters of s2.

Note
memccpy conforms to POSIX.1-2008.
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memchr
Synopsis
void *memchr(const void *s,
int c,
size_t n);

Description
memchr locates the first occurrence of c (converted to an unsigned char) in the initial n characters (each
interpreted as unsigned char) of the object pointed to by s. Unlike strchr, memchr does not terminate a search
when a null character is found in the object pointed to by s.
memchr returns a pointer to the located character, or a null pointer if c does not occur in the object.
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memcmp
Synopsis
int memcmp(const void *s1,
const void *s2,
size_t n);

Description
memcmp compares the first n characters of the object pointed to by s1 to the first n characters of the object
pointed to by s2. memcmp returns an integer greater than, equal to, or less than zero as the object pointed to
by s1 is greater than, equal to, or less than the object pointed to by s2.
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memcpy
Synopsis
void *memcpy(void *s1,
const void *s2,
size_t n);

Description
memcpy copies n characters from the object pointed to by s2 into the object pointed to by s1. The behavior of
memcpy is undefined if copying takes place between objects that overlap.
memcpy returns the value of s1.
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memcpy_fast
Synopsis
void *memcpy_fast(void *s1,
const void *s2,
size_t n);

Description
memcpy_fast copies n characters from the object pointed to by s2 into the object pointed to by s1. The
behavior of memcpy_fast is undefined if copying takes place between objects that overlap. The implementation
of memcpy_fast is optimized for speed for all cases of memcpy and as such has a large code memory
requirement. This function is implemented for little-endian ARM and 32-bit Thumb-2 instruction sets only.
memcpy_fast returns the value of s1.
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memmove
Synopsis
void *memmove(void *s1,
const void *s2,
size_t n);

Description
memmove copies n characters from the object pointed to by s2 into the object pointed to by s1 ensuring that
if s1 and s2 overlap, the copy works correctly. Copying takes place as if the n characters from the object pointed
to by s2 are first copied into a temporary array of n characters that does not overlap the objects pointed to by s1
and s2, and then the n characters from the temporary array are copied into the object pointed to by s1.
memmove returns the value of s1.
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mempcpy
Synopsis
void *mempcpy(void *s1,
const void *s2,
size_t n);

Description
mempcpy copies n characters from the object pointed to by s2 into the object pointed to by s1. The behavior of
mempcpy is undefined if copying takes place between objects that overlap.
mempcpy returns a pointer to the byte following the last written byte.

Note
This is an extension found in GNU libc.
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memset
Synopsis
void *memset(void *s,
int c,
size_t n);

Description
memset copies the value of c (converted to an unsigned char) into each of the first n characters of the object
pointed to by s.
memset returns the value of s.
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strcasecmp
Synopsis
int strcasecmp(const char *s1,
const char *s2);

Description
strcasecmp compares the string pointed to by s1 to the string pointed to by s2 ignoring differences in case.
strcasecmp returns an integer greater than, equal to, or less than zero if the string pointed to by s1 is greater
than, equal to, or less than the string pointed to by s2.

Note
strcasecmp conforms to POSIX.1-2008.
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strcasestr
Synopsis
char *strcasestr(const char *s1,
const char *s2);

Description
strcasestr locates the first occurrence in the string pointed to by s1 of the sequence of characters (excluding the
terminating null character) in the string pointed to by s2 without regard to character case.
strcasestr returns a pointer to the located string, or a null pointer if the string is not found. If s2 points to a string
with zero length, strcasestr returns s1.

Note
strcasestr is an extension commonly found in Linux and BSD C libraries.
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strcat
Synopsis
char *strcat(char *s1,
const char *s2);

Description
strcat appends a copy of the string pointed to by s2 (including the terminating null character) to the end of the
string pointed to by s1. The initial character of s2 overwrites the null character at the end of s1. The behavior of
strcat is undefined if copying takes place between objects that overlap.
strcat returns the value of s1.
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strchr
Synopsis
char *strchr(const char *s,
int c);

Description
strchr locates the first occurrence of c (converted to a char) in the string pointed to by s. The terminating null
character is considered to be part of the string.
strchr returns a pointer to the located character, or a null pointer if c does not occur in the string.
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strcmp
Synopsis
int strcmp(const char *s1,
const char *s2);

Description
strcmp compares the string pointed to by s1 to the string pointed to by s2. strcmp returns an integer greater
than, equal to, or less than zero if the string pointed to by s1 is greater than, equal to, or less than the string
pointed to by s2.
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strcpy
Synopsis
char *strcpy(char *s1,
const char *s2);

Description
strcpy copies the string pointed to by s2 (including the terminating null character) into the array pointed to by
s1. The behavior of strcpy is undefined if copying takes place between objects that overlap.
strcpy returns the value of s1.
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strcspn
Synopsis
size_t strcspn(const char *s1,
const char *s2);

Description
strcspn computes the length of the maximum initial segment of the string pointed to by s1 which consists
entirely of characters not from the string pointed to by s2.
strcspn returns the length of the segment.
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strdup
Synopsis
char *strdup(const char *s1);

Description
strdup duplicates the string pointed to by s1 by using malloc to allocate memory for a copy of s and then
copying s, including the terminating null, to that memory strdup returns a pointer to the new string or a null
pointer if the new string cannot be created. The returned pointer can be passed to free.

Note
strdup conforms to POSIX.1-2008 and SC22 TR 24731-2.

1063

CrossWorks for MSP430 Reference Manual

C Library User Guide

strerror
Synopsis
char *strerror(int num);

Description
strerror maps the number in num to a message string. Typically, the values for num come from errno, but
strerror can map any value of type int to a message.
strerror returns a pointer to the message string. The program must not modify the returned message string. The
message may be overwritten by a subsequent call to strerror.

1064

CrossWorks for MSP430 Reference Manual

C Library User Guide

strlcat
Synopsis
size_t strlcat(char *s1,
const char *s2,
size_t n);

Description
strlcat appends no more than nstrlen(dst)1 characters pointed to by s2 into the array pointed to by s1 and
always terminates the result with a null character if n is greater than zero. Both the strings s1 and s2 must be
terminated with a null character on entry to strlcat and a byte for the terminating null should be included in n.
The behavior of strlcat is undefined if copying takes place between objects that overlap.
strlcat returns the number of characters it tried to copy, which is the sum of the lengths of the strings s1 and s2
or n, whichever is smaller.

Note
strlcat is commonly found in OpenBSD libraries.
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strlcpy
Synopsis
size_t strlcpy(char *s1,
const char *s2,
size_t n);

Description
strlcpy copies up to n1 characters from the string pointed to by s2 into the array pointed to by s1 and always
terminates the result with a null character. The behavior of strlcpy is undefined if copying takes place between
objects that overlap.
strlcpy returns the number of characters it tried to copy, which is the length of the string s2 or n, whichever is
smaller.

Note
strlcpy is commonly found in OpenBSD libraries and contrasts with strncpy in that the resulting string is always
terminated with a null character.
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strlen
Synopsis
size_t strlen(const char *s);

Description
strlen returns the length of the string pointed to by s, that is the number of characters that precede the
terminating null character.
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strncasecmp
Synopsis
int strncasecmp(const char *s1,
const char *s2,
size_t n);

Description
strncasecmp compares not more than n characters from the array pointed to by s1 to the array pointed to by s2
ignoring differences in case. Characters that follow a null character are not compared.
strncasecmp returns an integer greater than, equal to, or less than zero, if the possibly null-terminated array
pointed to by s1 is greater than, equal to, or less than the possibly null-terminated array pointed to by s2.

Note
strncasecmp conforms to POSIX.1-2008.
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strncasestr
Synopsis
char *strncasestr(const char *s1,
const char *s2,
size_t n);

Description
strncasestr searches at most n characters to locate the first occurrence in the string pointed to by s1 of the
sequence of characters (excluding the terminating null character) in the string pointed to by s2 without regard
to character case.
strncasestr returns a pointer to the located string, or a null pointer if the string is not found. If s2 points to a
string with zero length, strncasestr returns s1.

Note
strncasestr is an extension commonly found in Linux and BSD C libraries.
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strncat
Synopsis
char *strncat(char *s1,
const char *s2,
size_t n);

Description
strncat appends not more than n characters from the array pointed to by s2 to the end of the string pointed to
by s1. A null character in s1 and characters that follow it are not appended. The initial character of s2 overwrites
the null character at the end of s1. A terminating null character is always appended to the result. The behavior of
strncat is undefined if copying takes place between objects that overlap.
strncat returns the value of s1.
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strnchr
Synopsis
char *strnchr(const char *str,
size_t n,
int ch);

Description
strnchr searches not more than n characters to locate the first occurrence of c (converted to a char) in the string
pointed to by s. The terminating null character is considered to be part of the string.
strnchr returns a pointer to the located character, or a null pointer if c does not occur in the string.
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strncmp
Synopsis
int strncmp(const char *s1,
const char *s2,
size_t n);

Description
strncmp compares not more than n characters from the array pointed to by s1 to the array pointed to by s2.
Characters that follow a null character are not compared.
strncmp returns an integer greater than, equal to, or less than zero, if the possibly null-terminated array pointed
to by s1 is greater than, equal to, or less than the possibly null-terminated array pointed to by s2.
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strncpy
Synopsis
char *strncpy(char *s1,
const char *s2,
size_t n);

Description
strncpy copies not more than n characters from the array pointed to by s2 to the array pointed to by s1.
Characters that follow a null character in s2 are not copied. The behavior of strncpy is undefined if copying takes
place between objects that overlap. If the array pointed to by s2 is a string that is shorter than n characters, null
characters are appended to the copy in the array pointed to by s1, until n characters in all have been written.
strncpy returns the value of s1.

Note
No null character is implicitly appended to the end of s1, so s1 will only be terminated by a null character if the
length of the string pointed to by s2 is less than n.
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strndup
Synopsis
char *strndup(const char *s1,
size_t n);

Description
strndup duplicates at most n characters from the the string pointed to by s1 by using malloc to allocate memory
for a copy of s1.
If the length of string pointed to by s1 is greater than n characters, only n characters will be duplicated. If n is
greater than the length of string pointed to by s1, all characters in the string are copied into the allocated array
including the terminating null character.
strndup returns a pointer to the new string or a null pointer if the new string cannot be created. The returned
pointer can be passed to free.

Note
strndup conforms to POSIX.1-2008 and SC22 TR 24731-2.
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strnlen
Synopsis
size_t strnlen(const char *s,
size_t n);

Description
strnlen returns the length of the string pointed to by s, up to a maximum of n characters. strnlen only examines
the first n characters of the string s.

Note
strnlen conforms to POSIX.1-2008.
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strnstr
Synopsis
char *strnstr(const char *s1,
const char *s2,
size_t n);

Description
strnstr searches at most n characters to locate the first occurrence in the string pointed to by s1 of the sequence
of characters (excluding the terminating null character) in the string pointed to by s2.
strnstr returns a pointer to the located string, or a null pointer if the string is not found. If s2 points to a string
with zero length, strnstr returns s1.

Note
strnstr is an extension commonly found in Linux and BSD C libraries.
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strpbrk
Synopsis
char *strpbrk(const char *s1,
const char *s2);

Description
strpbrk locates the first occurrence in the string pointed to by s1 of any character from the string pointed to by
s2.
strpbrk returns a pointer to the character, or a null pointer if no character from s2 occurs in s1.
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strrchr
Synopsis
char *strrchr(const char *s,
int c);

Description
strrchr locates the last occurrence of c (converted to a char) in the string pointed to by s. The terminating null
character is considered to be part of the string.
strrchr returns a pointer to the character, or a null pointer if c does not occur in the string.
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strsep
Synopsis
char *strsep(char **stringp,
const char *delim);

Description
strsep locates, in the string referenced by *stringp, the first occurrence of any character in the string delim (or
the terminating null character) and replaces it with a null character. The location of the next character after the
delimiter character (or NULL, if the end of the string was reached) is stored in *stringp. The original value of
*stringp is returned.
An empty field (that is, a character in the string delim occurs as the first character of *stringp can be detected by
comparing the location referenced by the returned pointer to the null character.
If *stringp is initially null, strsep returns null.

Note
strsep is an extension commonly found in Linux and BSD C libraries.
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strspn
Synopsis
size_t strspn(const char *s1,
const char *s2);

Description
strspn computes the length of the maximum initial segment of the string pointed to by s1 which consists
entirely of characters from the string pointed to by s2.
strspn returns the length of the segment.
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strstr
Synopsis
char *strstr(const char *s1,
const char *s2);

Description
strstr locates the first occurrence in the string pointed to by s1 of the sequence of characters (excluding the
terminating null character) in the string pointed to by s2.
strstr returns a pointer to the located string, or a null pointer if the string is not found. If s2 points to a string with
zero length, strstr returns s1.

1081

CrossWorks for MSP430 Reference Manual

C Library User Guide

strtok
Synopsis
char *strtok(char *s1,
const char *s2);

Description
strtok A sequence of calls to strtok breaks the string pointed to by s1 into a sequence of tokens, each of which
is delimited by a character from the string pointed to by s2. The first call in the sequence has a non-null first
argument; subsequent calls in the sequence have a null first argument. The separator string pointed to by s2
may be different from call to call.
The first call in the sequence searches the string pointed to by s1 for the first character that is not contained in
the current separator string pointed to by s2. If no such character is found, then there are no tokens in the string
pointed to by s1 and strtok returns a null pointer. If such a character is found, it is the start of the first token.
strtok then searches from there for a character that is contained in the current separator string. If no such
character is found, the current token extends to the end of the string pointed to by s1, and subsequent searches
for a token will return a null pointer. If such a character is found, it is overwritten by a null character, which
terminates the current token. strtok saves a pointer to the following character, from which the next search for a
token will start.
Each subsequent call, with a null pointer as the value of the first argument, starts searching from the saved
pointer and behaves as described above.

Note
strtok maintains static state and is therefore not reentrant and not thread safe. See strtok_r for a thread-safe and
reentrant variant.

See Also
strsep, strtok_r.
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strtok_r
Synopsis
char *strtok_r(char *s1,
const char *s2,
char **s3);

Description
strtok_r is a reentrant version of the function strtok where the state is maintained in the object of type char *
pointed to by s3.

Note
strtok_r conforms to POSIX.1-2008 and is commonly found in Linux and BSD C libraries.

See Also
strtok.
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<time.h>
API Summary
Types
__TIME_T_DEFINED

Time type

clock_t

Clock type

tm

Time structure

Functions
asctime

Convert a struct tm to a string

asctime_r

Convert a struct tm to a string

ctime

Convert a time_t to a string

ctime_r

Convert a time_t to a string

difftime

Calculates the difference between two times

gmtime

Convert a time_t to a struct tm

gmtime_r

Convert a time_t to a struct tm

localtime

Convert a time_t to a struct tm

localtime_r

Convert a time_t to a struct tm

mktime

Convert a struct tm to time_t

strftime

Format a struct tm to a string
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__TIME_T_DEFINED
Synopsis
#define __TIME_T_DEFINED

Description
__TIME_T_DEFINED is a long type that represents the time in number of seconds since UTC 1 January 1970,
negative values indicate time before UTC 1 January 1970.
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asctime
Synopsis
char *asctime(const tm *tp);

Description
asctime converts the *tp struct to a null terminated string of the form Sun Sep 16 01:03:52 1973. The
returned string is held in a static buffer. asctime is not re-entrant.
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asctime_r
Synopsis
char *asctime_r(const tm *tp,
char *buf);

Description
asctime_r converts the *tp struct to a null terminated string of the form Sun Sep 16 01:03:52 1973 in buf and
returns buf. The buf must point to an array at least 26 bytes in length.
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clock_t
Synopsis
typedef long clock_t;

Description
clock_t is the type returned by the clock function.

1088

CrossWorks for MSP430 Reference Manual

C Library User Guide

ctime
Synopsis
char *ctime(const time_t *tp);

Description
ctime converts the *tp to a null terminated string. The returned string is held in a static buffer, this function is
not re-entrant.
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ctime_r
Synopsis
char *ctime_r(const time_t *tp,
char *buf);

Description
ctime_r converts the *tp to a null terminated string in buf and returns buf. The buf must point to an array at
least 26 bytes in length.
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difftime
Synopsis
double difftime(time_t time2,
time_t time1);

Description
difftime returns time1 - time0 as a double precision number.
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gmtime
Synopsis
gmtime(const time_t *tp);

Description
gmtime converts the *tp time format to a struct tm time format. The returned value points to a static object this function is not re-entrant.
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gmtime_r
Synopsis
gmtime_r(const time_t *tp,
tm *result);

Description
gmtime_r converts the *tp time format to a struct tm time format in *result and returns result.
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localtime
Synopsis
localtime(const time_t *tp);

Description
localtime converts the *tp time format to a struct tm local time format. The returned value points to a static
object - this function is not re-entrant.
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localtime_r
Synopsis
localtime_r(const time_t *tp,
tm *result);

Description
localtime_r converts the *tp time format to a struct tm local time format in *result and returns result.
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mktime
Synopsis
time_t mktime(tm *tp);

Description
mktime validates (and updates) the *tp struct to ensure that the tm_sec, tm_min, tm_hour, tm_mon fields
are within the supported integer ranges and the tm_mday, tm_mon and tm_year fields are consistent. The
validated *tp struct is converted to the number of seconds since UTC 1 January 1970 and returned.
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strftime
Synopsis
size_t strftime(char *s,
size_t smax,
const char *fmt,
const tm *tp);

Description
strftime formats the *tp struct to a null terminated string of maximum size smax-1 into the array at *s based
on the fmt format string. The format string consists of conversion specifications and ordinary characters.
Conversion specifications start with a % character followed by an optional # character. The following conversion
specifications are supported:
Specification

Description

%a

Abbreviated weekday name

%A

Full weekday name

%b

Abbreviated month name

%B

Full month name

%c

Date and time representation appropriate for locale

%#c

Date and time formatted as "%A, %B %#d, %Y, %H:%M:
%S" (Microsoft extension)

%C

Century number

%d

Day of month as a decimal number [01,31]

%#d

Day of month without leading zero [1,31]

%D

Date in the form %m/%d/%y (POSIX.1-2008 extension)

%e

Day of month [ 1,31], single digit preceded by space

%F

Date in the format %Y-%m-%d

%h

Abbreviated month name as %b

%H

Hour in 24-hour format [00,23]

%#H

Hour in 24-hour format without leading zeros [0,23]

%I

Hour in 12-hour format [01,12]

%#I

Hour in 12-hour format without leading zeros [1,12]

%j

Day of year as a decimal number [001,366]

%#j

Day of year as a decimal number without leading zeros
[1,366]

%k

Hour in 24-hour clock format [ 0,23] (POSIX.1-2008
extension)
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%l

Hour in 12-hour clock format [ 0,12] (POSIX.1-2008
extension)

%m

Month as a decimal number [01,12]

%#m

Month as a decimal number without leading zeros
[1,12]

%M

Minute as a decimal number [00,59]

%#M

Minute as a decimal number without leading zeros
[0,59]

%n

Insert newline character (POSIX.1-2008 extension)

%p

Locale's a.m or p.m indicator for 12-hour clock

%r

Time as %I:%M:%s %p (POSIX.1-2008 extension)

%R

Time as %H:%M (POSIX.1-2008 extension)

%S

Second as a decimal number [00,59]

%t

Insert tab character (POSIX.1-2008 extension)

%T

Time as %H:%M:%S

%#S

Second as a decimal number without leading zeros
[0,59]

%U

Week of year as a decimal number [00,53], Sunday is
first day of the week

%#U

Week of year as a decimal number without leading
zeros [0,53], Sunday is first day of the week

%w

Weekday as a decimal number [0,6], Sunday is 0

%W

Week number as a decimal number [00,53], Monday is
first day of the week

%#W

Week number as a decimal number without leading
zeros [0,53], Monday is first day of the week

%x

Locale's date representation

%#x

Locale's long date representation

%X

Locale's time representation

%y

Year without century, as a decimal number [00,99]

%#y

Year without century, as a decimal number without
leading zeros [0,99]

%Y

Year with century, as decimal number

%z,%Z

Timezone name or abbreviation

%%

%
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tm
Synopsis
typedef struct {
int tm_sec;
int tm_min;
int tm_hour;
int tm_mday;
int tm_mon;
int tm_year;
int tm_wday;
int tm_yday;
int tm_isdst;
} tm;

Description
tm structure has the following fields.
Member

Description

tm_sec

seconds after the minute - [0,59]

tm_min

minutes after the hour - [0,59]

tm_hour

hours since midnight - [0,23]

tm_mday

day of the month - [1,31]

tm_mon

months since January - [0,11]

tm_year

years since 1900

tm_wday

days since Sunday - [0,6]

tm_yday

days since January 1 - [0,365]

tm_isdst

daylight savings time flag
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<wchar.h>
API Summary
Character minimum and maximum values
WCHAR_MAX

Maximum value of a wide character

WCHAR_MIN

Minimum value of a wide character

Constants
WEOF

End of file indication

Types
wchar_t

Wide character type

wint_t

Wide integer type

Copying functions
wcscat

Concatenate strings

wcscpy

Copy string

wcsncat

Concatenate strings up to maximum length

wcsncpy

Copy string up to a maximum length

wmemccpy

Copy memory with specified terminator (POSIX
extension)

wmemcpy

Copy memory

wmemmove

Safely copy overlapping memory

wmempcpy

Copy memory (GNU extension)

Comparison functions
wcscmp

Compare strings

wcsncmp

Compare strings up to a maximum length

wmemcmp

Compare memory

Search functions
wcschr

Find character within string

wcscspn

Compute size of string not prefixed by a set of
characters

wcsnchr

Find character in a length-limited string

wcsnlen

Calculate length of length-limited string

wcsnstr

Find first occurrence of a string within length-limited
string

wcspbrk

Find first occurrence of characters within string

wcsrchr

Find last occurrence of character within string
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wcsspn

Compute size of string prefixed by a set of characters

wcsstr

Find first occurrence of a string within string

wcstok

Break string into tokens

wcstok_r

Break string into tokens (reentrant version)

wmemchr

Search memory for a wide character

wstrsep

Break string into tokens

Miscellaneous functions
wcsdup

Duplicate string

wcslen

Calculate length of string

wmemset

Set memory to wide character

Multi-byte/wide string conversion functions
mbrtowc

Convert multi-byte character to wide character

mbrtowc_l

Convert multi-byte character to wide character

msbinit

Query conversion state

wcrtomb

Convert wide character to multi-byte character
(restartable)

wcrtomb_l

Convert wide character to multi-byte character
(restartable)

wctob

Convert wide character to single-byte character

wctob_l

Convert wide character to single-byte character

Multi-byte to wide character conversions
mbrlen

Determine number of bytes in a multi-byte character

mbrlen_l

Determine number of bytes in a multi-byte character

mbsrtowcs

Convert multi-byte string to wide character string

mbsrtowcs_l

Convert multi-byte string to wide character string

Single-byte to wide character conversions
btowc

Convert single-byte character to wide character

btowc_l

Convert single-byte character to wide character
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WCHAR_MAX
Synopsis
#define WCHAR_MAX

...

Description
WCHAR_MAX is the maximum value for an object of type wchar_t. Although capable of storing larger values,
the maximum value implemented by the conversion functions in the library is the value 0x10FFFF defined by ISO
10646.
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WCHAR_MIN
Synopsis
#define WCHAR_MIN

...

Description
WCHAR_MIN is the minimum value for an object of type wchar_t.
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WEOF
Synopsis
#define WEOF ((wint_t)~0U)

Description
WEOF expands to a constant value that does not correspond to any character in the wide character set. It is
typically used to indicate an end of file condition.
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btowc
Synopsis
wint_t btowc(int c);

Description
btowc function determines whether c constitutes a valid single-byte character. If c is a valid single-byte
character, btowc returns the wide character representation of that character
btowc returns WEOF if c has the value EOF or if (unsigned char)c does not constitute a valid single-byte
character in the initial shift state.
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btowc_l
Synopsis
wint_t btowc_l(int c,
locale_t loc);

Description
btowc_l function determines whether c constitutes a valid single-byte character in the locale loc. If c is a valid
single-byte character, btowc_l returns the wide character representation of that character
btowc_l returns WEOF if c has the value EOF or if (unsigned char)c does not constitute a valid single-byte
character in the initial shift state.
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mbrlen
Synopsis
size_t mbrlen(const char *s,
size_t n,
mbstate_t *ps);

Note
mbrlen function is equivalent to the call:
mbrtowc(NULL, s, n, ps != NULL ? ps : &internal);

where internal is the mbstate_t object for the mbrlen function, except that the expression designated by ps is
evaluated only once.
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mbrlen_l
Synopsis
size_t mbrlen_l(const char *s,
size_t n,
mbstate_t *ps,
locale_t loc);

Note
mbrlen_l function is equivalent to the call:
mbrtowc_l(NULL, s, n, ps != NULL ? ps : &internal, loc);

where internal is the mbstate_t object for the mbrlen function, except that the expression designated by ps is
evaluated only once.
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mbrtowc
Synopsis
size_t mbrtowc(wchar_t *pwc,
const char *s,
size_t n,
mbstate_t *ps);

Description
mbrtowc converts a single multi-byte character to a wide character in the current locale.
If s is a null pointer, mbrtowc is equivalent to mbrtowc(NULL, "", 1, ps), ignoring pwc and n.
If s is not null and the object that s points to is a wide-character null character, mbrtowc returns 0.
If s is not null and the object that points to forms a valid multi-byte character with a most n bytes, mbrtowc
returns the length in bytes of the multi-byte character and stores that wide character to the object pointed to by
pwc (if pwc is not null).
If the object that points to forms an incomplete, but possibly valid, multi-byte character, mbrtowc returns 2. If
the object that points to does not form a partial multi-byte character, mbrtowc returns 1.

See Also
mbtowc, mbrtowc_l
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mbrtowc_l
Synopsis
size_t mbrtowc_l(wchar_t *pwc,
const char *s,
size_t n,
mbstate_t *ps,
locale_t loc);

Description
mbrtowc_l converts a single multi-byte character to a wide character in the locale loc.
If s is a null pointer, mbrtowc_l is equivalent to mbrtowc(NULL, "", 1, ps), ignoring pwc and n.
If s is not null and the object that s points to is a wide-character null character, mbrtowc_l returns 0.
If s is not null and the object that points to forms a valid multi-byte character with a most n bytes, mbrtowc_l
returns the length in bytes of the multi-byte character and stores that wide character to the object pointed to by
pwc (if pwc is not null).
If the object that points to forms an incomplete, but possibly valid, multi-byte character, mbrtowc_l returns 2. If
the object that points to does not form a partial multi-byte character, mbrtowc_l returns 1.

See Also
mbrtowc, mbtowc_l
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mbsrtowcs
Synopsis
size_t mbsrtowcs(wchar_t *dst,
const char **src,
size_t len,
mbstate_t *ps);

Description
mbsrtowcs converts a sequence of multi-byte characters that begins in the conversion state described by the
object pointed to by ps, from the array indirectly pointed to by src into a sequence of corresponding wide
characters If dst is not a null pointer, the converted characters are stored into the array pointed to by dst.
Conversion continues up to and including a terminating null character, which is also stored.
Conversion stops earlier in two cases: when a sequence of bytes is encountered that does not form a valid multibyte character, or (if dst is not a null pointer) when len wide characters have been stored into the array pointed
to by dst. Each conversion takes place as if by a call to the mbrtowc function.
If dst is not a null pointer, the pointer object pointed to by src is assigned either a null pointer (if conversion
stopped due to reaching a terminating null character) or the address just past the last multi-byte character
converted (if any). If conversion stopped due to reaching a terminating null character and if dst is not a null
pointer, the resulting state described is the initial conversion state.

See Also
mbsrtowcs_l, mbrtowc
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mbsrtowcs_l
Synopsis
size_t mbsrtowcs_l(wchar_t *dst,
const char **src,
size_t len,
mbstate_t *ps,
locale_t loc);

Description
mbsrtowcs_l converts a sequence of multi-byte characters that begins in the conversion state described by
the object pointed to by ps, from the array indirectly pointed to by src into a sequence of corresponding wide
characters If dst is not a null pointer, the converted characters are stored into the array pointed to by dst.
Conversion continues up to and including a terminating null character, which is also stored.
Conversion stops earlier in two cases: when a sequence of bytes is encountered that does not form a valid multibyte character, or (if dst is not a null pointer) when len wide characters have been stored into the array pointed
to by dst. Each conversion takes place as if by a call to the mbrtowc function.
If dst is not a null pointer, the pointer object pointed to by src is assigned either a null pointer (if conversion
stopped due to reaching a terminating null character) or the address just past the last multi-byte character
converted (if any). If conversion stopped due to reaching a terminating null character and if dst is not a null
pointer, the resulting state described is the initial conversion state.

See Also
mbsrtowcs_l, mbrtowc
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msbinit
Synopsis
int msbinit(const mbstate_t *ps);

Description
msbinit function returns nonzero if ps is a null pointer or if the pointed-to object describes an initial conversion
state; otherwise, msbinit returns zero.
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wchar_t
Synopsis
typedef __RAL_WCHAR_T wchar_t;

Description
wchar_t holds a single wide character.
Depending on implementation you can control whether wchar_t is represented by a short 16-bit type or the
standard 32-bit type.
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wcrtomb
Synopsis
size_t wcrtomb(char *s,
wchar_t wc,
mbstate_t *ps);

If s is a null pointer, wcrtomb function is equivalent to the call wcrtomb(buf, L'\0', ps) where buf is an
internal buffer.
If s is not a null pointer, wcrtomb determines the number of bytes needed to represent the multibyte character
that corresponds to the wide character given by wc, and stores the multibyte character representation in
the array whose first element is pointed to by s. At most MB_CUR_MAX bytes are stored. If wc is a null wide
character, a null byte is stored; the resulting state described is the initial conversion state.
wcrtomb returns the number of bytes stored in the array object. When wc is not a valid wide character, an
encoding error occurs: wcrtomb stores the value of the macro EILSEQ in errno and returns (size_t)(-1); the
conversion state is unspecified.
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wcrtomb_l
Synopsis
size_t wcrtomb_l(char *s,
wchar_t wc,
mbstate_t *ps,
locale_t loc);

If s is a null pointer, wcrtomb_l function is equivalent to the call wcrtomb_l(buf, L'\0', ps, loc)
where buf is an internal buffer.
If s is not a null pointer, wcrtomb_l determines the number of bytes needed to represent the multibyte
character that corresponds to the wide character given by wc, and stores the multibyte character representation
in the array whose first element is pointed to by s. At most MB_CUR_MAX bytes are stored. If wc is a null wide
character, a null byte is stored; the resulting state described is the initial conversion state.
wcrtomb_l returns the number of bytes stored in the array object. When wc is not a valid wide character, an
encoding error occurs: wcrtomb_l stores the value of the macro EILSEQ in errno and returns (size_t)(-1);
the conversion state is unspecified.
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wcscat
Synopsis
wchar_t *wcscat(wchar_t *s1,
const wchar_t *s2);

Description
wcscat appends a copy of the wide string pointed to by s2 (including the terminating null wide character) to the
end of the wide string pointed to by s1. The initial character of s2 overwrites the null wide character at the end
of s1. The behavior of wcscat is undefined if copying takes place between objects that overlap.
wcscat returns the value of s1.
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wcschr
Synopsis
wchar_t *wcschr(const wchar_t *s,
wchar_t c);

Description
wcschr locates the first occurrence of c in the wide string pointed to by s. The terminating wide null character is
considered to be part of the string.
wcschr returns a pointer to the located wide character, or a null pointer if c does not occur in the string.
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wcscmp
Synopsis
int wcscmp(const wchar_t *s1,
const wchar_t *s2);

Description
wcscmp compares the wide string pointed to by s1 to the wide string pointed to by s2. wcscmp returns an
integer greater than, equal to, or less than zero if the wide string pointed to by s1 is greater than, equal to, or less
than the wide string pointed to by s2.

1119

CrossWorks for MSP430 Reference Manual

C Library User Guide

wcscpy
Synopsis
wchar_t *wcscpy(wchar_t *s1,
const wchar_t *s2);

Description
wcscpy copies the wide string pointed to by s2 (including the terminating null wide character) into the array
pointed to by s1. The behavior of wcscpy is undefined if copying takes place between objects that overlap.
wcscpy returns the value of s1.
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wcscspn
Synopsis
size_t wcscspn(const wchar_t *s1,
const wchar_t *s2);

Description
wcscspn computes the length of the maximum initial segment of the wide string pointed to by s1 which
consists entirely of wide characters not from the wide string pointed to by s2.
wcscspn returns the length of the segment.
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wcsdup
Synopsis
wchar_t *wcsdup(const wchar_t *s1);

Description
wcsdup duplicates the wide string pointed to by s1 by using malloc to allocate memory for a copy of s and then
copying s, including the terminating wide null character, to that memory. The returned pointer can be passed to
free. wcsdup returns a pointer to the new wide string or a null pointer if the new string cannot be created.

Note
wcsdup is an extension commonly found in Linux and BSD C libraries.
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wcslen
Synopsis
size_t wcslen(const wchar_t *s);

Description
wcslen returns the length of the wide string pointed to by s, that is the number of wide characters that precede
the terminating null wide character.
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wcsncat
Synopsis
wchar_t *wcsncat(wchar_t *s1,
const wchar_t *s2,
size_t n);

Description
wcsncat appends not more than n wude characters from the array pointed to by s2 to the end of the wide string
pointed to by s1. A null wide character in s1 and wide characters that follow it are not appended. The initial
wide character of s2 overwrites the null wide character at the end of s1. A terminating wide null character is
always appended to the result. The behavior of wcsncat is undefined if copying takes place between objects
that overlap.
wcsncat returns the value of s1.
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wcsnchr
Synopsis
wchar_t *wcsnchr(const wchar_t *str,
size_t n,
wchar_t ch);

Description
wcsnchr searches not more than n wide characters to locate the first occurrence of c in the wide string pointed
to by s. The terminating wide null character is considered to be part of the wide string.
wcsnchr returns a pointer to the located wide character, or a null pointer if c does not occur in the string.
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wcsncmp
Synopsis
int wcsncmp(const wchar_t *s1,
const wchar_t *s2,
size_t n);

Description
wcsncmp compares not more than n wide characters from the array pointed to by s1 to the array pointed to by
s2. Characters that follow a null wide character are not compared.
wcsncmp returns an integer greater than, equal to, or less than zero, if the possibly null-terminated array
pointed to by s1 is greater than, equal to, or less than the possibly null-terminated array pointed to by s2.
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wcsncpy
Synopsis
wchar_t *wcsncpy(wchar_t *s1,
const wchar_t *s2,
size_t n);

Description
wcsncpy copies not more than n wide characters from the array pointed to by s2 to the array pointed to by s1.
Wide characters that follow a null wide character in s2 are not copied. The behavior of wcsncpy is undefined
if copying takes place between objects that overlap. If the array pointed to by s2 is a wide string that is shorter
than n wide characters, null wide characters are appended to the copy in the array pointed to by s1, until n
characters in all have been written.
wcsncpy returns the value of s1.
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wcsnlen
Synopsis
size_t wcsnlen(const wchar_t *s,
size_t n);

Description
this returns the length of the wide string pointed to by s, up to a maximum of n wide characters. wcsnlen only
examines the first n wide characters of the string s.

Note
wcsnlen is an extension commonly found in Linux and BSD C libraries.
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wcsnstr
Synopsis
wchar_t *wcsnstr(const wchar_t *s1,
const wchar_t *s2,
size_t n);

Description
wcsnstr searches at most n wide characters to locate the first occurrence in the wide string pointed to by s1 of
the sequence of wide characters (excluding the terminating null wide character) in the wide string pointed to by
s2.
wcsnstr returns a pointer to the located string, or a null pointer if the string is not found. If s2 points to a string
with zero length, wcsnstr returns s1.

Note
wcsnstr is an extension commonly found in Linux and BSD C libraries.
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wcspbrk
Synopsis
wchar_t *wcspbrk(const wchar_t *s1,
const wchar_t *s2);

Description
wcspbrk locates the first occurrence in the wide string pointed to by s1 of any wide character from the wide
string pointed to by s2.
wcspbrk returns a pointer to the wide character, or a null pointer if no wide character from s2 occurs in s1.
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wcsrchr
Synopsis
wchar_t *wcsrchr(const wchar_t *s,
wchar_t c);

Description
wcsrchr locates the last occurrence of c in the wide string pointed to by s. The terminating wide null character is
considered to be part of the string.
wcsrchr returns a pointer to the wide character, or a null pointer if c does not occur in the wide string.
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wcsspn
Synopsis
size_t wcsspn(const wchar_t *s1,
const wchar_t *s2);

Description
wcsspn computes the length of the maximum initial segment of the wide string pointed to by s1 which consists
entirely of wide characters from the wide string pointed to by s2.
wcsspn returns the length of the segment.
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wcsstr
Synopsis
wchar_t *wcsstr(const wchar_t *s1,
const wchar_t *s2);

Description
wcsstr locates the first occurrence in the wide string pointed to by s1 of the sequence of wide characters
(excluding the terminating null wide character) in the wide string pointed to by s2.
wcsstr returns a pointer to the located wide string, or a null pointer if the wide string is not found. If s2 points to
a wide string with zero length, wcsstr returns s1.
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wcstok
Synopsis
wchar_t *wcstok(wchar_t *s1,
const wchar_t *s2,
wchar_t **ptr);

Description
wcstok A sequence of calls to wcstok breaks the wide string pointed to by s1 into a sequence of tokens, each of
which is delimited by a wide character from the wide string pointed to by s2. The first call in the sequence has a
non-null first argument; subsequent calls in the sequence have a null first argument. The separator wide string
pointed to by s2 may be different from call to call.
The first call in the sequence searches the wide string pointed to by s1 for the first wide character that is not
contained in the current separator wide string pointed to by s2. If no such wide character is found, then there are
no tokens in the wide string pointed to by s1 and wcstok returns a null pointer. If such a wide character is found,
it is the start of the first token.
wcstok then searches from there for a wide character that is contained in the current wide separator string. If
no such wide character is found, the current token extends to the end of the wide string pointed to by s1, and
subsequent searches for a token will return a null pointer. If such a wude character is found, it is overwritten by a
wide null character, which terminates the current token. wcstok saves a pointer to the following wide character,
from which the next search for a token will start.
Each subsequent call, with a null pointer as the value of the first argument, starts searching from the saved
pointer and behaves as described above.

Note
wcstok maintains static state and is therefore not reentrant and not thread safe. See wcstok_r for a thread-safe
and reentrant variant.
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wcstok_r
Synopsis
wchar_t *wcstok_r(wchar_t *s1,
const wchar_t *s2,
wchar_t **s3);

Description
wcstok_r is a reentrant version of the function wcstok where the state is maintained in the object of type
wchar_t * pointed to by s3.

Note
wcstok_r is an extension commonly found in Linux and BSD C libraries.

See Also
wcstok.
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wctob
Synopsis
int wctob(wint_t c);

Description
wctob determines whether c corresponds to a member of the extended character set whose multi-byte
character representation is a single byte when in the initial shift state in the current locale.

Description
this returns EOF if c does not correspond to a multi-byte character with length one in the initial shift state.
Otherwise, it returns the single-byte representation of that character as an unsigned char converted to an int.
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wctob_l
Synopsis
int wctob_l(wint_t c,
locale_t loc);

Description
wctob_l determines whether c corresponds to a member of the extended character set whose multi-byte
character representation is a single byte when in the initial shift state in locale loc.

Description
wctob_l returns EOF if c does not correspond to a multi-byte character with length one in the initial shift state.
Otherwise, it returns the single-byte representation of that character as an unsigned char converted to an int.
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wint_t
Synopsis
typedef long wint_t;

Description
wint_t is an integer type that is unchanged by default argument promotions that can hold any value
corresponding to members of the extended character set, as well as at least one value that does not correspond
to any member of the extended character set (WEOF).
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wmemccpy
Synopsis
wchar_t *wmemccpy(wchar_t *s1,
const wchar_t *s2,
wchar_t c,
size_t n);

Description
wmemccpy copies at most n wide characters from the object pointed to by s2 into the object pointed to by s1.
The copying stops as soon as n wide characters are copied or the wide character c is copied into the destination
object pointed to by s1. The behavior of wmemccpy is undefined if copying takes place between objects that
overlap.
wmemccpy returns a pointer to the wide character immediately following c in s1, or NULL if c was not found in
the first n wide characters of s2.

Note
wmemccpy conforms to POSIX.1-2008.
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wmemchr
Synopsis
wchar_t *wmemchr(const wchar_t *s,
wchar_t c,
size_t n);

Description
wmemchr locates the first occurrence of c in the initial n characters of the object pointed to by s. Unlike wcschr,
wmemchr does not terminate a search when a null wide character is found in the object pointed to by s.
wmemchr returns a pointer to the located wide character, or a null pointer if c does not occur in the object.
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wmemcmp
Synopsis
int wmemcmp(const wchar_t *s1,
const wchar_t *s2,
size_t n);

Description
wmemcmp compares the first n wide characters of the object pointed to by s1 to the first n wide characters of
the object pointed to by s2. wmemcmp returns an integer greater than, equal to, or less than zero as the object
pointed to by s1 is greater than, equal to, or less than the object pointed to by s2.
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wmemcpy
Synopsis
wchar_t *wmemcpy(wchar_t *s1,
const wchar_t *s2,
size_t n);

Description
wmemcpy copies n wide characters from the object pointed to by s2 into the object pointed to by s1. The
behavior of wmemcpy is undefined if copying takes place between objects that overlap.
wmemcpy returns the value of s1.
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wmemmove
Synopsis
wchar_t *wmemmove(wchar_t *s1,
const wchar_t *s2,
size_t n);

Description
wmemmove copies n wide characters from the object pointed to by s2 into the object pointed to by s1 ensuring
that if s1 and s2 overlap, the copy works correctly. Copying takes place as if the n wide characters from the
object pointed to by s2 are first copied into a temporary array of n wide characters that does not overlap the
objects pointed to by s1 and s2, and then the n wide characters from the temporary array are copied into the
object pointed to by s1.
wmemmove returns the value of s1.
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wmempcpy
Synopsis
wchar_t *wmempcpy(wchar_t *s1,
const wchar_t *s2,
size_t n);

Description
wmempcpy copies n wide characters from the object pointed to by s2 into the object pointed to by s1. The
behavior of wmempcpy is undefined if copying takes place between objects that overlap.
wmempcpy returns it returns a pointer to the wide character following the last written wide character.

Note
This is an extension found in GNU libc.
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wmemset
Synopsis
wchar_t *wmemset(wchar_t *s,
wchar_t c,
size_t n);

Description
wmemset copies the value of c into each of the first n wide characters of the object pointed to by s.
wmemset returns the value of s.
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wstrsep
Synopsis
wchar_t *wstrsep(wchar_t **stringp,
const wchar_t *delim);

Description
wstrsep locates, in the wide string referenced by *stringp, the first occurrence of any wide character in the wide
string delim (or the terminating wide null character) and replaces it with a wide null character. The location of
the next character after the delimiter wide character (or NULL, if the end of the string was reached) is stored in
*stringp. The original value of *stringp is returned.
An empty field (that is, a wide character in the string delim occurs as the first wide character of *stringp can be
detected by comparing the location referenced by the returned pointer to a wide null character.
If *stringp is initially null, wstrsep returns null.

Note
wstrsep is not an ISO C function, but appears in BSD4.4 and Linux.
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<wctype.h>
API Summary
Classification functions
iswalnum

Is character alphanumeric?

iswalpha

Is character alphabetic?

iswblank

Is character blank?

iswcntrl

Is character a control?

iswctype

Determine character type

iswdigit

Is character a decimal digit?

iswgraph

Is character a control?

iswlower

Is character a lowercase letter?

iswprint

Is character printable?

iswpunct

Is character punctuation?

iswspace

Is character a whitespace character?

iswupper

Is character an uppercase letter?

iswxdigit

Is character a hexadecimal digit?

wctype

Construct character class

Conversion functions
towctrans

Translate character

towlower

Convert uppercase character to lowercase

towupper

Convert lowercase character to uppercase

wctrans

Construct character mapping

Classification functions (extended)
iswalnum_l

Is character alphanumeric?

iswalpha_l

Is character alphabetic?

iswblank_l

Is character blank?

iswcntrl_l

Is character a control?

iswctype_l

Determine character type

iswdigit_l

Is character a decimal digit?

iswgraph_l

Is character a control?

iswlower_l

Is character a lowercase letter?

iswprint_l

Is character printable?

iswpunct_l

Is character punctuation?
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iswspace_l

Is character a whitespace character?

iswupper_l

Is character an uppercase letter?

iswxdigit_l

Is character a hexadecimal digit?

Conversion functions (extended)
towctrans_l

Translate character

towlower_l

Convert uppercase character to lowercase

towupper_l

Convert lowercase character to uppercase

wctrans_l

Construct character mapping
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iswalnum
Synopsis
int iswalnum(wint_t c);

Description
iswalnum tests for any wide character for which iswalpha or iswdigit is true.
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iswalnum_l
Synopsis
int iswalnum_l(wint_t c,
locale_t loc);

Description
iswalnum_l tests for any wide character for which iswalpha_l or iswdigit_l is true in the locale loc.
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iswalpha
Synopsis
int iswalpha(wint_t c);

Description
iswalpha returns true if the wide character c is alphabetic. Any character for which iswupper or iswlower returns
true is considered alphabetic in addition to any of the locale-specific set of alphabetic characters for which none
of iswcntrl, iswdigit, iswpunct, or iswspace is true.
In the C locale, iswalpha returns nonzero (true) if and only if iswupper or iswlower return true for the value of
the argument c.
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iswalpha_l
Synopsis
int iswalpha_l(wint_t c,
locale_t loc);

Description
iswalpha_l returns true if the wide character c is alphabetic in the locale loc. Any character for which iswupper_l
or iswlower_l returns true is considered alphabetic in addition to any of the locale-specific set of alphabetic
characters for which none of iswcntrl_l, iswdigit_l, iswpunct_l, or iswspace_l is true.
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iswblank
Synopsis
int iswblank(wint_t c);

Description
iswblank tests for any wide character that is a standard blank wide character or is one of a locale-specific set of
wide characters for which iswspace is true and that is used to separate words within a line of text. The standard
blank wide are space and horizontal tab.
In the C locale, iswblank returns true only for the standard blank characters.
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iswblank_l
Synopsis
int iswblank_l(wint_t c,
locale_t loc);

Description
iswblank_l tests for any wide character that is a standard blank wide character in the locale loc or is one of a
locale-specific set of wide characters for which iswspace_l is true and that is used to separate words within a line
of text. The standard blank wide are space and horizontal tab.
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iswcntrl
Synopsis
int iswcntrl(wint_t c);

Description
iswcntrl tests for any wide character that is a control character.
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iswcntrl_l
Synopsis
int iswcntrl_l(wint_t c,
locale_t loc);

Description
iswcntrl_l tests for any wide character that is a control character in the locale loc.

1156

CrossWorks for MSP430 Reference Manual

C Library User Guide

iswctype
Synopsis
int iswctype(wint_t c,
wctype_t t);

Description
iswctype determines whether the wide character c has the property described by t in the current locale.
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iswctype_l
Synopsis
int iswctype_l(wint_t c,
wctype_t t,
locale_t loc);

Description
iswctype_l determines whether the wide character c has the property described by t in the locale loc.
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iswdigit
Synopsis
int iswdigit(wint_t c);

Description
iswdigit tests for any wide character that corresponds to a decimal-digit character.
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iswdigit_l
Synopsis
int iswdigit_l(wint_t c,
locale_t loc);

Description
iswdigit_l tests for any wide character that corresponds to a decimal-digit character in the locale loc.
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iswgraph
Synopsis
int iswgraph(wint_t c);

Description
iswgraph tests for any wide character for which iswprint is true and iswspace is false.
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iswgraph_l
Synopsis
int iswgraph_l(wint_t c,
locale_t loc);

Description
iswgraph_l tests for any wide character for which iswprint is true and iswspace is false in the locale loc.
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iswlower
Synopsis
int iswlower(wint_t c);

Description
iswlower tests for any wide character that corresponds to a lowercase letter or is one of a locale-specific set of
wide characters for which none of iswcntrl, iswdigit, iswpunct, or iswspace is true.
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iswlower_l
Synopsis
int iswlower_l(wint_t c,
locale_t loc);

Description
iswlower_l tests for any wide character that corresponds to a lowercase letter in the locale loc or is one of a
locale-specific set of wide characters for which none of iswcntrl_l, iswdigit_l, iswpunct_l, or iswspace_l is true.
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iswprint
Synopsis
int iswprint(wint_t c);

Description
iswprint returns nonzero (true) if and only if the value of the argument c is any printing character.
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iswprint_l
Synopsis
int iswprint_l(wint_t c,
locale_t loc);

Description
iswprint_l returns nonzero (true) if and only if the value of the argument c is any printing character in the locale
loc.
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iswpunct
Synopsis
int iswpunct(wint_t c);

Description
iswpunct tests for any printing wide character that is one of a locale-specific set of punctuation wide characters
for which neither iswspace nor iswalnum is true.
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iswpunct_l
Synopsis
int iswpunct_l(wint_t c,
locale_t loc);

Description
iswpunct_l tests for any printing wide character that is one of a locale-specific set of punctuation wide
characters in locale loc for which neither iswspace_l nor iswalnum_l is true.
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iswspace
Synopsis
int iswspace(wint_t c);

Description
iswspace tests for any wide character that corresponds to a locale-specific set of white-space wide characters for
which none of iswalnum, iswgraph, or iswpunct is true.
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iswspace_l
Synopsis
int iswspace_l(wint_t c,
locale_t loc);

Description
iswspace_l tests for any wide character that corresponds to a locale-specific set of white-space wide characters
in the locale loc for which none of iswalnum, iswgraph_l, or iswpunct_l is true.

1170

CrossWorks for MSP430 Reference Manual

C Library User Guide

iswupper
Synopsis
int iswupper(wint_t c);

Description
iswupper tests for any wide character that corresponds to an uppercase letter or is one of a locale-specific set of
wide characters for which none of iswcntrl, iswdigit, iswpunct, or iswspace is true.
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iswupper_l
Synopsis
int iswupper_l(wint_t c,
locale_t loc);

Description
iswupper_l tests for any wide character that corresponds to an uppercase letter or is one of a locale-specific set
of wide characters in the locale loc for which none of iswcntrl_l, iswdigit_l, iswpunct_l, or iswspace_l is true.

1172

CrossWorks for MSP430 Reference Manual

C Library User Guide

iswxdigit
Synopsis
int iswxdigit(wint_t c);

Description
iswxdigit tests for any wide character that corresponds to a hexadecimal digit.
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iswxdigit_l
Synopsis
int iswxdigit_l(wint_t c,
locale_t loc);

Description
iswxdigit_l tests for any wide character that corresponds to a hexadecimal digit in the locale loc.
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towctrans
Synopsis
wint_t towctrans(wint_t c,
wctrans_t t);

Description
towctrans maps the wide character c using the mapping described by t in the current locale.
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towctrans_l
Synopsis
wint_t towctrans_l(wint_t c,
wctrans_t t,
locale_t loc);

Description
towctrans_l maps the wide character c using the mapping described by t in the current locale.
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towlower
Synopsis
wint_t towlower(wint_t c);

Description
towlower converts an uppercase letter to a corresponding lowercase letter.
If the argument c is a wide character for which iswupper is true and there are one or more corresponding wide
characters, in the current locale, for which iswlower is true, towlower returns one (and always the same one for
any given locale) of the corresponding wide characters; otherwise, c is returned unchanged.
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towlower_l
Synopsis
wint_t towlower_l(wint_t c,
locale_t loc);

Description
towlower_l converts an uppercase letter to a corresponding lowercase letter in locale loc.
If the argument c is a wide character for which iswupper_l is true and there are one or more corresponding wide
characters, in the locale loc, for which iswlower_l is true, towlower_l returns one (and always the same one for
any given locale) of the corresponding wide characters; otherwise, c is returned unchanged.
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towupper
Synopsis
wint_t towupper(wint_t c);

Description
towupper converts a lowercase letter to a corresponding uppercase letter.
If the argument c is a wide character for which iswlower is true and there are one or more corresponding wide
characters, in the current current locale, for which iswupper is true, towupper returns one (and always the same
one for any given locale) of the corresponding wide characters; otherwise, c is returned unchanged.
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towupper_l
Synopsis
wint_t towupper_l(wint_t c,
locale_t loc);

Description
towupper_l converts a lowercase letter to a corresponding uppercase letter in locale loc.
If the argument c is a wide character for which iswlower_l is true and there are one or more corresponding wide
characters, in the locale loc, for which iswupper_l is true, towupper_l returns one (and always the same one for
any given locale) of the corresponding wide characters; otherwise, c is returned unchanged.
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wctrans
Synopsis
wctrans_t wctrans(const char *property);

Description
wctrans constructs a value of type wctrans_t that describes a mapping between wide characters identified by
the string argument property.
If property identifies a valid mapping of wide characters in the current locale, wctrans returns a nonzero value
that is valid as the second argument to towctrans; otherwise, it returns zero.

Note
The only mappings supported are "tolower" and "toupper".
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wctrans_l
Synopsis
wctrans_t wctrans_l(const char *property,
locale_t loc);

Description
wctrans_l constructs a value of type wctrans_t that describes a mapping between wide characters identified by
the string argument property in locale loc.
If property identifies a valid mapping of wide characters in the locale loc, wctrans_l returns a nonzero value that
is valid as the second argument to towctrans_l; otherwise, it returns zero.

Note
The only mappings supported are "tolower" and "toupper".
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wctype
Synopsis
wctype_t wctype(const char *property);

Description
wctype constructs a value of type wctype_t that describes a class of wide characters identified by the string
argument property.
If property identifies a valid class of wide characters in the current locale, wctype returns a nonzero value that is
valid as the second argument to iswctype; otherwise, it returns zero.

Note
The only mappings supported are "alnum", "alpha", "blank", "cntrl", "digit", "graph", "lower",
"print", "punct", "space", "upper", and "xdigit".
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<xlocale.h>
API Summary
Functions
duplocale

Duplicate current locale data

freelocale

Free a locale

localeconv_l

Get locale data

newlocale

Create a new locale
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duplocale
Synopsis
locale_t duplocale(locale_t loc);

Description
duplocale duplicates the locale object referenced by loc.
If there is insufficient memory to duplicate loc, duplocale returns NULL and sets errno to ENOMEM as required
by POSIX.1-2008.
Duplicated locales must be freed with freelocale.
This is different behavior from the GNU glibc implementation which makes no mention of setting errno on
failure.

Note
This extension is derived from BSD, POSIX.1, and glibc.
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freelocale
Synopsis
int freelocale(locale_t loc);

Description
freelocale frees the storage associated with loc.
freelocale zero on success, 1 on error.
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localeconv_l
Synopsis
localeconv_l(locale_t loc);

Description
localeconv_l returns a pointer to a structure of type lconv with the corresponding values for the locale loc filled
in.
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newlocale
Synopsis
locale_t newlocale(int category_mask,
const char *locale,
locale_t base);

Description
newlocale creates a new locale object or modifies an existing one. If the base argument is NULL, a new locale
object is created.
category_mask specifies the locale categories to be set or modified. Values for category_mask are constructed
by a bitwise-inclusive OR of the symbolic constants LC_CTYPE_MASK, LC_NUMERIC_MASK, LC_TIME_MASK,
LC_COLLATE_MASK, LC_MONETARY_MASK, and LC_MESSAGES_MASK.
For each category with the corresponding bit set in category_mask, the data from the locale named by locale
is used. In the case of modifying an existing locale object, the data from the locale named by locale replaces the
existing data within the locale object. If a completely new locale object is created, the data for all sections not
requested by category_mask are taken from the default locale.
The locales C and POSIX are equivalent and defined for all settings of category_mask:
If locale is NULL, then the C locale is used. If locale is an empty string, newlocale will use the default locale.
If base is NULL, the current locale is used. If base is LC_GLOBAL_LOCALE, the global locale is used.
If mask is LC_ALL_MASK, base is ignored.

Note
POSIX.1-2008 does not specify whether the locale object pointed to by base is modified or whether it is freed
and a new locale object created.

Implementation
The category mask LC_MESSAGES_MASK is not implemented as POSIX messages are not implemented.
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Compiler driver
This section describes the switches accepted by the compiler driver, cc. The compiler driver is capable of
controlling compilation by all supported language compilers and the final link by the linker. It can also construct
libraries automatically.
In contrast to many compilation and assembly language development systems, with CrossWorks you don't
invoke the assembler or compiler directly. Instead you'll normally use the compiler driver cc as it provides an
easy way to get files compiled, assembled, and linked. This section will introduce you to using the compiler
driver to convert your source files to object files, executables, or other formats.
We recommend that you use the compiler driver rather than use the assembler or compiler directly because
there the driver can assemble multiple files using one command line and can invoke the linker for you too. There
is no reason why you should not invoke the assembler or compiler directly yourself, but you'll find that typing in
all the required options is quite tedious-and why do that when cc will provide them for you automatically?

1190

CrossWorks for MSP430 Reference Manual

Utilities Reference

File naming conventions
The compiler driver uses file extensions to distinguish the language the source file is written in. The compiler
driver recognizes the extension .c as C source files, .s and .asm as assembly code files.
The compiler driver recognizes the extension .hzo as object files, .hza as library files and .xml as special-purpose
XML files.
We strongly recommend that you adopt these extensions for your source files and object files because you'll find
that using the tools is much easier if you do.

C language files
When the compiler driver finds a file with a .c extension, it runs the C compiler to convert it to object code.

Assembly language files
When the compiler driver finds a file with a .s or .asm extension, it runs the C preprocessor and then the
assembler to convert it to object code.

Object code files
When the compiler driver finds a file with a .hzo or .hza extension, it passes it to the linker to include it in the
final application.
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Command-line options
This section describes the command-line options accepted by the CrossWorks compiler driver.
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-allow-multiple-definition (Allow multiple symbol
definition)
Syntax
-allow-multiple-definition

Description
Do not generate an error when linking multiple symbols of the same name.
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-ansi (Warn about potential ANSI problems)
Syntax
-ansi

Description
Warn about potential problems that conflict with the relevant ANSI or ISO standard for the files that are
compiled.
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-ar (Archive output)
Syntax
-ar

Description
This switch instructs the compiler driver to archive all output files into a library. Using -ar implies -c.

Example
The following command compiles file1.c, file2.asm, and file3.c to object code and archives them into the library
file libfunc.hza together with the object file file4.hzo.
cc -ar file1.c file2.asm file3.c file4.hzo -o libfunc.hza
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-c (Compile to object code, do not link)
Syntax
-c

Description
All named files are compiled to object code modules, but are not linked. You can use the -o option to name the
output if you just supply one input filename.

Example
The following command compiles file1.c and file4.c to produce the object files file1.o and file4.hzo.
cc -c file1.c file4.c

The following command compiles file1.c and produces the object file obj/file1.hzo.
cc -c file.c -o obj/file1.hzo
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-cpu (Set MSP430 architecture)
Syntax
-cpu -cpux -cpux64k

Description
Specifies the version of the instruction set to generate code for. The options are:
-cpu MSP430 instruction set
-cpux MSP430X instruction set with 20-bit PC
-cpux64k MSP430X instruction set with 16-bit PC

Example
To select compilation for MSP430X architecture you would use:
cc -cpux
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-d (Define linker symbol)
Syntax
-dname=value

Description
You can define linker symbols using the -d option. The symbol definitions are passed to linker.

Example
The following defines the symbol, STACK_SIZE with a value of 512.
-dSTACK_SIZE=512
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-D (Define macro symbol)
Syntax
-Dname
-Dname=value

Description
You can define preprocessor macros using the -D option. The macro definitions are passed on to the respective
language compiler which is responsible for interpreting the definitions and providing them to the programmer
within the language.
The first form above defines the macro name but without an associated replacement value, and the second
defines the same macro with the replacement value value.

Example
The following defines two macros, SUPPORT_FLOAT with a value of 1 and LITTLE_ENDIAN with no replacement
value.
-DSUPPORT_FLOAT=1 -DLITTLE_ENDIAN
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-E (Preprocess)
Syntax
-E

Description
This option preprocesses the supplied file and outputs the result to the standard output.

Example
The following preprocesses the file file.c supplying the macros, SUPPORT_FLOAT with a value of 1 and
LITTLE_ENDIAN.
-E -DSUPPORT_FLOAT=1 -DLITTLE_ENDIAN file.c
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-F (Set output format)
Syntax
-Ffmt

Description
The -F option instructs the linker to write its output in the format fmt. The linker supports the following formats:
-Fsrec Motorola S-record format
-Fhex Intel extended hex format
-Ftek Tektronix hex format
-Ttxt Texas Instruments hex format
-Flst Hexadecimal listing
-Fhzx Rowley native format
The default format, if no other format is specified, is -Fhzx.
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-g (Generate debugging information)
Syntax
-g

Description
The -g option instructs the compiler and assembler to generate source level debugging information.
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-help (Display help information)
Syntax
-help

Description
Displays a short summary of the options accepted by the compiler driver.
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-I (Define user include directories)
Syntax
-Idirectory

Description
In order to find include files the compiler driver arranges for the compilers to search a number of standard
directories. You can add directories to the search path using the -I switch which is passed on to each of the
language processors.
You can specify more than one include directory by separating each directory component with either a comma
or semicolon.

1204

CrossWorks for MSP430 Reference Manual

Utilities Reference

-I- (Exclude standard include directories)
Syntax
-I-

Description
Usually the compiler and assembler search for include files in the standard include directory created when the
product is installed. If for some reason you wish to exclude these system locations from being searched when
compiling a file, the -I- option will do this for you.
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-J (Define system include directories)
Syntax
-Jdirectory

Description
The -J option adds directory to the end of the list of directories to search for source files included (using
triangular brackets) by the #include preprocessor command.
You can specify more than one include directory by separating each directory component with either a comma
or semicolon in the property
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-K (Keep linker symbol)
Syntax
-Kname

Description
The linker removes unused code and data from the output file. This process is called deadstripping. To prevent
the linker from deadstripping unreferenced code and data you wish to keep, you must use the -K command line
option to force inclusion of symbols.

Example
If you have a C function, contextSwitch that must be kept in the output file (and which the linker will normally
remove), you can force its inclusion using:
-K_contextSwitch

Because -K is passed to the linker as an option, you must prefix the C function or variable name with an
underscore as the CrossWorks C compiler prefixes all external symbols with an underscore when constructing
linker symbols.
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-l- (Do not link standard libraries)
Syntax
-l-

Description
The -l option instructs the compiler driver not to link standard libraries. If you use this option you must supply
your own library functions or libraries.
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-L (Set library directory path)
Syntax
-Ldir

Description
Sets the library directory to dir. If -L is not specified on the command line, the default location to search for
libraries is set to $(InstallDir)/lib.
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-memorymap (Memory map file)
Syntax
-memorymap file

Description
The -memorymap option supplies the memory map file which is used to define the memory segments
referenced in the section placement file. See Memory Map file format for a description of the memory map file
format.

Example
-memorymap MemoryMap.xml
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-memorymapmacros (Memory map macros)
Syntax
-memorymapmacros macros

Description
The -memorymapmacros option supplies macro definitions that are applied to the memory map file.

Example
The macros FLASH_START and FLASH_SIZE are defined for the memory map using:
-memorymapmacros "FLASH_START=0x08000000;FLASH_SIZE=0x10000"
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-mul (Set MSP430 multiplier architecture)
Syntax
-mul16 -mul32

Description
Specifies the multiplier type to generate code for. The options are:
-mul16 16-bit multiplier
-mul32 32-bit multiplier

Example
To select compilation for a 32-bit multiplier
cc -mul32
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-M (Display linkage map)
Syntax
-M

Description
The -M option prints a linkage map named the same as the linker output file with the .map file extension.

1213

CrossWorks for MSP430 Reference Manual

Utilities Reference

-n (Dry run, no execution)
Syntax
-n

Description
When -n is specified, the compiler driver processes options as usual, but does not execute any subprocesses to
compile, assemble, archive or link applications.
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-nostderr (No stderr output)
Syntax
-nostderr

Description
When -nostderr is specified, any stderr output of subprocesses is redirected to stdout.
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-O (Optimize output)
Syntax
-Ox

Description
Pass the optimization option -Ox to the compiler and linker. Specific -O optimization options are described in
the compiler and linker reference sections.
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-o (Set output file name)
Syntax
-o filename

Description
The -o option instructs the compiler driver to write linker or archiver output to filename.
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-placement (Section placement file)
Syntax
-placement file

Description
The -placement option supplies the section placement file which is used to control the placement of program
sections in the memory map segments. See Section Placement file format for a description of the section
placement file format.

Example
-memorymap MemoryMap.xml -placement flash.xml
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-placementmacros (Section placement macros)
Syntax
-placementmacros macros

Description
The -placementmacros option supplies macro definitions that are applied to the section placement file.

Example
The macros FLASH_START and FLASH_SIZE are defined for the section placement using:
-placementmacros "FLASH_START=0x08000000;FLASH_SIZE=0x10000"
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-placementsegments (Section placement segments)
Syntax
-placementsegments segments

Description
The -placementsegments option supplies segments descriptions to the section placement file. You can use this
rather than supplying a memory map file.

Example
A simple memory map with FLASH and SRAM can be supplied as follows:
-placementsegments "FLASH RX 0x0 0x10000;SRAM RWX 0x20000000 0x10000" -placement flash.xml
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-printf (Select printf capability)
Syntax
-printf=c

Description
The -printf option selects the printf capability for the linked executable. The options are:
-printf=i[p][w] integer is supported, optional width and precision and optional wchar
-printf=l[p][w] long integer is supported, optional width and precision and optional wchar
-printf=ll[p][w] long long integer is supported, optional width and precision and optional wchar
-printf=f[ll][w] float, width and precision supported, optional long long and optional wchar
-printf=d[ll][w] double, width and precision supported, optional long long and optional wchar

Example
The minimal sized printf
-printf=i

The maximal functionality printf
-printf=dllw
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-R (Set section name)
Syntax
-Rx name

Description
These options name the default name of the sections generated by the compiler/assembler to be name. The
options are:
-Rc name change the default name of the code section
-Rd name change the default name of the data section
-Ri name change the default name of the isr section
-Rk name change the default name of the const section
-Rv name change the default name of the vector section
-Rz name change the default name of the bss section
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-scanf (Select scanf capability)
Syntax
-scanf= c

Description
The -scanf option selects the scanf capability for the linked executable. The options are:
-scanf=i[c] integer is supported, optional %[...] and %[^...] character class
-scanf=l[c] long integer is supported, optional %[...] and %[^...] character class
-scanf=ll[c] long long integer is supported, optional %[...] and %[^...] character class
-scanf=d[ll][c] floating point is supported, optional long long and %[...] and %[^...] character class

Example
The minimal sized scanf
-scanf=i

The maximal functionality scanf
-scanf=dllc
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-sd (Treat double as float)
Syntax
-sd

Description
The -sd option instructs the compiler to compile double as float and selects the appropriate library for linking.
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-U (Undefine macro symbol)
Syntax
-Uname

Description
The -U option undefines the preprocessor macro name.
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-v (Verbose execution)
Syntax
-v

Description
The -v switch displays command lines executed by the compiler driver.
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-w (Suppress warnings)
Syntax
-w

Description
This option instructs the compiler, assembler, and linker not to issue any warnings.
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-we (Treat warnings as errors)
Syntax
-we

Description
This option directs the compiler, assembler, and linker to treat all warnings as errors.
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-W (Pass option to tool)
Syntax
-Wtool option

Description
The -W command-line option passes option directly to the specified tool. Supported tools are
-Wa pass option to assembler
-Wc pass option to compiler
-Wl pass option to linker

Example
The following example passes the (compiler specific) -version option to the compiler
cc

-Wc-version
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-x (Specify file types)
Syntax
-x type

Description
The -x option causes the compiler driver to treat subsequent files to be of the following file type
-xa archives/libraries
-xasm assembly code files
-xc C code files
-xo object code files

Example
The following command line enables an assembly code file with the extension .arm to be assembled.
cc -xasm a.arm
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Compiler driver
This section describes the switches accepted by the compiler driver, hcl. The compiler driver is capable of
controlling compilation by all supported language compilers and the final link by the linker. It can also construct
libraries automatically.
In contrast to many compilation and assembly language development systems, with you don't invoke the
assembler or compiler directly. Instead you'll normally use the compiler driver hcl as it provides an easy way to
get files compiled, assembled, and linked. This section will introduce you to using the compiler driver to convert
your source files to object files, executables, or other formats.
We recommend that you use the compiler driver rather than use the assembler or compiler directly because
there the driver can assemble multiple files using one command line and can invoke the linker for you too. There
is no reason why you should not invoke the assembler or compiler directly yourself, but you'll find that typing in
all the required options is quite tedious-and why do that when hcl will provide them for you automatically?
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File naming conventions
The compiler driver uses file extensions to distinguish the language the source file is written in. The compiler
driver recognizes the extension .c as C source files, .s and .asm as assembly code files, and .hzo as object code
files.
We strongly recommend that you adopt these extensions for your source files and object files because you'll find
that using the tools is much easier if you do.

C language files
When the compiler driver finds a file with a .c extension, it runs the C compiler to convert it to object code.

Assembly language files
When the compiler driver finds a file with a .s or .asm extension, it runs the assembler to convert it to object
code.

Object code files
When the compiler driver finds a file with a .hzo extension, it passes it to the linker to include it in the final
application.
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Command-line options
This section describes the command-line options accepted by the CrossWorks compiler driver.
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-ansi (Warn about potential ANSI problems)
Syntax
-ansi

Description
Warn about potential problems that conflict with the relevant ANSI or ISO standard for the files that are
compiled.

Project property
Compiler Options > Enforce ANSI Checking
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-ar (Archive output)
Syntax
-ar

Description
This switch instructs the compiler driver to archive all output files into a library. Using -ar implies -c.

Example
The following command compiles file1.c, file2.asm, and file3.c to object code and archives them into the library
file libfunc.hza.
hcl file1.c file2.asm file3.c -o libfunc.hza
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-c (Compile to object code, do not link)
Syntax
-c

Description
All named files are compiled to object code modules, but are not linked.
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-g (Generate debugging information)
Syntax
-g

Description
The -g option instructs the compiler and assembler to generate debugging information (line numbers and data
type information) for the debugger to use and instructs the linker not to strip that debugging information.

Project property
Build Options > Include Debug Information
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-D (Define macro symbol)
Syntax
-Dname
-Dname=value

Description
You can define preprocessor macros using the -D option. The macro definitions are passed on to the respective
language compiler which is responsible for interpreting the definitions and providing them to the programmer
within the language.
The first form above defines the macro name but without an associated replacement value, and the second
defines the same macro with the replacement value value.

Project property
Preprocessor Options > Preprocessor Definitions

Example
The following defines two macros, SUPPORT_FLOAT with a value of 1 and LITTLE_ENDIAN with no replacement
value.
-DSUPPORT_FLOAT=1 -DLITTLE_ENDIAN
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-F (Set output format)
Syntax
-Fformat

Description
The -F option instructs the linker to write its output in the format fmt. The linker supports the following formats:
-Fsrec Motorola S-record format
-Fhex Intel extended hex format
-Ftek Tektronix hex format
-Ttxt Texas Instruments hex format
-Flst Hexadecimal listing
-Fhzx Rowley native format
The default format, if no other format is specified, is -Fhzx.
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-h (Display help information)
Syntax
-h

Description
Displays a short summary of the options accepted by the compiler driver.
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-I (Define user include directories)
Syntax
-Idirectory

Description
In order to find include files the compiler driver arranges for the compilers to search a number of standard
directories. You can add directories to the search path using the -I switch which is passed on to each of the
language processors.

Project property
Preprocessor Options > User Include Directories
You can specify more than one include directory by separating each directory component with either a comma
or semicolon.
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-J (Define system include directories)
Syntax
-Jdirectory

Description
The -J option adds directory to the end of the list of directories to search for source files included (using
triangular brackets) by the #include preprocessor command.

Project property
Preprocessor Options > System Include Directories
You can specify more than one include directory by separating each directory component with either a comma
or semicolon in the property
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-K (Keep linker symbol)
Syntax
-Kname

Description
The CrossWorks linker removes unused code and data from the output file. This process is called deadstripping.
To prevent the linker from deadstripping unreferenced code and data you wish to keep, you must use the -K
command line option to force inclusion of symbols.

Example
If you have a C function, contextSwitch that must be kept in the output file (and which the linker will normally
remove), you can force its inclusion using:
-K_contextSwitch

Because -K is passed to the linker as an option, you must prefix the C function or variable name with an
underscore as the CrossWorks C compiler prefixes all external symbols with an underscore when constructing
linker symbols.
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-l (Link library)
Syntax
-lx

Description
Link the library libx.hza from the library directory. The library directory is, by default $(InstallDir)/lib, but can be
changed with -L option.
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-L (Set library directory path)
Syntax
-Ldir

Description
Sets the library directory to dir. If -L is not specified on the command line, the default location to search for
libraries is set to $(InstallDir)/lib.
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-I- (Exclude standard include directories)
Syntax
-I-

Description
Usually the compiler and assembler search for include files in the standard include directory created when the
product is installed. If for some reason you wish to exclude these system locations from being searched when
compiling a file, the -I- option will do this for you.

Project property
Preprocessor Options > Ignore Includes

Note
The -I- option will clear any include directories previously set with the -I- option, so you must ensure that -Icomes before setting any directories you wish to search. Therefore, the following command line has a different
effect to the command line above:
hcl -I../include -I../lib/include -I- file.c
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-l- (Do not link standard libraries)
Syntax
-l-

Description
The -l option instructs the linker not to link standard libraries automatically included by the compiler or by the
assembler INCLUDELIB directive. If you use this options you must supply your own library functions or provide
the names of alternative sets of libraries to use.

Project property
Linker Options > Include Standard Libraries
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-m (Machine-level options)
Syntax
-mx

Description
Pass the option -mx to the compiler, assembler, and linker to select appropriate memory-model and code
generation characteristics. Specific -mx options are described in the C compiler and linker reference sections.
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-M (Display linkage map)
Syntax
-M
-Mfile

Description
The -M option prints a linkage map to standard output; -Mfile prints a linkage map to filename.
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-n (Dry run, no execution)
Syntax
-n

Description
When -n is specified, the compiler driver processes options as usual, but does not execute any subprocesses to
compile, assemble, or link applications.
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-o (Set output file name)
Syntax
-o filename

Description
The -o option instructs the compiler driver to write linked output to filename.
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-O (Optimize output)
Syntax
-mx

Description
Pass the optimization option -Ox to the compiler and linker. Specific -O optimization options are described in
the compiler and linker reference sections.
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-R (Set section name)
Syntax
-Rx

Description
Pass the option -Rx to the compiler and assembler to select standard section names. Specific -Rx options are
described in the C compiler and assembler reference sections.
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-s- (Exclude standard startup code)
Syntax
-s-

Description
C code requires a small startup file containing system initialization code to be executed before entering
main. The standard startup code is found in the object file $(InstallDir)/lib/crt0.hzo and the compiler driver
automatically links this into your program. If, however, you do not require the standard startup code because
you have a pure assembly language application, you can request the compiler driver to exclude this standard
startup code from the link using the -s- option.
You will find the source code for the standard startup module crt0 in the file $(InstallDir)/src/crt0.asm.

1254

CrossWorks for MSP430 Reference Manual

Utilities Reference

-v (Verbose execution)
Syntax
-v

Description
The -v switch displays command lines executed by the compiler driver.
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-V (Display version)
Syntax
-V

Description
The compiler driver and other tools usually operate without displaying any information messages or banners,
only diagnostics such as errors and warnings are displayed.
If the -V switch is given, the compiler driver displays its version and it passes the switch on to each compiler and
the linker so that they display their respective versions.
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-w (Suppress warnings)
Syntax
-w

Description
This option instructs the compiler, assembler, and linker not to issue any warnings.

Project property
Build Options > Suppress Warnings
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-we (Treat warnings as errors)
Syntax
-we

Description
This option directs the compiler, assembler, and linker to treat all warnings as errors.

Project property
Build Options > Treat Warnings as Errors
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-Wa (Pass option to assembler)
Syntax
-Wa,option

Description
The -Wa command-line option passes option directly to the assembler.

Example
The following command-line option passes -V directly to the assemblerthe effect of this is to force the compiler
to display its version information.
hcl -Wa,-V

1259

CrossWorks for MSP430 Reference Manual

Utilities Reference

-Wc (Pass option to compiler)
Syntax
-Wc,option

Description
The -Wc command-line option passes option directly to the compiler.

Example
The following command-line option passes -V directly to the compilerthe effect of this is to force the compiler to
display its version information.
hcl -Wc,-V
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-Wl (Pass option to linker)
Syntax
-Wl,option

Description
The -Wl command-line option passes option directly to the linker.

Example
The following command-line option passes -V directly to the linkerthe effect of this is to force the linker to
display its version information.
hcl -Wl,-V
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Hex extractor
The hex extractor hex to prepares images in a number of formats to burn into EPROM or flash memory.

Example
hex -Fhex app.hzx

This will generate a single Intel hex, app.hzx.hex, which contains all code and data in the application. The
addresses in the output file are the physical addresses of where the code and data are to be loaded.
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Command line options
This section describes the command line options accepted by the hex extractor.
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-T (Extract named section)
Syntax
-Tname

Description
The -T option extracts the named section from the input file. By default, all loadable sections are extracted from
the input file. You can specify multiple -T options on the command line to extract more than one section.

Example
hex app.hzx -Ftxt -TIDATA0 -TCODE

This reads the application file app.hzx, extracts the sections IDATA0 and CODE (ignoring all others) and writes
them to the file app.hzx.txt.
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-F (Set output format)
Syntax
-Ffmt

Description
The -F option sets the output format to fmt. The supported output formats are:
-Fsrec Motorola S-record format
-Fhex Intel extended hex format
-Ttxt Texas Instruments hex format
-Flst Hexadecimal listing
-Fbin Binary format
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-o (Set output prefix)
Syntax
-o prefix

Description
The -o option sets the prefix to use for the created files. If -o is not specified on the command line, the input file
name is used as the output prefix.

Example
hex app.hzx -Fhex -o app
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-P (Pad space)
Syntax
-Pval

Description
The -P option pads space directives with val.

Example
hex app.hzx -P0x00

This pads space directives in the output file with 0x00.
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-V (Display version)
Syntax
-V

Description
The -V option instructs the hex extractor to display its version information.
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Librarian
The librarian, or archiver, creates and manages object code libraries. An object code library is a collection of object
files consolidated into a single file, called an archive. The benefit of an archive is that you can pass it to the linker,
which will search the archive to resolve symbols needed during a link.

Automatic archiving
The compiler driver hcl can create archives if given the -ar option. This is more convenient than manipulating
archives by hand, so we recommend that you use the compiler driver to construct archives.

Command syntax
You can invoke the archiver using the following syntax:
har [ option ] archive file...

archive is the archive to operate on. file is an object file to add, replace, or delete from the archive, as determined
by option. option is a command-line option. Options are case sensitive and cannot be abbreviated.
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-c (Create archive)
Syntax
har -c archive-name object-file...

Description
This option creates a new archive, overwriting any archive that already exists with the same name.

Example
To create an archive called cclib.hza, which initially contains the two object code files ir.hzo and cg.hzo, you
would use:
har -c cclib.hza ir.hzo cg.hzo
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-r (Add or replace archive member)
har -r archive-name [object-file...]

Description
You can replace members in an archive using the -r switch. If you specify a file to add to the archive, and the
archive doesn't contain that member already, the file is appended to the archive as a new member.

Example
To replace the member ir.hzo in the archive cclib.hza with the file ir.hzo on disk, you would use:
har cclib.hza -r ir.hzo
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-d (Delete archive members)
Syntax
har -d archive-name [object-file...]

Description
You can remove members from the archive by using the -d switch, short for delete.

Example
To remove the member ir.hzo from the archive cclib.hza, you would use:
har cclib.hza -d ir.hzo
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-t (List archive members)
Syntax
har -t archive-name [object-file...]

Description
To show the members that comprise an archive, use the -t switch. The member's names are listed with their
sizes. If you only give the archive name on the command line, the archiver lists all the members contained in the
archive. However, you can list the attributes of specific members of the archive by specifying the names of the
members you are interested in.

Example
To list all the members of the archive cclib.hza, use:
har -t cclib.hza

To list only the attributes of the member ir.hzo that is contained in the archive cclib.hza, use:
har -t cclib.hza ir.hzo
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Command-Line Project Builder
CrossBuild is a program used to build your software from the command line without using CrossStudio. You
can, for example, use CrossBuild for nightly (automated) builds, production builds, and batch builds.
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Building with a CrossStudio project file
You can specify a CrossStudio project file:

Syntax
crossbuild [options] project-file
You must specify a configuration to build using -config. For instance:
crossbuild -config "V5T Thumb LE Release" arm.hzp

The above example uses the configuration V5T Thumb LE Release to build all projects in the solution contained
in arm.hzp.
To build a specific project that is in a solution, you can specify it using the -project option. For example:
crossbuild -config "V5T Thumb LE Release" -project "libm" libc.hzp

This example will use the configuration V5T Thumb LE Release to build the project libm that is contained in
libc.hzp.
If your project file imports other project files (using the <import> mechanism), when denoting projects you must
specify the solution names as a comma-separated list in parentheses after the project name:
crossbuild -config "V5T Thumb LE Release" -project "libc(C Library)" arm.hzp

libc(C Library) specifies the libc project in the C Library solution that has been imported by the project file
arm.hzp.
To build a specific solution that has been imported from other project files, you can use the -solution option.
This option takes the solution names as a comma-separated list. For example:
crossbuild -config "ARM Debug" -solution "ARM Targets,EB55" arm.hzp

In this example, ARM Targets,EB55 specifies the EB55 solution imported by the ARM Targets solution, which
was itself imported by the project file arm.hzp.
You can do a batch build using the -batch option:
crossbuild -config "ARM Debug" -batch libc.hzp

This will build the projects in libc.hzp that are marked for batch build in the configuration ARM Debug.
By default, a make-style build will be donei.e., the dates of input files are checked against the dates of output
files, and the build is avoided if the output is up to date. You can force a complete build by using the -rebuild
option. Alternatively, to remove all output files, use the -clean option.
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To see the commands being used in the build, use the -echo option. To also see why commands are being
executed, use the -verbose option. You can see what commands will be executed, without executing them, by
using the -show option.
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Building without a CrossStudio project file
To use CrossBuild without a CrossStudio project, specify the name of an installed project template, the name of
the project, and the files to build. For example:
crossbuild -config

-template LM3S_EXE -project myproject -file main.c

Or, instead of a template, you can specify a project type:
crossbuild -config

-type "Library" -project myproject -file main.c

You can specify project properties with the -property option:
crossbuild

-property Target=LM3S811
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Command-line options
This section describes the command-line options accepted by CrossBuild.
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-batch (Batch build)
Syntax
-batch

Description
Perform a batch build.
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-config (Select build configuration)
Syntax
-config name

Description
Specify the configuration for a build. If the configuration name can't be found, CrossBuild will list the available
configurations.
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-clean (Remove output files)
Syntax
-clean

Description
Remove all output files resulting from the build process.
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-D (Define macro)
Syntax
-D macro=value

Description
Define a CrossWorks macro value for the build process.
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-echo (Show command lines)
Syntax
-echo

Description
Show the command lines as they are executed.

1283

CrossWorks for MSP430 Reference Manual

Utilities Reference

-file (Build a named file)
Syntax
-file name

Description
Build the file name. Use with -template or -type.
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-packagesdir (Specify packages directory)
Syntax
-packagesdir dir

Description
Override the default value of the $(PackagesDir) macro.
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-project (Specify project to build)
Syntax
-project name

Description
Specify the name of the project to build. When used with a project file, if CrossBuild can't find the specified
project, the names of available projects are listed.
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-property (Set project property)
Syntax
-property name=value

Description
Specify the value of a project property use with -template or -type. If CrossBuild cannot find the specified
property, a list of the properties is shown.
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-rebuild (Always rebuild)
Syntax
-rebuild

Description
Always execute the build commands.
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-show (Dry run, don't execute)
Syntax
-show

Description
Show the command lines that would be executed, but do not execute them.
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-solution (Specify solution to build)
Syntax
-solution name

Description
Specify the name of the solution to build. If CrossBuild cannot find the given solution, the valid solution names
are listed.
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-studiodir (Specify CrossStudio directory)
Syntax
-studiodir name

Description
Override the default value of the $(StudioDir) macro.

1291

CrossWorks for MSP430 Reference Manual

Utilities Reference

-template (Specify project template)
Syntax
-template name

Description
Specify the project template to use. If CrossBuild cannot find the specified template then a list of template
names is shown.
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-time (Time the build)
Syntax
-time

Description
Show the time taken for the build.
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-threadnum (Specify number of build threads)
Syntax
-threadnum n

Description
Specify the number of build threads to use for the build. The default is zero which will use the number of
processor cores on your machine.
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-type (Specify project type)
Syntax
-type name

Description
Specify the project type to use. If CrossBuild cannot find the specified project type then a list of project type
names is shown.
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-verbose (Show build information)
Syntax
-verbose

Description
Show extra information relating to the build process.
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Command-Line Project Download and Debug
The CrossLoad program can be used to download and, optionally, debug applications without using
CrossStudio.
In order to carry out a download or verify, CrossLoad needs to know what target interface to use. The supported
target interfaces vary between operating systems; to list the supported target interfaces, use the -listtargets
option:
crossload -listtargets

This command will produce a list of target interface names and descriptions, such as:
usb
parport
sim

USB CrossConnect
Parallel Port Interface
Simulator

Use the -target option followed by the desired target interface's name to specify which interface to use:
crossload -target usb

CrossLoad normally is used to download and/or verify projects created and built with CrossStudio. To do this,
you must specify the target interface you want to use, the CrossStudio solution file, the project name, and the
build configuration. The following command line will download and verify the debug version of the project
MyProject contained within the MySolution.hzp solution file, using a USB CrossConnect:
crossload -target usb -solution MySolution.hzp -project MyProject -config Debug

In some cases, it is useful to download a program that was not created with CrossStudio by using the settings
from an existing CrossStudio project. You might want to do this if your existing project describes specific loaders
or scripts required in order to download the application. To do this, you simply add the name of the file you want
to download to the command line. For example, the following command line will download the Intel hex file
ExternalApp.hex using the release settings of the project MyProject connecting, using a USB CrossConnect:
crossload -target usb -solution MySolution.hzp -project MyProject -config Release
ExternalApp.hex

CrossLoad can download and verify a range of file types. The supported file types vary between systems; to list
the file types supported on your system, use the -listfiletypes option:
crossload -listfiletypes

This produces a list of the supported file types. For example:
hzx
bin
ihex
hex

CrossStudio Executable File
Binary File
Intel Hex File
Hex File
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TI Hex File
Motorola S-Record File

CrossLoad will attempt to determine the type of any load file given to it. If it cannot do this, you may specify the
file type using the -filetype option:
crossload -target usb -solution MySolution.hzp -project MyProject -config Release
ExternalApp.txt -filetype tihex

It is possible, with some targets, to download without specifying a CrossStudio project. In such cases, you only
need to specify the target interface and the load file. For example, the following will download myapp.s19 using
a USB CrossConnect:
crossload -target usb myapp.s19

Each target interface has a range of configurable properties allowing you to customize the default behaviour. To
list the target properties and their current values, use the -listprops option:
crossload -target parport -listprops

This command will list the parport target-interfaces properties, a description of what the properties are, and
their current values:
Name:
JTAG Clock Divider
Description: The amount to divide the JTAG clock frequency.
Value
: 1
Name:
Parallel Port
Description: The parallel port connection to use to connect to target.
Value
: Lpt1
Name:
Description:
programs is
Value
:

Parallel Port Sharing
Specifies whether sharing of the parallel port with other device drivers or
permitted.
No

You can modify a target property using the -setprop option. For example, the following command line would
set the parallel port interfaced used to lpt2:
crossload -target parport -setprop "Parallel Port"="Ltp2"
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Command line debugging
You can instruct CrossLoad to start a command-line debugging session by using -debug and optional -break
and -script options. For example:
crossload -target sim -solution mysolution.hzp -project myproject -config "ARM RAM Debug" debug -break main

This will load the executable created with the ARM RAM Debug configuration for myproject onto the simulator
and run it until its main function is called.
A command prompt is then shown that will accept JavaScript statements. The debugger functionality is
accessed using the built-in JavaScript object Debug, so all debugger commands are be entered using the form
Debug.command().
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Managing breakpoints
You can set breakpoints on global symbols using the Debug.breakexpr("expr") method. The type of the symbol
will determine the breakpoint that is set. For example
Debug.breakexpr("fn1")

will set a breakpoint on entry to the fn1 function, and
Debug.breakexpr("var1")

will set a breakpoint when the variable var1 is written. This method can also be used set breakpoints on
addresses. For example
Debug.breakexpr("0x248")

will cause a breakpoint when the address 0x248 is executed, and
Debug.breakexpr("(unsigned[1])0xec8")

will cause a breakpoint when the word at the address 0xec8 is written.
You can use the Debug.breakline("filename", linenumber) method to set breakpoints on specific lines of code.
For example, to set a breakpoint at line number 4 of c:/directory/file.c, you can use:
Debug.breakline("c:/directory/file.c", 4)

Note the use of forward slashes when specifying filenames.
To refer to the current file (the one where the debugger is located), you can use the Debug.getfilename()
method. Similarly, the current line number is accessed using the Debug.getlinenumber() method. Using these
functions, you can set a breakpoint at a line-offset from the current position. For example
Debug.breakline(Debug.getfilename(), Debug.getlinenumber()+4)

will break at 4 lines after the current line.
You can use the Debug.breakdata("expr", value, readNotWrite) method to set a breakpoint for when a value is
written to a global variable. For example
Debug.breakdata("var1", 4, false)

will cause a breakpoint when the value 4 is written to variable var. The third parameter, readNotWrite specifies
whether a breakpoint is set on reading (true) or writing (false) the data.
Each method of setting a breakpoint accepts three optional arguments: temporary, counter, and hardware.
A temporary breakpoint is removed the next time it occurs. For example
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Debug.breakexpr("fn1()", true)

will break on entry to fn1 unless another breakpoint occurs before this one.
Counted breakpoints are ignored for the specified number of hits. For example
Debug.breakexpr("fn1()", false, 9)

will break the 10th time fn1 is called.
The hardware argument specifies whether the debugger should use a hardware breakpoint in preference to a
software breakpoint. This can be used to set breakpoints on code that is copied to RAM prior to the copying.
The breakexpr and breakline methods return a positive breakpoint number that can be used to delete the
breakpoint using the Debug.deletebreak(number) method. For example:
fn1bkpt = Debug.breakexpr("fn1")
Debug.deletebreak(fn1bkpt)

To delete all breakpoints, supply zero to the deletebreak method. Note that temporary breakpoints do not have
breakpoint numbers.
The Debug.showbreak(number) method displays information about a breakpoint.
To show all breakpoints, supply zero to the showbreak method.
Some targets support exception breakpoints, which can be listed using the Debug.showexceptions() method.
For example, on an ARM9 or XScale target:
> Debug.showexceptions()
Reset disabled
Undef enabled
SWI disabled
P_Abort enabled
D_Abort enabled
IRQ disabled
FIQ disabled
>

You can enable or disable an exception with the Debug.enableexception("exception", enable) method. For
example
Debug.enableexception("IRQ", true)

will enable breakpoints when the IRQ exception occurs.
Some targets support breakpoint chaining. This enables breakpoints to be paired, with one breakpoint enabling
another one. For example:
> first = Debug.breakdata("count", 3)
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> second = Debug.breakexpr("fn1")
> Debug.chainbreak(first, second)

When count is written with the value 3, the breakpoint at fn1 is enabled; so when fn1 is subsequently called, if
ever, the breakpoint occurs. To remove breakpoint chaining, specify 0 as the second argument. For example:
Debug.chainbreak(first, 0)

Deleting either of the chained breakpoints will break the chain.

1302

CrossWorks for MSP430 Reference Manual

Utilities Reference

Displaying state
You can display the register state of the current context using the Debug.printregisters method, the local
variables of the current context using the Debug.printlocals() method and the global variables by using the
Debug.printglobals() method. To display single variables, use the Debug.print("expr"[,"format"]) method. For
example, where int i = -1:
> Debug.print("i")
0xffffffff
> Debug.print("i", "d")
-1
> Debug.print("i, "u")
4294967295
>

You can change the default radix, used when printing numbers, with the Debug.setprintradix(radix) method.
For example:
> Debug.setprintradix(10)
> Debug.print("i")
-1
> Debug.setprintradix(8)
> Debug.print("i)
037777777777
>

The Debug.print method is used to access registers
> Debug.print("@pc")
0x000002ac
>

and memory, too:
> Debug.print("((unsigned[2])0x0)")
[0xeafffffe, 0xe59ff018]
>

You can use the print method to update variables, registers, and memory using assignment operators:
> Debug.print("x=45")
0x0000002d
> Debug.print("x+=45")
0x0000005a
>

You can change whether character pointers are displayed as null-terminated strings using the
Debug.setprintstring(bool) method. For example, where const char *string = "hello":
> Debug.print("string")
hello
> Debug.print("string", "p")
0x00000770
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> Debug.setprintstring(false)
> Debug.print("string")
0x00000770
> Debug.print("string", "s")
hello
>

To change the maximum number of array elements that will be displayed, use the Debug.setprintarray(n)
method. For example, where unsigned array[4] = {1, 2, 3, 4}:
> Debug.print("array", "d")
[1, 2, 3, 4]
> Debug.setprintarray(2)
> Debug.print("array", "d")
[1, 2]

You can use the Debug.evaluate(expr) method to return the value of variables rather than displaying them. For
example
> x = Debug.evaluate("x")
> if (x == -1) Debug.echo("x is 45")
x is 45
>

where the method Debug.echo(str) outputs its string argument.
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Locating the current context
You can use the Debug.where() method to display a backtrace of the functions that have been called. Each entry
in the backtrace has its own framenumber which can be supplied to the Debug.locate(framenumber) method.
Framenumbers start at zero and are incremented for each function call. So framenumber zero is the current
location, framenumber one is the caller of the current location, and so on. For example
> Debug.where()
0) int debug_printf(const char* fmt=5) C:\svn\shared\target\libc\debug_printf.c:6
1) int main()
C:\tmp\try\main.c:17
2) ??? C:\svn\arm\arm\source\crt0.s:237
>

then
Debug.locate(1)

will locate the debugger context at main and
Debug.locate(0)

will change the debugger location back to debug_printf.
When the debugger locates (either because locate has been called or it has stopped), the corresponding
source line is displayed. You can display source lines around the located line by using the Debug.list(before,
after) method, which specifies the number of lines to display before and after the located line.
You can set the debugger to locate (and step) to machine instructions using the method
Debug.setmode(mode). Setting the mode to 1 selects interleaved mode (source code interleaved with
assembly code). Setting the mode to 2 selects assembly mode (disassembly with source code annotation).
Setting the mode to 0 selects source mode. For example:
> Debug.setmode(2)
0000031C E1A0C00D
> Debug.stepinto()
00000320 E92DD800
>Debug.setmode(0)
>

mov r12, sp
stmfd sp!, {r11-r12, lr-pc}

You can locate the debugger at a specified program counter by using the Debug.locatepc(pc) method. For
example, you can disassemble from specific address:
> Debug.setmode(2)
> Debug.locatepc(0x2f4)
000002F4
E59F30D0
> Debug.list(0, 1)
000002F4
E59F30D0
000002F8
E50B3020
>

ldr r3, [pc, #+0x0D0]
ldr r3, [pc, #+0x0D0]
str r3, [r11, #-0x020]
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You can locate the debugger to a full register context using the Debug.locateregisters(registers) method. This
method takes an array that specifies each register value, typically in ascending register number order. You can
use the Debug.printregisters() method to see the the order. For example, for an ARM7, ARM9, or XScale:
var a = new Array()
a[0] = 0 // r0 value
a[15] = 0x2f4 // pc value
a[16] = 0x10 // cspr value
Debug.locateregisters(a)

You can put the debugger context back at the stopped state by calling Debug.locate without any parameters:
Debug.locate()
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Controlling execution
To continue execution from a breakpoint, use the Debug.go() method. You can single step into function calls
with Debug.stepinto(). You can single step over function calls by using the Debug.stepover() method. To
complete execution of the current function, use the Debug.stepout() method.
You will get the debugger prompt immediately when the go, stepinto, stepover or stepout methods are called.
If you want to wait for the target to stop (for example in a script), you need to use the Debug.wait(mstimeout)
method, which returns 0 if the millisecond timeout occurred or 1 if execution has stopped. For example
> Debug.go(); Debug.wait(1000)

will wait for one second or until a breakpoint occurs. If a breakpoint isn't reached, you can use the method
Debug.breaknow() to stop execution. You can end the debug session with the Debug.quit() method.
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Support packages
The preceding examples assume that the support packages required to carry out the download or debugging
have already been installed using CrossStudio's package manager. On some systems however, it is not possible
or desirable to use CrossStudio to do this. This section describes how to manually install packages from the
command line and specify where CrossLoad should look for them.
The first thing to do is decide on the directory path to store the installed packages, we're going to use an
environment variable PACKAGES_DIR to specify this. For example:
export PACKAGES_DIR=/my_crossload_packages
echo $PACKAGES_DIR

Please note, Windows command prompt users should use set instead of export and %PACKAGES_DIR% instead
of $PACKAGES_DIR.
Next, we need to get hold of the package .hzq or .hzr files to be installed. These can be downloaded from our
package website or package archive.
Once we have got the package files, the mkpkg tool can be used to install the packages. For example:
mkpkg -x CMSIS_3.hzq $PACKAGES_DIR
mkpkg -x LPC1000.hzq $PACKAGES_DIR

By default, CrossLoad will look for packages in CrossStudio's packages directory. We can override this so that our
local package installation is used instead with CrossLoad's -packagesdir option. For example:
crossload -packagesdir $PACKAGES_DIR -target usb -solution MySolution.hzp -project
MyProject -config Debug
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Command-line options
This section describes the command-line options accepted by CrossLoad.

Usage
crossload [options] [files]

ARM Usage
crossload [options] [files] -serve [arguments]
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-break (Stop execution at symbol)
Syntax
-break symbol

Description
When used with the -debug option, this will stop execution at symbol.
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-config (Specify build configuration)
Syntax
-config name

Description
Specify the build configuration to use.
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-connection (Specify connection)
Syntax
-connection name

Description
Specify the connection to use.
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-debug (Enter command line debugging)
Syntax
-debug

Description
Enable command-line debugging. A command prompt is displayed at which debugger commands can be
entered. The command prompt has a simple history and editing mechanism.
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-eraseall (Erase all flash memory)
Syntax
-eraseall

Description
Erase all flash memory rather than just the flash memory to be programmed.
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-filetype (Specify load file type)
Syntax
-filetype filetype

Description
Specify the type of the file to download. By default, CrossLoad will attempt to detect the file type, you should
use this option if CrossLoad cannot determine the file type or to override the detection and force the type to a
specific value. Use the -listfiletypes option to list the supported file types.
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-help (Display help)
Syntax
-help

Description
Display the command-line options CrossLoad accepts.
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-listfiletypes (Display supported load file types)
Syntax
-listfiletypes

Description
Lists all the supported file types.
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-listprojectprops (Display all project properties)
Syntax
-listprojectprops

Description
List all properties of selected project and configuration
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-listprops (Display target properties)
Syntax
-listprops

Description
List the target properties of the target specified by the -target option.
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-listtargets (Display supported target interfaces)
Syntax
-listtargets

Description
List all the supported target interfaces.
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-loadaddress (Set load address)
Syntax
-loadaddress address

Description
When downloading a load file that doesn't contain any address information, such a binary file, this option
specifies the base address to which the file should be downloaded.
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-loader (Specify loader configuration)
Syntax
-loader config

Description
Select the loader configuration to use for the download.
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-nodifferential (Inhibit differential download)
Syntax
-nodifferential

Description
Do not use differential downloading.
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-nodisconnect (Inhibit target disconnection)
Syntax
-nodisconnect

Description
Do not disconnect the target interface when finished.
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-nodownload (Inhibit download)
Syntax
-nodownload

Description
Do not download, just verify.
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-noverify (Inhibit verification)
Syntax
-noverify

Description
Do not verify the downloaded application.
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-packagesdir (Specify package directory)
Syntax
-packagesdir directory

Description
Set $(PackagesDir) to directory.
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-project (Specify project name)
Syntax
-project name

Description
Specify the name of the desired project.
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-quiet (Be silent)
Syntax
-quiet

Description
Do not output any progress messages.
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-reset (Reset only)
Syntax
-reset

Description
Reset the target and don't carry out download.
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-script (Execute debug script)
Syntax
-script file

Description
When used with the -debug option, this will execute the debug commands in file.
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-serve (Run semihosting server)
Syntax
-serve

Description
Serve CrossStudio debug I/O operations. Any command-line arguments following this option will be passed to
the target application. The application can access them either by calling debug_getargs or by compiling the
startup code in crt0.s or crt0.asm with the FULL_LIBRARY C preprocessor symbol defined so that argc and argv
are passed to main.
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-setprop (Set target interface property)
Syntax
-setprop property=value

Description
Set the target interface property property to value.

1333

CrossWorks for MSP430 Reference Manual

Utilities Reference

-solution (Specify solution file)
Syntax
-solution file

Description
Specify the CrossWorks solution file to use.
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-studiodir (Specify Studio directory)
Syntax
-studiodir directory

Description
Set $(StudioDir) to directory.
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-target (Specify target interface)
Syntax
-target name

Description
Specify the target interface to use. Use the -listtargets option to list the supported target interfaces.
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-verbose (Display additional status)
Syntax
-verbose

Description
Produce verbose output.
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Command-Line Scripting
CrossScript is a program that allows you to run CrossStudio's JavaScript (ECMAScript) interpreter from the
command line.
The primary purpose of CrossScript is to facilitate the creation of platform-independent build scripts.

Syntax
crossscript [options] file
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Command-line options
This section describes the command-line options accepted by CrossScript.
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-define (Define global variable)
Syntax
-define variable=value

Description
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-help (Show usage)
Syntax
-help

Description
Display usage information and command line options.
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-load (Load script file)
Syntax
-load path

Description
Loads the script file path.

1342

CrossWorks for MSP430 Reference Manual

Utilities Reference

-define (Verbose output)
Syntax
-verbose

Description
Produces verbose output.
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CrossScript classes
CrossScript provides the following predefined classes:
BinaryFile
CWSys
WScript
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Example uses
The following example demonstrates using CrossScript to increment a build number:
First, add a JavaScript file to your project called incbuild.js containing the following code:
function incbuild()
{
var file = "buildnum.h"
var text = "#define BUILDNUMBER "
var s = CWSys.readStringFromFile(file);
var n;
if (s == undefined)
n = 1;
else
n = eval(s.substring(text.length)) + 1;
CWSys.writeStringToFile(file, text + n);
}
// Executed when script loaded.
incbuild();

Add a file called getbuildnum.h to your project containing the following code:
#ifndef GETBUILDNUM_H
#define GETBUILDNUM_H
unsigned getBuildNumber();
#endif

Add a file called getbuildnum.c to your project containing the following code:
#include "getbuildnum.h"
#include "buildnum.h"
unsigned getBuildNumber()
{
return BUILDNUMBER;
}

Now, to combine these:
Set the Build Options > Always Rebuild project property of getbuildnum.c to Yes.
Set the User Build Step Options > Pre-Compile Command project property of getbuildnum.c to
"$(StudioDir)/bin/crossscript" -load "$(ProjectDir)/incbuild.js".
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Embed
Embed is a program that converts a binary file into a C/C++ array definition.
The primary purpose of the Embed tool is to provide a simple method of embedding files into an application.
This may be useful if you want to include firmware images, bitmaps, etc. in your application without having to
read them first from an external source.

Syntax
embed variable_name input_file output_file
variable_name is the name of the C/C++ array to be initialised with the binary data.
input_file is the path to the binary input file.
output_file is the path to the C/C++ source file to generate.

Example
To convert a binary file image.bin to a C/C++ file called image.h:
embed img image.bin image.h

This will generate the following output in image.h:
static const unsigned char img[] = {
0x5B, 0x95, 0xA4, 0x56, 0x16, 0x5F,
0xC5, 0x04, 0xD4, 0x8D, 0x73, 0x40,
0x3E, 0x81, 0x90, 0x39, 0xA3, 0x8E,
0x3C, 0x63, 0xC8, 0x30, 0x90, 0x0C,
0xA2, 0x74, 0xC2, 0x8C, 0x1D, 0x56,
0x45, 0xCE, 0x3B, 0x92, 0xAD, 0x0B,
0x92, 0x59, 0xB9, 0x9D, 0x01, 0x30,
0xC5, 0xEA, 0xCE, 0x35, 0xF6, 0x4B,
};

0x2D,
0x31,
0x22,
0x54,
0x57,
0x2C,
0x59,
0x05,

0x47,
0x66,
0x37,
0xA4,
0x05,
0x39,
0x9F,
0xBF
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Header file generator
The command line program mkhdr generates a C or C++ header file from a CrossWorks memory map file.
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Using the header generator
For each register definition in the memory map file a corresponding #define is generated in the header file. The
#define is named the same as the register name and is defined as a volatile pointer to the address.
The type of the pointer is derived from the size of the register. A four-byte register generates an unsigned long
pointer. A two-byte register generates an unsigned short pointer. A one-byte register will generates an unsigned
char pointer.
If a register definition in the memory map file has bitfields then preprocessor symbols are generated for each
bitfield. Each bitfield will have two preprocessor symbols generated, one representing the mask and one
defining the start bit position. The bitfield preprocessor symbol names are formed by prepending the register
name to the bitfield name. The mask definition has _MASK appended to it and the start definition has _BIT
appended to it.
For example consider the following definitions in the the file memorymap.xml.
<RegisterGroup start="0xFFFFF000" name="AIC">
<Register start="+0x00" size="4" name="AIC_SMR0">
<BitField size="3" name="PRIOR" start="0" />
<BitField size="2" name="SRCTYPE" start="5" />
</Register>
...

We can generate the header file associated with this file using:
mkhdr memorymap.xml memorymap.h

This generates the following definitions in the file memorymap.h.
#define
#define
#define
#define
#define

AIC_SMR0 (*(volatile unsigned long *)0xFFFFF000)
AIC_SMR0_PRIOR_MASK 0x7
AIC_SMR0_PRIOR_BIT 0
AIC_SMR0_SRCTYPE_MASK 0x60
AIC_SMR0_SRCTYPE_BIT 5

These definitions can be used in the following way in a C/C++ program:
Reading a register
unsigned r = AIC_SMR0;

Writing a register
AIC_SMR0 = (priority << AIC_SMR0_PRIOR_BIT) | (srctype << AIC_SMR0_SRCTYPE_BIT);

Reading a bitfield
unsigned srctype = (AIC_SMR0 & AIC_SMR0_SRCTYPE_MASK) >> AIC_SMR0_SRCTYPE_BIT;

Writing a bitfield

AIC_SMR0 = (AIC_SMR0 & ~AIC_SMR0_SRCTYPE_MASK) | ((srctype & AIC_SMR0_SRCTYPE_MASK) << AIC_SMR0_SRCTYPE_BIT)
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Command line options
This section describes the command line options accepted by the header file generator.

Syntax
mkhdr inputfile outputfile targetname [option]
inputfile is the name of the source CrossWorks memory map file. outputfile is the the name of the file to write.
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-regbaseoffsets (Use offsets from peripheral base)
Syntax
-regbaseoffsets

Description
Instructs the header generator to include offsets of registers from the peripheral base.
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-nobitfields (Inhibit bitfield macros)
Syntax
-nobitfields

Description
Instructs the header generator not to generate any definitions for bitfields.
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Package generator
To create a package the program mkpkg can be used. The set of files to put into the package should be
in the desired location in the $(PackagesDir) directory. The mkpkg command should be run with
$(PackagesDir) as the working directory and all files to go into the package must be referred to using
relative paths. A package must have a package description file that is placed in the $(PackagesDir)/
packages directory. The package description file name must end with _package.xml. If a package is to
create entries in the new project wizard then it must have a file name project_templates.xml.
For example, a package for the mythical FX150 processor would supply the following files:
A project template file called targets/FX150/project_templates.xml. The format of the
project templates file is described in Project Templates file format.
The $(PackagesDir)-relative files that define the functionality of the package.
A package description file called packages/FX150_package.xml. The format of the package
description file is described in Package Description file format.
The package file FX150.hzq would be created using the following command line:
mkpkg -c packages/FX150.hzq targets/FX150/project_templates.xml

packages/FX150_package.xml

You can exclude specific files or directories from being added to a package using the -exclude option:
mkpkg -c packages/FX150.hzq targets/FX150 -exclude targets/FX150/excluded_file.txt -exclude
targets/FX150/excluded_directory packages/FX150_package.xml

You can list the contents of the package using the -t option:
mkpkg -t packages/FX150.hzq

You can remove an entry from a package using the -d option:
mkpkg -d packages/FX150.hzq -d fileName

You can add or replace a file into an existing package using the -r option:
mkpkg -r packages/FX150.hzq -r fileName

You can extract files from an existing package using the -x option:
mkpkg -x packages/FX150.hzq outputDirectory

You can automate the package creation process using a Combining project type.
Using the new project wizard create a combining project in the directory $(PackagesDir).
Set the Output File Path property to be $(PackagesDir)/packages/mypackage.hzq.
Set the Combine command property to $(StudioDir)/bin/mkpkg -c $(CombiningOutputFilePath)
$(CombiningRelInputPaths).
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Add the files you want to go into the package into the project using the Project Explorer.
Right-click the project node in the Project Explorer and choose Build.
When a package is installed, the files in the package are copied into the desired $(PackagesDir)-relative
locations. When a file is copied into the $(PackagesDir)/packages directory and its filename ends with
_package.xml the file $(PackagesDir)/packages/installed_packages.xml is updated with an
entry:
<include filename="FX150_package.xml" />

During development of a package you can manually edit this file. The same applies to the file
$(PackagesDir)/targets/project_templates.xml which will contain a reference to your
project_templates.xml file.

Usage:
mkpkg [options] packageFileName file1 file2
Option

Description

-c

Create a new package.

-compress level

Change compression level (0 for none, 9 for
maximum).

-d

Remove files from a package.

-exclude path

Exclude path when adding files to a package

-f

Output files to stdout.

-r

Replace files in a package.

-readonly

Force all files to have read only attribute.

-t

List the contents of a package.

-v

Be chatty.

-V

Show version information.

-x

Extract files from a package.
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File formats
This section describes the file formats CrossWorks uses:

Memory Map file format
Describes the memory map file format that defines memory regions and registers in a microcontroller.

Section Placement file format
Describes the section placement file format that maps program sections to memory areas in the target
microcontroller.

Project file format
Describes the format of CrossStudio project files.

Project Templates file format
Describes the format of project template files used by the New Project wizard.

Property Groups file format
Describes the format of the property groups file you can use to define meta-properties.

Package Description file format
Describes the format of the package description files you use to create packages other users can install in
CrossStudio.

External Tools file format
Describes the format of external tool configuration files you use to extend CrossStudio.

Debugger Type Interpretation file format
Describes the format of the debugger type interpretation file.
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Memory Map file format
CrossStudio memory-map files are structured using XML syntax for its simple construction and parsing.
The first entry of the project file defines the XML document type used to validate the file format.
<!DOCTYPE Board_Memory_Definition_File>

The next entry is the Root element. There can only be one Root element in a memory map file:
<Root name="My Board">

A Root element has a name attribute every element in a memory map file has a name attribute. Names should
be unique within a hierarchy level. Within a Root element, there are MemorySegment elements that represent
regions within the memory map.
<Root name="My Board">
<MemorySegment name="Flash" start="0x1000" size="0x200" access="ReadOnly">

MemorySegment elements have the following attributes:
start:The start address of the memory segment. A simple expression, usually a hexadecimal number with
a 0x prefix.
size:The size of the memory segment. A simple expression, usually a hexadecimal number with a 0x prefix.
access:The permissible access types of the memory segment. One of ReadOnly, Read/Write,
WriteOnly, or None.
address_symbol:A symbolic name for the start address of the memory segment.
size_symbol:A symbolic name for the size of the memory segment.
end_symbol:A symbolic name for the end address of the memory segment.
RegisterGroup elements are used to organize registers into groups. Register elements are used to define
peripheral registers:
<Root name="My Board" >
<MemorySegment name="System" start="0x2000" size="0x200" >
<RegisterGroup name="Peripheral1" start="0x2100" size="0x10" >
<Register name="Register1" start="+0x8" size="4" >

RegisterGroup elements have the same attributes as MemorySegment elements. Register elements
have the following attributes:
name:Register names should be valid C/C++ identifier names, i.e., alphanumeric characters and
underscores are allowed but names cannot start with a number.
start:The start address of the memory segment. Either a C-style hexadecimal number or, if given a + prefix,
an offset from the enclosing element's start address.
size:The size of the register in bytes, either 1, 2, or 4.
access:The same as the access attribute of the MemorySegment element.
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address_symbol:The same as the address_symbol attribute of the MemorySegment element.
A Register element can contain BitField elements that represent the bits in a peripheral register:
<Root name="My Board" >
<MemorySegment name="System" start="0x2000" size="0x200" >
<RegisterGroup name="Peripheral1" start="0x2100" size="0x10" >
<Register name="Register1" start="+0x8" size="4" >
<BitField name="Bits_0_to_3" start="0" size="4" />

BitField elements have the following attributes:
name:The same as the name attribute of the RegisterGroup element.
start:The starting bit position, 031.
size:The total number of bits, 132.
A Bitfield element can contain Enum elements:
<Root name="My Board" >
<RegisterGroup name="Peripheral1" start="0x2100" size="0x10" >
<Register name="Register1" start="+0x8" size="4" >
<BitField name="Bits_0_to_3" start="0" size="4" />
<Enum name="Enum3" start="3" />
<Enum name="Enum5" start="5" />

You can import CMSIS SVD files (see http://www.onarm.com/) into a memory map using the ImportSVD
element:
<ImportSVD filename="$(TargetsDir)/targets/Manufacturer1/Processor1.svd.xml">

The filename attribute is an absolute filename which is macro-expanded using CrossWorks system macros.
When a memory map file is loaded either for the memory map viewer or to be used for linking or debugging, it is
preprocessed using the (as yet undocumented) CrossWorks XML preprocessor.
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Section Placement file format
CrossStudio section-placement files are structured using XML syntax to enable simple construction and parsing.
The first entry of the project file defines the XML document type used to validate the file format:
<!DOCTYPE Linker_Placement_File>

The next entry is the Root element. There can only be one Root element in a memory map file:
<Root name="Flash Placement">

A Root element has a name attribute. Every element in a section-placement file has a name attribute. Each
name should be unique within its hierarchy level. Within a Root element, there are MemorySegment elements.
These correspond to memory regions defined in a memory map file that will be used in conjunction with the
section-placement file when linking a program. For example:
<Root name="Flash Placement">
<MemorySegment name="FLASH">

A MemorySegment contains ProgramSection elements that represent program sections created by the C/
C++ compiler and assembler. The order of ProgramSection elements within a MemorySegment element
represents the order in which the sections will be placed when linking a program. The first ProgramSection
will be placed first and the last one will be placed last.
<Root name="My Board" >
<MemorySegment name="FLASH">
<ProgramSection name=".text">

ProgramSection elements have the following attributes:
address_symbol:A symbolic name for the start address of the section.
alignment:The required alignment of the program section; a decimal number specifying the byte
alignment.
end_symbol:A symbolic name for the end address of the section.
load:If Yes, the section is loaded. If No, the section isn't loaded.
runin:This specifies the name of the section to copy this section to. Multiple sections can be specified
separated by a semicolon, the first section that exists will be used.
size:The optional size of the program section in bytes, a hexadecimal number with a 0x prefix.
size_symbol:A symbolic name for the size of the section.
start:The optional start address of the program section, a hexadecimal number with a 0x prefix.
When a section placement file is used for linking it is preprocessed using the (as yet undocumented) CrossWorks
XML preprocessor.
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Project file format
CrossStudio project files are held in text files with the .hzp extension. Because you may want to edit project
files, and perhaps generate them, they are structured using XML syntax to enable simple construction and
parsing.
The first entry of the project file defines the XML document type used to validate the file format:
<!DOCTYPE CrossStudio_Project_File>

The next entry is the solution element; there can only be one solution element in a project file. This
specifies the solution name displayed in the Project Explorer and has a version attribute that defines the fileformat version of the project file. Solutions can contain projects, projects can contain folders and files, and
folders can contain folders and files. This hierarchy is reflected in the XML nestingfor example:
<solution version="1" Name="solutionname">
<project Name="projectname">
<file Name="filename" />
<folder Name="foldername">
<file Name="filename2" />
</folder>
</project>
</solution>

Note that each entry has a Name attribute. Names of project elements must be unique to the solution, and
names of folder elements must be unique to the project, but names of files do not need to unique.
Each file element must have a file_name attribute that is unique to the project. Ideally, the file_name
is a file path relative to the project (or solution directory), but you can also specify a full file path, if you want to.
File paths are case-sensitive and use "/" as the directory separator. They may contain macro instantiations, so file
paths cannot contain the "$" character. For example
<file file_name="$(StudioDir)/source/crt0.s" Name="crt0.s" />

will be expanded using the value of $(StudioDir) when the file is referenced from CrossStudio.
Project properties are held in configuration elements with the Name attribute of the configuration element
corresponding to the configuration name, e.g., "Debug". At a given project level (i.e., solution, project, folder),
there can only be one named configuration elementi.e., all properties defined for a configuration are in single
configuration element.
<project Name="projectname">
<configuration project_type="Library" Name="Common" />
<configuration Name="Release" build_debug_information="No" />
</project>

You can use the import element to link projects:
<import file_name="target/libc.hzp" />
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Project Templates file format
The CrossStudio New Project dialog works from a file called project_templates.xml in the targets
subdirectory of the CrossStudio installation directory. Because you may want to add your own new project types,
they are structured using XML syntax to enable simple construction and parsing.
The first entry of the project file defines the XML document type used to validate the file format:
<!DOCTYPE Project_Templates_File>

The next entry is the projects element, which is used to group a set of new project entries into an XML
hierarchy.
<projects>
<project>
</projects>

Each entry has a project element that contains the class of the project (attribute caption), the name of the
project (attribute name), its type (attribute type) and a description (attribute description). For example:
<project caption="ARM Evaluator7T" name="Executable"
description="An executable for an ARM Evaluator7T." type="Executable"/>

The project type can be one of these:
Executable: a fully linked executable.
Library: a static library.
Object file: an object file.
Staging: a staging project.
Combining: a combining project.
Externally Built Executable: an externally built executable.
The configurations to be created for the project are defined using the configuration element, which must
have a name attribute:
<configuration name="ARM RAM Release"/>

The property values to be created for the project are defined using the property element. If you have a
defined value, you can specify this using the value attribute and, optionally, set the property in a defined
configuration, such as:
<property name="target_reset_script" configuration="RAM"
value="Evaluator7T_ResetWithRamAtZero()" />

Alternatively, you can include a property that will be shown to the user, prompting them to supply a value as
part of the new-project process.
<property name="linker_output_format"/>

1361

CrossWorks for MSP430 Reference Manual

Appendices

The folders to be created are defined using the folder element. The folder element must have a name
attribute and can also have a filter attribute. For example:
<folder name="Source Files" filter="c;cpp;cxx;cc;h;s;asm;inc" />

The files to be in the project are specified using the file element. You can use build-system macros (see
Project macros) to specify files located in the CrossStudio installation directory. Files will be copied to the
project directory or just left as references, depending on the value of the source attribute:
<file name="main.c" source="$(StudioDir)/samples/Shared/main.c"/>
<file name="$(StudioDir)/source/thumb_crt0.s"/>

You can define the set of configurations that can be referred to in the top-level configurations element:
<configurations>
<configuration>
</configurations>

This contains the set of all configurations that can be created when a project is created. Each configuration is
defined using a configuration element, which can define the property values for that configuration. For
example:
<configuration name="Debug">
<property name="build_debug_information" value="Yes">
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Property Groups file format
The CrossStudio project system provides a means to create new properties that change a number of project
property settings and can also set C pre-processor definitions when selected. Such properties are called property
groups and are defined in a property-groups file. The property-group file to use for a project is defined by the
Property Groups File property. These files usually define target-specific properties and are structured using XML
syntax to enable simple construction and parsing.
The first entry of the property groups file defines the XML document type, which is used to validate the file
format:
<!DOCTYPE CrossStudio_Group_Values>

The next entry is the propertyGroups element, which is used to group a set of property groups entries into
an XML hierarchy:
<propertyGroups>
<grouphdots
<grouphdots
</propertyGroups>

Each group has the name of the group (attribute name), the name of the options category (attribute group),
short (attribute short) and long (attribute long) help descriptions, and a default value (attribute default).
For example:
<group short="Target Processor" group="Build Options" short="Target Processor"
long="Select a set of target options" name="Target" default="STR912FW44" />

Each group has a number of groupEntry elements that define the enumerations of the group.
<group\>
<groupEntry>
<groupEntry>
</group>

Each groupEntry has the name of the entry (attribute name), e.g.:
<groupEntry name="STR910FW32">

A groupEntry has the property values and C pre-processor definitions that are set when the groupEntry is
selected; they are specified with property and cdefine elements. For example:
<groupEntry>
<property>
<cdefine>
<property>
</groupEntry>
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A property element has the property's name (attribute name), its value (attribute value), and an optional
configuration (attribute configuration):
<property name="linker_memory_map_file"
value="$(StudioDir)/targets/ST_STR91x/ST_STR910FM32_MemoryMap.xml" />

A cdefine element has the C preprocessor name (attribute name) and its value (attribute value):
<cdefine value="STR910FM32" name="TARGET_PROCESSOR" />
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Package Description file format
Package-description files are XML files used by CrossStudio to describe a support package, its contents, and any
dependencies it has on other packages.
Each package file must contain one package element that describes the package. Optionally, the package
element can contain a collection of file, history, and documentation elements to be used by
CrossStudio for documentation purposes.
The filename of the package-description file should match that of the package and end in "_package.xml".
Below is an example of two package-description files. The first is for a base chip-support package for the
LPC2000; the second is for a board-support package dependent on the first:

Philips_LPC2000_package.xml
<!DOCTYPE CrossStudio_Package_Description_File>
<package cpu_manufacturer="Philips" cpu_family="LPC2000" version="1.1"
crossstudio_versions="8:1.6-" author="Rowley Associates Ltd" >
<file file_name="$(TargetsDir)/Philips_LPC210X/arm_target_Philips_LPC210X.htm"
title="LPC2000 Support Package Documentation" />
<file file_name="$(TargetsDir)/Philips_LPC210X/Loader.hzp" title="LPC2000 Loader
Application Solution" />
<group title="System Files">
<file file_name="$(TargetsDir)/Philips_LPC210X/Philips_LPC210X_Startup.s" title="LPC2000
Startup Code" />
<file file_name="$(TargetsDir)/Philips_LPC210X/Philips_LPC210X_Target.js" title="LPC2000
Target Script" />
</group>
<history>
<version name="1.1" >
<description>Corrected LPC21xx header files and memory maps to include GPIO ports 2
and 3.</description>
<description>Modified loader memory map so that .libmem sections will be placed
correctly.</description>
</version>
<version name="1.0" >
<description>Initial Release.</description>
</version>
</history>
<documentation>
<section name="Supported Targets">
<p>This CPU support package supports the following LPC2000 targets:
<ul>
<li>LPC2103</li>
<li>LPC2104</li>
<li>LPC2105</li>
<li>LPC2106</li>
<li>LPC2131</li>
<li>LPC2132</li>
<li>LPC2134</li>
<li>LPC2136</li>
<li>LPC2138</li>
</ul>
</p>
</section>

1365

CrossWorks for MSP430 Reference Manual

Appendices

</documentation>
</package>

CrossFire_LPC2138_package.xml
<!DOCTYPE CrossStudio_Package_Description_File>
<package cpu_manufacturer="Philips" cpu_family="LPC2000" cpu_name="LPC2138"
board_manufacturer="Rowley Associates" board_name="CrossFire LPC2138"
dependencies="Philips_LPC2000" version="1.0">
<file file_name="$(SamplesDir)/CrossFire_LPC2138/CrossFire_LPC2138.hzp" title="CrossFire
LPC2138 Samples Solution" />
<file file_name="$(SamplesDir)/CrossFire_LPC2138/ctl/ctl.hzp" title="CrossFire LPC2138 CTL
Samples Solution" />
</package>

Package elements
The package element describes the support package, its contents, and any dependencies it has on other
packages. Valid attributes for this element are:
Attribute

Description

author

The author of the package.

board_manufacturer

The manufacturer of the board supported by the
package (if omitted, CPU manufacturer will be used).

board_name

The name of the specific board supported by the
package (only required for board-support packages).

company_name

The name of the company to group the package under
in the package dialogs. (if omitted, the Board/CPU
manufacturer will be used).

cpu_family

The family name of the CPU supported by the package
(optional).

cpu_manufacturer

The manufacturer of the CPU supported by the
package.

cpu_name

The name of the specific CPU supported by the
package (may be omitted if the CPU family is specified).

crossstudio_versions

A string describing which version of CrossStudio
supports the package (optional). The format of the
string is target_id_number:version_range_string.

description

A description of the package (optional).

dependencies

A semicolon-separated list of packages the package
requires to be installed in order to work.

installation_directory

The directory in which the package should be installed
(optional - if undefined, defaults to "$(PackagesDir)").

title

A short description of the package (optional).
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The package version number.

File elements
The file element is used by CrossStudio for documentation purposes by adding links to files of interest within
the package such as example project files and documentation.
Attribute

Description

file_name

The file path of the file.

title

A description of the file.

Optionally, file elements can be grouped into categories using the group element.

Group elements
The group element is used for categorizing files described by file elements into a particular group.
Attribute

Description

title

Title of the group.

History elements
The history element is used to hold a description of the package's version history.
The history element should contain a collection of version elements.

Version element
The version element is used to hold the description of a particular version of the package.
Attribute

Description

name

The name of the version being described.

The version element should contain a collection of description elements.

Description elements
Each description element contains text that describes a feature of the package version.
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Documentation elements
The documentation element is used to provide arbitrary documentation for the package.
The documentation element should contain a collection of one or more section elements.

Section elements
The section element contains package documentation in XHTML format.
Attribute

Description

name

The title of the documentation section.

target_id_number
The following table lists the possible target ID numbers:
Target

ID

AVR

4

ARM

8

MSP430

9

MAXQ20

18

MAXQ30

19

version_range_string
The version_range_string can be any of the following:
version_number:The package will only work on version_number.
version_number-:The package will work on version_number or any future version.
-version_number:The package will work on version_number or any earlier version.
low_version_number-high_version_number:The package will work on low_version_number,
high_version_number or any version in between.
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External Tools file format
CrossStudio external-tool configuration files are structured using XML syntax for its simple construction and
parsing.

Tool configuration files
The CrossStudio application will read the tool configuration file when it starts up. By default, CrossStudio will
read the file $(StudioUserDir)/tools.xml.

Structure
All tools are wrapped in a tools element:
<tools>
</tools>

Inside the tools element are item elements that define each tool:
<tools>
<item name="logical name">
</item>
</tools>

The item element requires an name attribute, which is an internal name for the tool, and has an optional wait
element. When CrossStudio invokes the tool on a file or project, it uses the wait element to determine whether
it should wait for the external tool to complete before continuing. If the wait attribute is not provided or is set to
yes, CrossStudio will wait for external tool to complete.
The way that the tool is presented in CrossStudio is configured by elements inside the
element.

menu
The menu element defines the wording used inside menus. You can place a shortcut to the menu using an
ampersand, which must be escaped using &amp in XML, before the shortcut letter. For instance:
<menu>&amp;PC-lint (Unit Check)</menu>

text
The optional text element defines the wording used in contexts other than menus, for instance when the tool
appears as a tool button with a label. If text is not provided, the tool's textual appearance outside the menu is
taken from the menu element (and is presented without an shortcut underline). For instance:
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<text>PC-lint (Unit Check)</text>

tip
The optional tip element defines the status tip, shown on the status line, when moving over the tool inside
CrossStudio:
<tip>Run a PC-lint unit checkout on the selected file or folder</tip>

key
The optional key element defines the accelerator key, or key chord, to use to invoke the tool using the keyboard.
You can construct the key sequence using modifiers Ctrl, Shift, and Alt, and can specify more than one key in a
sequence (note: Windows and Linux only; OS X does not provide key chords). For instance:
<key>Ctrl+L, Ctrl+I</key>

message
The optional message element defines the text shown in the tool log in CrossStudio when running the tool. For
example:
<message>Linting</message>

match
The optional match element defines which documents the tool will operator on. The match is performed using
the file extension of the document. If the file extension of the document matches one of the wildcards provided,
the tool will run on that document. If there is no match element, the tool will run on all documents. For instance:
<match>*.c;*.cpp</match>

output
The optional output element defines the name of the output file created by the tool. If this element is specified
the the output file will be opened in the editor when the tool has finished execution. The macros $(InputPath)
and $(InputBaseName) can be used to name the output file. For Instance:
<output>$(InputBaseName).txt</output>

commands
The commands element defines the command line to run to invoke the tool. The command line is expanded
using macros applicable to the file derived from the current build configuration and the project settings. Most
importantly, the standard $(InputPath) macro expands to a full pathname for the target file.
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Additional macros constructed by CrossStudio are:
$(DEFINES) is the set of -D options applicable to the current file, derived from the current configuration
and project settings.
$(INCLUDES) is the set of -I options applicable to the current file, derived from the current configuration
and project settings.
For instance:
<commands>
&quot;$(LINTDIR)/lint-nt&quot; -i$(LINTDIR)/lnt &quot;$(LINTDIR)/lnt/co-gcc.lnt&quot;
$(DEFINES) $(INCLUDES) -D__GNUC__ -u -b +macros -w2 -e537 +fie +ffn -width(0,4) -hF1
&quot;-format=%f:%l:%C:s%t:s%m&quot; &quot;$(InputPath)&quot;
</commands>

In this example we intend $(LINTDIR) to point to the directly where PC-lint is installed and for $(LINTDIR) to be
defined as a CrossStudio global macro. You can set global macros using Project > Macros... or Tools > Options >
Building > Global Macros.
Note that additional &quot entities are placed around pathnames in the commands sectionthis is to ensure that
paths that contain spaces are correctly interpreted when the command is executed by CrossStudio.
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Debugger Type Interpretation file format
CrossStudio debugger type interpretation files are used by the debugger to provide list and string displays of C+
+ template container types. The files are structured using XML syntax for its simple construction and parsing.
Consider the following C++ template type
template <class _Type> class VeryBasicArray
{
private:
size_t m_Count;
_Type *m_pData;
public:
VeryBasicArray(size_t count)
: m_Count(count)
, m_pData(new _Type[count])
{
}
}
VeryBasicArray<int> basicArray(5);

To display a variable of this type as a list the type interpretation file contains the following entry
<List Name="VeryBasicArray&lt;*&gt;"
Head="(($(T)*)HEAD).m_pData"
Data="(*($(T0)*)CURRENT)"
Length="(($(T)*)HEAD).m_Count"
Next="CURRENT+sizeof($(T0))"/>

The Name attribute is used to match the template type name note that the &lt and &gt xml entities are used to
match the template argument.
When an entry has been matched the head of the list is located by evaluating the debugger expression in the
Head attribute. The debugger expressions can contain macros that refer to the matched template type and will
use the symbols HEAD and CURRENT.
The macro $(T) refers to the instantiated template type, for the above example $(T)=VeryBasicArray<int>.
The template arguments are referred to using macros $(T0), for the above example $(T0)=int.
The symbol HEAD is the address of the variable being displayed, for the above example if the variable
basicArray is allocated at address 0x20004000 then the Head expression
((VeryBasicArray<int>*)0x20004000).m_pData

will be evaluated by the debugger, note that the . operator and the -> operator are equivalent in debugger
expressions.
To display an element the debugger will evaluate the Data expression. This expression contains the symbol
CURRENT which is the address of the element to display, for the above example the first element is at the
address basicArray.m_pData which is allocated at address 0x20008000 then the Data expression
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(*(int*)0x20008000)

will be evaluated by the debugger.
To increment the CURRENT symbol the Next expression
0x20008000+sizeof(int)

will be evaluated by the debugger.
Before the CURRENT symbol is incremented the debugger needs to check if it is at the end of list. The can be
done either as a Condition expression or as a Length expression
((VeryBasicArray<int>*)0x20004000).m_Count

The String display is simpler than the List display since the characters are contiguous and optionally null
terminated. The Data and Length expressions are supported, for example
<String Name="string"
Data="*(($(T) *)HEAD)._M_start_of_storage._M_data"
Length="(($(T) *)HEAD)._M_finish-(($(T) *)HEAD)._M_start_of_storage._M_data"/>

is used to display STLPort std::string types.
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Building Environment Options
Build
Property
Automatically Build Before Debug
Environment/Build/Build Before
DebugBoolean

Description
Enables auto-building of a project before downloading
if it is out of date.

Confirm Automatically Build Before Debug
Environment/Build/Show Build Before
DebugBoolean

Confirm Debugger Stop
Environment/Build/Confirm Debugger
StopBoolean

Display ETA
Environment/Build/Display ETABoolean

Enables the display of the auto-building popup.

Present a warning when you start to build that requires
the debugger to stop.
Selects whether to attempt to compute and display
the ETA on building.

Display Progress Bar
Environment/Build/Display Progress
BarBoolean

Echo Build Command Lines
Environment/Build/Show Command
LinesBoolean

Echo Raw Error/Warning Output
Environment/Build/Show Unparsed Error
OutputBoolean

Find Error After Building
Environment/Build/Find Error After
BuildBoolean

Global Macros
Environment/Macros/Global MacrosStringList

Selects whether to display progress bar on building.

Selects whether build command lines are written to
the build log.
Selects whether the unprocessed error and warning
output from tools is displayed in the build log.
Moves the cursor to the first diagnostic after a build
completes with errors.
Build macros that are shared across all solutions and
projects e.g. paths to library files.

Keep Going On Error
Environment/Build/Keep Going On
ErrorBoolean

Build doesn't stop on error.

Save Project File Before Building
Environment/Build/Save Project File On
BuildBoolean

Selects whether to save the project file prior to build.

Show Build Information
Environment/Build/Show Build
InformationBoolean

Show build information.
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Toolchain Root Directory
Environment/Build/Tool Chain Root
DirectoryString

Specifies where to find the toolchain (compilers etc).

Build Acceleration
Property
Disable Unity Build
Environment/Build/Disable Unity
BuildBoolean

Description
Ignore Unity Build project properties and always build
individual project components.

Parallel Building Threads
Environment/Build/Building
ThreadsIntegerRange

The number of threads to launch when building.

Parallel Project Building

Selects whether to build projects or files within
projects in parallel. When this is set one thread per
project/configuration is used.

Environment/Build/Parallel Project
BuildingBoolean

Window
Property

Description

Show Build Log On Build
Environment/Show Transcript On
BuildBoolean

Show the build log when a build starts.
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Debugging Environment Options
Breakpoint
Property

Description

Disassembly Breakpoints

What to do with disassembly breakpoints on debug
stop/start.

Environment/Debugger/Disassembly
BreakpointsBoolean

Display
Property

Description

Close Disassembly On Mode Switch
Environment/Debugger/Close Disassembly On Close Disassembly On Mode Switch.
Mode SwitchBoolean

Data Tips Display a Maximum Of

Selects the maximum number of array elements
displayed in a data tip.

Environment/Debugger/Maximum Array
Elements DisplayedIntegerRange

Default Display Mode
Selects the format that data values are shown in.

Environment/Debugger/Default Variable
Display ModeEnumeration

Display Floating Point Number In

The printf format directive used to display floating
point numbers.

Environment/Debugger/Floating Point
Format DisplayCustom

Maximum Backtrace Calls

Selects the maximum number of calls when
backtracing.

Environment/Debugger/Maximum Backtrace
CallsIntegerRange

Prompt To Display If More Than
The array size to display with prompt.

Environment/Debugger/Array Elements
Prompt SizeIntegerRange

Show Data Tips In Text Editor
Environment/Debugger/Show Data TipsBoolean

Show Data Tips In Text Editor.

Show Labels In Disassembly
Environment/Debugger/Disassembly Show
LabelsBoolean

Show Labels In Disassembly.

Show Source In Disassembly
Environment/Debugger/Disassembly Show
SourceBoolean

Show Source In Disassembly.

Show char * as null terminated string
Environment/Debugger/Display Char Ptr As
StringBoolean

Show char * as null terminated string.
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Source Path

Global search path to find source files.

Environment/Debugger/Source PathStringList

Extended Data Tips
Property

Description

ASCII
Display ASCII extended data tips.

Environment/Debugger/Extended Tooltip
Display Mode/ASCIIBoolean

Binary
Display Binary extended data tips.

Environment/Debugger/Extended Tooltip
Display Mode/BinaryBoolean

Decimal
Display Decimal extended data tips.

Environment/Debugger/Extended Tooltip
Display Mode/DecimalBoolean

Hexadecimal
Display Hexadecimal extended data tips.

Environment/Debugger/Extended Tooltip
Display Mode/HexadecimalBoolean

Octal
Display Octal extended data tips.

Environment/Debugger/Extended Tooltip
Display Mode/OctalBoolean

Unsigned Decimal
Display Unsigned Decimal extended data tips.

Environment/Debugger/Extended Tooltip
Display Mode/Unsigned DecimalBoolean

Target
Property

Description

Step Using Hardware Step

Step using hardware single stepping rather than
setting breakpoints.

Environment/Debugger/Step Using Hardware
StepBoolean

Switch Project To Text Editor
Environment/Debugger/Switch ProjectBoolean

Switch Project To Text Editor.

Window
Property
Clear Debug Terminal On Run
Environment/Clear Debug Terminal On
RunBoolean

Description
Clear the debug terminal automatically when a
program is run.
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Debugging/Hide Transcript On Successful
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Show Target Log On Load
Debugging/Show Transcript On LoadBoolean

Appendices

Hide the Output window when a load completes
without error.
Show the target log when a load starts.
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IDE Environment Options
Browser
Property

Description

Text Size

Sets the text size of the integrated HTML and help
browser.

Environment/Browser/Text SizeEnumeration

Underline Hyperlinks In Browser
Environment/Browser/Underline Web
LinksBoolean

Enables underlining of hypertext links in the
integrated HTML and help browser.

File Search
Property
Collapse Search Results
Find In Files/Collapse ResultsBoolean

Files To Exclude
Find In Files/Exclude File TypesStringList

Files To Search
Find In Files/File TypeStringList

Find History
Find In Files/Find HistoryStringList

Flat Search Result Output
Find In Files/Flat OutputBoolean

Folder History
Find In Files/Folder HistoryStringList

Match Case
Find In Files/Match CaseBoolean

Match Whole Word
Find In Files/Match Whole WordBoolean

Replace History
Find In Files/Replace HistoryStringList

Search Dependencies
Find In Files/Search DependenciesBoolean

Search In
Find In Files/ContextEnumeration

Use Regular Expressions
Find In Files/Use RegExpBoolean

Description
Whether to initially collapse search results.
The wildcard used to exclude files in Find In Files
searches.
The wildcard used to match files in Find In Files
searches.
The list of strings recently used in searches.
Whether to display file search results as a flat list.
The set of folders recently used in file searches.
Whether the case of letters must match exactly when
searching.
Whether the whole word must match when searching.
The list of strings recently used in searches.
Controls searching of dependent files."
Where to look to find files.
Whether to use a regular expression or plain text
search.
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Find And Replace
Property

Description

Greedy Regular Expressions

Enables greedy matching when using regular
expressions.

Find/Greedy RegExpBoolean

Internet
Property

Description

Automatically Check For Packages

Specifies whether to enable downloading of the list of
available packages.

Environment/Internet/Check PackagesBoolean

Automatically Check For Updates
Environment/Internet/Check UpdatesBoolean

Check For Latest News
Environment/Internet/RSS UpdateBoolean

Enable Connection Debugging
Environment/Internet/Enable
DebuggingBoolean

External Web Browser
Environment/External Web BrowserFileName

HTTP Caching
Environment/Internet/HTTP CachingBoolean

HTTP Proxy Host
Environment/Internet/HTTP Proxy
ServerString

Specifies whether to check for software updates.
Specifies whether to update the latest news window.
Controls debugging traces of internet connections and
downloads.
The path to the external web browser to use when
accessing non-local files.
Specifies if caching should be permitted when carrying
out HTTP requests.
Specifies the IP address or hostname of the HTTP proxy
server. If empty, no HTTP proxy server will be used.

HTTP Proxy Port
Environment/Internet/HTTP Proxy
PortIntegerRange

Maximum Download History Items

Specifies the HTTP proxy server's port number.

The maximum amount of download history kept in the

Environment/Internet/Max Download History
downloads window.
ItemsIntegerRange

Use Content Delivery Network
Environment/Package/Use Content Delivery
NetworkBoolean

Specifies whether to use content delivery network to
deliver packages."

Launcher
Property

Description

Confirm Check Solution Target

Specifies whether the CrossStudio launcher should
present a warning if the solution being launched
targets a device it does not support.

Environment/Launcher/Confirm Check
Solution TargetBoolean
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Launch Latest Installations Only

Specifies whether the CrossStudio launcher should
only consider the latest installations when deciding
which one to use.

Environment/Launcher Use Latest
Installations OnlyBoolean

Specifies whether the CrossStudio launcher should
be used when the operating system or an external
application requests a file to be opened.

Launcher Enabled
Environment/Launcher EnabledBoolean

Package Manager
Property

Description

Check Solution Package Dependencies

Specifies whether to check package dependencies
when a solution is loaded.

Environment/Package/Check Solution
Package DependenciesBoolean

Package Directory
Environment/Package/Destination
DirectoryString

Specifies the directory packages are installed to.

Show Logos

Specifies whether the package manager should display
company logos.

Environment/Package/Show LogosEnumeration

Verify Package Downloads

Specifies whether to carry out an MD5 sum check on
downloaded package files.

Environment/Package/Verify
DownloadsBoolean

Print
Property

Description

Bottom Margin
The page's bottom margin in millimetres.

Environment/Printing/Bottom
MarginIntegerRange

Left Margin
Environment/Printing/Left MarginIntegerRange

Page Orientation
Environment/Printing/OrientationEnumeration

Page Size

The page's left margin in millimetres.
The page's orientation.
The page's size.

Environment/Printing/Page SizeEnumeration

Right Margin
The page's right margin in millimetres.

Environment/Printing/Right
MarginIntegerRange

Top Margin
Environment/Printing/Top MarginIntegerRange

The page's top margin in millimetres.
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Startup
Property
Allow Multiple CrossStudios
Environment/Permit Multiple Studio
InstancesBoolean

Load Last Project On Startup
Environment/Load Last Project On
StartupBoolean

Description
Allow more than one CrossStudio to run at the same
time.
Specifies whether to load the last project the next time
CrossStudio runs.

New Project Directory
Environment/General/Solution
DirectoryString

Splash Screen
Environment/Splash ScreenEnumeration

The directory where projects are created.

How to display the splash screen on startup.

Status Bar
Property
(Visible)
Environment/Status BarBoolean

Description
Show or hide the status bar.

Show Build Status Pane
Environment/General/Status Bar/Show Build Show or hide the Build pane in the status bar.
StatusBoolean

Show Caret Position Pane
Environment/General/Status Bar/Show Caret Show or hide the Caret Position pane in the status bar.
PosBoolean

Show Insert/Overwrite Status Pane
Environment/General/Status Bar/Show
Insert ModeBoolean

Show or hide the Insert/Overwrite pane in the status
bar.

Show Read-Only Status Pane
Environment/General/Status Bar/Show Read
OnlyBoolean

Show or hide the Read Only pane in the status bar.

Show Size Grip
Environment/General/Status Bar/Show Size
GripBoolean

Show or hide the status bar size grip.

Show Target Pane
Environment/General/Status Bar/Show
TargetBoolean

Show or hide the Target pane in the status bar.

Show Time Pane
Environment/General/Status Bar/Show
TimeBoolean

Show or hide the Time pane in the status bar.
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Title Bar
Property

Description

Show Full Solution Path
Environment/General/Title Bar/Show Full
Solution PathBoolean

Show the full solution path in title bar.

User Interface
Property
Application Main Font
Environment/Application Main FontFont

Application Monospace Font
Environment/Application Monospace
FontFixedPitchFont

Error Display Timeout
Environment/Error Display
TimeoutIntegerRange

Errors Are Displayed
Environment/Error Display ModeEnumeration

File Size Display Units
Environment/Size Display UnitEnumeration

Number File Names in Menus
Environment/Number MenusBoolean

Qt Style Sheet
Environment/Qt Style SheetFileName

Show Large Icons In Toolbars
Environment/General/Large IconsBoolean

Show Ribbon
Environment/General/Ribbon/ShowBoolean

Show Window Selector On Ctrl+Tab
Environment/Show SelectorBoolean

Theme
Environment/Studio ThemeEnumeration

Window Menu Contains At Most
Environment/Max Window Menu
ItemsIntegerRange

Description
The font to use for the user interface as a whole.
The fixed-size font to use for the user interface as a
whole.
The minimum time, in seconds, that errors are shown
for in the status bar.
How errors are reported in CrossStudio.
How to display sizes of items in the user interface. SI
defines 1kB=1000 bytes, IEC defines 1kiB=1024 bytes,
Alternate SI defines 1kB=1024 bytes.
Number the first nine file names in menus for quick
keyboard access.
The Qt style sheet to use in order to customize the user
interface (experimental).
Show large or small icons on toolbars.
Show or hide the ribbon.
Present the Window Selector on Next Window and
Previous Window commands activated from the
keyboard.
The user interface style and color theme to use.
The maximum number of windows appearing in the
Windows menu.
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Programming Language Environment Options
Assembly Language
Property

Description

Column Guide Columns
Text Editor/Indent/Assembly Language/
Column GuidesString

The columns that guides are drawn for.

Indent Closing Brace
Text Editor/Indent/Assembly Language/
Close BraceBoolean

Indent the closing brace of compound statements.

Indent Context
Text Editor/Indent/Assembly Language/
Context LinesIntegerRange

The number of lines to use for context when indenting.

Indent Mode
Text Editor/Indent/Assembly Language/
Indent ModeEnumeration

How to indent when a new line is inserted.

Indent Opening Brace
Text Editor/Indent/Assembly Language/Open Indent the opening brace of compound statements.
BraceBoolean

Indent Size
Text Editor/Indent/Assembly Language/
SizeIntegerRange

The number of columns to indent a code block.

Tab Size
Text Editor/Indent/Assembly Language/Tab
SizeIntegerRange

The number of columns between tabstops.

Use Tabs
Text Editor/Indent/Assembly Language/Use
TabsBoolean

Insert tabs when indenting.

User-Defined Keywords
Text Editor/Indent/Assembly Language/
KeywordsStringList

Additional identifiers to highlight as keywords.

C and C++
Property

Description

Column Guide Columns
Text Editor/Indent/C and C++/Column
GuidesString

The columns that guides are drawn for.

1384

CrossWorks for MSP430 Reference Manual

Appendices

Indent Closing Brace
Text Editor/Indent/C and C++/Close
BraceBoolean

Indent the closing brace of compound statements.

Indent Context
Text Editor/Indent/C and C++/Context
LinesIntegerRange

The number of lines to use for context when indenting.

Indent Mode
Text Editor/Indent/C and C++/Indent
ModeEnumeration

How to indent when a new line is inserted.

Indent Opening Brace
Text Editor/Indent/C and C++/Open
BraceBoolean

Indent the opening brace of compound statements.

Indent Size
Text Editor/Indent/C and C++/
SizeIntegerRange

The number of columns to indent a code block.

Tab Size
Text Editor/Indent/C and C++/Tab
SizeIntegerRange

The number of columns between tabstops.

Use Tabs
Text Editor/Indent/C and C++/Use
TabsBoolean

Insert tabs when indenting.

User-Defined Keywords
Text Editor/Indent/C and C++/
KeywordsStringList

Additional identifiers to highlight as keywords.

Default
Property

Description

Column Guide Columns
Text Editor/Indent/Default/Column
GuidesString

The columns that guides are drawn for.

Indent Closing Brace
Text Editor/Indent/Default/Close
BraceBoolean

Indent the closing brace of compound statements.

Indent Context
Text Editor/Indent/Default/Context
LinesIntegerRange

The number of lines to use for context when indenting.

Indent Mode
Text Editor/Indent/Default/Indent
ModeEnumeration

How to indent when a new line is inserted.
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Indent Opening Brace
Indent the opening brace of compound statements.

Text Editor/Indent/Default/Open
BraceBoolean

Indent Size
Text Editor/Indent/Default/SizeIntegerRange

The number of columns to indent a code block.

Tab Size
The number of columns between tabstops.

Text Editor/Indent/Default/Tab
SizeIntegerRange

Use Tabs
Text Editor/Indent/Default/Use TabsBoolean

Insert tabs when indenting.

User-Defined Keywords
Additional identifiers to highlight as keywords.

Text Editor/Indent/Default/
KeywordsStringList

Java
Property

Description

Column Guide Columns
Text Editor/Indent/Java/Column GuidesString

Indent Closing Brace
Text Editor/Indent/Java/Close BraceBoolean

The columns that guides are drawn for.
Indent the closing brace of compound statements.

Indent Context
The number of lines to use for context when indenting.

Text Editor/Indent/Java/Context
LinesIntegerRange

Indent Mode
How to indent when a new line is inserted.

Text Editor/Indent/Java/Indent
ModeEnumeration

Indent Opening Brace

Indent the opening brace of compound statements.

Text Editor/Indent/Java/Open BraceBoolean

Indent Size

The number of columns to indent a code block.

Text Editor/Indent/Java/SizeIntegerRange

Tab Size
Text Editor/Indent/Java/Tab SizeIntegerRange

Use Tabs
Text Editor/Indent/Java/Use TabsBoolean

User-Defined Keywords
Text Editor/Indent/Java/KeywordsStringList

The number of columns between tabstops.
Insert tabs when indenting.
Additional identifiers to highlight as keywords.
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Source Control Environment Options
External Tools
Property

Description

Diff Command Line
Environment/Source Code Control/
DiffCommandStringList

The diff command line.

Merge Command Line
Environment/Source Code Control/
MergeCommandStringList

The merge command line.

Preference
Property
Add Immediately

Description
Bypasses the confirmation dialog and immediately

Environment/Source Code Control/Immediate
adds items to source control.
AddBoolean

Commit Immediately

Bypasses the confirmation dialog and immediately

Environment/Source Code Control/Immediate
commits items.
CommitBoolean

Get Immediately

Bypasses the confirmation dialog and immediately

Environment/Source Code Control/Immediate
gets items from source control.
GetBoolean

Lock Immediately

Bypasses the confirmation dialog and immediately

Environment/Source Code Control/Immediate
locks items.
LockBoolean

Remove Immediately

Bypasses the confirmation dialog and immediately

Environment/Source Code Control/Immediate
removes items from source control.
RemoveBoolean

Resolved Immediately

Bypasses the confirmation dialog and immediately

Environment/Source Code Control/Immediate
mark items resolved.
ResolvedBoolean

Revert Immediately

Bypasses the confirmation dialog and immediately

Environment/Source Code Control/Immediate
revert items.
RevertBoolean

Unlock Immediately

Bypasses the confirmation dialog and immediately

Environment/Source Code Control/Immediate
unlocks items.
UnlockBoolean
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Bypasses the confirmation dialog and immediately

Environment/Source Code Control/Immediate
updates items.
UpdateBoolean
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Text Editor Environment Options
Auto Recovery
Property
Auto Recovery Backup Time
Text Editor/Auto Recovery Backup
TimeIntegerRange

Auto Recovery Keep Time
Text Editor/Auto Recovery Keep
TimeIntegerRange

Description
The time in minutes between saving of auto recovery
backups files or 0 to disable generation of backup files.
The time in days to keep unrecovered backup files or 0
to disable deletion of unrecovered backup files.

Cursor Fence
Property
Bottom Margin
Text Editor/Margins/BottomIntegerRange

Keep Cursor Within Fence
Text Editor/Margins/EnabledBoolean

Left Margin
Text Editor/Margins/LeftIntegerRange

Right Margin
Text Editor/Margins/RightIntegerRange

Top Margin
Text Editor/Margins/TopIntegerRange

Description
The number of lines in the bottom margin.
Enable margins to fence and scroll around the cursor.
The number of characters in the left margin.
The number of characters in the right margin.
The number of lines in the right margin.

Editing
Property

Description

Allow Drag and Drop Editing

Enables dragging and dropping of selections in the
text editor.

Text Editor/Drag Drop EditingBoolean

Bold Popup Diagnostic Messages
Text Editor/Bold Popup DiagnosticsBoolean

Column-mode Tab
Text Editor/Column Mode TabBoolean

Confirm Modified File Reload
Text Editor/Confirm Modified File
ReloadBoolean

Displays popup diagnostic messages in bold for easier
reading.
Tab key moves to the next textual column using the
line above.
Display a confirmation prompt before reloading a file
that has been modified on disk.
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Copy Action When Nothing Selected
Text Editor/Copy ActionEnumeration

Cut Action When Nothing Selected
Text Editor/Cut ActionEnumeration

Cut Single Blank Line
Text Editor/Cut Blank LinesBoolean

Diagnostic Cycle Mode
Text Editor/Diagnostic Cycle
ModeEnumeration

Edit Read-Only Files
Text Editor/Edit Read OnlyBoolean

Enable Virtual Space
Text Editor/Enable Virtual SpaceBoolean

Numeric Keypad Editing
Text Editor/Numeric Keypad EnabledBoolean

Tab Key Indents Preprocessor Directives
Text Editor/Tab Key Indents Preprocessor
DirectivesBoolean

Undo And Redo Behavior
Text Editor/Undo ModeEnumeration

Appendices

What Copy copies when nothing is selected.
What Cut cuts when nothing is selected.
Selects whether to place text on the clipboard when
a single blank line is cut. When set to Yes, cutting
a single blank line will put the blank line on the
clipboard. When set to No, cutting a single blank line
deletes the line and does not place it on the clipboard.
Iterates through diagnostics either from most severe
to least severe or in reported order.
Allow editing of read-only files.
Permit the cursor to move into locations that do not
currently contain text.
Selects whether the numeric keypad plus and minus
buttons copy and cut text.
Enables or disables the indentation of C preprocessor
directives when using tab key indentation on a
selection.
How Undo and Redo group your typing when it is
undone and redone.

Find And Replace
Property

Description

Case Sensitive Matching

Enables or disables the case sensitivity of letters when
searching.

Text Editor/Find/Match CaseBoolean

Find History
Text Editor/Find/HistoryStringList

Regular Expression Matching
Text Editor/Find/Use RegExpBoolean

Replace History
Text Editor/Replace/HistoryStringList

Whole Word Matching
Text Editor/Find/Match Whole WordBoolean

The list of strings recently used in searches.
Enables regular expression matching rather than plain
text matching.
The list of strings recently used in replaces.
Enables or disables whole word matching when
searching.

Formatting
Property

Description
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Access Modifier Offset

The extra indent or outdent of access modifiers, e.g.
public:.

Text Editor/Formatting/
AccessModifierOffsetInteger

Additional Formatting Styles
Additional styles to pass to clang-format.

Text Editor/Additional Formatting
StylesStringList

Align After Open Bracket

If enabled, horizontally aligns arguments after an open
bracket.

Text Editor/Formatting/
AlignAfterOpenBracketBoolean

Align Consecutive Assignments
If enabled, aligns consecutive assignments.

Text Editor/Formatting/
AlignConsecutiveAssignmentsBoolean

Align Consecutive Declarations
Text Editor/Formatting/
AlignConsecutiveDeclarationsBoolean

If enabled, aligns consecutive declarations.

Align Escaped Newlines Left

If enabled, aligns escaped newlines as far left as
possible otherwise puts them into the right-most
column.

Text Editor/Formatting/
AlignEscapedNewlinesLeftBoolean

Align Operands

If enabled, horizontally align operands of binary and
ternary expressions.

Text Editor/Formatting/
AlignOperandsBoolean

Align Trailing Comments
If enabled, aligns trailing comments.

Text Editor/Formatting/
AlignTrailingCommentsBoolean

Allow All Parameters Of Declaration On Next Line

Allow putting all parameters of a function declaration
Text Editor/Formatting/
onto the next line even if Bin-pack Parameters is
AllowAllParametersOfDeclarationOnNextLineBoolean
disabled.
Allow Short 'if' Statements On A Single Line
Text Editor/Formatting/
AllowShortIfStatementsOnASingleLineBoolean

Allow Short Blocks On A Single Line
Text Editor/Formatting/
AllowShortBlocksOnASingleLineBoolean

Allow Short Case Labels On A Single Line
Text Editor/Formatting/
AllowShortCaseLabelsOnASingleLineBoolean

If enabled, short 'if' statements are put on a single line.

If enabled, allows contracting simple braced
statements to a single line.
If enabled, short case labels will be contracted to a
single line.

Allow Short Functions On A Single Line
Text Editor/Formatting/
Optionally compress small functions to a single line.
AllowShortFunctionsOnASingleLineEnumeration

Allow Short Loop Statements On A Single Line
Text Editor/Formatting/
AllowShortLoopsOnASingleLineBoolean

If enabled, short loop statements are put on a single
line.
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Text Editor/Formatting/
AlwaysBreakAfterReturnTypeEnumeration
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The function declaration return type breaking style to
use.

Always Break Before Multiline Strings
Text Editor/Formatting/
AlwaysBreakBeforeMultilineStringsBoolean

Always Break Template Declarations
Text Editor/Formatting/
AlwaysBreakTemplateDeclarationsBoolean

Bin-Pack Arguments
Text Editor/Formatting/
BinPackArgumentsBoolean

Bin-Pack Parameters
Text Editor/Formatting/
BinPackParametersBoolean

If enabled, always break before multiline strings.

If enabled, always break after the 'template<...>' of a
template declaration.
If disabled, a function call?s arguments will either be all
on the same line or will have one line each.
If disabled, a function call's or function definition's
parameters will either all be on the same line or will
have one line each.

Break Before Binary Operators
Text Editor/Formatting/
BreakBeforeBinaryOperatorsBoolean

The way to wrap binary operators.

Break Before Braces
Text Editor/Formatting/
BreakBeforeBracesEnumeration

Break Before Inheritance Comma
Text Editor/Formatting/
BreakBeforeInheritanceCommaBoolean

Break Before Ternary Operators
Text Editor/Formatting/
BreakBeforeTernaryOperatorsBoolean

Break Constructor Initializers Before Comma

The brace breaking style to use.

If enabled, the class inheritance expression will break
before : and , if there is multiple inheritance.
If enabled, ternary operators will be placed after line
breaks.
If enabled, always break constructor initializers before

Text Editor/Formatting/
commas and align the commas with the colon.
BreakConstructorInitializersBeforeCommaBoolean

Break String Literals
Text Editor/Formatting/
BreakStringLiteralsBoolean

C++11 Braced List Style
Text Editor/Formatting/
Cpp11BracedListStyleBoolean

Column Limit
Text Editor/Formatting/ColumnLimitInteger

Allow breaking string literals when formatting.

If enabled, format braced lists as best suited for C++11
braced lists.
The column limit which limits the width of formatted
lines.

A regular expression that describes comments with
special meaning, which should not be split into lines or
Text Editor/Formatting/CommentPragmasString
otherwise changed.
Comment Pragmas
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Compact Namespaces

If enabled, consecutive namespace declarations will
be on the same line. If disabled, each namespace is
declared on a new line.

Text Editor/Formatting/
CompactNamespacesBoolean

Constructor Initializer All On One Line Or One Per Line

If enabled and the constructor initializers don't fit on a

Text Editor/Formatting/
line, put each initializer on its own line.
ConstructorInitializerAllOnOneLineOrOnePerLineBoolean

Constructor Initializer Indent Width

The number of characters to use for indentation of
constructor initializer lists.

Text Editor/Formatting/
ConstructorInitializerIndentWidthInteger

Continuation Indent Width
Text Editor/Formatting/
ContinuationIndentWidthInteger

Indent width for line continuations.

Derive Pointer Alignment

If enabled, analyze the formatted file for the most
common alignment of address of and dereference.
PointerAlignment is then used only as fallback.

Text Editor/Formatting/
DerivePointerAlignmentBoolean

Empty Lines At End Of File
The number of lines to add at the end of the file.

Text Editor/Extra Formatting/
LinesAtEOFIntegerRange

Fix Namespace Comments

If enabled, add missing namespace end comments and
fix invalid existing ones.

Text Editor/Formatting/
FixNamespaceCommentsBoolean

For-Each Macros

A list of macros that should be interpreted as foreach
loops rather than function calls.

Text Editor/Formatting/
ForEachMacrosStringList

The number of columns the code formatter uses for
indentation. Note that this is not the indent width
used by the text editor, that value is specified in the
'Languages' environment option group.

Formatting Indent Width
Text Editor/Formatting/IndentWidthInteger

Formatting Style

Select a set of formatting options based on a named
standard.

Text Editor/FormattingStyleEnumeration

Formatting Tab Width
Text Editor/Formatting/TabWidthIntegerRange

Include Is Main Regex
Text Editor/Formatting/
IncludeIsMainRegexString

Indent Case Labels
Text Editor/Formatting/
IndentCaseLabelsBoolean

Indent Wrapped Function Names
Text Editor/Formatting/
IndentWrappedFunctionNamesBoolean

The number of columns the code formatter uses
for tab stops. Note that this is not the tab width
used by the text editor, that value is specified in the
'Languages' environment option group.
Specify a regular expression of suffixes that are
allowed in the file-to-main-include mapping.
If enabled, indent case labels one level from the switch
statement.
If enabled, Indent if a function definition or declaration
is wrapped after the type.
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Keep Empty Lines At The Start Of Blocks
If enabled, empty lines at the start of blocks are kept.

Text Editor/Formatting/
KeepEmptyLinesAtTheStartOfBlocksBoolean

Macro Block Begin

A regular expression matching macros that start a
block.

Text Editor/Formatting/
MacroBlockBeginString

Macro Block End
Text Editor/Formatting/MacroBlockEndString

Maximum Empty Lines To Keep

A regular expression matching macros that end a
block.
The maximum number of consecutive empty lines to
keep.

Text Editor/Formatting/
MaxEmptyLinesToKeepInteger

Namespace Indentation
The indentation used for namespaces.

Text Editor/Formatting/
NamespaceIndentationEnumeration

Penalty Break Assignment

The penalty for breaking around an assignment
operator.

Text Editor/Formatting/
PenaltyBreakAssignmentIntegerRange

Penalty Break Before First Call Parameter
Text Editor/Formatting/
The penalty for breaking a function call after 'call('.
PenaltyBreakBeforeFirstCallParameterIntegerRange

Penalty Break Before First Less-Less
The penalty for breaking before the first less-less.

Text Editor/Formatting/
PenaltyBreakFirstLessLessIntegerRange

Penalty Break Comment

The penalty for each line break introduced inside a
comment.

Text Editor/Formatting/
PenaltyBreakCommentIntegerRange

Penalty Break String

The penalty for each line break introduced inside a
string literal.

Text Editor/Formatting/
PenaltyBreakStringIntegerRange

Penalty Excess Character

The penalty for each character outside of the column
limit.

Text Editor/Formatting/
PenaltyExcessCharacterIntegerRange

Penalty Return Type On Its Own Line

Penalty for putting the return type of a function onto
its own line.

Text Editor/Formatting/
PenaltyReturnTypeOnItsOwnLineIntegerRange

Pointer Alignment
Pointer and reference alignment style.

Text Editor/Formatting/
PointerAlignmentEnumeration

Reflow Comments

If enabled, clang-format will attempt to re-flow
comments.

Text Editor/Formatting/
ReflowCommentsBoolean

Sort Includes
Text Editor/Formatting/SortIncludesBoolean

If enabled, sort #includes.
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Sort Using Declarations
Text Editor/Formatting/
SortUsingDeclarationsBoolean

If enabled, sort using declarations.

Space After C Style Cast
Text Editor/Formatting/
SpaceAfterCStyleCastBoolean

Space After Template Keyword
Text Editor/Formatting/
SpaceAfterTemplateKeywordBoolean

Space Before Assignment Operators
Text Editor/Formatting/
SpaceBeforeAssignmentOperatorsBoolean

Space Before Parentheses
Text Editor/Formatting/
SpaceBeforeParensEnumeration

If enabled, a space may be inserted after C style casts.

If enabled, a space will be inserted after the ?template?
keyword.
If disabled spaces will be removed before assignment
operators.
Defines in which cases to put a space before opening
parentheses.

Space In Empty Parentheses
Text Editor/Formatting/
SpaceInEmptyParenthesesBoolean

If enabled, spaces may be inserted into '()'.

Spaces Before Trailing Comments
Text Editor/Formatting/
SpacesBeforeTrailingCommentsIntegerRange

Spaces In Angles
Text Editor/Formatting/
SpacesInAnglesBoolean

The number of spaces before trailing line comments.

If enabled, spaces will be inserted around the angle
brackets in template argument lists.

Spaces In C-style Cast Parentheses
Text Editor/Formatting/
SpacesInCStyleCastParenthesesBoolean

If enabled, spaces may be inserted into C style casts.

Spaces In Container Literals
Text Editor/Formatting/
SpacesInContainerLiteralsBoolean

If enabled, spaces are inserted inside container literals.

Spaces In Parentheses
Text Editor/Formatting/
SpacesInParenthesesBoolean

If true, spaces will be inserted after '(' and before ')'.

Spaces In Square Brackets
Text Editor/Formatting/
SpacesInSquareBracketsBoolean

Standard
Text Editor/Formatting/StandardEnumeration

Tab Style
Text Editor/Formatting/UseTabEnumeration

If true, spaces will be inserted after '[' and before ']'.

Format compatible with this standard
The way to use hard tab characters in the resulting file.
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Use .clang-format File
Text Editor/Use .clang-format FileBoolean

Appendices

Load code formatting style configuration from
a .clang-format file located in one of the parent
directories of the source file rather than use the
formatting options.

International
Property
Auto-Detect UTF-8
Text Editor/Auto-Detect UTF-8Boolean

Default Text File Encoding
Text Editor/Default CodecEnumeration

Description
Auto-detect UTF-8 encoding without signature.
The encoding to use if not overridden by a project
property or file is not in a known format.

Mouse
Property

Description

Alt+Left Click Action
Environment/Project Explorer/Alt+Left
Click ActionEnumeration

The action the editor performs on Alt+Left Click.

Alt+Middle Click Action
Environment/Project Explorer/Alt+Middle
Click ActionEnumeration

The action the editor performs on Alt+Middle Click.

Alt+Right Click Action
Environment/Project Explorer/Alt+Right
Click ActionEnumeration

The action the editor performs on Alt+Right Click.

Copy On Mouse Select

Automatically copy text to clipboard when marking a
selection with the mouse.

Text Editor/Copy On Mouse SelectBoolean

Ctrl+Left Click Action
Environment/Project Explorer/Ctrl+Left
Click ActionEnumeration

The action the editor performs on Ctrl+Left Click.

Ctrl+Middle Click Action
Environment/Project Explorer/Ctrl+Middle
Click ActionEnumeration

The action the editor performs on Ctrl+Middle Click.

Ctrl+Right Click Action
Environment/Project Explorer/Ctrl+Right
Click ActionEnumeration

The action the editor performs on Ctrl+Right Click.

Middle Click Action
Environment/Project Explorer/Middle Click The action the editor performs on Middle Click.
ActionEnumeration
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Mouse Wheel Adjusts Font Size
Text Editor/Mouse Wheel Adjusts Font
SizeBoolean

Appendices

Enable or disable resizing of font by mouse wheel
when CTRL key pressed.

Shift+Middle Click Action
Environment/Project Explorer/Shift+Middle The action the editor performs on Shift+Middle Click.
Click ActionEnumeration

Shift+Right Click Action
Environment/Project Explorer/Shift+Right
Click ActionEnumeration

The action the editor performs on Shift+Right Click.

Programmer Assistance
Property
ATTENTION Tag List
Text Editor/ATTENTION TagsStringList

Ask For Index
Text Editor/Ask For IndexBoolean

Auto-Comment Text
Text Editor/Auto CommentBoolean

Auto-Surround Text
Text Editor/Auto SurroundBoolean

Check Spelling
Text Editor/Spell CheckingBoolean

Code Completion Replaces Existing Word
Text Editor/Completion Replaces Existing
WordBoolean

Description
Set the tags to display as ATTENTION comments.
Ask to index the project if goto symbol fails in current
editor context.
Enable or disable automatically swapping
commenting on source lines by typing '/' with an
active selection.
Enable or disable automatically surrounding selected
text when typing triangular brackets, quotation marks,
parentheses, brackets, or braces.
Enable spell checking in comments.
Replace existing word with completion suggestion if
cursor is located on one.

Code Completion Suggestion Selection Key
Text Editor/Suggestion Selection
KeyEnumeration

Display Code Completion Suggestions While Typing
Text Editor/Suggest Completion While
TypingBoolean

The key used to select a code completion suggestion.

Enable code completion as you type without needing
to use the show suggestions key (Ctrl+J).

Enable Popup Diagnostics
Text Editor/Enable Popup
DiagnosticsBoolean

FIXME Tag List
Text Editor/FIXME TagsStringList

Inactive Code Opacity
Text Editor/Inactive Code
OpacityIntegerRange

Enables on-screen diagnostics in the text editor.

Set the tags to display as FIXME comments.
Specifies the opacity of code that has been
conditionally excluded by the preprocessor.

1397

CrossWorks for MSP430 Reference Manual

Appendices

Include Preprocessor Definitions in Suggestions

Include or exclude preprocessor definitions in code
completion suggestions.

Text Editor/Preprocessor Definition
SuggestionsBoolean

Include Templates in Suggestions

Include or exclude templates in code completion
suggestions.

Text Editor/Template SuggestionsBoolean

Lint Tag List

Set the tags to display as Lint directives.

Text Editor/LINT TagsStringList

Show Inactive Code

Show code that has been conditionally excluded by
the preprocessor.

Text Editor/Show Inactive CodeBoolean

Show Symbol Declaration Tooltips

Show tooltips when hovering over symbols.

Text Editor/Show TooltipBoolean

Template Characters To Match

The number of characters to match before suggesting
a template.

Text Editor/Template Suggestions
CharactersIntegerRange

Save
Property

Description

Backup File History Depth

The number of backup files to keep when saving an
existing file.

Text Editor/Backup File DepthIntegerRange

The line ending format to use for a new file or a file
where the existing line ending format cannot be
Text Editor/Default Line EndingsEnumeration
determined.
Default Line Endings

Delete Trailing Space On Save

Deletes trailing whitespace from each line when a file
is saved.

Text Editor/Delete Trailing Space On
SaveBoolean

Tab Cleanup On Save
Text Editor/Cleanup Tabs On SaveEnumeration

Cleans up tabs when a file is saved.

Visual Appearance
Property

Description

Font

The font to use for text editors.

Text Editor/FontFixedPitchFont

Font Rendering

The font rendering scheme to use in text editors.

Text Editor/Font RenderingEnumeration

Font Smoothing Threshold
Text Editor/Antialias ThresholdIntegerRange

Hide Cursor When Typing
Text Editor/Hide Cursor When TypingBoolean

The minimum size for font smoothing: font sizes
smaller than this will have antialiasing turned off.
Hide or show the I-beam cursor when you start to type.
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Highlight All Selected Text
Text Editor/Highlight All Selected
TextBoolean

Highlight Cursor Line
Text Editor/Highlight Cursor LineBoolean

Horizontal Scroll Bar
Text Editor/HScroll BarEnumeration

Insert Caret Style
Text Editor/Insert Caret StyleEnumeration

Line Numbers
Text Editor/Line Number ModeEnumeration

Mate Match Off Screen
Text Editor/Mate Match Off ScreenBoolean

Mate Matching Mode

Appendices

Enable or disable visually highlighting all text that
matches the current selection.
Enable or disable visually highlighting the cursor line.
Show or hide the horizontal scroll bar.
How the caret is displayed with the editor in insert
mode.
How often line numbers are displayed in the margin.
Specifies whether braces, brackets, and parentheses
are matched when off screen.

Text Editor/Mate Matching ModeEnumeration

Controls when braces, brackets, and parentheses are
matched.

Minimum Scroll Width

Specifies the minimum width of the scrolling region in

Text Editor/Minimum Scroll WidthIntegerRange characters.

Overwrite Caret Style
Text Editor/Overwrite Caret
StyleEnumeration

Show Diagnostic Icons In Gutter
Text Editor/Diagnostic IconsBoolean

Show Icon Gutter
Text Editor/Icon GutterBoolean

Show Mini Toolbar
Text Editor/Mini ToolbarBoolean

Show Toolbar
Text Editor/ShowWidgetStripBoolean

Use I-beam Cursor
Text Editor/Ibeam cursorBoolean

Vertical Scroll Bar
Text Editor/VScroll BarEnumeration

View Whitespace
Text Editor/View WhitespaceBoolean

How the caret is displayed with the editor in overwrite
mode.
Enables display of diagnostic icons in the icon gutter.
Show or hide the left-hand gutter containing
breakpoint, bookmark, and optional diagnostic icons.
Show the mini toolbar when selecting text with the
mouse.
Show or hide the Editor toolbar in the dock window.
Show an I-beam or arrow cursor in the text editor.
Show or hide the vertical scroll bar.
Make whitespace characters visible in the text editor.
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Windows Environment Options
Autos
Property
Show Member Functions
Environment/AutosWindow/Show Member
FunctionsBoolean

Show Variable Address Column
Environment/AutosWindow/Show Address
ColumnBoolean

Description
Controls whether C++ class member functions are
displayed.
Controls whether the variable address column is
displayed.

Show Variable Size Column
Environment/AutosWindow/Show Size
ColumnBoolean

Show Variable Type Column
Environment/AutosWindow/Show Type
ColumnBoolean

Controls whether the variable size column is displayed.

Controls whether the variable type column is
displayed.

Call Stack
Property
Execution Frame at Top
Environment/Call Stack/Most Recent At
TopBoolean

Description
Controls whether the most recent call is at the top or
the bottom of the list.

Show Call Address
Environment/Call Stack/Show Call
AddressBoolean

Show Call Source Location
Environment/Call Stack/Show Call
LocationBoolean

Show Frame Size
Environment/Call Stack/Show Stack
UsageBoolean

Enables the display of the call address in the call stack.

Enables the display of the call source location in the
call stack.
Enables the display of the amount of stack used by the
call.

Show Frame Size In Bytes
Environment/Call Stack/Show Stack Usage
In BytesBoolean

Show Parameter Names
Environment/Call Stack/Show Parameter
NamesBoolean

Display the stack usage in bytes rather than words.

Enables the display of parameter names in the call
stack.
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Show Parameter Types
Environment/Call Stack/Show Parameter
TypesBoolean

Show Parameter Values
Environment/Call Stack/Show Parameter
ValuesBoolean

Show Stack Pointer
Environment/Call Stack/Show Stack
PointerBoolean

Enables the display of parameter types in the call stack.

Enables the display of parameter values in the call
stack.
Enables the display of the stack pointer in the call
stack.

Show Stack Usage
Environment/Call Stack/Show Cumulative
Stack UsageBoolean

Enables the display of the amount of stack used.

Show Stack Usage In Bytes
Environment/Call Stack/Show Cumulative
Stack Usage In BytesBoolean

Display the stack usage in bytes rather than words.

Clipboard Ring
Property
Maximum Items Held In Ring
Environment/Clipboard Ring/Max
EntriesIntegerRange

Preserve Contents Between Runs
Environment/Clipboard Ring/SaveBoolean

Description
The maximum number of items held on the clipboard
ring before they are recycled.
Save the clipboard ring across CrossStudio runs.

Debug Terminal
Property
Backscroll Buffer Lines
Debug Terminal/Backscroll Buffer
LinesIntegerRange

Use Window System Colors
Debug Terminal/Use Window System
ColorsBoolean

Description
The number of lines you can see when you scroll
backward in the debug terminal window.
Substitute window system colors for ANSI black
background and white foreground in debug terminal.

Globals
Property

Description
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Show Member Functions

Controls whether C++ class member functions are
displayed.

Environment/GlobalsWindow/Show Member
FunctionsBoolean

Show Variable Address Column

Controls whether the variable address column is
displayed.

Environment/GlobalsWindow/Show Address
ColumnBoolean

Show Variable Size Column
Controls whether the variable size column is displayed.

Environment/GlobalsWindow/Show Size
ColumnBoolean

Show Variable Type Column

Controls whether the variable type column is
displayed.

Environment/GlobalsWindow/Show Type
ColumnBoolean

Latest News
Property

Description

Article Grouping
Environment/Latest News/GroupingEnumeration

How to display the RSS feed articles.

Locals
Property
Show Member Functions
Environment/LocalsWindow/Show Member
FunctionsBoolean

Show Variable Address Column
Environment/LocalsWindow/Show Address
ColumnBoolean

Description
Controls whether C++ class member functions are
displayed.
Controls whether the variable address column is
displayed.

Show Variable Size Column
Environment/LocalsWindow/Show Size
ColumnBoolean

Show Variable Type Column
Environment/LocalsWindow/Show Type
ColumnBoolean

Controls whether the variable size column is displayed.

Controls whether the variable type column is
displayed.

Memory
Property

Description
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Confirm Large Download
Environment/Memory Window/Confirm
SizeBoolean

Group Auto Columns
Environment/Memory Window/Group Auto
ColumnsBoolean

Scroll Wheel Modifies Start Address
Environment/Memory Window/Scroll Wheel
Modifies Start AddressBoolean

Appendices

Present a warning if you attempt to download a large
amount of memory in the memory window.
Selects whether columns are grouped in automatic
column mode.
Selects whether the mouse scroll wheel can change
the memory window start address.

Outline
Property

Description

Group #define Directives

Group consecutive #define and #undef preprocessor
directives.

Windows/Outline/Group DefinesBoolean

Group #include Directives
Windows/Outline/Group IncludesBoolean

Group Top-Level Declarations
Windows/Outline/Group Top Level
ItemsBoolean

Group consecutive #include preprocessor directives.
Group consecutive top-level variable and type
declarations.

Project Explorer
Property
Add Filename Replace Macros
Environment/Project Explorer/Filename
Replace MacrosStringList

Check Solution Target
Environment/Project Explorer/Check
Solution TargetBoolean

Color Project Nodes
Environment/Project Explorer/Color
NodesBoolean

Confirm Configuration Folder Delete
Project Explorer/Confirm Configuration
Folder DeleteBoolean

Confirm File Replacement Warning

Description
Macros (system and global) used to replace the start of
a filename on project file addition.
Specifies whether to check target is correct when
loading a solution.
Show the project nodes colored for identification in
the Project Explorer.
Display a confirmation prompt before deleting a
configuration folder cotaining properties.
Display a confirmation prompt before replacing

Project Explorer/Confirm File Replacement
project files for import and creation
WarningBoolean
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Confirm Forget Modified Properties
Project Explorer/Confirm Reject Property
ChangesBoolean

Context Menu Uses Common Folder

Appendices

Display a confirmation prompt before forgetting
property modifications.
Controls how common options are displayed by the

Environment/Project Explorer/Context Menu
Project Explorer's context menu.
Common FolderBoolean

Edit Properties At Top

Controls where edit properties is displayed by the

Environment/Project Explorer/Context Menu
Project Explorer's context menu.
Properties PositionBoolean

External Editor
Environment/Project Explorer/External
EditorFileName

Favorite Properties
Environment/Project Explorer/Favorite
PropertiesStringList

Highlight Dynamic Items

The file name of the application to use as the external
text editor. The external editor is started by holding
down the Shift key when opening files from the
project explorer.
The favorite list of properties that are displayed starred
and before other properties in the Project Explorer.
Show an overlay on an item if it is populated from a

Environment/Project Explorer/Show Dynamic
dynamic folder.
OverlayBoolean

Highlight External Items
Environment/Project Explorer/Show NonLocal OverlayBoolean

Output Files Folder
Environment/Project Explorer/Show Output
FilesBoolean

Read-Only Data In Code
Environment/Project Explorer/Statistics
Read-Only Data HandlingBoolean

Show an overlay on an item if it is not held within the
project directory.
Show the build output files in an Output Files folder in
the project explorer.
Configures whether read-only data contributes to the
Code or Data statistic.

Show Dependencies
Environment/Project Explorer/Dependencies Controls how the dependencies are displayed.
DisplayEnumeration

Show Favorite Properties

Controls if favorite properties are displayed by the

Environment/Project Explorer/Context Menu
Project Explorer's context menu.
Show FavoritesBoolean

Show File Count on Folder
Environment/Project Explorer/Count
FilesBoolean

Show Modified Properties on Folder/File
Environment/Project Explorer/Show
Modified PropertiesBoolean

Show Project Count on Solution
Environment/Project Explorer/Count
ProjectsBoolean

Show the number of files contained in a folder as a
badge in the Project Explorer.
Show if a folder or file has modified properties as a
badge in the Project Explorer.
Show the number of projects contained in a solution
as a badge in the Project Explorer.
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Show Properties
Environment/Project Explorer/Properties
DisplayEnumeration

Show Source Control Annotation
Environment/Project Explorer/Show Source
Control AnnotationBoolean

Controls how the properties are displayed.

Annotate items in the project explorer with their
source control status.

Show Statistics Rounded
Environment/Project Explorer/Statistics
FormatBoolean

Source Control Status Column
Environment/Project Explorer/Show Source
Control ColumnBoolean

Show exact or rounded sizes in the project explorer.

Show the source control status column in the project
explorer.

Starred Files Names

The list of wildcard-matched file names that are
Environment/Project Explorer/Starred File highligted with stars, to bring attention to themselves,
NamesStringList
in the Project Explorer.
Statistics Column
Environment/Project Explorer/Statistics
DisplayBoolean

Synchronize Explorer With Editor
Environment/Project Explorer/Sync
EditorBoolean

Show the code and data size columns in the Project
Explorer.
Synchronizes the Project Explorer with the document
being edited.

Use Common Properties Folder
Environment/Project Explorer/Common
Properties DisplayBoolean

Controls how common properties are displayed.

Properties
Property

Description

Enable Favorites Group
Environment/Properties Windows/Favorites
GroupedEnumeration

Assign favorites to their own group.

Properties Displayed
Environment/Properties Windows/Property
Display FormatEnumeration

Set how the properties are displayed.

Public Setting Check
Environment/Properties Windows/Public
Setting CheckEnumeration

Warn when setting property in public configuration.

Show Property Details
Environment/Properties Windows/Show
DetailsBoolean

Show or hide the property description.
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Source Navigator
Property

Description

Show definitions only. When set to Yes only symbols
Show Definitions Only
that are defined will be included in the source
Windows/Source Navigator/Show Definitions navigator display. When set to No declarations of
OnlyBoolean
symbols will also be included in the source navigator
display.

Symbol Browser
Property

Description

Code Field
Environment/Symbol Browser/Display
CodeBoolean

Selects whether the Code field is displayed.

Const Field
Environment/Symbol Browser/Display
ConstBoolean

Selects whether the Const field is displayed.

Data Field
Environment/Symbol Browser/Display
DataBoolean

Selects whether the Data field is displayed.

Frame Size Field
Environment/Symbol Browser/Display Frame
SizeBoolean

Selects whether the Frame Size field is displayed.

Range Field
Environment/Symbol Browser/Display
RangeBoolean

Selects whether the Range field is displayed.

Section Field
Environment/Symbol Browser/Display
SectionBoolean

Selects whether the Section field is displayed.

Size Field
Environment/Symbol Browser/Display
SizeBoolean

Selects whether the Size field is displayed.

Sort Criteria
Environment/Symbol Browser/
GroupingEnumeration

Selects how to sort or group the symbols displayed.

Type Field
Environment/Symbol Browser/Display
TypeBoolean

Selects whether the Type field is displayed.

Value Field
Environment/Symbol Browser/Display
ValueBoolean

Selects whether the Value field is displayed.
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Terminal Emulator
Property
Backscroll Buffer Lines
Terminal Emulator/Backscroll Buffer
LinesIntegerRange

Description
The number of lines you can see when you scroll
backward in the terminal emulator window.

Baud Rate
Terminal Emulator/Communications/Baud
RateEnumeration

Data Bits
Terminal Emulator/Communications/Data
BitsEnumeration

Baud rate used when transmitting and receiving data.

Number of data bits to use when transmitting and
receiving data.

Flow Control
Terminal Emulator/Communications/Flow
ControlEnumeration

Line Feed On Carriage Return
Terminal Emulator/Line Feed On Carriage
ReturnBoolean

Local Echo
Terminal Emulator/Local EchoBoolean

The flow control method to use.

Append a line feed character when a carriage return
character is received.
Displays every character typed before sending to the
remote computer.

Maximum Input Block Size
Terminal Emulator/Maximum Input Block
SizeIntegerRange

The maximum number of bytes to read at a time.

Parity
Terminal Emulator/Communications/
ParityEnumeration

Port
Terminal Emulator/Communications/
PortUnknown

Port Used By Target Interface
Terminal Emulator/Communications/Port
Used By Target InterfaceBoolean

Parity used when transmitting and receiving data.

The communications port to use, e.g. /dev/ttyS0, /dev/
ttyS1, etc.
The COM port will be disconnected when the target
interface is connected and reconnected when the
target interface is disconnected.

Set DTR
Terminal Emulator/Communications/
DTRBoolean

Set the DTR signal.

Stop Bits
Terminal Emulator/Communications/Stop
BitsEnumeration

Number of stop bits to use when transmitting data.

Watch 1
Property

Description
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Show Member Functions
Environment/Watch1Window/Show Member
FunctionsBoolean

Show Variable Address Column
Environment/Watch1Window/Show Address
ColumnBoolean

Appendices

Controls whether C++ class member functions are
displayed.
Controls whether the variable address column is
displayed.

Show Variable Size Column
Environment/Watch1Window/Show Size
ColumnBoolean

Show Variable Type Column
Environment/Watch1Window/Show Type
ColumnBoolean

Controls whether the variable size column is displayed.

Controls whether the variable type column is
displayed.

Watch 2
Property
Show Member Functions
Environment/Watch2Window/Show Member
FunctionsBoolean

Show Variable Address Column
Environment/Watch2Window/Show Address
ColumnBoolean

Description
Controls whether C++ class member functions are
displayed.
Controls whether the variable address column is
displayed.

Show Variable Size Column
Environment/Watch2Window/Show Size
ColumnBoolean

Show Variable Type Column
Environment/Watch2Window/Show Type
ColumnBoolean

Controls whether the variable size column is displayed.

Controls whether the variable type column is
displayed.

Watch 3
Property
Show Member Functions
Environment/Watch3Window/Show Member
FunctionsBoolean

Show Variable Address Column
Environment/Watch3Window/Show Address
ColumnBoolean

Description
Controls whether C++ class member functions are
displayed.
Controls whether the variable address column is
displayed.

Show Variable Size Column
Environment/Watch3Window/Show Size
ColumnBoolean

Controls whether the variable size column is displayed.
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Show Variable Type Column
Environment/Watch3Window/Show Type
ColumnBoolean
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Controls whether the variable type column is
displayed.

Watch 4
Property
Show Member Functions
Environment/Watch4Window/Show Member
FunctionsBoolean

Show Variable Address Column
Environment/Watch4Window/Show Address
ColumnBoolean

Description
Controls whether C++ class member functions are
displayed.
Controls whether the variable address column is
displayed.

Show Variable Size Column
Environment/Watch4Window/Show Size
ColumnBoolean

Show Variable Type Column
Environment/Watch4Window/Show Type
ColumnBoolean

Controls whether the variable size column is displayed.

Controls whether the variable type column is
displayed.

Windows
Property

Description

Buffer Grouping

How the files are grouped or listed in the Windows
window.

Environment/Windows/GroupingEnumeration

Show File Path as Tooltip
Environment/Windows/Show Filename
TooltipsBoolean

Show Line Count and File Size
Environment/Windows/Show SizesBoolean

Show the full file name as a tooltip when hovering
over files in the Windows window.
Show the number of lines and size of each file in the
windows list.
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Code Options
Assembler
Property

Description
Enables additional options to be supplied to the
assembler. This property will have macro expansion
applied to it.

Additional Assembler Options
asm_additional_optionsStringList

Enables additional options to be supplied to the
assembler from a file. This property will have macro
asm_additional_options_from_fileProjFileName
expansion applied to it.
Additional Assembler Options From File

Backup Additional Assembler Options

Value of additional assembler options prior to generic
options processing.

asm_additional_options_backupString

Build
Property

Description

Always Rebuild

Specifies whether or not to always rebuild the project/
folder/file.

build_always_rebuildBoolean

Batch Build Configurations

The set of configurations to batch build.

batch_build_configurationsStringList

Build Options Generic File Name
build_generic_options_file_nameProjFileName

Build Quietly
build_quietlyBoolean

Dependency File Name
build_dependency_file_nameFileName

Enable Unused Symbol Removal
build_remove_unused_symbolsBoolean

Exclude From Build
build_exclude_from_buildBoolean

Include Debug Information
build_debug_informationBoolean

Intermediate Directory
build_intermediate_directoryDirPath

Object File Name
build_object_file_nameFileName

The file name containing the generic options.
Suppress the display of startup banners and
information messages.
The file name to contain the dependencies.
Enable the removal of unused symbols from the
executable.
Specifies whether or not to exclude the project/folder/
file from the build.
Specifies whether symbolic debug information is
generated.
Specifies a relative path to the intermediate file
directory. This property will have macro expansion
applied to it. The macro $(IntDir) is set to this value.
Specifies a name to override the default object file
name.
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Output Directory
build_output_directoryDirPath

Project Can Build In Parallel
project_can_build_in_parallelEnumeration

Project Dependencies
project_dependenciesStringList

Project Directory
project_directoryString

Project Macros
macrosStringList

Project Type
project_typeEnumeration

Property Groups File
property_groups_file_pathProjFileName

Root Output Directory
build_root_output_directoryDirPath

Suppress Warnings
build_suppress_warningsBoolean

Toolchain Directory
build_toolchain_directoryDirPath

Treat Warnings as Errors
build_treat_warnings_as_errorsBoolean

Appendices

Specifies a relative path to the output file directory.
This property will have macro expansion applied
to it. The macro $(OutDir) is set to this value. The
macro $(RootRelativeOutDir) is set relative to the Root
Output Directory if specified.
Specifies that dependent projects can be built in
parallel. Default is No for Staging and Combining
project types, Yes for all other project types.
Specifies the projects the current project depends
upon.
Path of the project directory relative to the directory
containing the project file. The macro $(ProjectDir) is
set to the absolute path of this property.
Specifies macro values which are expanded in
project properties and for file names in Common
configuration only. Each macro is defined as
name=value and are seperated by ;.
Specifies the type of project to build. The options are
Executable, Library, Object file, Staging, Combining,
Externally Built Executable, Externally Built Library,
Externally Built Object file.
The file containing the property groups for this project.
This is applicable to Executable and Externally Built
Executable project types only.
Allows a common root output directory to be specified
that can be referenced using the $(RootOutDir) macro.
Don't report warnings.
Specify the root of the toolchain directory. This
property will have macro expansion applied to it. The
macro $(ToolChainDir) is set to this value.
Treat all warnings as errors.

Code Analyzer
Property
Analyze After Compile
analyze_after_compileBoolean

Clang Tidy Checks C
clang_tidy_checks_cStringList

Description
Run the static code analyzer after compile
Checks to supply to clang-tidy for C source files.
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Clang Tidy Checks C++
clang_tidy_checks_cppStringList

Appendices

Checks to supply to clang-tidy for C++ source files.

Code Generation
Property

Description

Block Localization Optimization

Reduce spand-dependent jumps by rearranging basic
blocks to improve their locality.

optimize_block_localityBoolean

Code Factoring Optimization
optimize_cross_callingEnumeration

Code Factoring Passes

Reduces code size at the expense of execution
speed by factoring common code sequences into
subroutines.
The maximum number of passes to perform when

linker_cross_call_maximum_passesIntegerRange code factoring (0=unlimited).

Code Factoring Subroutine Size

The minimum size of subroutine created by code

linker_cross_call_minimum_subroutine_sizeIntegerRange
factoring.

Code Motion Optimization
optimize_code_motionBoolean

Copy Propagation Optimization
optimize_copy_propagationBoolean

Cross Jumping Optimization
optimize_cross_jumpingBoolean

Dead Code Elimination
optimize_dead_codeBoolean

Enable Exception Support
cpp_enable_exceptionsBoolean

Enable RTTI Support
cpp_enable_rttiBoolean

Flattening Optimization
optimize_flatteningBoolean

Generate Listing File
asm_generate_listing_fileBoolean

Instruction Set
msp430_insn_setEnumeration

Jump Chaining Optimization
optimize_jump_chainingBoolean

Jump Threading Optimization
optimize_jump_threadingBoolean

Memory Size
msp430_memory_sizeEnumeration

Rearrange code to reduce the number of jump
instructions.
Tries to eliminate copy instructions and reduce code
size.
Always reduces code size at the expense of a single
jump instruction.
Remove code that is not referenced by the application.
Specifies whether exception support is enabled for C+
+ programs.
Specifies whether RTTI support is enabled for C++
programs.
Subroutines that are just a call followed by a return are
flattened into a jump.
An source/assembler listing file is generated which can
be found in the output files folder
The architecture instruction set to use for code
generation.
Reduce spand-dependent jump sizes by chaining
jumps together.
Follow jump chains and retarget jumps to jump
instructions.
The memory size to use for MSP430X code generation.
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Optimization Strategy
compiler_optimization_strategyEnumeration

Peephole Optimization
optimize_peepholesBoolean

Register Allocation
optimize_register_allocationEnumeration

Tail Merging Optimization
optimize_tail_mergingBoolean

Treat 'double' as 'float'
double_is_floatBoolean

Use Hardware Multiplier
build_use_hardware_multiplierEnumeration

Appendices

Minimize code size or maximize execution speed
(positive values).
Find instruction sequences that can be replaced with
faster, smaller code.
Whether to allocate registers to locals or locals and
global addresses.
Always reduces code size at the expense of a single
jump instruction.
Forces the compiler to make 'double' equivalent to
'float'.
Enables code generation for the hardware multiplier.

Combining
Property

Combine Command
combine_commandUnknown

Combine Command Working Directory
combine_command_wdString

Output File Path
combine_output_filepathString

Set To Read-only
combine_set_readonlyEnumeration

Description
The command to execute. This property will have
macro expansion applied to it with the macro
$(CombiningOutputFilePath) set to the output
filepath of the combine command and the macro
$(CombiningRelInputPaths) is set to the (project
relative) names of all of the files in the project.
The working directory in which the combine command
is run. This property will have macro expansion applied
to it.
The output file path the stage command will create.
This property will have macro expansion applied to it.
Set the output file to read only or read/write.

Compiler
Property
Additional C Compiler Only Options
c_only_additional_optionsStringList

Description
Enables additional options to be supplied to the
C compiler only. This property will have macro
expansion applied to it.

Enables additional options to be supplied to the C
compiler only from a file. This property will have macro
c_only_additional_options_from_fileProjFileName
expansion applied to it.
Additional C Compiler Only Options From File
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Additional C Compiler Options
c_additional_optionsStringList

Additional C Compiler Options From File
c_additional_options_from_fileProjFileName

Additional C++ Compiler Only Options
cpp_only_additional_optionsStringList

Appendices

Enables additional options to be supplied to the C
compiler. This property will have macro expansion
applied to it.
Enables additional options to be supplied to the C
compiler from a file. This property will have macro
expansion applied to it.
Enables additional options to be supplied to the
C++ compiler only. This property will have macro
expansion applied to it.

Enables additional options to be supplied to the C++
compiler only from a file. This property will have macro
cpp_only_additional_options_from_fileProjFileName
expansion applied to it.
Additional C++ Compiler Only Options From File

Backup Additional C Compiler Only Options
c_only_additional_options_backupString

Backup Additional C++ Compiler Only Options
cpp_only_additional_options_backupString

Backup Additional Compiler Options
c_additional_options_backupString

Compile C Files As C++
c_files_are_cppBoolean

Enforce ANSI Checking
c_enforce_ansi_checkingBoolean

Value of additional C compiler options prior to generic
options processing
Value of additional C++ compiler options prior to
generic options processing
Value of additional compiler options prior to generic
options processing
Compile files that have the .c extension with the C++
compiler.
Perform additional checks for ensure strict
conformance to the selected ISO (ANSI) C or C++
standard.

External Build
Property

Description
The command line to archive object files. This property
will have macro expansion applied to it with the
additional macros:
$(TargetPath) contains the full file name of the
Library File Name property
$(RelTargePath) contains the project directory
relative file name of the Object File Name
property.
$(Objects) a space seperated list of files to archive,
generated from the source files of the project OR.
$(ObjectsFilePath) contains the full file name of
the file containing the list of files to archive
$(RelObjectsFilePath) contains the project
directory relative file name of the file containing
the list of files to link

Archive Command
external_archive_commandUnknown
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The command line to assemble an assembly source
file. This property will have macro expansion applied
to it with the additional macros:
$(TargetPath) contains the full file name of the
Object File Name property.
$(RelTargePath) contains the project directory
relative file name of the Object File Name
property.
$(AsmOptions) contains a space seperated list
of options as set in the Additional Assembler
Options property.
$(DependencyPath) contains the filename of
the .d file that is required to be output by the
compilation for dependency support.
$(RelDependencyPath) contains the relative
filename of the .d file that is required to be output
by the compilation for dependency support.
$(Defines) contains a space seperated list
of preprocessor definitions as set in the
Preprocessor Definitions property.
$(Undefines) contains a space seperated list
of preprocessor undefinitions as set in the
Preprocessor Definitions property.
$(Includes) contains a space seperated list of
user include directories as set in the User Include
Directories property.

Assemble Command
external_assemble_commandUnknown

Build Command
external_build_commandUnknown

The command line to build the executable e.g. make.
This property will have macro expansion applied to it.
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The command line to compile a C source file. This
property will have macro expansion applied to it with
the additional macros:
$(TargetPath) contains the full file name of the
Object File Name property.
$(RelTargePath) contains the project directory
relative file name of the Object File Name
property.
$(COptions) contains a space seperated list of
options as set in the C Additional C/C++ Compiler
Options property.
$(COnlyOptions) contains a space seperated list
of options as set in the C Additional C Compiler
Only Options property.
$(DependencyPath) contains the filename of
the .d file that is required to be output by the
compilation for dependency support.
$(RelDependencyPath) contains the relative
filename of the .d file that is required to be output
by the compilation for dependency support.
$(Defines) contains a space seperated list
of preprocessor definitions as set in the
Preprocessor Definitions property.
$(Undefines) contains a space seperated list
of preprocessor undefinitions as set in the
Preprocessor Definitions property.
$(Includes) contains a space seperated list of
user include directories as set in the User Include
Directories property.

C Compile Command
external_c_compile_commandUnknown
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The command line to compile a C++ source file. This
property will have macro expansion applied to it with
the additional macros:
$(TargetPath) contains the full file name of the
Object File Name property.
$(RelTargePath) contains the project directory
relative file name of the Object File Name
property.
$(COptions) contains a space seperated list of
options as set in the C Additional C/C++ Compiler
Options property.
$(CppOnlyOptions) contains a space seperated
list of options as set in the C Additional C++
Compiler Only Options property.
$(DependencyPath) contains the filename of
the .d file that is required to be output by the
compilation for dependency support.
$(RelDependencyPath) contains the relative
filename of the .d file that is required to be output
by the compilation for dependency support.
$(Defines) contains a space seperated list
of preprocessor definitions as set in the
Preprocessor Definitions property
$(Undefines) contains a space seperated list
of preprocessor undefinitions as set in the
Preprocessor Definitions property.
$(Includes) contains a space seperated list of
user include directories as set in the User Include
Directories property.

C++ Compile Command
external_cpp_compile_commandUnknown

1417

CrossWorks for MSP430 Reference Manual

Appendices

The command line to link an executable. This property
will have macro expansion applied to it with the
additional macros:
$(TargetPath) contains the full file name of the
Executable File Name property.
$(RelTargePath) contains the project directory
relative file name of the Executable File Name
property.
$(LinkOptions) contains a space seperated list of
options as set in the Additional Linker Options
property.
$(Objects) a space seperated list of files to link,
generated from the source files of the project and
the outputs of any dependent projects OR.
$(ObjectsFilePath) contains the full file name of
the file containing the list of files to link
$(RelObjectsFilePath) contains the project
directory relative file name of the file containing
the list of files to link
$(LinkerScriptPath) contains the full file name of
the Linker Script File property.
$(RelLinkerScriptPath) contains the project
directory relative file name of the Linker Script
File property.
$(MapPath) contains the full file name of the
required map file.
$(RelMapPath) contains the project directory
relative file name of the required map file.

C++ Link Command
external_cpp_link_commandUnknown

Clean Command
external_clean_commandUnknown

The command line to clean the executable e.g. make
clean. This property will have macro expansion applied
to it.
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The command line to link an executable. This property
will have macro expansion applied to it with the
additional macros:
$(TargetPath) contains the full file name of the
Executable File Name property.
$(RelTargePath) contains the project directory
relative file name of the Executable File Name
property.
$(LinkOptions) contains a space seperated list of
options as set in the Additional Linker Options
property.
$(Objects) a space seperated list of files to link,
generated from the source files of the project and
the outputs of any dependent projects OR.
$(ObjectsFilePath) contains the full file name of
the file containing the list of files to link
$(RelObjectsFilePath) contains the project
directory relative file name of the file containing
the list of files to link
$(LinkerScriptPath) contains the full file name of
the Linker Script File property.
$(RelLinkerScriptPath) contains the project
directory relative file name of the Linker Script
File property.
$(MapPath) contains the full file name of the
required map file.
$(RelMapPath) contains the project directory
relative file name of the required map file.

Link Command
external_link_commandUnknown

Objects File
external_objects_file_nameUnknown

The name of the file containing the list of files to
archive or link, generated from the source files of
the project.This property will have macro expansion
applied to it. The macro $(ObjectsFilePath) is set to this
value.

File
Property

Description

File Encoding

Specifies the encoding to use when reading and
writing the file.

file_codecEnumeration
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File Name
file_nameString

File Open Action
file_open_withEnumeration

File Type
file_typeEnumeration

Flag
file_flagEnumeration

Appendices

The name of the file. This property will have global
macro expansion applied to it. The following macros
are set based on the value: $(InputDir) relative
directory of file, $(InputName) file name without
directory or extension, $(InputFileName) file name,
$(InputExt) file name extension, $(InputPath) absolute
path to the file name, $(RelInputPath) relative path
from project directory to the file name.
Specifies how to open the file when it is double
clicked.
The type of file. Default setting uses the file extension
to determine file type.
Flag which you can use to draw attention to important
files in your project.

Folder
Property
Dynamic Folder Directory
pathDirPath

Dynamic Folder Exclude
excludeStringList

Dynamic Folder Filter
filterString

Dynamic Folder Recurse
recurseBoolean

Unity Build Exclude Filter
unity_build_exclude_filterString

Unity Build File Name
unity_build_file_nameFileName

Description
Dynamic folder directory specification - ; seperated
directory names that will have global macro expansion
applied to them.
Dynamic folder exclude specification - ; seperated
wildcards.
Dynamic folder filter specification - ; seperated
wildcards.
Dynamic folder recurse into subdirectories.
The filter specification to exclude from the unity build
- ; seperated wildcards.
The file name created that #includes all files in the
folder for the unity build.

General
Property
Environment Variables
environment_variablesStringList

Inherited Configurations
inherited_configurationsStringList

Description
Environment variables to set on solution load.
The list of configurations that are inherited by this
configuration.
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Library
Property

Description

Exclude Default Library Helper Functions

Specifies whether to exclude default library helper
functions.

link_use_multi_threaded_librariesBoolean

Include Standard Libraries
link_include_standard_librariesBoolean

Library File Name
build_output_file_nameFileName

Standard Libraries Directory
link_standard_libraries_directoryString

Specifies whether the standard libraries should be
linked into your application.
Specifies a name to override the default library file
name.
Specifies where to find the standard libraries

Linker
Property

Description

Additional Input Files

Enables additional object and library files to be
supplied to the linker.

linker_additional_filesStringList

Additional Linker Options
linker_additional_optionsStringList

Additional Linker Options From File

Enables additional options to be supplied to the linker.
Enables additional options to be supplied to the linker

linker_additional_options_from_fileProjFileName
from a file.

The format used when creating an additional linked
output file.The options are:
None do not create an additional output file.
hex create an Intel Hex file.
lst create a hex file.
srec create a Motorola S-Record file.
bin create a binary file.

Additional Output Format
linker_output_formatEnumeration

Backup Additional Linker Options
link_additional_options_backupString

Checksum Algorithm
linker_checksum_algorithmEnumeration

Checksum Sections
linker_checksum_sectionsStringList

Generate Absolute Listing
linker_absolute_listingBoolean

Generate Map File
linker_map_fileBoolean

Heap Size
linker_heap_sizeIntegerRange

Value of additional linker options prior to generic
options processing
The algorithm used to checksum sections.
The list of sections to checksum using the set
checksum algorithm.
Generate an absolute listing of the application.
Specifies whether to generate a linkage map file.
The number of bytes to allocate for the application's
heap.
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Keep Symbols
linker_keep_symbolsStringList

Link Dependent Projects
link_dependent_projectsBoolean

Linker Script File
link_linker_script_fileProjFileName

Linker Symbol Definitions
link_symbol_definitionsStringList

Memory Map File
linker_memory_map_fileProjFileName

Memory Map Macros
linker_memory_map_macrosStringList

Memory Segments
linker_section_placements_segmentsString

Optimize Sections
optimize_sectionsStringList

Pad Space
pad_spaceBoolean

Pad Space Value
pad_space_valueIntegerHex

Rename Sections
rename_sectionsStringList

Section Placement File
linker_section_placement_fileProjFileName

Section Placement Macros
linker_section_placement_macrosStringList

Stack Size
linker_stack_sizeIntegerRange

Use Manual Linker Script
link_use_linker_script_fileBoolean

Verbose Output
verboseBoolean

Appendices

Specifies the symbols that should be kept by the linker
even if they are not reachable.
Specifies whether to link the output of dependent
library projects.
The name of the manual linker script file.
Specifies one or more linker symbol definitions.
The name of the file containing the memory map
description.
Macro values to substitue in memory map nodes. Each
macro is defined as name=value and are seperated by
;.
The start, access and size of named segments in the
target, these are used when no memory map file is
available.Each segment is specified by NAME RWX
HEXSTART HEXSIZE for example FLASH RX 0x08000000
0x00010000
The list of section names to optimize.
Replace space instructions with the pad value.
The value to replace space instructions with.
The list of input module section names to rename.
The name of the file containing section placement
description.
Macro values to substitue in section placement nodes MACRO1=value1;MACRO2=value2.
The number of bytes to allocate for the application's
stack.
Specifies whether to use a manual linker script.
Show verbose output - useful for long optimisations.

Package
Property

Description
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Package Dependencies
package_dependenciesStringList

Appendices

Specifies the packages the current project depends
upon.

Preprocessor
Property
Ignore Includes
c_ignore_includesBoolean

Preprocessor Definitions
c_preprocessor_definitionsStringList

Preprocessor Undefinitions
c_preprocessor_undefinitionsStringList

System Include Directories
c_system_include_directoriesStringList

Undefine All Preprocessor Definitions

Description
Ignore the include directories properties.
Specifies one or more preprocessor definitions. This
property will have macro expansion applied to it.
Specifies one or more preprocessor undefinitions. This
property will have macro expansion applied to it.
Specifies the system include path. This property will
have macro expansion applied to it.
Does not define any standard preprocessor definitions.

c_undefine_all_preprocessor_definitionsBoolean

User Include Directories
c_user_include_directoriesStringList

Specifies the user include path. This property will have
macro expansion applied to it.

Printf/Scanf
Property

Description

Printf Floating Point Supported

Are floating point numbers supported by the printf
function group.

linker_printf_fp_enabledEnumeration

Printf Integer Support
linker_printf_fmt_levelEnumeration

The largest integer type supported by the printf
function group.

Printf Width/Precision Supported

Enables support for width and precision specification
linker_printf_width_precision_supportedBoolean
in the printf function group.
Scanf Classes Supported

Enables support for %[...] and %[^...] character class
linker_scanf_character_group_matching_enabledBoolean
matching in the scanf functions.
Scanf Floating Point Supported
linker_scanf_fp_enabledBoolean

Scanf Integer Support
linker_scanf_fmt_levelEnumeration

Wide Characters Supported
linker_printf_wchar_enabledBoolean

Are floating point numbers supported by the scanf
function group.
The largest integer type supported by the scanf
function group.
Are wide characters supported by the printf function
group.
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Project
Property

Description

Flag

Flag which you can use to draw attention to important
projects in your solution.

project_flagEnumeration

Section
Property

Description

Code Section Name

Specifies the default name to use for the program code
section.

default_code_sectionString

Constant Section Name
default_const_sectionString

Data Section Name
default_data_sectionString

ISR Section Name
default_isr_sectionString

Vector Section Name
default_vector_sectionString

Zeroed Section Name
default_zeroed_sectionString

Specifies the default name to use for the read-only
constant section.
Specifies the default name to use for the initialized,
writable data section.
Specifies the default name to use for the ISR code.
Specifies the default name to use for the interrupt
vector section.
Specifies the default name to use for the zeroinitialized, writable data section.

Solution
Property

Description

Flag

Flag which you can use to draw attention to important
projects in your solution.

solution_flagEnumeration

Properties Filter
properties_filterStringList

The names of project properties that can be displayed
at the solution

Source Code
Property

Description

Additional Code Completion Compiler Options

Additional source indexing and code completion
compiler options.

code_completion_optionsStringList

Inhibit Source Indexing
project_inhibit_indexingBoolean

Source Code Control Directory
source_code_control_directoryDirPath

Disable source indexing and code completion for files/
folders/projects that would normally be indexed (C/C+
+ files in executable and library projects).
Source code control directory root.
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Staging
Property

Description

Output File Path

The output file path the stage command will create.
This property will have macro expansion applied to it.

stage_output_filepathString

Set To Read-only
stage_set_readonlyEnumeration

Stage Command
stage_commandUnknown

Stage Command Working Directory
stage_command_wdString

Stage Project Command
stage_post_build_commandUnknown

Stage Project Command Working Directory
stage_post_build_command_wdString

Set the output file permissions to read only or read/
write.
The command to execute. This property will have
macro expansion applied to it with the additional
$(StageOutputFilePath) macro set to the output
filepath of the stage command.
The working directory in which the stage command is
run. This property will have macro expansion applied
to it.
The command to execute after staging commands
have executed. This property will have macro
expansion applied to it.
The working directory where the post build command
runs. This property will have macro expansion applied
to it.

User Build Step
Property

Link Patch Command
linker_patch_build_commandUnknown

Link Patch Working Directory
linker_patch_build_command_wdDirPath

Post-Archive Command
archive_post_build_commandUnknown

Post-Archive Working Directory
archive_post_build_command_wdDirPath

Post-Build Command
post_build_commandUnknown

Description
A command to run after the link but prior to additional
binary file generation. This property will have
macro expansion applied to it with the additional
$(TargetPath) macro set to the output filepath of the
linker command.
The working directory where the link patch command
is run. This property will have macro expansion applied
to it.
A command to run after the archive command has
completed.This property will have macro expansion
applied to it with the additional $(TargetPath) macro
set to the output filepath of the archive command.
The working directory where the post-archive
command is run. This property will have macro
expansion applied to it.
The command to execute after a project build. This
property will have macro expansion applied to it.
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Post-Build Command Control
post_build_command_controlEnumeration

Post-Build Command Working Directory
post_build_command_wdString

Post-Compile Command
compile_post_build_commandUnknown

Post-Compile Working Directory
compile_post_build_command_wdDirPath

Post-Link Command
linker_post_build_commandUnknown

Appendices

Controls when the post-build command is run, either
Always Run or when Run When Build Has Occurred.
The working directory in which the post-build
command is run. This property will have macro
expansion applied to it.
A command to run after the compile command has
completed. This property will have macro expansion
applied to it with the additional $(TargetPath) macro
set to the output filepath of the compiler command.
The working directory where the post-compile
command is run. This property will have macro
expansion applied to it.
A command to run after the link command has
completed.This property will have macro expansion
applied to it with the additional $(TargetPath) macro
set to the output filepath of the linker command and
$(PostLinkOutputFilePath) set to the value of the
output filepath of the post link command.

The name of the file created by the post-link
command. This property will have macro expansion
linker_post_build_command_output_fileString
applied to it.
Post-Link Output File

Post-Link Working Directory
linker_post_build_command_wdDirPath

Pre-Build Command
pre_build_commandUnknown

Pre-Build Command Control
pre_build_command_controlEnumeration

Pre-Build Command Working Directory
pre_build_command_wdString

Pre-Compile Command

The working directory where the post-link command is
run. This property will have macro expansion applied
to it.
The command to execute before a project build. This
property will have macro expansion applied to it.
Controls when the pre-build command is run, either
Always Run or when Run When Build Required.
The working directory in which the pre-build
command is run. This property will have macro
expansion applied to it.

compile_pre_build_commandUnknown

A command to run before the compile command. This
property will have macro expansion applied to it.

Pre-Compile Command Output File Path

The pre-compile generated file name. This property

compile_pre_build_command_output_file_nameString
will have macro expansion applied to it.

Pre-Compile Working Directory
compile_pre_build_command_wdDirPath

Pre-Link Command
linker_pre_build_commandUnknown

Pre-Link Working Directory
linker_pre_build_command_wdDirPath

The working directory where the pre-compile
command is run. This property will have macro
expansion applied to it.
A command to run before the link command. This
property will have macro expansion applied to it.
The working directory where the pre-link command is
run. This property will have macro expansion applied
to it.
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Debug Options
Debugger
Property

Description

Command Arguments

The command arguments passed to the executable.
This property will have macro expansion applied to it.

debug_command_argumentsString

The debugger will load (if not already loaded by
Load Additional Projects) and debug the specified
additional projects.

Debug Additional Projects
debug_dependent_projectsStringList

The name of the debug symbols file. This property will
have macro expansion applied to it. If it is not defined
external_debug_symbols_file_nameProjFileName
then the main load file is used.
Debug Symbols File[0]

The name of the debug symbols file. This property will
have macro expansion applied to it. If it is not defined
external_debug_symbols_file_name1ProjFileName
then the main load file is used.
Debug Symbols File[1]

The name of the debug symbols file. This property will
have macro expansion applied to it. If it is not defined
external_debug_symbols_file_name2ProjFileName
then the main load file is used.
Debug Symbols File[2]

The name of the debug symbols file. This property will
have macro expansion applied to it. If it is not defined
external_debug_symbols_file_name3ProjFileName
then the main load file is used.
Debug Symbols File[3]

Debug Symbols Load Address[0]

The (code) address to be added to the debug symbol
(code) addresses.

external_debug_symbols_load_addressString

Debug Symbols Load Address[1]
external_debug_symbols_load_address1String

Debug Symbols Load Address[2]
external_debug_symbols_load_address2String

Debug Symbols Load Address[3]
external_debug_symbols_load_address3String

Debug Terminal Log File
debug_terminal_log_fileUnknown

Entry Point Symbol
debug_entry_point_symbolString

Initial Breakpoint
debug_initial_breakpointString

Initial Breakpoint Is Set

The (code) address to be added to the debug symbol
(code) addresses.
The (code) address to be added to the debug symbol
(code) addresses.
The (code) address to be added to the debug symbol
(code) addresses.
A file to write the output from the debug terminal to.
Debugger will start execution at symbol if defined.
The initial breakpoint to set
Specify when the initial breakpoint should be set

debug_initial_breakpoint_set_optionEnumeration

Leave Target Running
debug_leave_target_runningBoolean

Debugger will leave the target running on debug stop.
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Load Additional Projects
debug_load_additional_projectsStringList

Register Definition File
debug_register_definition_fileProjFileName

Start Address
external_start_addressString

Appendices

The debugger will load the outputs of the specified
additional projects.
The name of the file containing register definitions.
The address to start the externally built executable
running from.

If yes the debugger will start execution from the entry
point symbol.If no the debugger will start execution
debug_start_from_entry_point_symbolBoolean
from the core specific location.
Start From Entry Point Symbol

Startup Completion Point
debug_startup_completion_pointString

Thread Maximum
debug_threads_maxIntegerRange

Threads Script File
debug_threads_scriptProjFileName

Working Directory
debug_working_directoryDirPath

Specifies the point in the program where startup is
complete. Software breakpoints and debugIO will be
enabled after this point has been reached.
The maximum number of threads to display.
The threads script used by the debugger.
The working directory for a debug session. This
property will have macro expansion applied to it.

Loader
Property
Additional Load File Address[0]
debug_additional_load_file_addressString

Additional Load File Address[1]
debug_additional_load_file_address1String

Additional Load File Address[2]
debug_additional_load_file_address2String

Additional Load File Address[3]
debug_additional_load_file_address3String

Additional Load File Type[0]

Description
The address to load the additional load file.
The address to load the additional load file.
The address to load the additional load file.
The address to load the additional load file.

debug_additional_load_file_typeEnumeration

The file type of the additional load file. The options are
Detect, hzx, bin, ihex, hex, tihex, srec.

Additional Load File Type[1]

The file type of the additional load file. The options are

debug_additional_load_file_type1Enumeration Detect, hzx, bin, ihex, hex, tihex, srec.

Additional Load File Type[2]

The file type of the additional load file. The options are

debug_additional_load_file_type2Enumeration Detect, hzx, bin, ihex, hex, tihex, srec.

Additional Load File Type[3]

The file type of the additional load file. The options are

debug_additional_load_file_type3Enumeration Detect, hzx, bin, ihex, hex, tihex, srec.

Additional Load File[0]
debug_additional_load_fileProjFileName

Additional file to load on debug load. This property will
have macro expansion applied to it.
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Additional Load File[1]
debug_additional_load_file1ProjFileName

Additional Load File[2]
debug_additional_load_file2ProjFileName

Additional Load File[3]
debug_additional_load_file3ProjFileName

Load File
external_build_file_nameProjFileName

Load File Address
external_load_addressString

Load File Type
external_load_file_typeEnumeration

Appendices

Additional file to load on debug load. This property will
have macro expansion applied to it.
Additional file to load on debug load. This property will
have macro expansion applied to it.
Additional file to load on debug load. This property will
have macro expansion applied to it.
The name of the main load file. This property will have
macro expansion applied to it. If it is not defined then
the output filepath of the linker command is used.
The address to download the main load file to.
The file type of the main load file. The options are
Detect, hzx, bin, ihex, hex, tihex, srec.
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System Macros
System Macro Values
Property
$(Date)
$(Date)String

$(DateDay)
$(DateDay)String

$(DateMonth)
$(DateMonth)String

$(DateYear)
$(DateYear)String

$(DesktopDir)
$(DesktopDir)String

$(DocumentsDir)
$(DocumentsDir)String

$(HomeDir)
$(HomeDir)String

$(HostArch)
$(HostArch)String

$(HostDLL)
$(HostDLL)String

$(HostDLLExt)
$(HostDLLExt)String

$(HostEXE)
$(HostEXE)String

$(HostOS)
$(HostOS)String

$(Micro)
$(Micro)String

$(PackagesDir)
$(PackagesDir)String

$(Platform)
$(Platform)String

$(ProductNameShort)
$(ProductNameShort)String

$(SamplesDir)
$(SamplesDir)String

Description
Day Month Year e.g. 21 June 2011.
Day e.g. 21.
Month e.g. 01 to 12.
Year e.g. 2011.
Path to users desktop directory.
Path to users documents directory.
Path to users home directory.
The CPU architecture that CrossStudio is running on
e.g. x86.
The file extension for dynamic link libraries on the CPU
that CrossStudio is running on e.g. .dll.
The file extension for dynamic link libraries used by
the operating system that CrossStudio is running on
e.g. .dll, .so, .dylib.
The file extension for executables on the CPU that
CrossStudio is running on e.g. .exe.
The name of the operating system that CrossStudio is
running on e.g. win.
The CrossStudio target e.g. ARM.
Path to the users packages directory.
The target platform.
The product name.
Path to the samples subdirectory of the packages
directory.
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$(StudioArchiveFileExt)
$(StudioArchiveFileExt)String

$(StudioBuildToolExeName)
$(StudioBuildToolExeName)String

$(StudioBuildToolName)
$(StudioBuildToolName)String

$(StudioDir)
$(StudioDir)String

$(StudioExeName)
$(StudioExeName)String

$(StudioMajorVersion)
$(StudioMajorVersion)String

$(StudioMinorVersion)
$(StudioMinorVersion)String

$(StudioName)
$(StudioName)String

$(StudioNameShort)
$(StudioNameShort)String

$(StudioPackageFileExt)
$(StudioPackageFileExt)String

$(StudioProjectFileExt)
$(StudioProjectFileExt)String

$(StudioRevision)
$(StudioRevision)String

$(StudioScriptToolExeName)
$(StudioScriptToolExeName)String

$(StudioScriptToolName)
$(StudioScriptToolName)String

$(StudioSessionFileExt)
$(StudioSessionFileExt)String

$(StudioSimulatorExeName)
$(StudioSimulatorExeName)String

$(StudioSimulatorName)
$(StudioSimulatorName)String

$(StudioUserDir)
$(StudioUserDir)String

$(TargetID)
$(TargetID)String

$(TargetsDir)
$(TargetsDir)String

Appendices

The filename extension of a studio archive file.
The filename of the build tool executable.
The name of the build tool executable.
The install directory of the product.
The filename of the studio executable.
The major release version of software.
The minor release version of software.
The full name of studio.
The short name of studio.
The filename extension of a studio package file.
The filename extension of a studio project file.
The release revision of software.
The filename of the script tool executable.
The name of the script tool executable.
The filename extension of a studio session file.
The filename of the simulator executable.
The name of the simulator executable.
The directory containing the user data.
ID number representing the CrossStudio target.
Path to the targets subdirectory of the packages
directory.
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$(Time)
$(Time)String

$(TimeHour)
$(TimeHour)String

$(TimeMinute)
$(TimeMinute)String

$(TimeSecond)
$(TimeSecond)String

$(UnixTime)
$(UnixTime)String

Appendices

Hour:Minutes:Seconds e.g. 15:34:03.
Hour e.g. 15.
Minute e.g. 34.
Seconds e.g. 03.
Seconds since 00:00, Jan 1 1970 UTC
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Build Macros
(Build Macro Values)
Property

Description

$(AsmOptions)

A space seperated list of assembler options for the
external assemble command.

$(AsmOptions)String

$(CLANGTIDY)
$(CLANGTIDY)String

$(COnlyOptions)
$(COnlyOptions)String

$(COptions)
$(COptions)String

$(CombiningOutputFilePath)
$(CombiningOutputFilePath)String

$(CombiningRelInputPaths)
$(CombiningRelInputPaths)String

$(Configuration)
$(Configuration)String

$(Defines)
$(Defines)String

$(DependencyPath)
$(DependencyPath)String

$(EXE)
$(EXE)String

$(FolderName)
$(FolderName)String

$(FolderPath)
$(FolderPath)String

$(Includes)
$(Includes)String

$(InputDir)
$(InputDir)String

$(InputExt)
$(InputExt)String

$(InputFileName)
$(InputFileName)String

$(InputName)
$(InputName)String

The path to the clang-tidy command.
A space seperated list of compiler options for the
external c compile command.
A space seperated list of compiler options for the
external c and c++ compile commands.
The full path of the output file of the combining
command.
The relative inputs to the combining command.
The build configuration e.g. ARM Flash Debug.
The preprocessor defines property value for the
external compile command.
The path of the dependency file for the external
compile command.
The default file extension for an executable file
including the dot e.g. .elf.
The folder name of the containing folder.
The folder path of the containing folders.
The user includes property value for the external
compile command.
The absolute directory of the input file.
The extension of an input file not including the dot e.g
cpp.
The name of an input file relative to the project
directory.
The name of an input file relative to the project
directory without the extension.
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$(InputPath)
$(InputPath)String

$(IntDir)
$(IntDir)String

$(LIB)
$(LIB)String

$(LinkOptions)
$(LinkOptions)String

$(LinkerScriptPath)
$(LinkerScriptPath)String

$(MapPath)
$(MapPath)String

$(MemorySegments)
$(MemorySegments)String

$(OBJ)
$(OBJ)String

$(Objects)
$(Objects)String

$(ObjectsFilePath)
$(ObjectsFilePath)String

$(OutDir)
$(OutDir)String

$(PackageExt)
$(PackageExt)String

$(PostLinkOutputFilePath)
$(PostLinkOutputFilePath)String

$(ProjectDir)
$(ProjectDir)String

$(ProjectName)
$(ProjectName)String

$(ProjectNodeName)
$(ProjectNodeName)String

$(RelDependencyPath)
$(RelDependencyPath)String

$(RelInputDir)
$(RelInputDir)String

$(RelInputPath)
$(RelInputPath)String

$(RelLinkerScriptPath)
$(RelLinkerScriptPath)String

Appendices

The absolute name of an input file including the
extension.
The macro-expanded value of the Intermediate
Directory project property.
The default file extension for a library file including the
dot e.g. .lib.
A space seperated list of compiler options for the
external link command.
The full path of the linker script file for the link
command.
The full path of the map file of the external link
command.
The value of the Memory Segments property supplied
to pre/post link command.
The default file extension for an object file including
the dot e.g. .o.
A space seperated list of files for the external archive or
link command.
The full path containing the files for the external
archive or link command.
The macro-expanded value of the Output Directory
project property.
The file extension of a package file e.g. hzq.
The full path of the output file of the post link
command.
The absolute value of the Project Directory project
property of the current proje ct. If this isn't set then the
directory containing the solution file.
The project name of the current project.
The name of the selected project node.
The relative path of the dependency file for the
external compile command.
The relative path to the directory containing the input
file from the project directory or dot if not relative.
The relative path to the input file from the project
directory or the full path if not relative.
The relative path of the linker script file for the link
command.
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$(RelMapPath)
$(RelMapPath)String

$(RelObjectsFilePath)
$(RelObjectsFilePath)String

$(RelTargetPath)
$(RelTargetPath)String

$(RootOutDir)
$(RootOutDir)String

$(RootRelativeOutDir)
$(RootRelativeOutDir)String

$(SolutionDir)
$(SolutionDir)String

$(SolutionExt)
$(SolutionExt)String

$(SolutionFileName)
$(SolutionFileName)String

$(SolutionName)
$(SolutionName)String

$(SolutionPath)
$(SolutionPath)String

$(StageOutputFilePath)
$(StageOutputFilePath)String

$(TargetPath)
$(TargetPath)String

$(ToolChainDir)
$(ToolChainDir)String

$(Undefines)
$(Undefines)String

Appendices

The relative path of the map file of the external link
command.
The relative path containing the files for the external
archive or link command.
The project directory relative path of the output file of
the link or compile command.
The macro-expanded value of the Root Output
Directory project property.
The relative path to get from the path specified by
the Output Directory project property to the path
specified by the Root Output Directory project
property.
The absolute path of the directory containing the
solution file.
The extension of the solution file without the dot.
The filename of the solution file.
The basename of the solution file.
The absolute path of the solution file.
The full path of the output file of the stage command.
The full path of the output file of the link or compile
command.
The macro-expanded value of the Toolchain Directory
project property.
The preprocessor undefines property value for the
external compile command.
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BinaryFile
The following table lists the BinaryFile object's member functions.
BinaryFile.crc32(offset, length) returns the CRC-32 checksum of an address range length bytes long, starting
at offset. This function computes a CRC-32 checksum on a block of data using the standard CRC-32 polynomial
(0x04C11DB7) with an initial value of 0xFFFFFFFF. Note that this implementation doesn't reflect the input or the
output and the result is inverted.
BinaryFile.length() returns the length of the binary file in bytes.
BinaryFile.load(path) loads binary file from path.
BinaryFile.loadAppend(path) loads binary file from path and appends it to the binary image.
BinaryFile.peekBytes(offset, length) returns byte array containing length bytes peeked from offset.
BinaryFile.peekUint32(offset, littleEndian) returns a 32-bit word peeked from offset. The littleEndian argument
specifies the endianness of the access, if true or undefined it will be little endian, otherwise it will be big endian.
BinaryFile.pokeBytes(offset, byteArray) poke byte array byteArray to offset.
BinaryFile.pokeUint32(offset, value, littleEndian) poke a value to 32-bit word located at offset. The littleEndian
argument specifies the endianness of the access, if true or undefined it will be little endian, otherwise it will be
big endian.
BinaryFile.resize(length, fill) resizes the binary image to length bytes. If the operation extends the size, the
binary image will be padded with bytes of value fill.
BinaryFile.save(path) saves binary file to path.
BinaryFile.saveRange(path, offset, length) saves part of the binary file to path. The offset argument specifies
the byte offset to start from. The length argument specifies the maximum number of bytes that should be
saved.
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CWSys
The following table lists the CWSys object's member functions.
CWSys.appendStringToFile(path, string) appends string to the end of the file path.
CWSys.copyFile(srcPath, destPath) copies file srcPath to destPath.
CWSys.crc32(array) returns the CRC-32 checksum of the byte array array. This function computes a CRC-32
checksum on a block of data using the standard CRC-32 polynomial (0x04C11DB7) with an initial value of
0xFFFFFFFF. Note that this implementation doesn't reflect the input or the output and the result is inverted.
CWSys.fileExists(path) returns true if file path exists.
CWSys.fileSize(path) return the number of bytes in file path.
CWSys.getRunStderr() returns the stderr output from the last CWSys.run() call.
CWSys.getRunStdout() returns the stdout output from the last CWSys.run() call.
CWSys.makeDirectory(path) create the directory path.
CWSys.packU32(array, offset, number, le) packs number into the array at offset.
CWSys.popup(text, caption) prompt the user with text and return true for yes and false for no.
CWSys.readByteArrayFromFile(path) returns the byte array contained in the file path.
CWSys.readStringFromFile(path) returns the string contained in the file path.
CWSys.removeDirectory(path) remove the directory path.
CWSys.removeFile(path) deletes file path.
CWSys.renameFile(oldPath, newPath) renames file oldPath to be newPath.
CWSys.run(cmd, wait) runs command line cmd optionally waits for it to complete if wait is true.
CWSys.unpackU32(array, offset, le) returns the number unpacked from the array at offset.
CWSys.writeByteArrayToFile(path, array) creates a file path containing the byte array array.
CWSys.writeStringToFile(path, string) creates a file path containing string.
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Debug
The following table lists the Debug object's member functions.
Debug.breakexpr(expression, count, hardware) set a breakpoint on expression, with optional ignore count
and use hardware parameters. Return the, none zero, allocated breakpoint number.
Debug.breakline(filename, linenumber, temporary, count, hardware) set a breakpoint on filename and
linenumber, with optional temporary, ignore count and use hardware parameters. Return the, none zero,
allocated breakpoint number.
Debug.breaknow() break execution now.
Debug.deletebreak(number) delete the specified breakpoint or all breakpoints if zero is supplied.
Debug.disassembly(source, labels, before, after) set debugger mode to disassembly mode. Optionally specify
source and labels to be displayed and the number of bytes to disassemble before and after the located program
counter.
Debug.echo(s) display string.
Debug.enableexception(exception, enable) enable break on exception.
Debug.evaluate(expression) evaluates debug expression and returns it as a JavaScript value.
Debug.getfilename() return located filename.
Debug.getlineumber() return located linenumber.
Debug.go() continue execution.
Debug.locate(frame) locate the debugger to the optional frame context.
Debug.locatepc(pc) locate the debugger to the specified pc.
Debug.locateregisters(registers) locate the debugger to the specified register context.
Debug.print(expression, fmt) evaluate and display debugexpression using optional fmt. Supported formats are
b binary, c character, d decimal, e scientific float, f decimal float, g scientific or decimal float, i signed decimal, o
octal, p pointer value, s null terminated string, u unsigned decimal, x hexadecimal.
Debug.printglobals() display global variables.
Debug.printlocals() display local variables.
Debug.quit() stop debugging.
Debug.setprintarray(elements) set the maximum number of array elements for printing variables.
Debug.setprintradix(radix) set the default radix for printing variables.
Debug.setprintstring(c) set the default to print character pointers as strings.
Debug.showbreak(number) show information on the specified breakpoint or all breakpoints if zero is
supplied.
Debug.showexceptions() show the exceptions.
Debug.source(before, after) set debugger mode to source mode. Optionally specify the number of source
lines to display before and after the location.
Debug.stepinto() step an instruction or a statement.
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Debug.stepout() continue execution and break on return from current function.
Debug.stepover() step an instruction or a statement stepping over function calls.
Debug.stopped() return stopped state.
Debug.wait(ms) wait ms millseconds for a breakpoint and return the number of the breakpoint that hit.
Debug.where() display call stack.

1439

CrossWorks for MSP430 Reference Manual

Appendices

WScript
The following table lists the WScript object's member functions.
WScript.Echo(s) echos string s to the output terminal.
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